Corporate Office
Trimble Navigation Limited
Engineering and Construction Division
5475 Kellenburger Road
Dayton, Ohio 45424-1099
U.S.A.
Phone: +1-937-233-8921
Toll free (in USA): +1-800-538-7800
Fax: +1-937-233-9441
www.trimble.com

Copyright and Trademarks
© 2005-2008, Trimble Navigation Limited. All rights reserved.
The Globe & Triangle logo and Trimble are trademarks of
Trimble Navigation Limited. All other trademarks are the
property of their respective owners.

Release Notice
This is the help for version 2.00 of Trimble Business Center
software.
## Contents

### Welcome To Trimble Business Center  

### Get Started  

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Register This Software</td>
<td>2</td>
</tr>
<tr>
<td>Retaining User Settings When Upgrading</td>
<td>4</td>
</tr>
<tr>
<td>Get Familiar with the Interface</td>
<td>5</td>
</tr>
<tr>
<td>Project Explorer</td>
<td>6</td>
</tr>
<tr>
<td>Selection Explorer</td>
<td>7</td>
</tr>
<tr>
<td>View Filter Manager</td>
<td>8</td>
</tr>
<tr>
<td>Status Bar</td>
<td>9</td>
</tr>
<tr>
<td>Device Pane</td>
<td>10</td>
</tr>
<tr>
<td>Command Pane</td>
<td>12</td>
</tr>
<tr>
<td>Properties Pane</td>
<td>12</td>
</tr>
<tr>
<td>Flags Pane</td>
<td>13</td>
</tr>
<tr>
<td>Coordinates Scroll</td>
<td>14</td>
</tr>
<tr>
<td>Data Views</td>
<td>15</td>
</tr>
<tr>
<td>Customize the Menu</td>
<td>15</td>
</tr>
<tr>
<td>Customize the Toolbar</td>
<td>17</td>
</tr>
<tr>
<td>Customize the Keyboard</td>
<td>19</td>
</tr>
<tr>
<td>Customization Options and Tools</td>
<td>19</td>
</tr>
<tr>
<td>Troubleshoot a Toolbar or Menu Problem</td>
<td>20</td>
</tr>
<tr>
<td>Find Help Topics</td>
<td>21</td>
</tr>
<tr>
<td>Help Options</td>
<td>22</td>
</tr>
</tbody>
</table>

### View, Navigate, and Select  

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Graphic Views</td>
<td>24</td>
</tr>
<tr>
<td>Spreadsheets and Other Views</td>
<td>28</td>
</tr>
<tr>
<td>Pane and Data View Positioning</td>
<td>37</td>
</tr>
<tr>
<td>Data View Display Formats</td>
<td>38</td>
</tr>
<tr>
<td>Tabbed View Arrangement</td>
<td>40</td>
</tr>
<tr>
<td>2D View Navigation</td>
<td>41</td>
</tr>
<tr>
<td>3D View Navigation</td>
<td>43</td>
</tr>
<tr>
<td>3D View Settings</td>
<td>44</td>
</tr>
<tr>
<td>Keyboard Navigation</td>
<td>46</td>
</tr>
<tr>
<td>Mouse Modes</td>
<td>48</td>
</tr>
<tr>
<td>Data Selection</td>
<td>48</td>
</tr>
<tr>
<td>View and Edit an Object’s Properties</td>
<td>73</td>
</tr>
<tr>
<td>Delete an Object</td>
<td>74</td>
</tr>
<tr>
<td>Edit an Object</td>
<td>75</td>
</tr>
<tr>
<td>Undo or Redo an Action</td>
<td>76</td>
</tr>
</tbody>
</table>
Contents

Import Data ....................................................................................................................................................... 212
Set Up Geodetic Reference Data ....................................................................................................................... 189
Set Up Projects ..................................................................................................................................................... 148
Calculate and Enter Values .................................................................................................................................. 95

Import Data ....................................................................................................................................................... 212

Set Up Projects

Choose Application Options ................................................................................................................................. 148
Choose Project Settings ................................................................................................................................. 155
Choose Local Site Settings ............................................................................................................................... 178
Create a New Project ......................................................................................................................................... 180
Use a Project Template ....................................................................................................................................... 181
Open an Existing Project .................................................................................................................................... 183
Save a Project ...................................................................................................................................................... 184
Archive a Project .................................................................................................................................................. 185
Print a View or Report ....................................................................................................................................... 185
Troubleshoot a Project Problem ......................................................................................................................... 186
Troubleshoot a Program Freeze ......................................................................................................................... 187

Set Up Geodetic Reference Data

Understanding Geodetic Reference Data ........................................................................................................... 189
Define the Coordinate System ............................................................................................................................ 190
Use a Datum ......................................................................................................................................................... 193
Define a Projection ............................................................................................................................................... 195
Use a Geoid ........................................................................................................................................................ 196
Calibrate a Site .................................................................................................................................................... 200
Using Geoid Models .......................................................................................................................................... 202
Rules for ensuring a useful calibration .................................................................................................................. 202

Calculate and Enter Values

Understanding COGO Controls ......................................................................................................................... 95
COGO Expressions, Units, and Entry Formats ..................................................................................................... 97
Set the Pick Aperture .......................................................................................................................................... 98
Snaps Modes and Commands ........................................................................................................................... 98
Enter an Angle .................................................................................................................................................... 101
Enter a Bearing .................................................................................................................................................. 103
Enter a Coordinate ........................................................................................................................................... 106
Enter a Distance ................................................................................................................................................ 129
Enter an Elevation .......................................................................................................................................... 134
Enter an Offset ................................................................................................................................................ 137
Enter a Station .................................................................................................................................................. 142
Measure Values Between Points ....................................................................................................................... 144
Measure Options ............................................................................................................................................. 145
Measure Angles ............................................................................................................................................... 146
Measure Angle Options ................................................................................................................................... 147

Manage the Data in Your Views .......................................................................................................................... 76
Troubleshoot a View or Selection Problem ......................................................................................................... 93
## Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>View and Edit Mean Angle Residuals</td>
<td>330</td>
</tr>
<tr>
<td>Run a Mean Angle Report</td>
<td>331</td>
</tr>
<tr>
<td><strong>Work with Level Data</strong></td>
<td>332</td>
</tr>
<tr>
<td>Understanding Level Data</td>
<td>332</td>
</tr>
<tr>
<td>Workflow for Level Data</td>
<td>333</td>
</tr>
<tr>
<td>Import DiNi Digital Level Files (.dat)</td>
<td>334</td>
</tr>
<tr>
<td>View and Edit Level Data</td>
<td>336</td>
</tr>
<tr>
<td>View Level Data in Project Explorer</td>
<td>342</td>
</tr>
<tr>
<td>Level Data Errors</td>
<td>346</td>
</tr>
<tr>
<td>Adjust Level Runs</td>
<td>347</td>
</tr>
<tr>
<td>Merge Level Runs</td>
<td>348</td>
</tr>
<tr>
<td>Note on Level Runs Without Benchmarks</td>
<td>349</td>
</tr>
<tr>
<td><strong>Adjust Networks</strong></td>
<td>351</td>
</tr>
<tr>
<td>Understanding Network Adjustment</td>
<td>351</td>
</tr>
<tr>
<td>Workflow for Adjusting a Network</td>
<td>352</td>
</tr>
<tr>
<td>Enable and Disable Vectors</td>
<td>353</td>
</tr>
<tr>
<td>Apply a Network Adjustment Style</td>
<td>354</td>
</tr>
<tr>
<td>Change Network Adjustment Settings</td>
<td>355</td>
</tr>
<tr>
<td>Adjust a Network</td>
<td>356</td>
</tr>
<tr>
<td>Network Adjustment Options</td>
<td>358</td>
</tr>
<tr>
<td>Run a Network Adjustment Report</td>
<td>361</td>
</tr>
<tr>
<td><strong>Work with Point Data</strong></td>
<td>364</td>
</tr>
<tr>
<td>Understanding Point Types</td>
<td>364</td>
</tr>
<tr>
<td>Add and Edit Points and Coordinates</td>
<td>365</td>
</tr>
<tr>
<td>Calculate the Inverse Between Points</td>
<td>375</td>
</tr>
<tr>
<td>Inverse Options</td>
<td>376</td>
</tr>
<tr>
<td>Measure Values Between Points</td>
<td>377</td>
</tr>
<tr>
<td>Measure Options</td>
<td>378</td>
</tr>
<tr>
<td>Points Spreadsheet</td>
<td>379</td>
</tr>
<tr>
<td>Troubleshoot an Import Problem</td>
<td>380</td>
</tr>
<tr>
<td><strong>Work with Line Data</strong></td>
<td>382</td>
</tr>
<tr>
<td>Create and Edit an Alignment</td>
<td>382</td>
</tr>
<tr>
<td>Create and Edit a Linestring</td>
<td>396</td>
</tr>
<tr>
<td>Create and Edit a Simple Breakline</td>
<td>408</td>
</tr>
<tr>
<td>Breakline Options</td>
<td>410</td>
</tr>
<tr>
<td>Break a Line</td>
<td>410</td>
</tr>
<tr>
<td>Join Lines</td>
<td>411</td>
</tr>
<tr>
<td>Delete a Line Segment</td>
<td>412</td>
</tr>
<tr>
<td>Set a Line Elevation</td>
<td>413</td>
</tr>
<tr>
<td>Explore an Object</td>
<td>414</td>
</tr>
<tr>
<td>Explode a Block</td>
<td>415</td>
</tr>
</tbody>
</table>
Contents

Work with Surface Data 416

Create and Edit a Surface ................................................................. 416
Create a Surface Boundary and Contours ........................................... 435
Add Surface Materials ....................................................................... 445
Shrink 3D Faces .............................................................................. 452

Work with Feature Data 455

Understanding Feature Data .............................................................. 455
Workflow for Feature Data ............................................................... 457
Feature Code Processing Settings ..................................................... 458
Enter, Edit, and Delete Feature Code Strings ..................................... 459
Rules for Merging Feature Attributes ............................................... 461
Split Line Features ......................................................................... 462
Process Feature Codes ..................................................................... 463
Export Geodatabase Files (.xml) ....................................................... 464
Feature Definition Manager Utility .................................................. 465

Run Reports 466

Run an Alignment Geometry Report ............................................... 466
Run a Baseline Processing Report .................................................... 467
Run an Earthwork Report ............................................................... 469
Run an Import Report ..................................................................... 470
Run a Mean Angle Report ................................................................ 471
Run a Network Adjustment Report .................................................. 472
Run a Point Derivation Report ......................................................... 474
Run a Point List Report ................................................................. 474
Run a Project Computation Report .................................................. 475
Run a Renamed Point List ............................................................... 475
Run a Site Calibration Report .......................................................... 475
Run a Job File Report .................................................................... 476
Run a Surface Report ..................................................................... 478
Run a Vector List Report ............................................................... 479
Run a Loop Closure Report ............................................................ 480
Customize a Report ....................................................................... 481
Report View ................................................................................... 482
Report Options .............................................................................. 483

Export Data 486

Export Data .................................................................................... 486
Export and Upload Data Formats ...................................................... 487
Export Related Files ........................................................................ 490
Export ASCII Files ......................................................................... 491
Export CAD Files (.dxf/.dwg) ........................................................... 491
Export Geodatabase Files (.xml) ....................................................... 492
Export Event Data ......................................................................... 492
## Contents

Export GNSS Job Files (.job) ......................................................................................................................... 493  
Export LandXML Files (.xml) ....................................................................................................................... 493  
Export Trimble Data Collector Files (.dc) .................................................................................................... 496  
Export Trimble Surface Files (.ttm) ............................................................................................ .................. 496  
Export Trimble JobXML Files (.jxl) .............................................................................................................. 496  
Export Data in a Custom Format................................................................................................. ................. 497  

### Troubleshoot Issues 502

- Troubleshoot a Coordinate System Problem .................................................................................. 502  
- Troubleshoot a Data Transfer/Synchronization Problem ................................................................. 502  
- Troubleshoot a Layer or View Filter Problem ................................................................................. 503  
- Troubleshoot an Import Problem ................................................................................................. ................ 504  
- Troubleshoot a Program Freeze .................................................................................................. .................. 504  
- Troubleshoot a Project Problem ................................................................................................ 506  
- Troubleshoot a Toolbar or Menu Problem ...................................................................................... 506  
- Troubleshoot a View or Selection Problem .................................................................................... 507  
- Troubleshoot an Import Problem ................................................................................................. ................ 508  

### Use Related Utilities 510

- Coordinate System Manager ...................................................................................................... 510  
- Feature Definition Manager Utility .............................................................................................. 510  
- Planning Utility ........................................................................................................................................ 511  
- External Tools Manager .............................................................................................................. 511  
- Trimble Configuration Utility ........................................................................................................ 511  
- Trimble Data Transfer Utility ........................................................................................................ 512  

### Index 513
Welcome To Trimble Business Center

Trimble® Business Center office software is ideal for processing and analyzing GNSS and terrestrial (total station and level) survey data recorded in the field, and exporting it to a design package. The software provides numerous innovative and unique features, and it is easy to learn and use.

If you are new to this software, you might start by reading the following topics: Overview of the User Interface (see "Get Familiar with the Interface" on page 5), Project Explorer (on page 6), Plan View (on page 24), and Point Spreadsheet (see "Points Spreadsheet" on page 28).

Related topics

- About Trimble Business Center Command
- Products Command
- Register This Software (on page 2)
- Start Page Command
Get Started

Register This Software

Register this software so you can receive product upgrades, support, and warranty-related services.

**Note:** The *Product Registration* dialog appears in English only. The following steps guide you through the dialog in your installed language.

**To register:**

1. Select **Help > About**. The *About* dialog displays.

2. Click **Register**. The *Product Registration* dialog displays, showing these notes:

   Please register your new software with the MyTrimble system. The MyTrimble system provides access to the latest product information from, and helps track your company’s products and warranty information.

   Enter your email address. Each MyTrimble account has an associated email address. If your company has an existing MyTrimble account, enter that email address.

   If your company does not have an existing MyTrimble account, then you will create an account in the next step.

   **Note:** We value your privacy. We will not sell, rent, or share this information with third party marketing firms or other manufacturers or products. For further details, please click on the link to see our Privacy Statement.

3. Type your email address in the box, and click **Next**. These notes appear:

   To create an account, enter your contact details below. **All fields are required.** If your company already has an account, click **Back** to return to the previous screen and enter the email address for that account.
Get Started

Note: These contact details may be used for the delivery of product upgrades or enhancements, and warranty-related services. Refer to our Privacy Statement for additional details.

4. Type the following in the boxes: (all are required)
   - First name
   - Last name
   - Company name
   - Address
   - City
   - State/Province
   - Postal code
   - Country
   - Phone number

5. Click Next. This note appears:

   If you have a dongle attached to your computer, its serial number has been read and entered below. If your software did not come with a dongle, refer to the sticker on the software box for your serial number. These boxes should be automatically filled:
   - Serial number
   - Product name
   - Part number
   - Ship date

Note: Your software product may not require a dongle or other license.

6. If the boxes are empty, type the serial number for your software in the Serial Number box, and click Product Lookup. Otherwise, skip to step 9.

Note: If you receive this warning: Serial Number Not Found! Please make sure you have entered the serial code correctly, click Reenter Serial Number, and correct the serial number.

7. If you have a company-specific reference number for software, you can type it in the Reference Number box.

8. Click Submit. This note appears:

   Thank you for registering! Your software has been successfully registered! Your password has been sent to your email. Please check your email to find the details on how to access your MyTrimble account.
This note may also appear: Our system found that you have other products that are not yet registered. Please choose below which product you want to register and click Register.

9. Check boxes for any other products you want to register, and click Register. Otherwise, click Not this time.

Note: To login to your MyTrimble account, please visit our web site's Register page.

Retaining User Settings When Upgrading

As you use the program, many of your settings and other customizations are saved as files in an application data folder. These settings, which remain constant regardless of which project is open, include:

**Application settings**
These program-wide settings include startup preferences, default file locations, and display properties. Application settings are primarily found in the Options dialog.

**Custom Import and Export Format Definitions**
These include changes to how file formats are defined in the Import Format Editor and Export Format Editor.

**Project Templates**
These include project settings, coordinate systems, view filters, selection sets, and data that you have saved as project templates.

**Internet Download Configurations**
These include new data provider groups and Internet sites that you have added to the Internet Download command.

**Baseline Processing and Network Adjustment Styles**
These include combinations of project settings that you have defined as templates for baseline processing and network adjustment.

When you upgrade from your current version of the program to a newer version, the installation program searches for previous files containing these settings and customizations. If any are found, the Copy Settings dialog appears.

To retain previous settings and customizations:

1. In the Copy column, uncheck the box for each old file that you do not want to retain in the upgrade.
2. Check the box for each old file that you do want to use to overwrite the new file.
3. Click Copy Selected Files. The previous settings and customizations that you selected are copied to the new installation.
Note: Any files that conflict with the files in the new installation are marked with a red flag and are not selected by default.

Note: It is always a good idea to confirm your project and application settings in the new installation to make sure that any new options in the current version are set to the defaults you want.

Note: Customized menus and toolbars cannot be saved when you upgrade.

Get Familiar with the Interface

This software comes with an integrated user interface, including:
## Interface elements

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Menu</strong> (see &quot;Customize the Menu&quot; on page 15)</td>
<td>Gives you comprehensive access to all available commands.</td>
</tr>
<tr>
<td><strong>Toolbar</strong> (see &quot;Customize the Toolbar&quot; on page 17)</td>
<td>Gives you quick access to the most commonly used commands and views using icons.</td>
</tr>
<tr>
<td><strong>Data views</strong> (on page 15)</td>
<td>Allows multiple views of data in the plan view (on page 24), 3D view (on page 27), time-based view (on page 32), point spreadsheet (see &quot;Points Spreadsheet&quot; on page 28), and vector spreadsheet (on page 30). The data view area can be set up as a tabbed interface or a multiple window interface. Navigation and selection can be controlled both graphically and by commands.</td>
</tr>
<tr>
<td><strong>Status bar</strong> (on page 9)</td>
<td>Includes status information, current units, an error flag (indicating computation errors), an indicator that the project should be computed again, the number of currently selected objects, and a coordinate display.</td>
</tr>
<tr>
<td><strong>Project Explorer</strong> (on page 6)</td>
<td>Shows a tree view of project data that includes sections for points, sessions, surfaces, alignments, and imported file data, enabling you to easily select any object.</td>
</tr>
<tr>
<td><strong>Selection Explorer</strong> (on page 7)</td>
<td>Shows the currently selected objects, as well as saved sets of objects known as 'selection sets'.</td>
</tr>
<tr>
<td><strong>View Filter Manager</strong> (on page 8)</td>
<td>Lets you specify what data types and layers are visible and selectable in graphic views.</td>
</tr>
<tr>
<td><strong>Device Pane</strong></td>
<td>Gives you access the Office Synchronizer's office copy folder (also known as the root sync folder).</td>
</tr>
<tr>
<td><strong>Command Pane</strong> (on page 12)</td>
<td>Provides a consistent place to work through most commands.</td>
</tr>
<tr>
<td><strong>Properties Pane</strong> (on page 12)</td>
<td>Displays the properties associated with the currently selected object(s), enabling them to be edited.</td>
</tr>
<tr>
<td><strong>Flags Pane</strong> (on page 13)</td>
<td>Lists objects with import or computation errors.</td>
</tr>
</tbody>
</table>

### Project Explorer

The **Project Explorer** displays your project data organized in a tree structure.

**To display and pin the Project Explorer:**

1. Do one of the following:
Get Started

- Click the 🔄️ icon on the toolbar.
- Select View > Project Explorer.
- Press [F9] on the keyboard.

The Project Explorer displays, docked on the left side of the application window, or where you positioned it last.

2. If desired, pin the explorer open by clicking the 🔄️ icon at the top. If the pane is unpinned, the pane can "slide" to the side and out of view. To show it again, click the Project Explorer tab.

**Using the Project Explorer**

- To expand nodes, click the 📜 icon. To collapse nodes, click the 📜 icon.
- To select a node or a data object, click it.
- To display the properties for an object, double-click it. The Properties pane displays.
- To access common commands for an object, right-click for a context menu.

**Related Topics**

- Select from the Project Explorer (on page 54)
- Pane and Data View Positioning (on page 37)
- Properties Pane (on page 12)

**Selection Explorer**

The Selection Explorer is a pane that lists the selection sets in your project in the top section and lists the objects in the active set in the bottom section.

- When you click on a selection set, all the objects in the set are selected in the project.
- When you select one or more objects in the list of objects, those objects are selected in the project.
- When <Selection Snapshot> is active, objects selected in the graphics area are listed.

Using selection sets makes accessing and selecting groups of commonly-used objects faster and more consistent.

**To display and pin the Selection Explorer:**

1. Do one of the following:
   - Select View > Selection Explorer.
   - Select Select > Selection Set > Selection Explorer.
- Click the icon on the toolbar.
- Right-click in a graphic view and select Selection Explorer from the context menu.

The Selection Explorer displays, docked on the left side of the application window, or where you positioned it last.

2. If desired, pin the explorer open by clicking the icon at the top. If the pane is unpinned, the pane can "slide" to the side and out of view. To show it again, click the Selection Explorer tab.

Related topics
- Understanding Selection Sets (on page 64)
- Create and Use Selection Sets (on page 66)
- Modify Selection Sets (on page 68)
- Pane and Data View Positioning (on page 37)

View Filter Manager

The View Filter Manager is a pane in which you can select data types and layers to specify what is visible in the current graphic view, helping you reduce and simplify what you see. As you make changes in the manager, the view updates to reflect them.

View filters are saved sets of criteria that control what data and layers are displayed in the views. View filters can be defined separately for each type of view so that only the data that is important for the current phase of your work is displayed. When you change to a different view, the current and available view filters may change as well, because view filters are saved with views. The view filters for each view in your project can be accessed from the view filter list on the toolbar.

To display and pin the View Filter Manager:

1. Do one of the following:
   - Select View > View Filter Manager.
   - Click the icon on the toolbar.

The View Filter Manager displays, docked on the left side of the application window, or where you positioned it last.

Note: If the Project Explorer or Selection Explorer are also active, they may share the same pane, and be accessible as tabs at the bottom of the pane.

2. If desired, pin the manager open by clicking the icon at the top. If the pane is unpinned, it can "slide" to the side and out of view. To show it again, click the View Filter Manager tab on the left edge of the application window.
Using the View Filter Manager

- When you check and uncheck boxes for data types and layers in the View Filter Manager, the current view changes in response.
- Arrange the order of the data type groups in the tree by right-clicking on a group and selecting Move Up or Move Down from the context menu.
- To set the selectability of data types and layers, click the 🗑️ icon on the pane's toolbar to display the Advanced View Filter Settings dialog.

Related topics

- Create a View Filter (on page 82)
- Edit a View Filter (on page 84)
- Filter a View (on page 85)
- Pane and Data View Positioning (on page 37)

Status Bar

The status bar, located at the bottom of the application window, displays several useful pieces of information:

| Elevation | Snap | Meter | 🌋 | 🟢 | 1 | □ | 6.272 m, 2.141 m | ☑ |
Status line
Displays information about the current command.

Snap button
Click this to display the Snap mode dialog, in which you can set running snap modes.

Units button
Displays the current distance units. Click this to display the Units section of the Project Settings dialog.

Flag Pane button
Appears if errors have been detected in the project. Click this to display the Flags pane. Flagged items have associated messages or errors.

Compute Project button
Appears if changes made to the data require that final coordinates for points be recalculated. Click this to start the Compute Project command.

Number of selected objects
Displays the number of objects that are currently selected.

Plan view dimensions icon
Appears when the cursor is not in the data view area.

Plan view dimensions or Coordinates display
Displays the XY dimensions of the current view, when the cursor is not in the view area. Displays the true northing and easting coordinate of the current cursor location, when the cursor is within view area.

Display Coordinate Pane checkbox
Check this to display the Coordinates pane, which shows the current northing, easting, latitude, and longitude of the cursor.

Related Topics
- Running Snap Modes (see "Set Running Snap Modes" on page 99)
- Change Project Units (see "Unit Settings" on page 159)
- Flags Pane (on page 13)
- Coordinates Pane (see "Coordinates Scroll" on page 14)

Device Pane
The Device pane enables you to directly access Microsoft® Windows® CE-based field devices or the data synchronization area (also known as the root sync folder in the Office Synchronizer utility), which contains the files maintained by Office Synchronizer.

To display the Device pane:
Do one of the following:

- Click the device icon on the toolbar.
Get Started

- Select View > Device Pane.
- Press [F10] on the keyboard.

The Devices pane displays, docked on the left side of the application window, or where you positioned it last.

To connect to a field device:

1. Connect the field device to the computer using a USB or serial connection.
2. If the device asks if you want it to be connected, click Yes. The Device pane displays, showing a list of files on the device.
3. As needed, upload (see "Upload Files (via Direct Connection)" on page 267) or download (see "Download Files (via Direct Connection)" on page 267) files via this direct connection.

To connect to field data in the data synchronization area:

In Office copy mode, the Device pane points to a folder on your office computer that contains the data previously synchronized from the field device, using the Office Synchronizer utility (see "Office Synchronizer" on page 264).

1. To verify that data in the synchronization area is selected, click the icon, and verify that Office Copy is checked in the drop-down list. The contents of the synchronizer root folder display.
2. As needed, upload files (see "Upload Files (via data synchronization)" on page 270), upload tasks (see "Upload Tasks (via data synchronization)" on page 271), or download files (see "Download Files (via data synchronization)" on page 269) from the data synchronization area.
Command Pane

The Command pane gives you access to the All Commands list, a comprehensive list from which you can execute most commands. The Command pane also provides a place for you to work through many commands.

To display the Command pane:

- Select View > Command Pane.
- Press [F12].

The Command pane displays docked on the right side of the application window, or where you positioned it last.

To run a command from the Command pane:

Do one of the following:

- Enter a command in the Command box (command line).
- Double-click a command in the Recent Commands list.
- Click a command in the All Commands list.

When a command is active in the Command pane, these options are available on the pane’s toolbar.

Options

- Click this to display a list of the commands that are currently on the stack.

In the default command pane, click this to display the last/current command on the stack.

In any other command pane, click this to display the default command pane.

Related Topics

- Pane and Data View Positioning (on page 37)

Properties Pane

The Properties pane shows properties for selected objects, enabling you to edit certain values. If you select a single object, the properties for that object are displayed. If you select multiple objects, the properties common to all of them are displayed. You can edit the common properties, or select a subset of the selected objects using the drop-down list near the top of the pane.
To view the properties of another object in the Properties pane, click the object within any data view or pane. If the Properties pane is displayed, selecting any object will show its properties.

**Note:** The toolbar icons and context menu items available in the Properties pane depend on the types of objects you have selected. The Properties pane also enables you to use COGO controls and snap commands within certain property boxes.

**Note:** An icon for the type of object you have selected appears at the top of the Properties pane. If a flag icon appears instead of the object icon, there are import or computation errors associated with one or more of the selected objects. Open the Flags Pane (on page 13) for details.

---

**To display the Properties pane:**

- Click the icon on the toolbar.
- Select **Edit > Properties**.
- Double-click an object in the **Project Explorer**.
- Right-click an object in a view, spreadsheet, or the **Project Explorer** and select **Properties**.
- Press [F11].

The Properties pane displays, docked on the right side of the application window, or where you positioned it last.

**Related Topics**

- [View and Edit an Object’s Properties](on page 73)
- [Pane and Data View Positioning](on page 37)

---

**Flags Pane**

The Flags pane shows import or computation errors. You can select individual or multiple objects from the Flags pane if the objects have been flagged with errors. If there are no objects in the Flags pane, no objects have been identified as having errors.

**To display the Flags pane:**

- Click the flag icon on the toolbar or the status bar if flags are present.
- Select **View > Flags Pane**.

The Flags pane displays at the bottom of the application window, or where you positioned it last.
To highlight points using the Flags pane:

- In the Flags pane, select a point to view. The selected point(s) highlight in any graphic views and spreadsheets you have open.

Tip: [Ctrl] + click to select multiple objects, or [Shift] + click to select a range in the Flags pane.

Related Topics

- Compute Project Command
- Pane and Data View Positioning (on page 37)
- Select from the Flags Pane (on page 54)
- Status Bar (on page 9)

Coordinates Scroll

The Coordinates scroll displays values, such as northing, easting, latitude, longitude, elevation, and offset, based on the position of the cursor in a graphic view. The values shown depend on what type of view the cursor is in.

To display the Coordinates scroll:

- Click the checkbox at the right end of the status bar.
- Select View > Coordinates Scroll.

The Coordinates scroll displays.

To use the Coordinates scroll:

1. Display the scroll and right-click in it for options.
2. Select any type of value to show or hide when using the scroll.

Note: Although all of the possible values can be selected in the context menu, only certain values will display for each type of graphic view. For example, elevation and offset values will display in profile and cross-section views, but not in the plan view. The coordinates scroll cannot be used in the 3D view.

3. Move the cursor into a 2D view. The values at the cursor’s position are displayed in the scroll.

Related Topics

- Coordinate System Manager (on page 192)
- Change the Coordinate System (on page 157)
- Define a New Coordinate System (on page 158)
- Restore the Original Coordinate System File (on page 158)
- Pane and Data View Positioning (on page 37)
Data Views

You can view your project data in a variety of graphical, tabular, and chronological formats, such as:

- Plan view (on page 24)
- Profile view (on page 25)
- 3D view (on page 27)
- Points spreadsheet (on page 28)

Customize the Menu

You can customize the menus by:

- Rearranging menu commands
- Adding a command to a menu
- Deleting a command from a menu
- Saving a layout

**Adding external tools to the Tools menu To rearrange menu commands:**

2. Click the Commands tab.
3. Click Rearrange Commands.
4. In the Rearrange Commands dialog, select Menu Bar option and then select a menu from the drop-down list.
5. In the Commands area, highlight the menu command that you want to move.
6. To move the menu item, do one of the following:
   - Click Move Up to move the item up the menu list.
   - Click Move Down to move the item down the menu list.
   - Click Close to exit, or click Reset to return to the default setting.

**To add a command to a menu:**

2. Click the Commands tab.
3. Click Rearrange Commands.
4. In the Rearrange Commands dialog, select Menu Bar and then select a menu from the drop-down list.
5. Click Add.

6. In the Add Command dialog, select a category and then the command that you want to add to the menu selected in the Rearrange Commands dialog.

7. Click OK.

8. Do one of the following:
   - Click Close to exit.
   - Click Move Up or Move Down to move the command if you want it in a different position.
   - Click Reset to remove the added command and return to the default setting.

To delete a command from a menu:

2. Click the Commands tab.
3. Click Rearrange Commands.
4. In the Rearrange Commands dialog, select Menu Bar and then select a menu from the drop-down list.
5. In the Commands area, highlight the menu command that you want to delete.
6. Click Delete.
7. Click Close to exit, or click Reset to return to the default setting.

To save a custom layout:

After customizing a menu using one of the procedures above, save it so that the new layout appears each time you open the software.

1. Click the Save/Load tab.
2. Click New and give your layout a name and click OK. Your layout now appears in the Saved Layouts window.

To add a new tool to the menu:

3. Type a name for the tool in the Title box.
4. Next to the Command box, click the [browse] icon to browse for a tool file. For example, if you want to add the executable for the calculator, browse to C:\WINDOWS\system32\calc.exe.
5. If needed, click **Move Up** or **Move Down** to change the position of the new item in the menu.

6. Click **OK**. The tool appears in the tools menu.

**To delete a tool from the menu:**

1. In the *External Tools* dialog, highlight the tool to delete.
2. Click **Delete**.
3. Click **OK**.

**Related topics**

- [Customize the Toolbar](#) (on page 17)
- [Customize the Keyboard](#) (on page 19)
- [External Tools Manager](#) (on page 511)

### Customize the Toolbar

You can customize the toolbars by:

- Selecting toolbars to display
- Creating a new toolbar
- Adding a command to a toolbar
- Rearranging toolbar commands
- Deleting a command from a toolbar

**Note:** Click **Reset** to return to the default setting.

**To select toolbars to display:**

1. Select **Tools > Customize**. The *Customize* dialog displays.
2. Click the **Toolbars** tab.
3. In the **Toolbars** list, select or clear the required toolbar(s).
4. Click **Close**.

**To create a new toolbar:**

1. Select **Tools > Customize**. The *Customize* dialog displays.
2. Click the **Toolbars** tab.
3. Click **New**.
4. Assign a name to the toolbar, for example **Tools**.
5. Select a location from the drop-down list.
6. Click **OK**. The toolbar appears in the project toolbar.

**To add a command to a toolbar:**

1. Select **Tools > Customize**. The **Customize** dialog displays.
2. Click the **Commands** tab.
3. Click **Rearrange Commands**.
4. In the **Rearrange Commands** dialog, select the **Toolbar** option, then select a toolbar from the drop-down list.
5. Click **Add**.
6. In the **Add Command** dialog, select a category then the command that you want to add to the toolbar selected in the **Rearrange Commands** dialog.
7. Click **OK**.
8. Do one of the following:
   - Click **Close** to exit.
   - Click **Move Up** or **Move Down** to move the command if you want it in a different position.

**To rearrange toolbar commands:**

1. Select **Tools > Customize**. The **Customize** dialog displays.
2. Click the **Commands** tab.
3. Click **Rearrange Commands**.
4. In the **Rearrange Commands** dialog, select the **Toolbar** option, then select a toolbar from the drop-down list.
5. In the **Commands** area, highlight the toolbar command that you want to move.
6. To move the toolbar item, do one of the following:
   - Click **Move Up** to move the item up the toolbar list.
   - Click **Move Down** to move the item down the toolbar list.
   - Drag and drop items.
7. Click **Close** to exit.

**To delete a command from a toolbar:**

1. Select **Tools > Customize**. The **Customize** dialog displays.
2. Click the **Commands** tab.
3. Click **Rearrange Commands**.
4. In the *Rearrange Commands* dialog, select the *Toolbar* option, then select a toolbar from the drop-down list.

5. In the *Commands* area, highlight the toolbar command that you want to delete.

6. Click *Delete*.

7. Click *Close* to exit.

**Related topics**
- [Customize the Menu](#) (on page 15)
- [Customize the Keyboard](#) (on page 19)

### Customize the Keyboard

**To customize the keyboard:**

1. Select **Tools > Customize**. The *Customize* dialog displays.

2. Click *Keyboard*.

3. In the *Customize Keyboard* dialog:
   - To specify a command, select a category and a command.
   - To specify a shortcut, select a shortcut from the drop-down list.
   - To assign the shortcut to the command, click *Assign*.
   - To remove the shortcut from the command, click *Remove*.
   - To reset all shortcuts, click *Reset All*.

4. Click *Close*.

**Related topics**
- [Customize the Toolbar](#) (on page 17)
- [Customize the Menu](#) (on page 15)

### Customization Options and Tools

Customization allows you to configure and save a specific layout for your menus, toolbars, display settings and keyboard shortcuts. When more than one person uses the same computer, each user can create their own layout.

**Note:** In the *Options* dialog, if you set the *Window display mode* to *Multiple window views*, the last position of your windows is restored when you reopen a project. The restoration of window positions is not affected by customization. See *Pane and Data View Positioning* (on page 37).
To customize tools:

2. Click the Options tab. In this tab you can:
   - Personalize menus and toolbars
   - Select display options
3. Click the Custom Tools tab. In this tab, you can:
   - Create a new custom command and add its icon to a toolbar
   - Delete a custom command
   - Customize the keyboard

   **Tip:** If you customize, save it so that it is available the next time you use the office software.

4. Click the Save/Load tab. In this tab, you can:
   - Save a new layout or load a different custom layout
   - Customize the keyboard
5. When you have made the desired changes, click Close.

Related topics
- Customize the Toolbar (on page 17)
- Customize the Menu (on page 15)
- Customize the Keyboard (on page 19)

Troubleshoot a Toolbar or Menu Problem

Before calling Support, use any applicable solutions to known issues below.

<table>
<thead>
<tr>
<th>Symptom</th>
<th>Possible Cause</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>Toolbars are not in the same language as the installation.</td>
<td>The program was run in one language, and then reinstalled in a different language.</td>
<td>Reset the toolbars to the reinstalled language by loading the default layout. Select Tools &gt; Customize. In the Customize dialog, click Save/Load. In Default Layout, select Default Layout and click Load. Click OK in the New layout dialog.</td>
</tr>
</tbody>
</table>
Some text in the user interface (the units on the Status bar for instance) is in a different language. This only occurs when opening project files that were created in a different language.

The user interface text is being stored in the project file.

There is no solution at this time. Newly created projects will not have the problem, but it will remain in the original project file.

---

### Find Help Topics

Use this help system to find the information you need on the concepts, procedures, and options used in the software.

**To display the help system:**

- Select **Help > Search** to find topics by entering a keyword.
- Select **Help > Contents** to browse through topics and glossary items in a table of contents.
- Select **Help > Index** to find topics and glossary items alphabetically.
- Press [F1].

**To display context-sensitive help on a specific command:**

- Press [F1] while in the specific command or dialog.
- Right-click on a command in the Command pane's **All Commands** list, and select **Help** from the context menu.

**To print a help topic:**

- Click the icon.
- Right-click on a topic in the Help window, and select **Print** from the context menu. Then select **Print > Print the selected topic** from the context menu.
- To print a topic and all of its associated subtopics, select the topic, and select **Print > Print the selected heading and all subtopics** from the context menu.

**Related topics**

- **Help Options** (on page 22)
Help Options

Use these options to find information and answers on the concepts, procedures, and options covered in the help system. They are available in the help dialog.
Tabs

Contents
Click this tab to show all of the help topics in a tree structure. Click a chapter or topic to view it.

Search
Type a keyword in the search box. Then, click List Topics to search for any occurrence of the word in the help topics. Select a topic in the search results, and click Display to open it. The word you search on is highlighted in each help topic. See the Search highlight on/off option below.

1. The Find Setup wizard may appear. If it does, select the Minimize database size option and click Next. Then click Finish.

2. In the Type the word(s) you wish to find box, enter the word or phrase that you want to find.

3. If necessary, in the Select matching word(s) to narrow the search box, enter a word to narrow the search.

In the Choose topic to display box, select a topic. It will be displayed in the right side of the Help window.

Menu options

Hide/show tabs
Click this to hide the Contents and Search tabs.

Back
Click this to view the previous topic.

Print
Click this to display the Print Topics dialog. Select an option to either print just the selected topic, or the heading and all subtopics.

Stop
Click this to end a search function.

Refresh
Click this to reset the display of the current page.

Internet options
Click this to display the Internet Options dialog, where you can set security, privacy, content, connections, programs, and other settings for the Internet.

Search highlight on/off
Click this to enable/disable the highlighting of each instance of the keyword in searched topics.

Related topics
- Find Help Topics (on page 21)
View, Navigate, and Select

Graphic Views

Plan View

The plan view is the default view for your project data. It displays a graphical view from above, as in a map display. Multiple plan views can be opened at the same time. The data that is visible in graphics views is controlled by the view filter (see "Filter a View" on page 85).

Within the plan view you can:
View, Navigate, and Select

- Pan and zoom to explore the data.
- Select objects to view their properties or start a command.

Related topics

- [2D View Navigation](on page 41)
- [Data View Display Formats](on page 38)
- [Pane and Data View Positioning](on page 37)
- [Select from the 2D Views](see "Select from 2D Views" on page 50)
- [Tabbed View Arrangement](on page 40)

Profile View

Profile View

Use the profile view to check the geometry of a vertical alignment. The profile view displays a vertical, graphic view of a single, specific alignment. When the alignment that the view is based on is modified or deleted, the view updates accordingly.

![Profile View Diagram]

The bold vertical line at 120 denotes a station equation.

Related topics

- [2D View Navigation](on page 41)
- [Create an Alignment](see "Understanding Alignments" on page 382)
- [Data View Display Formats](on page 38)
- [Pane and Data View Positioning](on page 37)
- [Select from the 2D Views](see "Select from 2D Views" on page 50)
- [Tabbed View Arrangement](on page 40)

Cross-Section View

Use the cross-section view to check surface cross-section geometry along a single, specific alignment anywhere it coincides with a single, specific surface. The cross-section view is a vertical, graphic view that changes depending on where you are along the alignment. When the alignment or surface that the view is based on is modified or deleted, the view updates accordingly. Multiple cross-section views can be open concurrently.
Red tic marks denote where the cross-section crosses points or breaklines. Bold vertical lines (not shown) denote station equations. At some view magnifications, the slope value is shown for each segment of the cross-section.

Related topics

- **Create and View a Cross-Section** (see "Create and View a Surface Cross-Section" on page 422)
- **2D View Navigation** (on page 41)
- **Data View Display Formats** (on page 38)
- **Pane and Data View Positioning** (on page 37)
- **Select from the 2D Views** (see "Select from 2D Views" on page 50)
- **Tabbed View Arrangement** (on page 40)

**Surface Slicer View**

Use the surface slicer view to check any surface by slicing vertically through it to create a ‘quick profile’. Multiple surface slicer views can be open at a time, and you can view multiple surfaces in the view concurrently.

Red tic marks denote where the surface slice crosses points or breaklines. At some view magnifications, the slope value is shown for each segment of the profile.

Related topics

- **View a Slice of a Surface** (on page 423)
- **Create and View a Cross-Section** (see "Create and View a Surface Cross-Section" on page 422)
3D View

Use the 3D view to visualize your project data from pre-defined viewpoints, or by rotating the view. You can set a point around which the view rotates, and exaggerate the vertical scale to see changes in topography more easily using the 3D View Settings (on page 44). You can also select objects in the 3D view using the standard graphic selection methods (on page 49).

The 3D view includes a compass triad with north, east, and Z axes to help you stay oriented in the view.

The performance of the 3D view may vary based on your system settings. If you have trouble, try these fixes:

1. Right-click on your desktop and select Properties from the context menu. The Display Properties dialog displays. Click the Settings tab. Select a different/higher setting in the Color quality list. Click OK.

2. Right-click on your desktop and select Properties from the context menu. The Display Properties dialog displays. Click the Settings tab. Click Advanced. The Plug and Play dialog displays. Click the Troubleshoot tab, and move the Hardware Acceleration slider to/near Full. Click OK, and OK again.

Tip: To reduce clutter in the 3D view, you can hide 2D objects or objects with a zero elevation. This can be set in Project Settings by selecting Project > Project Settings. Then click View and 3D View in the left pane to access the settings.

Note: Microsoft® DirectX® does not work over Microsoft® NetMeeting®. The 3D view uses DirectX® and will show a blank view when attempting to use it across either communication tool.
Spreadsheets and Other Views

Points Spreadsheet

The points spreadsheet view lists the survey points in the current project, enabling you to easily edit the data. The plan view and the Properties pane reflect all changes made to data in the point spreadsheet view.

Using the spreadsheet

- **To select a point**, click in the left column for that row.

- **To display more detail on a point** in the Properties pane, select the point and press [F11], or right-click and select Properties.

- **To edit a point’s ID, coordinate, elevation, or feature code**, select it by clicking on the cell. You can also tab from cell to cell and simply type over the value in the cell.

- **To sort points based on a criteria**, click on a column heading. Up ▲ or down ▼ icons appear on the selected column heading, indicating the current sort order (ascending or descending).

- **To filter the point data**, click on the ▼ icon at the top of the column and select an option from the drop-down menu.

  **Note:** If the filter for a column is active, the icon ▼ appears blue.
**View, Navigate, and Select**

- **To copy data to a text editor**, such as Microsoft® Notepad, select data, and copy and paste by using the right-click menu or by pressing [Ctrl] + C to copy and [Ctrl] + V to paste. You can select all data by pressing [Ctrl] + A.

- **To change the order of columns** across the spreadsheet, click and drag the column heading to a new location.

**Related topics**

- [Data View Display Formats](on page 38)
- [Pane and Data View Positioning](on page 37)
- [Select from Spreadsheet Views](on page 52)
- [Tabbed View Arrangement](on page 40)
- [Create a Point](on page 365)

**Occupation Spreadsheet**

The occupation spreadsheet view lists the GNSS occupations in the current project, enabling you to easily edit the data. The plan view and the **Properties** pane reflect all changes made to data in the spreadsheet view.

**Note:** To change the data that is displayed in the occupation spreadsheet, use the **Project Settings** command.

**Using the spreadsheet**

- **To select an occupation**, click in the left column for that row.

- **To display more detail** on a occupation in the **Properties** pane, select the occupation and press [F11], or right-click and select **Properties**.

- **To edit a cell**, select it by clicking on the cell and make the edit. The edits will be applied when you leave the row.

**Note:** Grayed out cells are not editable.
**View, Navigate, and Select**

- **To sort the entries**, click on a column heading. Up ▲ or down ▼ icons appear on the selected column heading, indicating the current sort order (ascending or descending).

- **To filter data**, click on the ☑ icon at the top of the column and select an option from the drop-down menu.

  **Note:** If the filter for a column is on, the icon ☑️ appears blue.

- **To copy data to a text editor**, such as Microsoft® Notepad, select data, and copy and paste by using the right-click menu or by pressing [Ctrl] + C to copy and [Ctrl] + V to paste. You can select all data by pressing [Ctrl] + A.

- **To change the order of columns** across the spreadsheet, click and drag the column heading to a new location.

**Related topics**

- Data View Display Formats (on page 38)
- Pane and Data View Positioning (on page 37)
- Select from Spreadsheet Views (on page 52)
- Tabbed View Arrangement (on page 40)

**Vector Spreadsheet**

The vector spreadsheet lists the vectors in the current project. Except for enabling and disabling the **Vector Status**, the spreadsheet data cannot be edited. The data can, however, be sorted by clicking at the top of any column. The plan view and the **Properties** pane reflect all changes made to data in the vector spreadsheet view. For details on columns in the vector spreadsheet, see **View Settings** (on page 161).

**To create a new vector spreadsheet:**

Do one of the following:

- Select View > New Vector Spreadsheet.

- Click the ☑️ icon.

  A new vector spreadsheet appears listing the processed vectors in the project.

**To navigate the spreadsheet:**

- **To select a vector**, click in the left column for that row.
To display vector details:

- Select the vector (click on the left edge of the row) and press [F11] or right-click and select Properties. The Properties pane displays.

Note: The Delta X, Y, and Z values in the Vector Spreadsheet and the Vector List report reflect the distance from survey marker to survey marker, so Vector Length shows the distance of the ground slope. To see the Delta X, Y, and Z between antenna phase centers, view the vector’s properties in the Properties pane.

To sort entries:

- Click on a column heading. An up or down icon appears in the selected column heading, indicating the current sort order (ascending or descending).

To copy data:

- Select data, and copy and paste it to a text editor (such as Microsoft® Notepad) by using the context menu or by pressing [Ctrl] + [C] to copy and [Ctrl] + [V] to paste. You can select all data by pressing [Ctrl] + [A].

To manage column display:

- Select Project > Project Settings. Then click View and Vector Spreadsheet. For each type of data, select to Show or Hide the column in the spreadsheet. To change the order of columns across the spreadsheet, click and drag the column heading to a new location.

Related topics

- Data View Display Formats (on page 38)
- Pane and Data View Positioning (on page 37)
- Select from Spreadsheet Views (on page 52)
- Tabbed View Arrangement (on page 40)
Time-Based View

The time-based view displays your data in a chronological format that makes it easy to visualize how session and occupation times relate to each other, helping you check for valid sessions.
Elements of the Time-Based View

1 - Timeline
Displays the span of one or more occupations in GPS time. The default view shows the time span for all project data, from the first occupation’s start time to the end time of the last occupation. When you zoom to specific session data, the timeline changes to reflect the new time span. The current time format is displayed on the status bar. Click it to access GPS time settings in the Units section of the Project Settings dialog.

2 - Sessions list
Lists all of the sessions in chronological order, from the earliest to the latest session in the project. This list is similar to the session tree in the Project Explorer. Each session is defined by two concurrent or overlapping occupations.

Note: Continuous files from CORS stations are often logged, and import, in one-hour increments. Once they have been imported, however, they are concatenated (joined sequentially) into the single observation they represent.

3 - Session icon
Indicates whether the session is a static or kinematic session

\[ \text{\sigma} \text{ static} \]

\[ \text{\omega} \text{ kinematic} \]

4 - Point ID of Upper Occupation
Identifies the upper occupation in the session. In the example, it is the blue bar in the view. The same occupation can be represented in multiple sessions.

5 - Point ID of Lower Occupation
Identifies the lower occupation in the session. In the example, it is the green bars in the view.

6 - Chronological view
Plots each of the sessions, from start time to end time, in relation to the timeline. When you move the cursor in the chronological view, the timeline displays the exact time represented by the pointer’s position.
7 - Static occupation

Each occupation is graphically represented from start time to end time, in relation to the timeline and its session.

When you hover over an occupation in the chronological view, a tooltip displays the point ID and the duration of the occupation.

Clicking an occupation highlights and adds a border to it in all sessions, enabling you to see the relationship between sessions.

For static sessions, each bar represents a single occupation.

8 - Kinematic session display

The bar is broken to show stop-and-go occupations and/or continuous segments.

Occupation colors

Blue
Static occupation, generally at the base station

Green
Static occupation, generally at the rover

Yellow
Kinematic occupation - continuous segment

White
Kinematic occupation - roving segment

Related topics

- Check Sessions (on page 286)
- Time-Based View Options (on page 286)
- Session Editor (on page 34)

Session Editor

When you find gaps in your GPS data in the time-based view, encounter sessions that won't process in the Baseline Processor, or have floating lines reported on the Processor Report, use the Session Editor to visually analyze the quality of the raw satellite data in a session. Gaps in the data could indicate antenna measurement errors, satellite signal cycle slips, invalid range errors, and other signal loss problems. To improve the quality of your processed baselines, use the Session Editor to:
- Disable unhealthy satellites
- Mask bad sections of satellite data
- Adjust occupation times

**Elements**

**Title bar**
This shows the name of the session you are viewing.

**Timeline**
This displays the times for each of the satellites used in the session. The default view shows the time span for all of the satellites, from the first occupation's start time to the end time of the second occupation. When you zoom to specific data, the timeline changes to reflect the new span.

**Satellite list**
This lists the satellites that contributed data to the session.
- GPS satellite names begin with G.
- GLONASS satellite names begin with R.

**Satellite ID**
This shows the name of the satellite.

**Time slot information**

- **Satellite** - This displays the name of the satellite you are editing.
- **Start time** - Edit the beginning of the cross-out.
- **End time** - Edit the end of the cross-out.

Click the **Apply Time Edits** button for these changes to take effect.

**Chronological view**
This plots each of the satellites, and the times they were visible in each of the two occupations in the session. Tick marks denote the beginnings of segments within occupations.

When you move the cursor in the view, the timeline displays the exact time represented by the cursor's position.

**Disabled satellite**
Gray indicates that a satellite has been disabled so it will not be considered in baseline processing.

**Time slot**
Cross-outs indicate that a section of the satellite data has been masked so it will not be considered in baseline processing.

**View session extents**
Enable this to display only the extent of the session (overlap of the occupations).

**Color Key**

- **Blue bar**
  Static occupation, generally at the base station
- **Green bar**
  Static occupation, generally at the rover

**Related topics**

- [Check Sessions](on page 286)
- [Edit Sessions](on page 287)
- [Session Editor Options](on page 291)
- [Time-Based View](on page 32)
Alignment Editor

The Alignment Editor enables you to edit the horizontal, vertical, and stationing values of existing alignments. The graphic views reflect all changes made to alignments in the editor.

<table>
<thead>
<tr>
<th>Type</th>
<th>North Azimuth</th>
<th>Radius</th>
<th>Lt / Rt</th>
<th>Length</th>
<th>Delta</th>
<th>A Param</th>
<th>Station</th>
<th>North</th>
<th>East</th>
</tr>
</thead>
<tbody>
<tr>
<td>POB</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>-0+048.0</td>
<td>289423.659</td>
<td>392776.747</td>
</tr>
<tr>
<td>Arc</td>
<td>83°18'04&quot;&quot;</td>
<td>464.425 Right</td>
<td>29.051</td>
<td>3°35'02&quot;&quot;</td>
<td></td>
<td></td>
<td>-0+019.8</td>
<td>289426.143</td>
<td>392805.687</td>
</tr>
<tr>
<td>Line</td>
<td>80°45'24&quot;&quot;</td>
<td></td>
<td>70.321</td>
<td></td>
<td></td>
<td></td>
<td>0+050.49</td>
<td>289437.439</td>
<td>392875.094</td>
</tr>
<tr>
<td>Spiral</td>
<td>63°23'31&quot;&quot;</td>
<td>370.000 Left</td>
<td>65.188</td>
<td></td>
<td></td>
<td></td>
<td>0+115.68</td>
<td>289468.332</td>
<td>392932.472</td>
</tr>
<tr>
<td>Arc</td>
<td>58°20'10&quot;&quot;</td>
<td>370.000 Left</td>
<td>39.451</td>
<td>6°06'33&quot;&quot;</td>
<td></td>
<td></td>
<td>0+155.13</td>
<td>289490.790</td>
<td>392964.884</td>
</tr>
<tr>
<td>Spiral</td>
<td>52°13'37&quot;&quot;</td>
<td>370.000 Left</td>
<td>65.188</td>
<td></td>
<td></td>
<td></td>
<td>0+220.32</td>
<td>289533.661</td>
<td>393013.962</td>
</tr>
<tr>
<td>Line</td>
<td>47°10'47&quot;&quot;</td>
<td></td>
<td>296.002</td>
<td></td>
<td></td>
<td></td>
<td>0+516.32</td>
<td>289734.854</td>
<td>393231.077</td>
</tr>
<tr>
<td>Spiral</td>
<td>37°49'42&quot;&quot;</td>
<td>400.000 Right</td>
<td>60.299</td>
<td></td>
<td></td>
<td></td>
<td>0+576.62</td>
<td>289781.526</td>
<td>393329.233</td>
</tr>
<tr>
<td>Arc</td>
<td>42°06'49&quot;&quot;</td>
<td>400.000 Right</td>
<td>6.879</td>
<td>0'59'07&quot;&quot;</td>
<td></td>
<td></td>
<td>0+583.50</td>
<td>289786.586</td>
<td>393323.893</td>
</tr>
<tr>
<td>Spiral</td>
<td>43°07'56&quot;&quot;</td>
<td>400.000 Right</td>
<td>60.299</td>
<td></td>
<td></td>
<td></td>
<td>0+643.80</td>
<td>289828.454</td>
<td>393317.266</td>
</tr>
<tr>
<td>Spiral</td>
<td>47°27'03&quot;&quot;</td>
<td>265.000 Left</td>
<td>91.018</td>
<td></td>
<td></td>
<td></td>
<td>0+734.82</td>
<td>289933.652</td>
<td>393380.605</td>
</tr>
<tr>
<td>Arc</td>
<td>37°36'41&quot;&quot;</td>
<td>265.000 Left</td>
<td>79.408</td>
<td>1'7&quot;10'08&quot;&quot;</td>
<td></td>
<td></td>
<td>0+814.23</td>
<td>289962.826</td>
<td>393418.992</td>
</tr>
<tr>
<td>Line</td>
<td>20°26'33&quot;&quot;</td>
<td></td>
<td>50.009</td>
<td></td>
<td></td>
<td></td>
<td>0+864.24</td>
<td>290003.686</td>
<td>393436.458</td>
</tr>
</tbody>
</table>

Related topics

- [Edit an Alignment](#) (on page 386)
- [Data View Display Formats](#) (on page 38)
- [Pane and Data View Positioning](#) (on page 37)
- [Tabbed View Arrangement](#) (on page 40)

Report View

The Report View displays when you run certain reports. Along with the content of the report, the view includes a toolbar located along the top of the tab that allows you to:
- Navigate to a specific page in the report
- View and change the print setup information
- View the print layout and print the report
- Export the report to a spreadsheet or PDF document
- Select a magnification to view the report
- Search for text in the report

Related topics
- Tabbed View Arrangement (on page 40)

Pane and Data View Positioning

Control when and where panes and views display by pinning, floating, and docking them. Unpin panes to allow them to slide out of view when they are not being used. Pin panes to keep them open. Float views to move them around the screen for the best arrangement. Dock views to attach them to an edge of the application window.

To pin and unpin (AutoHide) panes:

- To pin an open pane, click the icon at the top of the pane.
- To unpin a pane, click on the icon. If the pane is unpinned, the pane can "slide" to the side and out of view. To display the pane again, hover the cursor over the vertical tab.

To float and dock panes and views:

By default, most panes display docked, that is, locked to one side of the application window.

- To float a docked pane, right-click on its titlebar and select Floating from the context menu. You can also click on the titlebar and drag the pane to float it.
- To float a spreadsheet, editor, or other view, right-click beneath the titlebar and select Float View. The floated view can even be dragged to an adjacent monitor if you are running dual monitors.

**Note:** Graphic views, such as the plan, 3D, and profile view, cannot be floated.

- To dock a floating pane, right-click on its titlebar and deselect Floating. You can also click on its title bar and drag it to a docked position along any edge of the application window.

**Note:** The docking location is determined by the position of the cursor when it intersects the edge of the application window.
To dock a floating spreadsheet, editor, or view, right-click on the body of the view (not on its titlebar) and select Unfloat View.

Related topics
- Data View Display Formats (on page 38)

Data View Display Formats

You can control how data views are displayed, by arranging them as one or two groups of tabbed views, or as one or more tiled or cascaded views. Using multiple views let you easily view different parts of your project concurrently, and from different perspectives.

To change the data view format:

1. Select Tools > Options. The Options dialog displays.
2. Select a display format in the Display with box.

Note: There are Window menu options for more tabbed view options.
Data display options

Tabbed views (SDI)
Displays one view in the view area at a time, with tabs at the top to access additional views.
To change views, click a tab.

Multiple views (MDI)
Displays one or more views at a time
- To change views, click on the title bar of the view you want; the active title label is dark blue.
- To tile or cascade the views, select **Window > (option)**.

This image displays the multiple data views displayed in a tabbed format.
This image displays the multiple data views in an MDI format.

Related topics

- Pane and Data View Positioning (on page 37)
- Startup and Display Options (on page 148)
- Tabbed View Arrangement (on page 40)

**Tabbed View Arrangement**

When you are working with tabbed views, you can display the views in two or more groups (windows), arranged either horizontally or vertically. The command is active under these conditions:
Data view display is set to tabbed view (SDI) format in **Options**.

At least 2 views (tabs) are present.

**To display tabbed views in multiple groups:**

- Select **Window > New Horizontal Tab Group**.
- Select **Window > New Vertical Tab Group**.
- Click the tabbed view icon on the toolbar.
- Click the tabbed view icon on the toolbar.
- The tabbed views are divided and arranged accordingly.

You can also move tabs from one group to the other group of tabs. It is only active in data view under these conditions:

- Data view display is set to tabbed view (SDI) format in **Options**.
- At least 3 views (tabs) are present (for example, 2 plan views and a point spreadsheet view).
- The 3 views are separated into 2 groups.

**To move a tabbed view to the next or previous group:**

- Click the tab to move, and then select **Window > Move to Next Tab Group**. The tabbed view moves to the next group of tabbed views.
- Click the tab to move, and then select **Window > Move to Previous Tab Group**. The tabbed view moves to the next group of tabbed views.

**Related topics**

- Data View Display Formats (on page 38)
- Pane and Data View Positioning (on page 37)
- Startup and Display Options (on page 148)

**2D View Navigation**

Use these options and keyboard combinations to change what is displayed in the plan and alignment profile views.

**To pan the view:**

Use this to shift a different area of the screen to the center of the view.
- Click and drag the mouse wheel (or middle mouse button).

- Click the 👝 icon on the toolbar, or select View > Pan. Click and drag from one point to another point in the plan view.

**Tip:** When using a laptop without a mouse, click the 👝 (left mouse pan) on the toolbar. You can also press and hold both the left-click and right-click buttons while moving the cursor.

**To zoom in:**

Use this to display a smaller area of the plan view, in more detail.

- Click the 🔍 icon on the toolbar.
- Click in a view, and roll the mouse wheel forward.
- Select View > Zoom > Zoom In.

**To zoom out:**

Use this to display a larger area of the plan view, in less detail.

- Click the 🔍 icon on the toolbar.
- Click in a view, and roll the mouse wheel backwards.
- Select View > Zoom > Zoom Out.

**To zoom into a certain area:**

Use this to display the data within a box you draw in the view.

- Press [Ctrl] + [Alt], and click and drag around an area.

- Click the 🔍 icon on the toolbar, or select View > Zoom > Zoom. Click and drag around the area you want to display in the view.

**To zoom to the extents of your data:**

Use this to zoom to the limits of your visible data.
• Click the icon on the toolbar.
• Double-click the mouse wheel (or middle mouse button).
• Select View > Zoom > Zoom Extents.

To center a selected point in the plan view:

• Select one or more points in the Project Explorer or the plan view. Right-click, and select Center from the context menu.
• Select one or more points in the Project Explorer or the plan view, and select View > Center.
• Select View > Center. The Center command pane displays. Pick a point in the plan view, or type a point ID in the Point box.

Related topics

• 3D View Navigation (on page 43)
• Plan View (on page 24)
• Mouse Modes (on page 48)

3D View Navigation

Use these keyboard and mouse combinations to change your viewpoint in the 3D view.
**3D view**

**Pan**
Click the mouse wheel (or middle mouse button) and drag.

**Zoom in/out**
Roll the mouse wheel.

**Zoom extents**
Double-click the mouse wheel (or middle mouse button).

**Note:** Zooming extents restores the vertical exaggeration back to its original value.

**Vertical scale**
Press [Ctrl] + [Shift], and roll the mouse wheel to exaggerate differences between elevations used in a surface.

The exaggeration value displays in the **Scale** box of the 3D View Settings command pane. To restore the original vertical exaggeration, type 1 in the box.

**Rotate horizontal**
Press [Ctrl], and roll the mouse wheel to turn the view around the X axis.

The value displays in the **Elevation** box of the 3D View Settings command pane.

**Rotate vertical**
Press [Shift], and roll the mouse wheel to turn the view around the Z axis.

The value displays in the **Azimuth** box of the 3D View Settings command pane.

**Free rotation**
Press [Ctrl], and click and drag the mouse wheel to rotate the view freely in any direction.

**Related topics**
- [2D View Navigation](on page 41)
- [3D View](on page 27)
- [3D View Settings](on page 44)
- [Mouse Modes](on page 48)

**3D View Settings**

Use these settings to change your viewpoint, and the vertical scale in the 3D view. The compass triad in the bottom, left corner of the view shows the current orientation. By default, the 3D view rotates around the center of the view, which is usually the center of the bounding volume of the data in your project.

**Tip:** To reduce clutter in the 3D view, you can hide 2D objects or objects with a zero elevation. This can be changed in Project Settings by selecting **Project > Project Settings**. Then click **View** and **3D View** in the left pane to access the settings.
To access pre-defined 3D views and settings:

- Select View > 3D View Settings. The 3D View Settings command pane displays.

**Options**

**Preset views**
Click an arrow icon to switch to one of nine predefined, orthographic or isometric views.
The view names refer to the direction the view is facing.

**Rotation**
Use these values to rotate the viewpoint. Entering zero in both boxes makes the view equivalent to the plan view.

**Elevation**
Drag the vertical slider, or type a value in the box, to rotate the view on the X axis.

**Azimuth**
Drag the horizontal slider, or type a value in the box, to rotate the view on the Z axis.

**Vertical scale**

**Scale**
Drag the horizontal slider, or type a value in the box, to increase the difference between elevations. The scale is the factor by which all elevations in the project are multiplied.

**Min**
Set the minimum and maximum exaggeration values in the boxes at either end of the slider.

**Max**

To change the point around which the view rotates:

1. Select View > 3D View Settings. The 3D View Settings command pane displays.
2. Click Top in the Preset Views group.
3. Pan the point around which you want to rotate into the center of the view.
4. Press [Ctrl] and roll the mouse wheel until the view is perpendicular to the plan view.

**Tip:** You can watch the compass triad to determine when the view is perpendicular.

5. Pan the point around which you want to rotate into the center of the view again.
6. Check the new rotation point by pressing [Ctrl], and clicking and dragging the mouse wheel to rotate the view.

Related topics

- 2D View Navigation (on page 41)
- 3D View (on page 27)
- 3D View Navigation (on page 43)
- Mouse Modes (on page 48)
Keyboard Navigation

Use the keyboard to navigate the application and perform tasks if it is easier for you than using a mouse.

Shortcut keys

[F1] Displays the Help window.

[F2] Toggles grid cells in spreadsheets and dialogs between editable and uneditable. When a cell is editable, the arrow keys move the insertion point within the cell. When a cell is uneditable, the arrow keys move the focus from cell to cell.

[F4] Computes the current project.

[F5] Switches the left mouse button to select mode.

[F6] Switches the left mouse button to rotate mode.

Note: This mode only works in 3D views. If you select this mode in 3D view, it reverts to the Select mode when in plan view.

[F7] Switches the left mouse button to pan mode.

[F8] Switches the left mouse button to zoom mode.

Displays or hides the Project Explorer.

[F9]
[F10] Displays or hides the **Device** pane.

[F11] Displays the **Properties** pane.

[F12] Displays or the **Command** pane.

**Note:** [F11] and [F12] toggle between the **Command** and **Properties** panes.

**Other keys**

- **[Enter]**
  For commands with an **OK** button, this initiates the command.

- **[Esc]**
  When the command pane has focus, this clears the most recent command from the stack.

  In the **Properties** pane, this cancels an edit, reverting the property to its original value.

- **[Tab]**
  Accepts the current value, and advances to the next control or button.

- **[Shift] + [Tab]**
  Accepts the current value, and moves to the previous control or button.

- **[Space]**
  Accepts the highlighted button.

  Opens advanced dialogs when you have tabbed into certain controls:
  - Color list - Opens the Color dialog.
  - Layer list - Opens the New Layer dialog.
  - Line Style list - Opens the Line Style Manager.
  - Select box - Opens the Advanced Select command pane.

- **[Ctrl] + [Tab]**
  Lets you select any of the active views, panes, or commands.

- **[Ctrl] + [Shift] + [Tab]**
  Lets you select any of the active views, panes, or commands.

- **[Ctrl] + [↑] or [↓]**
  Navigates within groups.

  Press [Ctrl] + [↑] to move up to the previous folder in **Project Settings** (and similar lists).

- **[Ctrl] + [←] or [→]**
  Expands or contracts groups in the **Project Explorer** and the **Properties** pane.

- **[Shift] + [F10]**
  Displays the context menu when you are in a control (box).

- **[Ctrl] + [D]**
  Deletes selected objects from a project.

**Related topics**

- [2D View Navigation](#) (on page 41)
Mouse Modes

Activate different modes to control what the left-mouse button does in graphic views. These modes are essential when you are using a laptop, or a mouse with no wheel/center button. They are available on the mouse toolbar.

Options

- Click this to pick objects when you click or click and drag the left mouse button. You can also press [F5] to switch to the select mouse mode.
- Click this to rotate the view when you click and drag the left mouse button. You can also press [F6] to switch to the rotate mouse mode.
  
  **Note:** This mode only works in 3D views. If you select this mode in 3D view, it reverts to the select mode when in plan view
- Click this to move the view in a planar way when you click and drag the left mouse button. You can also press [F7] to switch to the pan mouse mode.
- Click this to zoom in or out when you click and drag the left mouse button. You can also press [F8] to switch to the zoom mouse mode.

Data Selection

Select objects by picking them in graphic views or spreadsheets, selecting menu options, or using keyboard combinations. Objects that you select highlight in graphic views, spreadsheets, and the Project Explorer, depending on which you have open. The number of objects selected appears on the status bar at the bottom of the application window.

**Note:** To set the visibility and selectability of objects, create a new view filter in the View Filter Manager (see "Filter a View" on page 85).

Related topics

- 2D View Navigation (on page 41)
- 3D View Navigation (on page 43)
- Graphic Selection Methods (on page 49)
Selection Methods and Options

Use these options to choose a selection method. They are available in the Select menu and through the Options button, which is available in various commands. Objects set to visible and selectable in the current view filter can be selected.

**Note:** The number of objects currently selected displays on the status bar at the bottom of the window.

**Options**

**Select All**

Use this to select all of the visible and selectable objects (as set in the current view filter) in the views and spreadsheets.

You can also press [Ctrl] + [A] to select all objects.

**Invert Selection**

Use this to deselect the currently selected objects, and select the currently unselected objects visible in the view.

**Select Points**

Use this to select points with specific properties.

**Select Duplicate Point Identifiers**

Use this to select points with the same point IDs, often prior to merging duplicate points.

**Select Observations**

Use this to select survey observations with specific properties.

**Select Unprocessed Sessions**

Use this to select all sessions for which baselines have not been processed.

**Select by Elevation Range**  
(on page 62)

Use this to select data within, or outside of, a specific elevation range.

**Select by Layer**  
(on page 63)

Use this to select data by its layer.

**Advanced Select**  
(see "Select Using Advanced Criteria" on page 63)

Use this to select data from the entire data set using a custom set of criteria.

Related topics

- Select from the 2D Views (see "Select from 2D Views" on page 50)
- Select from the 3D View (on page 51)
- Select from Spreadsheet Views (on page 52)
- Select from the Project Explorer (on page 54)
- View Filter Manager Command

Graphic Selection Methods

Select objects by clicking and dragging in graphic views in these ways:
Options

**Windowing**
Click and drag a box from left to right. All of the objects **entirely within the box** are selected.

**Crossing**
Click and drag a box from right to left. All of the objects **within the box and crossed by the box** are selected.

In graphic views, there are also two context menu options that you can access by right-clicking when you have data selected.

- **Previous selection**
  Select this to clear the current selection and reselect the objects last selected.

- **Clear selection**
  Select this to deselect all objects.

The appearance of the cursor will change in graphic views, depending on the control you are using. When you are using a COGO control, the name of the control will also appear on the status bar. The status line's tooltip lists ways in which you can use the control.

**Cursor types**

- **Pick any point.**
- **Pick any point or applicable object (arc, line, segment, point).**
- **Pick any applicable object.**
- **No anchor point has been defined.**
- The pick function is unavailable, or the object you are trying to pick is invalid. Often, you can click a blank space in the Project Explorer to refresh the pick cursor for the graphic views.

**Related topics**

- [Select from the 2D Views](#) (see "Select from 2D Views" on page 50)
- [Select from the 3D View](#) (on page 51)
- [Selection Methods and Options](#) (on page 49)

**Select from 2D Views**

Select objects in the plan and profile views using these standard methods, or graphic selection methods.
To select all objects:

- Select Select > Select All.
- Press [Ctrl] + [A].

To select individual objects:

- Move the cursor over an object in the view and click. If there is more than one object within the pick aperture, a list of objects from which you can select appears. Select the object you need.
- Click the name of the object in the Project Explorer.

To select a group of points or observations:

- [Ctrl] + click - to add an object to the selection set
- [Shift] + [Ctrl] + click - to remove an object from the selection set
- Click and drag (from left to right) - to select objects within the window.
- Click and drag (from right to left) - to select all objects within or crossed by the window.

To undo a selection:

- Right-click and select Clear Selection from the context menu - the last object selected will be removed from the selection.
- Click any blank space in a graphic view. This deselects everything.

To clear the selection:

- Right-click the selected point or group of points and select Clear Selection.
- Click in an empty area of a graphic view.

Related topics

- 2D View Navigation (on page 41)
- Graphic Selection Methods (on page 49)
- Filter a View (on page 85)

Select from the 3D View

Select objects in 3D views using these standard methods, or graphic selection methods.
To select all objects:

- Select **Select > Select All**.
- Press `[Ctrl] + [A]`.

To select individual objects:

- Move the cursor over an object in the view and click. If there is more than one object within the pick aperture, a list of objects from which you can select appears. Select the object you need in the list.
- Click the name of the object in the **Project Explorer**.

To select a group of points or observations:

- `[Ctrl] + click` - to add an object to the selection set.
- **Click and drag (from left to right)** - to select objects within the window.
- **Click and drag (from right to left)** - to select all objects within or crossed by the window.
- `[Shift] + [Ctrl] + click` - to remove an object from the selection set.

To undo a selection:

- Right-click and select **Clear Selection** from the context menu. The last object selected is removed from the selection set.
- Click any blank space in a graphic view.

To clear a selection:

- Right-click the selected point or group of points and select **Clear Selection**.
- Click in an empty area of a graphic view.

Related topics

- **3D View** (on page 27)
- **3D View Navigation** (on page 43)
- **3D View Settings** (on page 44)
- **Graphic Selection Methods** (on page 49)

**Select from Spreadsheet Views**

To select individual or multiple points or vectors in a spreadsheet (see "Points Spreadsheet" on page 28) view, use the mouse. Selected objects also highlight in graphic views, and the **Project Explorer**. The number of selected points or vectors appears on the status bar at the bottom of the application window. Edits in a spreadsheet cell are reflected in the **Properties Pane** after you exit from the cell.
To select a single point or vector:

- Click the gray box on the left of the row:

  ![Point Spreadsheet](image)

  Note: When you edit northing, easting, and elevation values in a point spreadsheet view, the quality of the point is upgraded to Control.

To select multiple points or vectors:

- To select a series of rows, click the first row in the series, press [Shift], and click the last row in the series. All rows in-between are selected.
- To select multiple, separate rows, press [Ctrl] + click on each individual row to add to the selection.
- To select all rows, right-click anywhere in the spreadsheet and select Select All from the context menu.

  Note: To edit the feature code for multiple points, use the Properties pane.

To undo a selection:

- Click any cell.
- Right-click and select Undo Selection from the context menu - the last object selected will be removed from the selection set.

To delete a selected row:

- Right-click the selected row and select Delete from the context menu.

Related topics

- Point Spreadsheet (see "Points Spreadsheet" on page 28)
- Select Observations (on page 58)
- Select Points (on page 55)
- Select Unprocessed Sessions (on page 62)
- Vector Spreadsheet (on page 30)
Select from the Flags Pane

Select one or more objects from the Flags pane if the objects have been flagged with import or computation errors. If there are no objects in the Flags pane, no objects have been identified as having errors.

**Tip:** The number of objects selected appears on the status bar at the bottom of the application window.

To display the Flags pane:

- Select View > Flags Pane.
- Click the  icon (appears in the toolbar and on the status bar)

**Note:** Press [F11] or click the  icon to display the Properties pane. Within the properties dialog, you can edit the errors. Click on a data object in the Flags pane to display its properties.

To select flagged objects:

- To select an individual object, click on the left edge of the row.
- To select multiple objects, do one of the following:
  - Click the first row of the series, hold [Shift], and click the ending row of the series.
  - Hold [Ctrl] and click individual rows to add these rows to the selection.

The selected points now appear highlighted in the plan view.

Related topics

- Compute Project Command
- Flags Pane (on page 13)
- Run an Import Summary Report (see "Run an Import Report" on page 261)

Select from the Project Explorer

The Project Explorer displays your project data organized in a tree structure. The number of objects selected appears on the status bar at the bottom of the application window.

To select objects:

- To select an individual object, click on the object.
- To select multiple objects, do one of the following:
  - Click the first object, hold [Shift], and click the ending object of the series.
Hold [Ctrl] and click individual objects to add these objects to the selection. The selected points appear highlighted in the graphic and spreadsheet views.

Related topics
- Project Explorer (on page 6)
- Properties Pane (on page 12)

Select Points

Select individual, multiple, ranges, or sets of points based on specific criteria.

To select points:

1. Do one of the following:
   - Select Select > Select Points.
   - Click the icon on the toolbar.
   - Click Options next to a select box in a command, and select Select Points from the drop-down list.

   The Select Points command pane displays. Each tab (General, GPS, and Occupation) shows a subset of possible selection criteria.

2. Set the selection criteria you wish to use to select points. You can set multiple criteria and check more than one box in each group.
   - To add points selected to the current selection, check the Add to current selection box.
   - To preview the selection in an open graphic view, Project Explorer, or points spreadsheet, click Apply. All points meeting all of the criteria are selected.

3. Refine the criteria if needed, and click OK to make the selection and close the dialog. The number of selected points appears on the status bar.
To select a single point, enter the point ID.

To select a range of points, enter the ID of the first point in the range followed by three dots (...) and the ID of the last point in the range. For example, you would enter 1...5 to select points 1, 2, 3, 4, and 5.

To select two or more non-contiguous points, enter the ID of each point separated by a comma. For example, you would enter 1, 3, 6 to select points 1, 3, and 6.

Note that you can enter multiple ranges by separating each range with a comma. For example, you could enter 1...5, 101...105.

**Note:** Alpha characters used in point IDs are not case sensitive.

Enter the abbreviation you have given to a feature associated with the points you want to select.

Enter the name of a point from which the points you want to select were observed.

Select the layer that the points you want to select reside on.

**Fixed in adjustment** - Check this box to select control quality points that were designated as 'fixed' during the last network adjustment.

**Adjusted** - Check this box to select points with final coordinates resulting from the last network adjustment.

**Control** - Check this box to select NGS surveyed coordinates of the highest quality.

**Survey** - Check this box to select surveyed coordinates of the second highest quality.

**Mapping** - Check this box to select coordinates of the low to average quality.

**Unknown** - Check this box to select coordinates of the lowest or unverified quality.

Select operators, and enter precisions in the format shown in the Properties pane for vectors in your project.
### Solution type

- **Code** - Check this box to select points with autonomous positions.

- **Fixed** - Check this box to select coordinates for which the baseline processor was **able** to resolve the integer ambiguity with enough confidence to select one set of integers over another during baseline processing.

- **Float** - Check this box to select coordinates for which the baseline processor was **unable** to resolve the integer ambiguity search with enough confidence to select one set of integers over another.

### Field method

- **Continuous** - Check this box to select points observed during a continuous trajectory.

- **Event** - Check this box to select points observed in a Real-Time Kinematic (RTK) GPS mode in which the resulting vectors include an ‘event’ marker.

- **Observed control** - Check this box to select control points observed in an RTK GPS mode.

- **Rapid** - Check this box to select points observed in an RTK GPS mode was collected at a fast data rate, such as every second.

- **Static or fast static** - Check this box to select points observed in a PPK GPS mode collecting up to 20 minutes or several hours (respectively) of raw data, and then postprocessing to achieve sub-centimeter precisions.

- **Stop and go** - Check this box to select points observed in short PPK or RTK Stop and Go occupations, while maintaining lock, and then postprocessing to achieve centimeter precisions.

- **Topo** - Check this box to select points observed in a GPS survey mode defined as topographic.

### Occupation tab

- **Antenna heights between** Enter antenna height parameters in the format shown in the Properties pane for points in your project.

- **Add to current selection** Check this to add the results of current selection to any previously selected data.

### Related topics

- [Select Observations](#) (on page 58)
- [Select Unprocessed Sessions](#) (on page 62)
- [Selection Methods and Options](#) (on page 49)
**Select Duplicate Points**

Select all of the points with duplicate IDs in your project if you need to review or merge them into single points. Merge duplicate points if you know that they are the same physical point, and you do not need them to be separate points.

**To select points with duplicate IDs:**

1. Select Select > Select Duplicates. The Select Duplicate Points command pane displays.

2. If you do not want to set a distance tolerance between the points selected, uncheck Within the following distance.

3. Otherwise, click two points in a graphic view, or type a distance in the box. Points within the distance will be selected as duplicates, depending on what you set in the next group.

4. Select an option to ignore point IDs, or include them only if they are identical or different.

5. Click Apply if you want to see and refine the selection, or click OK to use the current selection criteria. All points meeting all of the criteria are selected. The number of selected points appears on the status bar.

**Related topics**

- Merge Duplicate Points (on page 373)
- Selection Methods and Options (on page 49)

**Select Observations**

Select observations associated with vectors based on criteria you set. Selectable observations can be from any type of vector.

**Note:** The options with entries on both the General and GPS tabs are used for selecting vectors (postprocessed baselines). If you get no selection results, run the Process Baselines command.

**Note:** This is a database query; view filter settings do not apply.

**To select observations:**

1. Do one of the following to display the Select Observations command:
   - Select Select > Select Observations.
   - Click the icon on the toolbar.

2. Set the selection criteria you wish to use to select observations. You can set multiple criteria and check more than one box in each group. See options below.
2. To add observations selected to the current selection, check the *Add to current selection* box.

3. To preview the selection in an open graphic view, *Project Explorer*, or occupation spreadsheet, click *Apply*. All points meeting all of the criteria are selected.

4. Refine the criteria if needed, and click *OK* to make the selection and close the dialog. The number of selected observations appears on the status bar.

5. Click *Apply* if you want to see and refine the selection, or click *OK* to use the current selection criteria.
Options
General tab
From/To
Pick two points in a graphic view, or enter two point IDs. By definition, vectors have a direction.

Feature code
Enter the alphanumeric string used to identify a feature associated with the points you want to select.

Type
Check boxes for the types of observations you want to select.

Status
Check boxes for the status of vectors you want to select.

Observation ID
Note: An observation ID consists of the alphanumeric characters displayed in parenthesis at the end of the observation node name in the Project Explorer.
The alpha characters used for observation IDs are as follows:
- “V” is used for RTK vectors (for example, “V1”).
- “PV” is used for vectors that are post-processed in the software (for example, “PV1”).
- “IPV” is used for vectors that are post-processed in other software and imported into this software using a TDEF file (for example, “IPV1”).

To select a single observation, enter the observation ID. To select a range of observations, enter the ID of the first observation in the range followed by three dots (...) and the ID of the last observation in the range. For example, you would enter v1...v5 to select observations V1, V2, V3, V4, and V5.

To select two or more non-contiguous observations, enter the name of each observation separated by a comma. For example, you would enter v1, v3, v6 to select points V1, V3, and V6.

Note that you can enter multiple ranges by separating each range with a comma. For example, you could enter v1...v5, v10...v15.

Note: Alpha characters used in observation IDs are not case sensitive.

Sideshots only
Check this to exclude all observations but sideshots from the selection.

Start time/
End time
Select operators in the Start Time and End Time lists. Then, enter dates and times in the format shown in the Properties pane for vectors in your project.
**Duration**

Select an operator and type a time in the format:  
**Hour:Minutes**.

---

**GPS tab - Observation with vectors with**

**Horizontal/vertical precision**

Select operators and enter precisions in the format shown in the *Properties* pane for vectors in your project.

**Solution type**

- **Code** - Check this box to select observations with autonomous positions.
- **Fixed** - Check this box to select coordinates for which the baseline processor was able to resolve the integer ambiguity with enough confidence to select one set of integers over another during baseline processing.
- **Float** - Check this box to select coordinates for which the baseline processor was unable to resolve the integer ambiguity search with enough confidence to select one set of integers over another.

**Field method**

- **Continuous** - Check this box to select data collected during a continuous trajectory.
- **Event** - Check this box to select occupations at points observed in a Real-Time Kinematic (RTK) GPS mode in which the resulting vectors include an ‘event’ marker.
- **Observed control** - Check this box to select occupations at control points observed in an RTK GPS mode.
- **Rapid** - Check this box to select occupations at points observed in an RTK GPS mode was collected at a fast data rate, such as every second.
- **Static or fast static** - Check this box to select occupations at points observed in a PPK GPS mode collecting up to 20 minutes or several hours (respectively) of raw data, and then postprocessing to achieve sub-centimeter precisions.
- **Stop and go** - Check this box to select occupations at points observed in short PPK or RTK Stop and Go occupations, while maintaining lock, and then postprocessing to achieve centimeter precisions.
- **Topo** - Check this box to select occupations at points observed in a GPS survey mode defined as topographic.

---

**Antenna tab**

**Antenna heights**

Enter antenna height parameters in the format shown in the *Properties* pane for vectors in your project.

**Add to current selection**

Check this to add the results of current selection to any previously selected data.
Related topics

- Process Baselines (on page 305)
- Selection Methods and Options (on page 49)

Select Unprocessed Sessions

Use this command to select any unprocessed sessions in the current project. A session can contain either one static baseline or multiple kinematic trajectories and segments. The number of sessions selected appears on the status bar.

**To select unprocessed sessions:**

- Select Select > Select Unprocessed Sessions. No dialog displays.

| Tip: This command is a simple way to check for unprocessed baselines. After selecting the unprocessed sessions, begin the Process Baselines command. |

Related topics

- Process Baselines (on page 305)
- Run a Baseline Processing Report (on page 308)
- Status Bar (on page 9)

Select by Elevation Range

Use an elevation range to select data, such as a set of surveyed points, that lies between high and low points in your project. You can also select objects, such as surfaces, that cross the elevation range you specify.

**To select data using an elevation range:**

1. Select Select > Select by Elevation Range. The Select by Elevation Range command pane displays.
2. Click in the Max elevation box, and pick a point in a graphic view to use its elevation, or type an elevation in the box.
3. Click in the Min elevation box, and pick a point in a graphic view, or type an elevation in the box.
4. Specify whether to include only data that falls completely within the range, or data that falls within or crosses the range.
5. If you want to add consecutive selections to your selection set, leave Add to current selection checked.
6. Click Apply if you want to see and refine the selection, or click OK to use the current selection criteria. All data meeting all of the criteria are selected. The number of selected points appears on the status bar.
Select By Layer

Select data that resides on specific layers in your project.

To select data by its layer:

1. Select Select > Select by Layer. The Select by Layer command pane displays.
2. Simply check or uncheck the boxes next to any layer names in the list. The graphic views and Project Explorer update in real-time to show the selected data.
3. Click Close.

Select Using Advanced Criteria

Select objects by specifying a type of data (baseline, coordinate, point, etc.) and a specific property of that data. If needed, continue to build or modify your selection by specifying additional data types and their properties.

To select data using specific criteria:

1. Select Select > Advanced Select. The Advanced Select dialog displays, showing your current selection in the Current Status group.
2. In the Apply This Selection To group, specify whether to select from the currently selected objects or from all data, and whether to replace or add to the current selection.
3. Designate the kind of objects you want to select in the Data type list.
4. To narrow your selection by specifying a property, click Data with the following property and select a property in the list. Otherwise, click Apply to preview the results, or OK to make the selection and close the Advanced Select dialog.
5. If you are specifying a property of the data, select a mathematical operator in the That is box. Then type or select a value in the This value box.

Note: Check the Project Explorer to easily see what you have selected.

Related topics

- Selection Methods and Options (on page 49)
- Create and Edit a Layer (on page 77)
- Selection Methods and Options (on page 49)
6. To select the inverse of the criteria you specify, check the **Invert selected objects** box. This deselects all objects that would have been selected and selects all of the previously unselected objects.

7. Click **Apply** to preview the results, or **OK** to make the selection and close the **Advanced Select** dialog.

**Related topics**

- [Selection Methods and Options](on page 49)

**Selection Explorer and Selection Sets**

**Understanding Selection Sets**

If you need to select the same objects over and over, it can be frustrating to manually do it and it is easy to make mistakes. Instead, use the **Selection Explorer** to create, modify, and reuse selection sets.

Selection sets can be created and modified in a variety of ways, including Boolean operations using two or more sets.

<table>
<thead>
<tr>
<th><strong>Action</strong></th>
<th><strong>Selection Explorer Command</strong></th>
<th><strong>Resulting Sets</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Project with data</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Group project data into selection sets.</td>
<td><img src="image" alt="Save as..." /></td>
<td><img src="image" alt="Red(3)" /> <img src="image" alt="Yellow(5)" /> <img src="image" alt="Blue(5)" /></td>
</tr>
<tr>
<td>Add currently selected objects to a selection set.</td>
<td><img src="image" alt="Add Current Selection" /></td>
<td>current selection(2) <img src="image" alt="+ Red(3)" /> <img src="image" alt="--&gt; Red (5)" /></td>
</tr>
</tbody>
</table>

**Note:** Don't forget to **Save as**.
Subtract currently selected objects from a selection set.

**Subtract Current Selection**

Blue(5) – current selection (1)
--> Blue (4)

**Note:** Don’t forget to **Save as**.

Add objects to a more than one selection set.

Pick current selection(1)

**Add To** Red(4), Yellow(5)
--> Red(5), Yellow(6)

Subtract a selection set from another selection set.

**Select** Blue(5)

**Subtract From** Yellow(6)
--> Yellow(4)

**Note:** Only the two objects that Blue and Yellow have in common are subtracted from Yellow.

Create a new set from two or more selection sets.

**Select** Yellow(6), Blue(5)

**Save as** Green(8)

**Note:** Use [Ctrl] or [Shift] to multi-select selection sets from the Selection Explorer list.

Create a selection set of only the common objects from two or more sets.

**Select** Yellow(6), Blue(5)

**Save Common Items as** Green(8)

**Selection Explorer**

The **Selection Explorer** is a pane that lists the selection sets in your project in the top section and lists the objects in the active set in the bottom section.
When you click on a selection set, all the objects in the set are selected in the project.

When you select one or more objects in the list of objects, those objects are selected in the project.

When <Selection Snapshot> is active, objects selected in the graphics area are listed.

Using selection sets makes accessing and selecting groups of commonly-used objects faster and more consistent.

To display and pin the Selection Explorer:

1. Do one of the following:
   - Select View > Selection Explorer.
   - Select Select > Selection Set > Selection Explorer.
   - Click the icon on the toolbar.
   - Right-click in a graphic view and select Selection Explorer from the context menu.

   The Selection Explorer displays, docked on the left side of the application window, or where you positioned it last.

2. If desired, pin the explorer open by clicking the icon at the top. If the pane is unpinned, the pane can "slide" to the side and out of view. To show it again, click the Selection Explorer tab.

Related topics

- Understanding Selection Sets (on page 64)
- Create and Use Selection Sets (on page 66)
- Modify Selection Sets (on page 68)
- Pane and Data View Positioning (on page 37)

Create and Use Selection Sets

Use the Selection Explorer to create, modify, and reuse selection sets for easier selection and editing. Using selection sets makes accessing and selecting groups of commonly-used objects faster and more consistent.

The Selection Explorer contains two lists: the Selection Sets list at the top of the pane, and the object list at the bottom of the pane. The object list shows the objects that are contained in the selected selection set(s).

Note: The selection sets you create, and those created from some types of imported files, also appear in the View Filter Manager (on page 8). They can be used as a starting point in creating view filters.
To create a temporary list of the currently selected objects:

1. Open the Selection Explorer.
2. Click <Selection Snapshot> on the list of selection sets.
3. Select objects that you want to list in a graphic view, spreadsheet view, or the Project Explorer. This list of objects displays in the object list of the Selection Explorer.

Note: If the list does not update automatically, click the (Refresh) icon in the Selection Explorer.

To create a selection set (with the Selection Explorer open):

1. Select objects that you want to include in the set in a graphic view, spreadsheet view, or the Project Explorer.
2. Click the icon on the Selection Explorer's toolbar. The Save As dialog displays.
3. Type a name for the selection set, and click OK. The name of the new set appears in the Selection Sets list.

To create a selection set (from the menu):

1. Select objects that you want to include in the set in a graphic view, spreadsheet view, or the Project Explorer.
2. Select Select > Selection Set > Save As. The Save As dialog displays.
3. Type a name for the selection set, and click OK.

Note: When you open the Selection Explorer, the selection set displays in the Selection Sets list.

To select all objects in a selection set:

1. Open the Selection Explorer.
2. Select one or more sets in the Selection sets list. All of the objects in the sets are selected in your project.

Note: Use [Ctrl]-click and [Shift]-click to multi-select in the Selection Sets list.

3. Deselect, modify, and use the objects as needed.

To copy a selection set:

1. Open the Selection Explorer.
2. Select the selection set to copy in the Selection sets list.
3. Click the icon on the Selection Explorer's toolbar. The Save As dialog displays.
4. Type a new name for the selection set, and click OK.

To remove a selection set (from the menu):

1. Select Select > Selection Set > Remove. The Remove dialog displays.
2. Select one or more sets to remove in the list, and click OK.

Note: Remove does not delete the objects in the selection set from your project. If you delete objects from your project, they are also removed from any selection sets they were in.

Note: <Selection Snapshot> is a default selection set that cannot be removed.

To remove a selection set (with the Selection Explorer open):

1. Select one or more sets to remove in the Selection Sets list
2. Click the icon. The selection set disappears from the list.

Related topics
- Selection Explorer Options (on page 69)
- Understanding Selection Sets (on page 64)
- View Filter Manager (on page 8)

Modify Selection Sets

To add objects to an existing selection set (from the Selection Explorer):

1. Open the Selection Explorer and select the selection set from the Selection Sets list.
2. Select the objects to add.
3. Click icon on the Selection Explorer. The objects appear in the list below.
4. (optional) Click to save the updated selection set.

To subtract objects to an existing selection set (from the Selection Explorer):

1. Open the Selection Explorer and select a selection set from the Selection Sets list.
2. Select the objects to subtract.
3. Click (or right-click and select Subtract Current Selection from the context menu). The objects are subtracted from the set.
4. (optional) Click to save the updated selection set.

To add objects to an existing selection set (from the menu):

1. Select objects that you want to add to a set.
2. Select Select > Selection Set > Add To. The Add To dialog displays.
3. Select the set to edit in the list and click OK. The objects are added to the set.

To subtract objects from an existing selection set (from the menu):
1. Select objects that you want to remove from a set.
2. Select Select > Selection Set > Subtract From. The Subtract From dialog displays.
3. Select the set to edit in the list and click OK. The objects are removed from the set.

To edit multiple selection sets at once:
1. Open the Selection Explorer.
2. Select one or more sets in the Selection sets list. All of the objects in the sets are selected in your project.
   
   **Note:** Use [Ctrl]-click and [Shift]-click to multi-select in the Selection Sets list.
3. Select objects that you want to add; then right-click and select Add Current Selection.
4. Select objects that you want to remove in the objects list; then right-click and select Subtract Current Selection.

To combine multiple selection sets:
1. Open the Selection Explorer.
2. Select each of the selection sets that you want to combine in the Selection Sets list.
   
   **Note:** Use [Ctrl]-click and [Shift]-click to multi-select in the list.
3. Click the icon on the Selection Explorer's toolbar. The Save As dialog displays.
4. Type a name for the new selection set, and click OK. The name of the combined set appears in the Selection Explorer.
   
   **Note:** Objects that were in more than one set are not duplicated in the new combined set.

Related topics
- Selection Explorer Options (on page 69)
- Understanding Selection Sets (on page 64)

**Selection Explorer Options**

Use these Selection Explorer options to create, edit, and use selection sets.
### Options

<table>
<thead>
<tr>
<th>Icon</th>
<th>Context menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="icon" alt="Save as" /></td>
<td><strong>Save as</strong></td>
<td>The icon and the context menu option work in slightly different ways: Click the icon to display the <strong>Save Selection List As</strong> dialog, where you can save all of the objects in the Selection List as a new selection set, regardless of whether they are selected or not. Select the context menu option to display the <strong>Save As</strong> dialog, where you can save just the objects that are selected in the Selection List as a new selection set. Use <strong>Save As</strong> to copy and combine selection sets as well. You can also enter an existing set name to overwrite that set with the current selection.</td>
</tr>
<tr>
<td><img src="icon" alt="Refresh" /></td>
<td><strong>Refresh</strong></td>
<td>Click this to refresh the Selection Explorer’s list of currently selected objects after you have selected or deselected objects in another view, spreadsheet, or the Project Explorer.</td>
</tr>
<tr>
<td><img src="icon" alt="Properties" /></td>
<td><strong>Properties</strong></td>
<td>Click this to display the Properties pane, where you can view and edit the properties common to all the objects in the current selection set. <strong>Tip:</strong> Using the <code>&lt;Selection Snapshot&gt;</code>, you can select all of the objects you need to modify and then view and edit properties for each one without losing the others in the list.</td>
</tr>
<tr>
<td><img src="icon" alt="Remove" /></td>
<td><strong>Remove</strong></td>
<td>Click this to remove the selected selection sets. <strong>Note:</strong> This does not delete the members of the selection set from your project.</td>
</tr>
<tr>
<td><img src="icon" alt="Add Current Selection" /></td>
<td><strong>Add Current Selection</strong></td>
<td>Click this to add newly selected objects to the current selection set.</td>
</tr>
<tr>
<td><img src="icon" alt="Subtract Current Selection" /></td>
<td><strong>Subtract Current Selection</strong></td>
<td>Click this to subtract newly selected objects from the current selection set.</td>
</tr>
</tbody>
</table>
### Selection sets

This column lists the *<Selection Snapshot>* (always present), selection sets automatically generated by some types of imported files, and selection sets you have created.

**Note:** Selection sets also appear in the **View Filter Manager** (on page 8). They can be used as a starting point in creating view filters.

**Note:** Selection sets can contain objects that have no visible display, such as coordinates. In the **Selection Explorer**, all selection sets are available. In the **View Filter Manager**, however, only selection sets that contain at least one visible object are available.

### Objects

This column shows the number of objects that are members of the selection set.

### Selection List

This list shows the members of the currently selected set.

Click this to sort the set by selection status, either 'selected' or 'unselected'.

This column also denotes the last object selected with the icon, and displays the icon for each member's object type.

### Name

Click this column heading to sort the members of the set by object name.

Unnamed objects are shown with '?' for the name, but they can be partially distinguished by the object type icon in the next column.

### Type

Click this column heading to sort the objects in a set by their object type.
Right-click on any selection set or object to access these options. Options vary, depending on what is selected.

**Save Common Objects As** - Select this to display the **Save As** dialog, where you can create a new selection set containing all of the objects that were in each of the selected sets.

**Lock/Unlock Selection Sets** - Select these to prevent or allow changes to the selected sets.

**Note:** Locked selection sets can only be changed by deleting objects from the project.

**Select all** - Select this to select every object in the selected selection set.

**Select This Type** - Select this to select all the objects in the set whose type (such as ‘point’) matches the selected object.

**Invert** - Select this to switch the selection state in the object list. This deselects the currently selected objects in the set, and selects the currently unselected objects.

**Add To** - Select this to display the **Add To** dialog, where you can select one or more sets to which you want to add the selected objects. If you add objects are already exist in the set, they are not duplicated.

**Subtract From** - Select this to display the **Subtract From** dialog, where you can select one or more sets from which you want to subtract the selected objects.

**Delete** - Select this to remove the selected object from the current selection set.

**Rename** - Select this to put the selection set name into edit mode in the **Selection Sets** list.

**Related topics**

- [Create and Use Selection Sets](on page 66)
- [Understanding Selection Sets](on page 64)
View and Edit an Object's Properties

Review and edit the properties for selected objects to ensure they have the correct attributes. If you select a single object, the properties for that object are displayed. If you select multiple objects, the properties common to all of them are displayed. You can edit the common properties, or select a subset of the selected objects using the drop-down list near the top of the pane.

To view the properties of another object in the Properties pane, click the object within any data view or pane. If the Properties pane is displayed, selecting any object will show its properties.

**Note:** The toolbar icons and context menu items available in the Properties pane depend on the types of objects you have selected. The Properties pane also enables you to use COGO controls and snap commands within certain property boxes.

**To edit properties:**

- Click in a property box, highlight the value to edit, and type a new value, or (if applicable) select a new value from the list.

**Note:** You can enter a value in units different from the project units; it will be converted to the project units. For example, if an elevation is displayed in meters and you enter a value as "10 ft", it will convert to "3.048" (meters).
View, Navigate, and Select

- Press [Esc] to cancel an edit; the property will revert to its original value.
- Press [Tab] to accept an edit and move to the next property box.
- Press [Shift] + [Tab] to accept an edit and move to the previous property box.
- Press [Enter] to accept an edit and close the Properties pane.

Sections

- Click this on the pane's toolbar to select any associated point, coordinate, baseline, vector, or trajectory when survey data is selected.
- This displays all of the selected objects by type. If you have selected multiple objects, you can accept the default selection of All, or click the drop-down arrow to narrow the selection to a specific type of object.
- This displays groups of properties. Click a property label to see additional information, or click in a property box to edit the value, when available.

**Note:** If you are in a COGO control (see "Understanding COGO Controls" on page 95) in the grid, you can pick a point(s) or object(s) in the view, or right-click for snap options.

(information box)

This displays a description of the selected property.

Related Topics

- Properties Pane (on page 12)
- Pane and Data View Positioning (on page 37)

Delete an Object

Remove objects that you no longer need from the project database.

To select and then delete data:

1. Select the data to delete in a graphic view, spreadsheet, or the Project Explorer.
   The number of objects selected appears in the status bar.
2. Do one of the following:
   - Select Edit > Delete.
   - Press [Ctrl] + [D].
   - Right-click and select Delete from the context menu.
The selected objects are removed from graphic views, spreadsheets, and the Project Explorer. The Delete command pane does not display.

**To start Delete and then select the data:**

1. Select Edit > Delete. The Delete command pane displays.
2. Select data using one of the following:
   - Click Options, and select an option from the menu.
   - Pick objects in a graphic view, spreadsheet, or the Project Explorer.
   The number of objects selected appears in the status bar.
3. Click OK. The selected objects are removed from graphic views, spreadsheets, and the Project Explorer.

**To restore deleted data:**

- Select Edit > Undo Delete immediately after using the Delete command.

**Related topics**
- Filter a View (on page 85)
- Undo and Redo Commands
- Selection Methods and Options (on page 49)

---

**Edit an Object**

When you need to edit an object, the program will open the editor appropriate to the object’s type.

**To edit an object:**

- Right-click an object, and select Edit from the context menu.
- Select Edit > Edit.
- Click the icon on the toolbar, or on the Properties pane toolbar.

Depending upon whether you have an object selected or not, either the Edit command pane displays (prompting you to select an object) or the editor appropriate to the selected object displays.

**Related topics**
- Edit an Alignment (on page 386)
- Edit a Linestring's Horizontal Segments (on page 397)
- Edit a Surface by Adding and Removing Members (on page 424)
**Undo or Redo an Action**

Any action that affects the project database, such as creating an object, can be redone or undone. Commands that don’t affect the database, such as opening a file, cannot be redone or undone.

**To undo an action:**

Use the *Undo* command to revert to the state prior to the last action.

- Select **Edit > Undo** command.
- Press **[Ctrl] + Z**.
- Click the icon on the toolbar.

Multiple actions can be undone one at a time. The most-recently performed action is undone first. Once you close the project or the software, no actions can be undone.

**To redo an action:**

Use the *Redo* command to reverse the Undo command.

- Select **Edit > Redo** command.
- Click the icon on the toolbar.

Once you close the project or the software, no actions can be redone.

**Note:** Viewing actions, such as zoom, pan, and rotate, do not appear in the *Undo / Redo list.*

**Manage the Data in Your Views**

**Understanding Layers and View Filters**

Layers enable you to separate *different* types of data, and group *related* types of data, in the same way that transparent overlays in drawings used to.

View filters let you set the visibility of each data type and layer to control what is displayed in graphic views, helping you reduce and simplify what you see. View filters can be customized for each kind of view so that only the useful types of data are shown in each view.

With view filters, you can also set the selectability of data types and layers. For example, if you have a layer containing just background reference data that you will always need to see, but never need to use, simply make it unselectable.
Layers and view filters serve unique purposes, but work powerfully in conjunction with each other. Once you have set up layers and view filters, you can save them in project templates, making them ready to use each time you start a new project.

Related topics
- Create and Edit a Layer (on page 77)
- Create a View Filter (on page 82)
- Layer Options (on page 80)
- View Filter Manager (on page 8)

Create and Edit a Layer

Use layers to keep your data organized by type. You can create and delete individual layers, purge all empty layers, and select objects by choosing their layer. Layer properties allow you to change layer colors and line styles to help you distinguish more easily between data on different layers.

Note: Layers can only be imported or exported as part of CAD (.dxf, .dwg, and .dgn) files.

To create a new layer:

1. Do one of the following:
   - Select Project > Layer Options.
   - Click the icon on the toolbar. The Layer Options command pane displays.
2. Click the icon on the command pane's toolbar. The New Layer dialog displays.
3. Type a unique name in the Layer name box to indicate what type of data the layer will contain.
4. Select layer display options in the Color, and Line style lists.

   Note: If you have a separate line styles file, you can import it using the line styles list.
   Note: If the scale of your lines is small in a graphic view, some line styles display as solid lines to improve performance.
5. Click OK. The new layer appears in the pane's Layers list.

To edit properties of a layer:

1. Starting after step 1 above, select a layer in the Layers list. The layer's properties appear in the Layer Properties group.
2. Click in a box and edit the property or select a new property. The edits are reflected in graphic views immediately.
To delete one or all empty layers:

1. Select one or more empty layers in the Layers list.
2. Click the icon on the pane's toolbar. The layer is deleted.
3. To delete all empty layers, click the icon on the pane's toolbar.

Note: Empty layers are those that have no objects assigned to them. If there are no empty layers selected or in your project, the icons are unavailable.

To select the objects that reside on a layer:

1. Select one or more layers in the Layers list.
2. Click the icon on the pane's toolbar. The objects on the selected layers highlight in graphic and spreadsheet views and in the Project Explorer.

To change the layer on which objects reside:

1. Select the objects for which you want to change the layer.
3. If needed, select a subset of the objects in the data type list at the top of the pane.

Note: To change the layer, all of the selected objects must have Layer as a property. Generally, survey data and survey points do not have a layer property.
4. Click in the Layer box and select the new layer.
5. Click Close.

To set the visibility or selectability of objects by layer:

1. Do one of the following:
   - Select View > View Filter Manager.
   - Click the icon on the toolbar.

   The View Filter Manager displays.
2. Click the tab at the top of the view for which you want to edit the layers.
3. Select an unlocked view filter in the list at the top of the pane.

Note: This sets the visibility and selectability of the layers only for the view filter you have selected.
Note: To unlock a locked view filter, you can modify or copy it. See Create and Edit a View Filter (see "Create a View Filter" on page 82).
4. Click the icon on the pane's toolbar. The Advanced View Filter Settings dialog displays.

5. Scroll down and click the icon next to Layers to expand the group.

6. Check and uncheck boxes in the Visible and Selectable columns as needed.

7. Click OK.

Related topics

- Layer Options (on page 80)
- Isolate or Exclude a Layer (on page 79)
- Create and Edit a View Filter (see "Create a View Filter" on page 82)
- Filter a View (on page 85)

Isolate or Exclude a Layer

Turn individual layers on or off to better understand what data is on each layer in your project, and to help you create view filters using just the relevant layers.

To isolate individual layers:

1. Do one of the following:
   - Select the View > View Filter Manager.
   - Click the icon on the toolbar.

   The View Filter Manager displays.

2. Click the tab at the top of the view in which you want to isolate the layer.

3. Select a view filter in the list at the top of the pane. If you want to create a new view filter from an unlocked view filter, click the icon to make a copy so you do not modify the original view filter.

4. If desired, click the icon on the pane's toolbar to turn on the Auto Zoom (to the extents of the visible data) mode.

5. Click the icon on the pane's toolbar to turn on the Isolate Layers mode. The groups in the View Filter Manager collapse so that only the Layers group shows.

6. Click the name of each layer to see the data that resides on it in the graphic view. Only objects on the selected layer are visible.

7. If you are creating a view filter and want it to show the selected layer, make sure its box is checked. If you do not want to include the layer in the view filter, uncheck the box.
Tip: You may find it faster to use the keyboard to isolate layers. Click a layer name, and then use the up and down arrow keys to move through the list. Press the spacebar to check and uncheck the boxes that control the layer visibility.

8. Once you are done, click the and icons again to return to normal mode. The new view filter shows only the data on the layers for which the boxes are checked.

To hide (exclude) layers by selecting objects:

1. Starting after step 4 above, select one or more objects (in the graphic view) of the types you want to hide or that reside on the layers you want to hide.

2. Click the icon on the View Filter Manager's toolbar. The layers that the objects were assigned to are hidden.

3. Click the icon again to return to normal mode.

Tip: This method will not hide unlayered data types, such as survey data. If you are primarily interested in CAD data, you may want to hide raw data types before using this method.

Related topics

- Create and Edit a Layer (on page 77)
- Layer Options (on page 80)
- Create and Edit a View Filter (see "Create a View Filter" on page 82)
- Filter a View (on page 85)
- View Filter Manager (on page 8)

Layer Options

Use these options to create and delete layers, select objects by choosing their layers, and edit layer properties. They are available in the Layer Options command pane.
View, Navigate, and Select

Options

- Click this to open the New Layer dialog, where you can create a new layer.
- Click this to delete one or more empty layers that you have selected in the Layers list.
- Empty layers are those that have no objects assigned to them. You cannot delete layers that have objects assigned to them.
- Click this to delete all empty layers from the Layers list and your project.
- Click this to select all of the objects on the layers you have selected.

Layers

This lists all of the layers in your project, enabling you to select one or more layers or the objects on them.

Layer properties

This shows the attributes of the selected layer. Click in the box for any property to edit it.

Related topics

- Create and Edit a Layer (on page 77)
- Isolate or Exclude a Layer (on page 79)

View Filter Manager

The View Filter Manager is a pane in which you can select data types and layers to specify what is visible in the current graphic view, helping you reduce and simplify what you see. As you make changes in the manager, the view updates to reflect them.

View filters are saved sets of criteria that control what data and layers are displayed in the views. View filters can be defined separately for each type of view so that only the data that is important for the current phase of your work is displayed. When you change to a different view, the current and available view filters may change as well, because view filters are saved with views. The view filters for each view in your project can be accessed from the view filter list on the toolbar.

To display and pin the View Filter Manager:

1. Do one of the following:
   - Select View > View Filter Manager.
   - Click the icon on the toolbar.

The View Filter Manager displays, docked on the left side of the application window, or where you positioned it last.

Note: If the Project Explorer or Selection Explorer are also active, they may share the same pane, and be accessible as tabs at the bottom of the pane.
2. If desired, pin the manager open by clicking the icon at the top. If the pane is unpinned, it can "slide" to the side and out of view. To show it again, click the View Filter Manager tab on the left edge of the application window.

Using the View Filter Manager

- When you check and uncheck boxes for data types and layers in the View Filter Manager, the current view changes in response.
- Arrange the order of the data type groups in the tree by right-clicking on a group and selecting Move Up or Move Down from the context menu.
- To set the selectability of data types and layers, click the icon on the pane's toolbar to display the Advanced View Filter Settings dialog.

Related topics

- Create a View Filter (on page 82)
- Edit a View Filter (on page 84)
- Filter a View (on page 85)
- Pane and Data View Positioning (on page 37)

Create a View Filter

Use the View Filter Manager to select data types and layers to specify what is visible in graphic views, helping you reduce and simplify what you see. As you make changes in the manager, the current view updates to reflect them. You can create, copy, and delete view filters in the manager. View filters allow you to select data types and layers to control what is visible in graphic views, helping you reduce and simplify what you see. In creating a view filter, you set criteria for what to show in views.

To create a view filter:

1. Do one of the following:
   - Select the View > View Filter Manager.
   - Click the icon on the toolbar.
   The View Filter Manager displays.
2. Click the tab at the top of the view for which you want to create the view filter.
3. In the list, select a locked view filter that is close to the one you are trying to create; a copy of the original view filter is created as you make changes. If you are concerned about accidentally changing your existing view filters, and have most of them locked, use this method.
   Or
Select an **unlocked** view filter that is close to the one you are trying to create and click the 🪪 icon on the pane's toolbar. A copy of the view filter is created. If you do not want to be bothered with locking/unlocking view filters, and have most of them unlocked, use this method.

**Note:** There is one pre-defined view filter (**All**) which cannot be deleted.

**Tip:** If you have project templates, you may want to create and add custom view filters to them.

4. If desired, narrow the view filter by selecting a selection set in the 📘 list (for more on selection sets, see [Create and Use Selection Sets](#) (on page 66)).

5. If necessary, click the 📷 and 🏷 icons to expand and collapse groups.

6. Check and uncheck boxes to show and hide different data types and layers as you watch the changes in the graphic view. All of the changes you make are automatically saved to the current view filter for the current view.

7. For additional display style options, click the tabs at the bottom of the pane and change the settings as needed.

**Note:** The display styles tabs are only available for unlocked view filters, and generally only affect raw data, such as survey data.

### To create a view filter using advanced settings:

1. Starting after selecting an unlocked view filter in step 3 above, click the 🪪 icon on the pane's toolbar. The **Advanced View Filter Settings** dialog displays.

2. Use the process described in steps 4 - 6 above to create a view filter. Additional options (such as **Include newly created layers**, **Locked**, **Show display styles**, and **Selectable**) are also available. See [Advanced View Filter Options](#) (on page 90) for details.

**Note:** Since you are working in a dialog, you will not see the graphic view update as you make changes to the view filter. For projects with a lot of data, this is more efficient because the screen does not have to refresh between changes. You can, however, click **Apply** at the bottom of the dialog to manually refresh the graphic view at any time.

3. Click **OK**. The new view filter is associated with the current graphic view; other views have the option of using the new view filter as well.
To copy a view filter:

- Select a view filter in the list, and click the icon on the pane's toolbar. The copy of the view filter appears in the list. The original view filter's name is appended with "- Copy" in the new view filter's name. The copy is unlocked and is associated with the current graphic view.

**Note:** The Copy, Delete, and other commands can also be accessed by clicking in the view filter list and selecting from the context menu.

To delete a view filter:

- Select a view filter in the list, and click the icon on the pane's toolbar. The view filter disappears from the list, and the current graphic view becomes associated with the default view filter. If the default view filter does not exist, the view is associated with the original default view filter named All.

**Note:** The All view filter cannot be deleted.

Related topics
- Edit a View Filter (on page 84)
- Filter a View (on page 85)
- View Filter Manager Options (on page 88)
- Create and Edit a Layer (on page 77)

**Edit a View Filter**

Use the View Filter Manager to edit, copy, and rename existing view filters. View filters can be customized for each view so that you see only the types of data you need for your current task.

**To unlock/lock a view filter:**

1. Do one of the following:
   - Select the View > View Filter Manager.
   - Click the icon on the toolbar.
   The View Filter Manager displays.

2. Click the tab of the view associated with the view filter you want to unlock.

3. Select the view filter in the list.

4. Click the icon on the pane's toolbar. The Advanced View Filter Settings dialog displays.

5. Check or uncheck the Locked box, and click OK.
To edit a view filter:

1. Starting after step 3 above, click the and icons to expand and collapse groups if necessary.
2. Check and uncheck boxes to show and hide different data types and layers as you watch the changes in the graphic view. All of the changes you make are automatically saved to the current view filter for the current view.
3. For additional display style options, click the tabs at the bottom of the pane and change the settings as needed. For advanced options, click the icon on the pane’s toolbar.

To rename a view filter:

1. Select an unlocked view filter in the list and click the icon on the pane’s toolbar. Alternately, you can click in the view filter list and select Rename View Filter from the context menu.
2. Type a new name for the view filter in the box, and click .

Related topics

- Create and Edit a Layer (on page 77)
- Filter a View (on page 85)
- Troubleshoot a Layer or View Filter Problem (see “Troubleshoot a Layer or View Filter Problem” on page 92)
- Layers and View Filters (see “Manage the Data in Your Views” on page 76)

Filter a View

Use view filters to reduce and simplify what you see in graphic views. The software comes with one pre-defined, default view filter that shows all of the visible data in your project. Use this view filter, named All, as the starting point, and adapt it to create a set of basic view filters to fit your needs. Then, you can modify those view filters to build more subtle and complex ones.

Filter a view to inspect your project data: (simple)

1. Click the tab of the graphic view you want to filter.
2. Click in the view filter list on the toolbar, and select the view filter that meets your needs for the current view. Depending on the data in your project, the view changes.
The view filter list on the toolbar looks like this:

| All |

**Note:** The view filter list shows all of the view filters that have been created in the **View Filter Manager**. If no additional view filters have been created for the project, only the default **All** view filter is available.

**Note:** The **All** view filter cannot be deleted.

3. Select other view filters in the list to try other view filters. If the view filter you need has not been created yet, and you want to modify the existing view filter, use the procedure below.

**Filter a view to inspect your project data:**

1. Click the tab of the graphic view you want to filter.
2. Do one of the following:
   - Select the **View > View Filter Manager**.
   - Click the ![icon](image) icon on the toolbar.
   
   The **View Filter Manager** displays.
3. Select a view filter in the ![icon](image) view filter list at the top of the pane.
4. If you selected an unlocked view filter, and want to preserve the original, click the ![icon](image) icon on the pane's toolbar to create a copy.
5. If desired, narrow the view filter by choosing a selection set in the ![icon](image) list.

**Note:** Selection sets are automatically created for many types of imported files. For more information on selection sets, see [Create and Use Selection Sets](on page 66).
6. If necessary, click the ![icon](image) and ![icon](image) icons to expand and collapse the groups.
7. Check and uncheck boxes to show and hide different data types and layers as you watch the changes in the graphic view.
8. For additional display style options, click the tabs at the bottom of the pane and change the settings as needed. Continue to experiment by making different combinations of data visible. This will help you understand what is in your project.
9. If an unneeded view filter was created, click the ![icon](image) icon on the pane's toolbar to delete it. If you do not delete the view filter, it will be available in the view filter list on the toolbar.
Filter a view to see only one type of data:

1. Starting after step 4 above, click the and icons to expand and collapse the groups if necessary.
2. Right-click the name of a data type you want to view, and select View Only This from the context menu. All of the other boxes in the group are automatically unchecked so that only the selected object type is visible.
   Or
3. Right-click on the tree view and select Hide All from the context menu. All of the boxes in the group are automatically unchecked.
4. Check the box for the one object type you want to see.

**Note:** When using View Only This or Hide All, the check boxes in other groups are not affected. If you want to see only one data type from all groups, uncheck the boxes next to the other group names before selecting View Only This or Hide All.

**Note:** There are two things that affect whether an object is visible in the graphic views: whether the box for the object type is checked, and whether the box for the layer that the object resides on is checked. If an object does not display as expected, make sure both boxes are checked. Generally, this only applies to Points and CAD Blocks, Lines, and Text (only available in the Advanced View Filter Settings dialog).

Filter a view to see only one layer:

- See Isolate or Exclude a Layer (on page 79).

Filter a view to see only objects in a selection set:

Selection sets are automatically generated by some types of imported files. You can also define them using selected objects in the Selection Explorer (on page 7). Use selection sets to narrow the data included in a view filter.

**Note:** Selection sets can contain objects that have no visible display, such as coordinates. In the Selection Explorer, all selection sets are available. In the View Filter Manager, however, only selection sets that contain at least one visible object are available.

1. Select the All view filter in the list.
2. Select the selection set in the list. Only data that is in the selection set is visible.
Filter a view to see everything but one data type or layer:

1. Select the All view filter in the View Filter Manager. Alternately, you can also check the box for each group or right-click in each group and select View All from the context menu to see all of the data.

2. Uncheck the box for just the data type or layer you want to hide.

Related topics

- Create and Edit a View Filter (see "Create a View Filter" on page 82)
- Create and Edit a Layer (on page 77)
- Troubleshoot a Layer or View Filter Problem (see "Troubleshoot a Layer or View Filter Problem" on page 92)

View Filter Manager Options

Use these options to select data types and layers to control what is visible in graphic views, helping you reduce and simplify what you see. View filters can be customized for each kind of view so that only the useful types of data are shown for each view. They are available in the View Filter Manager.
Options

Click this to make a copy of the currently selected view filter. The original view filter's name is appended with "- Copy" in the new view filter's name.

Click this to rename the currently selected view filter. Then type a unique name for the view filter in the New name box, and click OK.

Click this to delete the currently selected view filter. The view filter disappears from the list, and the current graphic view becomes associated with the default view filter. If the default view filter does not exist, the view is associated with the view filter named All.

Only unlocked view filters can be deleted.

Click this to put the View Filter Manager into Auto Zoom mode in which the current graphic view automatically zoom to the extents of the data that is visible in the current view filter.

Click this to put the View Filter Manager into Isolate Layers mode. All of the groups collapse except for the Layers group. Select a single layer to see only the data on that layer.

Pick objects in the graphic view, and click this to hide the layers on which the selected objects reside.

Click this to open the Advanced View Filter Settings dialog, where you can set additional view filter and layer settings, as well as the standard settings found in the View Filter Manager.

Select a view filter to apply it to the current view. Then you can edit it or copy it.

This list matches the view filter list found on the toolbar.

Select from selection sets automatically generated by imported files or selection sets you have defined to narrow the data included in the selected view filter.

Note: Selection sets can contain objects that have no visible display, such as coordinates. In the Selection Explorer, all selection sets are available. In the View Filter Manager, however, only selection sets that contain at least one visible object are available.

Click the icon to expand a group, and check and uncheck boxes in the group to control the visibility of different types of objects and layers in the graphic view.

Click these tabs near the bottom of the pane to set additional display style options. They only appear when you select an unlocked view filter, and they are part of the view filter criteria. For details, and to hide the tabs, see Advanced View Filter Options (on page 90).

Context menu options
View, Navigate, and Select

**View all/Hide all**
Within a group, use this option to check/uncheck all of the boxes, thereby displaying or hiding all of those object types or layers in the graphic view.

**View only this**
Within a group, use this option to check the selected object type or layer, and uncheck everything else in the group.

**Note:** If no data is visible after you select View Only This, make sure that the box for the layer the data is on is also checked.

**Move up/Move down**
On a group, use this option to move the group up or down in the tree so that your most frequently used groups are at the top. The order is saved with your project, and is the same for all view filters.

**Invert**
Within a group, use this option to check all of the boxes that are unchecked and uncheck all of the boxes that are checked.

**Layer options**
Within the **Layers** group, use this option to open the **Layer Options** (on page 80) command pane.

**Related topics**
- [Create a View Filter](on page 82)
- [Edit a View Filter](on page 84)
- [Filter a View](on page 85)
- [Troubleshoot a Layer or View Filter Problem](see "Troubleshoot a Layer or View Filter Problem" on page 92)
- [Advanced View Filter Options](on page 90)

**Advanced View Filter Options**

Use these options to manage view filters, including controlling selectability and how new objects are handled. Most of the View Filter Manager options are also available. They are available in the Advanced View Filter Settings dialog.
**Options**

**Filter name**
If necessary, rename the selected view filter in this box.

Select from selection sets automatically generated by imported files or selection sets you have defined to narrow the data included in the selected view filter.

**Note:** Selection sets can contain objects that have no visible display, such as coordinates. In the Selection Explorer, all selection sets are available. In the View Filter Manager, however, only selection sets that contain at least one visible object are available.

**Include newly created layers**
Check/uncheck this box to include/exclude object types and layers that are added to the project after the view filter was defined.

**Locked**
Check/uncheck this box to make the view filter uneditable/editable.

**Show display styles**
Check/uncheck this box to show/hide the display styles tabs in the View Filter Manager.

**Show CAD display options**
Check/uncheck this box to show/hide the CAD data group (CAD block, line, text) in the View Filter Manager.

**Visible / Selectable (in the groups)**
Check/uncheck the boxes to control what is visible and selectable in graphic views.

In addition to the standard data types and layers available in the View Filter Manager, there is a group for CAD blocks, lines, and text.

**Apply (button)**
Click this to apply your changes and refresh the current graphic view.

**Point tab options**
**Show point labels**
Check and uncheck this box to show and hide the label text of the point ID for points.

**Show disconnected points**
Check and uncheck this box to show and hide points that are not connected to baselines or vectors.

**Observations tab options**
Click this tab for survey-related view filter options.

**GNSS tab options**
Click this tab for survey-related view filter options.
View, Navigate, and Select

Context menu options

View all/
Hide all
Within a group, select this to check/unccheck all of the boxes, displaying of hiding all of those object types or layers in the graphic view.

View only this
Within a group, select this to check the selected object type or layer, and uncheck everything else in the group.

Note: If no data is visible after you select View Only This, make sure that the box for the layer the data is on is also checked.

Move up/
Move down
On a group, select this to move the group up or down in the tree so that your most frequently used groups are at the top.
The order is saved with your project, and is the same for all view filters.

Layer options
Within the Layers group, select this to open the Layer Options (on page 80) command pane.

Related topics

- Create a View Filter (on page 82)
- Edit a View Filter (on page 84)
- Filter a View (on page 85)
- Troubleshoot a Layer or View Filter Problem (see "Troubleshoot a Layer or View Filter Problem" on page 92)
- View Filter Options (see "View Filter Manager Options" on page 88)

Troubleshoot a Layer or View Filter Problem

Before calling Support, use any applicable solutions to known issues below.

<table>
<thead>
<tr>
<th>Symptom</th>
<th>Possible Cause</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>The graphic view redraws slowly when you make changes to view filters.</td>
<td>Your project contains a lot of data, and your computer's graphics memory is running at capacity.</td>
<td>Click the icon on the View Filter Manager's toolbar to open the Advanced View Filter Settings dialog. When you make changes to view filters in this dialog, the graphic view does not automatically redraw. You can click Apply at any time to have the view redraw. or Select Project &gt; Project Settings. Click View and then View Filters in the left pane, and select a default view filter other than All so that graphic views refresh more quickly.</td>
</tr>
</tbody>
</table>
The points on a layer are not visible, even though you have the layer's box checked in the View Filter Manager to make it visible.

The Point box in the Raw Data group is not checked.

Make sure that the boxes for both the points and the layer that the points are on are checked, making them visible in the view.

Some of the selection sets you created do not appear in the View Filter Manager's selection sets list.

The missing selection sets that do not contain any visible objects.

None. Selection sets can contain objects that have no visible display, such as coordinates. In the Selection Explorer, all selection sets are available. In the View Filter Manager, however, only selection sets that contain at least one visible object are available.

Related topics

- Create a View Filter (on page 82)
- Edit a View Filter (on page 84)
- Filter a View (on page 85)
- View Filter Options (see "View Filter Manager Options" on page 88)
- Advanced View Filter Options (on page 90)

Troubleshoot a View or Selection Problem

Before calling Support, use any applicable solutions to known issues below.

<table>
<thead>
<tr>
<th>Symptom</th>
<th>Possible Cause</th>
<th>Solution</th>
</tr>
</thead>
</table>
| The graphic view redraws slowly when you make changes to view filters, or when you change the size of panes. | Your project contains a lot of data, and your computer's graphics memory is running at capacity. | Click the  icon on the View Filter Manager's toolbar to open the Advanced Settings dialog. When you make changes to view filters in this dialog, the graphic view does not automatically redraw. You can click Apply at any time to have the view redraw.  

or  
Select Project > Project Settings.  
Click View and then View Filters in the left pane, and select a default view filter other than All so that graphic views refresh more quickly. |

<table>
<thead>
<tr>
<th>Symptom</th>
<th>Possible Cause</th>
<th>Solution</th>
</tr>
</thead>
</table>
| The 3D view is replaced by a red X and this message: "The system has run out of graphics (no screen saver interruption)" | The system has run out of graphics memory. | 1. Close any unneeded programs that are running, especially ones that are graphics intensive.  
2. Close all 3D views, including those with a red X. |
### View, Navigate, and Select

<table>
<thead>
<tr>
<th>Issue</th>
<th>Recommendation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Memory. Close any unnecessary windows and retry.</td>
<td>Close the 3D view and reopen it. Long-term: Consider upgrading your graphics card.</td>
</tr>
<tr>
<td>The 3D view is replaced by a red X and this message: &quot;The system has run out of graphics memory. Close any unnecessary windows and retry.&quot;</td>
<td>Close the 3D view and reopen it. Close and reopen the program and the project. Update to the latest version of DirectX.</td>
</tr>
<tr>
<td>Some of the selection sets I created do not appear in the View Filter Manager’s selection sets list. The missing selection sets that do not contain any visible objects.</td>
<td>None. Selection sets can contain objects that have no visible display, such as coordinates. In the Selection Explorer, all selection sets are available. In the View Filter Manager, however, only selection sets that contain at least one visible object are available.</td>
</tr>
<tr>
<td>Your graphic views are pixilated or contain artifacts when you pan or rotate them. You are not using the optimal advanced display setting.</td>
<td>Select <strong>Tools &gt; Options</strong>. In the <strong>Options</strong> dialog, click <strong>Startup and Display</strong> in the left pane, and then click <strong>Advanced</strong>. Check the <strong>Override automatic detection</strong> box, and select the appropriate option for your operating system.</td>
</tr>
<tr>
<td>Your mouse movements are delayed or track intermittently, even though you are using an advanced display setting (see above). Your graphics card is integrated into the motherboard, or is not sufficient for advanced display settings.</td>
<td>Select <strong>Tools &gt; Options</strong>. In the <strong>Options</strong> dialog, click <strong>Startup and Display</strong> in the left pane, and then click <strong>Advanced</strong>. Check the <strong>Override automatic detection</strong> box, and try each of these graphics display packages (in order, restarting the program between each): 1. DirectX 2. OpenGL 3. GDI</td>
</tr>
</tbody>
</table>
**Your system suffers from generally poor graphics performance.**

**Two system settings are not set to optimize the graphics display.**

Try the solution directly above first. If it does not improve your graphics performance, right-click on your Windows desktop, and select **Properties** from the context menu. In the **Display Properties** dialog, click the **Settings** tab, and select **Medium (16 bit)** in the **Color quality** list. Second, click the **Advanced** button in the same dialog. In the **Plug and Play** dialog, click the **Troubleshoot** tab, and set **Hardware acceleration** to **Full**.

---

## Calculate and Enter Values

This software incorporates interactive, graphical tools that you can use to calculate and enter values.

They include:

- **COGO controls** (see "Understanding COGO Controls" on page 95)
- **Running snap modes** (see "Set Running Snap Modes" on page 99)
- **Snap commands** (see "Use Snap Commands" on page 100)

Use these tools to calculate and enter angles, bearings, coordinates, distances, elevations, and offsets in your project. After you have imported survey, map, or engineering data, start at a known point or object, and use these functions to create other points and lines in your project.

COGO and snap tools are powerful because they enable you to enter data in consistent ways for a variety of commands.

### Understanding COGO Controls

COGO controls are the boxes in various commands that help you calculate angles, bearings, coordinates, distances, elevations, and offsets in your project. They enable you to enter data in a variety of ways, including:
- Typing values and point IDs in the box
- Picking points in graphic views
- Right-clicking in graphic views and selecting additional snap and COGO options from the context menu

COGO controls give you this flexibility so that you have many ways in which you can enter data within a single command, rather than forcing you to work through multiple commands.

Since COGO controls are used in many commands, once you understand how to use them, you will be able to apply your knowledge all to the commands that use them.

**COGO cursors**

Depending on the type of control you are in, the appearance of the cursor changes in graphic views. The name of the control also appears on the status bar, and the status line’s tooltip tells how use the control.

**Cursor types**

- Pick any point.
- Pick any point or applicable object (arc, line, segment, point).
- Pick any applicable object.
- No anchor point has been defined.
- No anchor point has been defined.

The pick function is unavailable, or the object you are trying to pick is invalid. Often, you can click a blank space in the *Project Explorer* or a command pane to refresh the cursor for the graphic views.

**Related topics**

- [COGO Expressions, Units, and Entry Formats](on page 97)
- [Set the Pick Aperture](on page 98)
- [Snaps Modes and Commands](on page 98)
COGO Expressions, Units, and Entry Formats

Mathematical expressions

You can enter numbers in many of the COGO controls. When a COGO control supports numeric entry, you can use basic mathematic expressions by including the operators as shown. The value is calculated when you leave the control.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Addition</td>
<td>10+10</td>
</tr>
<tr>
<td>Subtraction</td>
<td>10-2</td>
</tr>
<tr>
<td>Multiplication</td>
<td>10*8</td>
</tr>
<tr>
<td>Division</td>
<td>8/4</td>
</tr>
<tr>
<td>Power</td>
<td>10^2</td>
</tr>
<tr>
<td>Simple expressions</td>
<td>5*(6+8)</td>
</tr>
<tr>
<td>(for distance, bearing, and coordinate controls)</td>
<td>052&gt;054 (for distance or bearing between points)</td>
</tr>
<tr>
<td>Exponential notation</td>
<td>1.01E+6</td>
</tr>
<tr>
<td>(for distance and coordinate controls)</td>
<td></td>
</tr>
<tr>
<td>Separated formats</td>
<td>1,000,000 = 1000000</td>
</tr>
<tr>
<td>(for distance and coordinate controls)</td>
<td>1.000.000 = 1000000</td>
</tr>
</tbody>
</table>

Units and data entry formats

The units, and entry and display formats, for data can be found and set in the Units (see "Unit Settings" on page 159) section of the Project Settings dialog.

The current distance units, which are also used for the gridlines, display on the status bar. Distances that you enter are in these units. You can, however, enter other units in COGO controls by including a character for the type of unit. For example, if your project units are set to international foot, you can enter 3m in a COGO control to specify 3 meters. The unit you enter will be converted to the project units.

Entering point IDs

If you enter a point ID for a single value, such as an elevation, type quotation marks around the point ID to distinguish it as the elevation of the point, not just an elevation value. For example, to use the elevation for point 1001, type "1001" in the control. In coordinate controls where you are entering a pair of coordinates, typing the point ID without quotes will suffice. The coordinates of the point are used.

Related topics

- Change Project Units (on page 160)
- Unit Settings (on page 159)
Set the Pick Aperture

The pick aperture is the box appearing on certain cursors. It shows the area in which applicable objects can be picked.

To set the size of the pick aperture:

1. Select Tools > Options. The Options dialog displays.
2. Click Startup and Display.
3. Specify a value in the Pick aperture box.
4. Click OK.

Related topics

- Startup and Display Options (on page 148)

Snaps Modes and Commands

Snaps use geometric calculations to help you specify and select coordinates and points more easily and accurately. Snaps can either use existing geometry or values that you enter during the command. There are two types of snap functions:

Snaps

Running snap modes

These modes are similar to the snap commands, except that (when enabled) they are always active. The running snap modes establish the order of precedence for the point snap modes. They can be temporarily overridden by using a specific snap command.

Note: Running snaps are available only for point (coordinate) snaps. There are no running snaps for angle, bearing, distance, offset, elevation, or station controls.

Snap commands

These commands enable you to enter angles, bearings, coordinates, distances, elevations, and offsets to calculate coordinates in your project. You can also select (or enter) applicable objects, such as breaklines, alignments, surfaces, and point IDs in snap commands.

Related topics

- COGO Controls (see "Understanding COGO Controls" on page 95)
- Running Snap Mode Options (on page 99)
- Set Running Snap Modes (on page 99)
- Use Snap Commands (on page 100)
Set Running Snap Modes

Running snaps are frequently-used snaps that are constantly enabled ("running"), so that you do not have to initiate a specific snap command each time you need one. You can, however, specify which of the five running snap modes you want to be active at any time.

**Note:** If multiple snap modes are active, and you pick a point in a graphic view that satisfies multiple snaps, the snap closest to the center of the pick aperture prevails.

When a snap is active, the cursor’s appearance indicates the type of snap. For instance, when you are in a snap mode that lets you pick an object, the cursor displays with a pick aperture (box). If you are in free snap, the cursor displays with cross hairs. See COGO Controls (see "Understanding COGO Controls" on page 95) for more information.

There is no visual feedback in graphic views when you snap to a point, but the coordinate of the point is entered into the control in which you are working.

**To set running snap modes:**

1. Do one of the following:
   - Click Snap on the status bar.
   - Select Project > Snap Mode.
   
   The **Snap mode** dialog displays.

2. Check (or uncheck) boxes next to any of the modes you want to enable (or disable).

   **Note:** You need to have at least one snap mode enabled. Otherwise, you will not be able to pick anything in the graphic views.

3. Click OK to close the dialog.

   **Note:** Running snap modes are superseded by snap commands.

**Related Topics**

- Running Snap Mode Options (on page 99)

**Running Snap Mode Options**

Use these options to set which frequently-used snaps are constantly enabled, so that you do not have to initiate a specific command each time you need a snap. They are available in the **Snap Mode** dialog.
Options

Point
If a point object is inside the pick aperture, the coordinate of the point will be used.

End point
If the end point of a line or arc segment is inside the pick aperture, the coordinate of the end point will be used.

Insertion point
If any part of a text or block object is inside the pick aperture, the insertion point of the object will be used.
This running snap mode is disabled by default.

Surface vertex
If a surface vertex is inside the pick aperture, the coordinate of the vertex will be used.

Free
The coordinate at the intersection of the cross hairs will be used.
This mode will be used if none of the other modes are satisfied or selected.
If no other modes are active, the Free mode is active by default.

Related topics
- Set Running Snap Modes (on page 99)

Use Snap Commands

Snap commands use geometric calculations to help you specify coordinates more easily and accurately. Snaps can either calculate a snap point using existing geometry, or use parameters that you enter during a command. Snap commands, as opposed to running snaps, are single-instance snaps that you initiate each time you need one. They apply to the current command only.

There is no visual feedback in graphic views when you calculate (snap) to a point, but the coordinate of the point is entered into the control in which you are working.

To use a snap command:

1. When you are in a COGO control (see "Understanding COGO Controls" on page 95), move your cursor into a graphic view and right-click. A context menu displays snap command options, depending on the control you are using.

2. Select one of the snap commands. The snap's command pane displays.

3. Specify parameters for the snap.

4. Click OK to return to the original COGO control.

Note: Snap commands supersede running snap modes.
Calculate and Enter Values

Stacked commands

To help you calculate a certain value, you can "stack" multiple snap commands. This means that you can access one snap command from within another until you have several snap commands stacked upon one another in the command pane. To practice, work through the tutorial.

Related Topics

- Set Running Snap Modes (on page 99)
- Snaps Modes and Commands (on page 98)

Enter an Angle

Use the Angle control to enter an angle by specifying a bearing in relation to the default bearing. The default bearing (and zero angle) is east. Positive angles are measured counter-clockwise from 0 to <360 degrees. "Angle" appears on the status bar when the command is active.

Angle controls are used in these snap commands:

- Bearing + Angle Snap (on page 105)

Angle controls give you access to these snap commands on the context menu:

- Deflection Angle Snap (on page 101)
- Three Point Snap (on page 102)

To specify an angle:

- Pick an anchor point in a graphic view. With the cursor "rubber-banding" from the default bearing, pick another point to specify the angle.
- Type a value in the Angle box, using one of the standard entry formats. Check and set the entry format in Project Settings by selecting Project > Project Settings > Units > Angular.
- Right-click in a graphic view, select a snap command from the context menu, and specify the necessary parameters.

Related topics

- COGO Controls (see "Understanding COGO Controls" on page 95)
- COGO Expressions, Units, and Entry Formats (on page 97)
- Snaps Modes and Commands (on page 98)

Deflection Angle Snap

Use this command to calculate an angle between two bearings.

**Deflection Angle Snap** can be used in these controls:
Calculate and Enter Values

- **Angle** (see "Enter an Angle" on page 101)

To use a **Deflection Angle Snap**:  

1. While in an angle control, right-click in a graphic view, and select **Deflection Angle Snap** from the context menu. The **Deflection Angle Snap** command pane displays.
2. Pick two points or a line in the view, or type a value in the **Bearing 1** box.
3. Pick two more points or another line in the view, or type a value in the **Bearing 2** box. The angle between the bearings is recorded, and the command pane returns to the previous command.

Related topics

- [Understanding COGO Controls](#) (on page 95)
- [COGO Expressions, Units, and Entry Formats](#) (on page 97)
- [Snaps Modes and Commands](#) (on page 98)

**Three Point Snap**

Use this command to calculate an angle based on three points picked in sequence.

**Three Point Snap** can be accessed from these control context menus:
Calculate and Enter Values

- **Angle** (see "Enter an Angle" on page 101)

![Diagram of a 55° angle between three points](image)

**To use a Three Point Snap:**

1. While in an angle control, right-click in a graphic view, and select **Three Point Snap** from the context menu. The **Three Point Snap** command pane displays.
2. Select an angle type (**Acute** or **Obtuse**) in the **Options** list.
3. Pick a point, or type a coordinate or Point ID in the **Start point** box.
4. Pick a second point, or type a coordinate or Point ID in the **Pivot point** box.
5. Pick a third point, or type a coordinate or Point ID in the **End point** box to specify the angle.
6. The angle between the three points is recorded, and the command pane returns to the previous command.

**Related topics**

- [Understanding COGO Controls](#) (on page 95)
- [COGO Expressions, Units, and Entry Formats](#) (on page 97)
- [Snaps Modes and Commands](#) (on page 98)

**Enter a Bearing**

Use the Bearing control to specify an azimuthal bearing. The default bearing (and zero angle) is north. Positive bearings are measured clockwise. "Bearing" appears on the status bar when the command is active.

Bearing control is used in these snap commands:
Calculate and Enter Values

- **Bearing Bearing Snap** (on page 108)
- **Bearing Distance Snap** (on page 109)
- **Bearing + Angle Snap** (on page 105)

Bearing control gives you access to these snap commands on the context menu:
- **Bearing + Angle Snap** (on page 105)
- **Point to Point Bearing Snap** (on page 106)

**To specify a bearing:**

- Pick an anchor point in a graphic view. With the cursor "rubber-banding" from the default bearing, pick another point to specify the bearing.

- Pick a line segment in a graphic view. The bearing of the segment is used. Each line segment has two bearings, so pick a point on the line segment close to the end to which you want to the bearing to travel. If you pick an arc segment, the bearing tangent to the segment at that point will be computed. If you pick a text object, the bearing at which the text object is located is used. This allows you to use the bearing control to align text objects with other text objects.

- Type a value in the **Bearing** box, using one of the standard entry formats. Check and set the entry format in **Project Settings** by selecting **Project > Project Settings > Units > Azimuth**.

- Type a point ID to point ID notation (e.g. 1>2) in the **Bearing** box, to recall the bearing between the points.

- Right-click in a graphic view, select a snap command from the context menu, and specify the necessary parameters.

**Horizontal Angle Modes**

You can also enter bearings using a prefix or suffix code for the angle mode. For example, for a 90 degree, 15 minute, and 2 second angle from the north azimuth, type: **NA901502** or **901502NA**.

The codes below are supported.

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>NA</td>
<td>North Azimuth</td>
</tr>
<tr>
<td>SA</td>
<td>South Azimuth</td>
</tr>
<tr>
<td>AR</td>
<td>Angle Right</td>
</tr>
<tr>
<td>AL</td>
<td>Angle Left</td>
</tr>
<tr>
<td>DR</td>
<td>Deflection Right</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Bearing + Angle Snap

Use this command to calculate a bearing by adding an angle to a given bearing.

Bearing + Angle Snap can be used in these controls:

- **Bearing** (see "Enter a Bearing" on page 103)

To use a Bearing Plus Angle Snap:

1. While in a bearing control, right-click in a graphic view, and select **Bearing + Angle Snap** from the context menu. The **Bearing + Angle Snap** command pane displays.
2. Pick two points in the view, or type a value in the **Bearing** box.
3. Pick two more points, or type a value in the **Angle** box. The bearing is recorded, and the command pane returns to the previous command.

Related topics

- **Understanding COGO Controls** (on page 95)
Point to Point Bearing Snap

Use this command to compute the bearing from one point to another point.

Point to Point Bearing Snap can be used in these controls:

- **Bearing** (see "Enter a Bearing" on page 103)

**To use a Point to Point Bearing Snap:**

1. While in a bearing control, right-click in a graphic view, and select **Point to Point Snap** from the context menu. The **Point to Point Snap** command pane displays.

2. Pick a point in the view, or type a coordinate or Point ID in the **Reference point 1** box.

3. Pick a point, or type a coordinate or Point ID in the **Reference point 2** box. The bearing is recorded, and the command pane returns to the previous command.

Related topics

- **Understanding COGO Controls** (on page 95)
- **COGO Expressions, Units, and Entry Formats** (on page 97)
- **Snaps Modes and Commands** (on page 98)

Enter a Coordinate

Use the Coordinate control to specify X, Y, and Z, or latitude, longitude, and elevation coordinates of a point. If a Z or elevation coordinate is entered in the coordinate control, and there is also an elevation control for the same point, the value will be placed in the elevation control. "Coordinate" appears on the status bar when the command is active.
To specify a coordinate:

- Pick a point in a graphic view. If no running snap modes are enabled, the default operation does not specify a Z coordinate. If running snaps are enabled, the cursor will potentially snap to a location and use its Z value based on the snap mode.

- Type a point ID in the coordinate box using any of the standard entry formats. If there are multiple points with the same ID, then the one with the best quality is used. Check and set the entry format in the Project Settings by selecting Project > Project Settings > Units > Coordinate.

  **Note:** If you enter a point ID for a single value, such as an elevation, type quotation marks around the point ID to distinguish it as the elevation of the point, not just an elevation value. For example, to use the elevation for point 1001, type "1001." in the control. In coordinate controls where you are entering a pair of coordinates, typing the point ID without quotes will suffice. The coordinates of the point are used.

- Type two or three numbers separated by a space or comma to specify a coordinate pair or triplet, in the format N, E, (Z). The separator is user-definable in the Project Settings. Typically, spaces or commas are used to specify coordinate pairs or triplets.

  Examples: 27,42, (1)

  27 42 1

  27,42

  In the plan view, these normally represent N, E, (Z). In the profile view these normally represent station and elevation. The control honors the ordering of the X and Y values as specified for the current view.

  Although you will usually be entering grid based coordinates, you can also enter latitude and longitude coordinates in the format Latitude, Longitude, (Z). To do this, a coordinate system must be defined for the project. Do not use spaces to separate the coordinates because spaces are used to separate the angle components.

  Examples: N40°35’18.12345”, E120°23’12.32145”, 1000

  N40 35 18.12345, E120 23 12.32145, 1000

  N40 35 18.12345, E120 23 12.32145
To specify a relative coordinate:

- Type an @ before a value to specify a relative distance from a previous point (when the cursor has an anchor point). The @ symbol must be used before each relative coordinate, but you can enter both relative and absolute coordinates in the same control. The relative distance separator is user-definable in the Project Settings, but typically, @ is used as shown.

Examples:  
@27, @42  
@27 @42

In any view with a vertical exaggeration you can substitute a grade (G) for the elevation when setting a point relative to a previous point. This can be used in conjunction with a relative (@S) station value. Valid entries for grade are: (%) or P) for percent of grade and (;, or R) for ratio grade, e.g. 2:1.

Examples:  
@500,2%  
@500 2P

In any view with a vertical exaggeration, you can substitute a Maximum (M) depth for the station and grade (G) for the elevation when setting a point relative to a previous point. The maximum depth will be the change in depth (elevation) from the previous point. Valid entries for grade are: (%) or P) for per cent of grade and (;, or R) for ratio grade, e.g. 2:1. This type of entry is typically used in defining templates used with roads.

Examples:  
5,2%  
5 2%

Related topics
- COGO Controls (see "Understanding COGO Controls" on page 95)
- COGO Expressions, Units, and Entry Formats (on page 97)
- Snaps Modes and Commands (on page 98)

**Bearing Bearing Snap**

Use this command to calculate the intersection of two bearings defined by a first point and second point. No elevation (Z value) is set using this option. This snap is helpful in calculating the coordinates of a location that cannot be occupied, such as the center of a tree.

**Bearing Bearing Snap** can be used in these controls:
To use a Bearing Bearing Snap:

1. While in a coordinate control, right-click in a graphic view, and select **Bearing Bearing Snap** from the context menu. The **Bearing-Bearing Snap** command pane displays.

2. Pick a point in the view, or type a coordinate or point ID in the **Reference point 1** box.

3. Pick a second point, or type a value in the **Bearing 1** box.

4. Pick a point, or type a coordinate or point ID in the **Reference point 2** box.

5. Pick a second point, or type a value in the **Bearing 2** box, to specify the bearing. The coordinate is calculated at the intersection of **Bearing 1** and **Bearing 2**, and the command pane returns to the previous command.

**Related topics**

- **Understanding COGO Controls** (on page 95)
- **COGO Expressions, Units, and Entry Formats** (on page 97)
- **Snaps Modes and Commands** (on page 98)

**Bearing Distance Snap**

Use this command to calculate a point based on a beginning point, a bearing, and a distance. The zero (0) bearing is north, and bearings are measured clockwise. No elevation (Z value) is set using this option.

**Bearing Distance Snap** can be used in these controls:
Calculate and Enter Values

- **Coordinate** (see "Enter a Coordinate" on page 106)

To use a Bearing Distance Snap:

1. While in a coordinate control, right-click in a graphic view, and select **Bearing Distance Snap** from the context menu. The **Bearing Distance Snap** command pane displays.

2. Pick a point in the view, or type a coordinate or point ID in the **Reference point** box.

3. Pick a second point, or type a value in the **Bearing** box.

4. Pick a third point, or type a value in the **Distance** box. The coordinate is recorded, and the command pane returns to the previous command.

Related topics

- **Understanding COGO Controls** (on page 95)
- **COGO Expressions, Units, and Entry Formats** (on page 97)
- **Snaps Modes and Commands** (on page 98)

Center of Arc Snap

Use this snap command to calculate the center point of an arc (or parabolic curve segment or spiral curve segment) when you select the arc. The elevation of the arc is used as the Z value.

**Center of Arc Snap** can be used in these controls:
To use a Center of Arc Snap:

1. Right-click in a graphic view, and select Center of Arc Snap from the context menu. The Center of Arc Snap command pane displays.
2. In the view, pick an arc. The coordinate is recorded, and the command pane returns to the previous command.

Related topics
- Understanding COGO Controls (on page 95)
- COGO Expressions, Units, and Entry Formats (on page 97)
- Snaps Modes and Commands (on page 98)

Center of Gravity Snap

Use this command to calculate a point based on the area within a closed line. If the line segment picked has an elevation, the Z value of the segment is used.

Center of Gravity Snap can be used in these controls:
- Coordinate (see "Enter a Coordinate" on page 106)
To use a Center of Gravity Snap:

1. While in a coordinate control, right-click in a graphic view, and select Center of Gravity Snap from the context menu. The Center of Gravity Snap command pane displays.
2. Pick a segment of a closed line in the view. The coordinate at the center of the area is recorded, and the command pane returns to the previous command.

Related topics
- Understanding COGO Controls (on page 95)
- COGO Expressions, Units, and Entry Formats (on page 97)
- Snaps Modes and Commands (on page 98)

Distance Distance Snap

Use this command to calculate a point based on radial distances from two reference points, selecting one of the two points where the resulting arcs intersect.

Distance Distance Snap can be used in these controls:
- Coordinate (see "Enter a Coordinate" on page 106)

To use a Distance Distance Snap:

1. While in a coordinate control, right-click in a graphics view, and select Distance Distance Snap from the context menu. The Distance Distance command pane displays.
2. Pick a point in the view, or type a coordinate or point ID in the Center point 1 box.
3. Pick a second point, or type a value in the Distance 1 box.
4. Pick a point, or type a coordinate or point ID in the Center point 2 box.
5. Pick a second point, or type a value in the Distance 2 box.
6. Select one of the intersecting points by picking a side in the view, or by selecting an option in the Side list. The coordinate is recorded, and the command pane returns to the previous command.

Related topics
- Understanding COGO Controls (on page 95)
- COGO Expressions, Units, and Entry Formats (on page 97)
- Snaps Modes and Commands (on page 98)

Delta X Delta Y Snap

Use this command to calculate a point using a relative X and Y distance from a reference point. The elevation of the origin point is used as the Z value.

DxDy Snap can be used in these controls:
Calculate and Enter Values

- **Coordinate** (see "Enter a Coordinate" on page 106)

To use a DxDy Snap:

1. While in a coordinate control, right-click in a graphic view, and select **DxDy Snap** from the context menu. The **DxDy Snap** command pane displays.
2. Pick a point in the view, or type a coordinate or point ID in the **Reference point** box.
3. Pick a second point, or type a distance from the reference point in the **Easting Distance** box.
4. Pick a third point, or type a distance from the reference point in the **Northing Distance** box. The coordinate is recorded, and the command pane returns to the previous command.

Related topics

- [Understanding COGO Controls](on page 95)
- [COGO Expressions, Units, and Entry Formats](on page 97)
- [Snaps Modes and Commands](on page 98)

**End Snap**

Use this command to calculate the point at the end of a line segment closest to where you pick on the line segment. The elevation of the end point is used.

**End Snap** can be used in these controls:
Calculate and Enter Values

- **Coordinate** (see "Enter a Coordinate" on page 106)

---

**To use an End Snap:**

1. While in a coordinate control, right-click in a graphic view and select **End Snap** from the context menu. The **End Snap** command pane displays.
2. Pick a line segment near the end to which you want to snap. The coordinate at the end of the line segment is recorded, and the command pane returns to the previous command.

**Related topics**
- **Understanding COGO Controls** (on page 95)
- **COGO Expressions, Units, and Entry Formats** (on page 97)
- **Snaps Modes and Commands** (on page 98)

**Factor of Line Snap**

Use this command to calculate a point at a factored distance along a line. You can enter any multiplication factor greater than zero (for example, 0.5 = 50% from the end of the line). If the line has a slope, the Z value is interpolated.

**Factor of Line Snap** can be used in these commands:
To use a Factor of Line Snap:

1. While in a coordinate control, right-click in a graphic view, and select Factor > Factor of Line Snap from the context menu. The Factor of Line Snap command pane displays.
2. Pick a line near the end from which you want to factor the distance. The line is recorded in the Line box.
3. Type a factor in the Multiplication Factor box.
4. Click OK. The coordinate is recorded, and the command pane returns to the previous command.

Related topics

- Understanding COGO Controls (on page 95)
- COGO Expressions, Units, and Entry Formats (on page 97)
- Snaps Modes and Commands (on page 98)

**Factor of Segment Snap**

Use this command to calculate a point at a factored distance along a line segment. You can enter any multiplication factor greater than zero (for example, 0.5 = 50% from the end of the line). Zero (0) snaps to the end of the line closest to where you pick, and 1 snaps to the furthest end of the line. If the line has a slope, the Z value is interpolated.

**Factor of Segment Snap** can be used in these controls:
To use a Factor of Segment Snap:

1. While in a coordinate control, right-click in a graphic view, and select **Factor > Factor of Segment Snap** from the context menu. The **Factor of Segment Snap** command pane displays.
2. Pick a line segment near the end from which you want to factor the distance. The segment is recorded in the **Segment** box.
3. Type a factor in the **Multiplication Factor** box.
4. Click **OK**. The coordinate is calculated, and the command pane returns to the previous command.

Related topics

- Understanding COGO Controls (on page 95)
- COGO Expressions, Units, and Entry Formats (on page 97)
- Snaps Modes and Commands (on page 98)

**Free Snap**

Use this command to use the coordinates of any point picked in a view. No elevation is set using this option.

**Free Snap** can be used in these controls:
To use a Free Snap:

1. While in a coordinate control, right-click in a graphic view, and select **Free Snap** from the context menu. The **Free Snap** command pane displays.

2. Pick a point, or type a coordinate or point ID in the **Free Point** box. The command pane returns to the previous command.

**Note:** **Free Snap** is one of the default running snap modes, so unless you have it disabled in the **Snap Mode** dialog, you don't need to explicitly select **Free Snap** from the context menu. Use this option when you have multiple running snaps active and you don't want to snap to a point, end point, etc.

Related topics
- [Understanding COGO Controls](#) (on page 95)
- [COGO Expressions, Units, and Entry Formats](#) (on page 97)
- [Snaps Modes and Commands](#) (on page 98)

**Intersection of Lines Snap**

Use this command to calculate the intersection (or projected intersection) of two lines. If there are several possible intersections, the intersection closest to where the lines were picked is used. No elevation is set using this option.

**Intersection of Lines Snap** can be used in these controls:
- **Coordinate** (see "Enter a Coordinate" on page 106)

**To use an Intersection of Lines Snap:**

1. While in a coordinate control, right-click in a graphic view, and select **Intersection > Intersection of Lines Snap** from the context menu. The **Intersection of Lines Snap** command pane displays.

2. Pick a line in the view. The line is recorded in the **Line 1** box.
3. Pick another line. The line is recorded in the Line 2 box. The coordinate is recorded, and the command pane returns to the previous command.

Related topics
- Understanding COGO Controls (on page 95)
- COGO Expressions, Units, and Entry Formats (on page 97)
- Snaps Modes and Commands (on page 98)

Intersection of Offset Segments Snap

Use this command to calculate the intersection of offsets from two selected line or arc segments. From the end of the segment closest to where it was picked, looking to the other end, positive offsets are to the right and negative offsets are to the left of the segment.

Intersection of Offset Segments Snap can be used in these controls:
- Coordinate (see "Enter a Coordinate" on page 106)

To use an Intersection of Offset Segments Snap:

1. While in a coordinate control, right-click in a graphic view, and select Intersection > Intersection of Offset Segments Snap from the context menu. The Intersection of Offset Segments Snap command pane displays.
2. Pick a line or arc segment in the view. The segment is recorded in the Line segment 1 box.
3. Pick a point offset from the line, or type a value in the Offset 1 box. For the offsets, you can enter a negative or positive offset distance from the line.
4. Pick a second line or arc segment. The segment is recorded in the Line segment 2 box.
5. Pick a point offset from the second line, or type a value in the Offset 2 box. You can enter a negative or positive offset distance from the line. The coordinate is recorded, and the command pane returns to the previous command.

Related topics
- Understanding COGO Controls (on page 95)
- COGO Expressions, Units, and Entry Formats (on page 97)
- Snaps Modes and Commands (on page 98)

Intersection of Offset Lines Snap

Use this command to calculate the intersection of offsets from two lines or arcs. The offsets are projected from the entire lines or arcs, rather than just line or arc segments. From the end of the line closest to where it was picked, looking to the other end, positive offsets are to the right and negative offsets are to the left of the line.
You can also calculate the intersection of offsets from two horizontal alignments (HALs).

*Intersection of Offset Lines Snap* is used in these controls:

- **Coordinate** (see "Enter a Coordinate" on page 106)

**To use an Intersection of Offset Lines Snap:**

1. While in a coordinate control, right-click in a graphic view, and select *Intersection > Intersection of Offset Lines Snap* from the context menu. The *Intersection of Offset Segments Snap* command pane displays.

2. Pick a line in the view. The line is recorded in the *Line 1* box.

3. Pick a point offset from the line, or type a value in the *Offset 1* box. For the offsets, you can enter a negative or positive offset distance from the line.

4. Pick a second line. The line is recorded in the *Line 2* box.

5. Pick a point offset from the second line, or type a value in the *Offset 2* box. The coordinate is recorded, and the command pane returns to the previous command.

**Related topics**

- **Understanding COGO Controls** (on page 95)
- **COGO Expressions, Units, and Entry Formats** (on page 97)
- **Snaps Modes and Commands** (on page 98)

**Intersection of Segments Snap**

Use this command to calculate the projected intersection of two line or arc segments. If there are several possible intersections, the intersection closest to where the lines were picked is used.

*Intersection of Segments Snap* can be used in these commands:
- **Coordinate** (see "Enter a Coordinate" on page 106)

To use an Intersection of Segments Snap:

1. While in a coordinate control, right-click in a graphic view, and select *Intersection* > *Intersection of Segments Snap* from the context menu. The *Intersection of Segments Snap* command pane displays.

2. Pick a line segment in the view. The segment is recorded in the *Line segment 1* box.

3. In the view, pick another line segment. The segment is recorded in the *Line segment 2* box. The coordinate is recorded, and the command pane returns to the previous command.

Related topics

- [Understanding COGO Controls](on page 95)
- [COGO Expressions, Units, and Entry Formats](on page 97)
- [Snaps Modes and Commands](on page 98)

**Middle of Point to Point Snap**

Use this command to calculate the midpoint between two points.

*Middle of Point to Point Snap* can be used in these controls:

- **Coordinate** (see "Enter a Coordinate" on page 106)

To use a *Middle of Point to Point Snap*:

1. While in a coordinate control, right-click in a graphic view, and select *Middle of Point to Point Snap* from the context menu. The *Middle of Point to Point Snap* command pane displays.

2. Pick a point in the view, or type a coordinate or point ID in the *From point* box.
3. Pick a point, or type a coordinate or point ID in the To point box. The midpoint between the two selected points is recorded, and the command pane returns to the previous command.

Related topics
- Understanding COGO Controls (on page 95)
- COGO Expressions, Units, and Entry Formats (on page 97)
- Snaps Modes and Commands (on page 98)

Middle of Segment Snap

Use this command to calculate the middle point of a line or arc segment. If the line segment has a slope, the Z value is interpolated from the segment.

Middle of Segment Snap can be used in these controls:
- Coordinate (see "Enter a Coordinate" on page 106)

To use a Middle of Segment Snap:

1. While in a coordinate control, right-click in a graphic view, and select Middle of Segment Snap from the context menu. The Middle of Segment Snap command pane displays.

2. Pick a line segment in the view. The coordinate is recorded, and the command pane returns to the previous command.

Related topics
- Understanding COGO Controls (on page 95)
- COGO Expressions, Units, and Entry Formats (on page 97)
- Snaps Modes and Commands (on page 98)
Nearest to Line Snap

Use this command to calculate the closest point on a line within the pick aperture to the point you pick. If the point is on a line with a slope, the elevation value is interpolated.

**Nearest to Line Snap** can be used in these controls:
- Coordinate (see "Enter a Coordinate" on page 106)

To use a Nearest to Line Snap:

1. While in a coordinate control, right-click in a graphic view, and select **Nearest to Line Snap** from the context menu. The **Nearest to Line Snap** command pane displays.
2. Pick a line in the view. The coordinates on the line nearest to your pick location are recorded, and the command pane returns to the previous command.

Related topics
- Understanding COGO Controls (on page 95)
- COGO Expressions, Units, and Entry Formats (on page 97)
- Snaps Modes and Commands (on page 98)

Offset Line Snap

Use this snap command to calculate a point based on an offset from a station along the entire length of a line or an arc. Station zero is the end of the line closest to where it was picked. From station zero, looking down the line, positive offsets are to the right and negative offsets are to the left of the line. If the line has a sloping elevation, the Z value is interpolated from the station used.

**Note:** You can use this option to select a specific position along an arc by making the offset distance zero.
Offset Line Snap can be used in these controls:

- Coordinate (see "Enter a Coordinate" on page 106)

To use an Offset Line Snap:

1. While in a coordinate control, right-click in a graphics view, and select Offset > Offset Line Snap from the context menu. The Offset Line Snap command pane displays.
2. Pick a line in the view. The line is recorded in the Line box.
3. Pick a point, or type a value in the Station box.
4. Pick a point, or type a value in the Offset box. You can enter a negative or positive offset distance from the line. The coordinate is recorded, and the command pane returns to the previous command.

Related topics

- Understanding COGO Controls (on page 95)
- COGO Expressions, Units, and Entry Formats (on page 97)
- Snaps Modes and Commands (on page 98)

Offset Segment Snap

Use this command to calculate a point based on an offset from a station along a line or arc segment. Station zero is the end of the line closest to where it was picked. From station zero, looking down the line, positive offsets are to the right and negative offsets are to the left of the segment.

Offset Segment Snap can be used in these controls:

Coordinate (see "Enter a Coordinate" on page 106)

To use an Offset Segment Snap:

1. While in a coordinate control, right-click in a graphic view, and select Offset > Offset Segment Snap from the context menu. The Offset Segment Snap command pane displays.
2. Pick a line or arc segment in the view. The segment is recorded in the Line segment box.
3. Pick a point, or type a value in the Station box. You can enter a negative or positive offset distance from the segment.
4. Type a value in the Offset box. The coordinate is calculated, and the command pane returns to the previous command.

Tip: You can use this option to select a specific position along an arc by making the offset distance zero (0).
Related topics
- Understanding COGO Controls (on page 95)
- COGO Expressions, Units, and Entry Formats (on page 97)
- Snaps Modes and Commands (on page 98)

Perpendicular to Segment Snap

Use this command to calculate a perpendicular intersection from a point to a line segment or arc segment. If the line segment has an elevation, the Z value will be interpolated from the segment.

*Perpendicular to Segment Snap* can be used in these controls:
- **Coordinate** (see "Enter a Coordinate" on page 106)

**To use a Perpendicular to a Segment Snap:**

1. While in a coordinate control, right-click in a graphic view, and select **Perpendicular > Perpendicular to Segment Snap** from the context menu. The **Perpendicular to Segment Snap** command pane displays.
2. Pick a line segment in the view. The line is recorded in the *Line segment* box.
3. Pick a point or type a coordinate in the *Reference point* box. The coordinate is recorded, and the command pane returns to the previous command.

Related topics
- Understanding COGO Controls (on page 95)
- COGO Expressions, Units, and Entry Formats (on page 97)
- Snaps Modes and Commands (on page 98)

Perpendicular to Line Snap

Use this command to calculate a perpendicular intersection from a point to a line or arc. The entire length of the line or arc is used in the calculation. You can also calculate a perpendicular intersection of a point to a horizontal alignment (HAL).

*Perpendicular to Line Snap* can be used in these controls:
To use a Perpendicular to Line Snap:

1. While in a coordinate control, right-click in a graphic view, and select
   *Perpendicular > Perpendicular to Line Snap* from the context menu. The
   *Perpendicular to Line Snap* command pane displays.
2. Pick a line or a HAL in the view. The line or HAL is recorded in the *Line* box.
3. Pick a point, or type a coordinate in the *Reference point* box. The coordinate is
   recorded, and the command pane returns to the previous command.

Related topics

- [Understanding COGO Controls](#) (on page 95)
- [COGO Expressions, Units, and Entry Formats](#) (on page 97)
- [Snaps Modes and Commands](#) (on page 98)

**Point of Intersection Snap**

Use this command to calculate the point of intersection (PI) of a selected arc, spiral, or
parabola. No elevation is set using this option.

*Point of Intersection Snap* can be used in these commands:
**To use a Point of Intersection Snap:**

1. While in a coordinate control, right-click in a graphic view, and select *Point of Intersection Snap* from the context menu. The *Point of Intersection Snap* command pane displays.

2. Pick a spiral, arc, or parabola in the view. The intersection coordinates are recorded, and the command pane returns to the previous command.

**Related topics**
- [Understanding COGO Controls](on page 95)
- [COGO Expressions, Units, and Entry Formats](on page 97)
- [Snaps Modes and Commands](on page 98)

**Point Snap**

Use this command to specify the coordinates of a point ID. The elevation of the point is used as the Z value.

*Point Snap* can be used in these controls:
Calculate and Enter Values

- **Coordinate** (see "Enter a Coordinate" on page 106)

To use a Point Snap:

1. While in a coordinate control, right-click in a graphic view, and select **Point Snap** from the context menu. The **Point Snap** command pane displays.

2. Pick a point in the view, or type a point name in the **Point ID** box. The coordinates are recorded, and the command pane returns to the previous command.

Related topics

- [Understanding COGO Controls](on page 95)
- [COGO Expressions, Units, and Entry Formats](on page 97)
- [Snaps Modes and Commands](on page 98)

**Tangent Snap**

Use this command to calculate a point on an arc tangent to a previous point. No elevation is set using this option.

**Tangent Snap** can be used in these commands:
To use a Tangent Snap:

1. While in a coordinate control, right-click in a graphic view, and select Tangent Snap from the context menu. The Tangent Snap command pane displays.
2. Pick a point, or type a coordinate or point ID in the Reference Point box.
3. Pick an arc. The coordinates on the arc tangent to the reference point are recorded, and the command pane returns to the previous command.

Related topics
- Understanding COGO Controls (on page 95)
- COGO Expressions, Units, and Entry Formats (on page 97)
- Snaps Modes and Commands (on page 98)

XY Snap

Use this command to calculate a point based on the easting (Y-coordinate) of the first point you pick, and then to the northing (X-coordinate) of the second point you pick. If the second point has an elevation, it will be used for the Z value.

XY Snap can be used in these commands:
To use an XY Snap:

1. While in a coordinate control, right-click in a graphic view, and select **XY Snap** from the context menu. The **XY Snap** command pane displays.
2. Pick a point, or type a coordinate or point ID in the **Easting of point** box.
3. Pick a point, or type a coordinate or point ID in the **Northing of point** box. The coordinate is recorded, and the command pane returns to the previous command.

Related topics
- [Understanding COGO Controls](on page 95)
- [COGO Expressions, Units, and Entry Formats](on page 97)
- [Snaps Modes and Commands](on page 98)

Enter a Distance

Use the Distance control to specify a distance. Typically, this is a horizontal distance. When calculating 3D points, the horizontal distance can also be a slope distance (SD) and you will be alerted as such. "Distance" appears in the status bar when this control is active.

Distance control is used in these commands:
- [Bearing Distance Snap](on page 109)
- [Distance Distance Snap](on page 112)
- [DxDy Snap](see "Delta X Delta Y Snap" on page 112)
- [Distance + Distance Snap](see "Distance + Distance Snap (distance)" on page 130)
- [Factor of Distance Snap](see "Factor of Distance Snap (distance)" on page 131)

Distance control gives you access to these commands on the context menu:
Calculate and Enter Values

- **Distance + Distance Snap** (see "Distance + Distance Snap (distance)" on page 130)
- **Factor of Distance Snap** (see "Factor of Distance Snap (distance)" on page 131)
- **Point to Point Snap** (see "Point to Point Snap (distance)" on page 132)
- **Radius of Arc Snap** (see "Radius of Arc Snap (distance)" on page 133)

To specify a distance:

- Pick a point in a graphic view. With the cursor "rubber-banding", pick another point to specify the distance.
- Pick a line or line segment; the length of the segment will be used as the distance.
- Type a value in the **Distance** box to specify the horizontal distance or slope distance (SD), using any of the standard entry formats. Check and set the entry format in the **Project Settings** by selecting **Project > Project Settings > Units > Distance**.

  **Note:** When specifying a distance and slope from a point in the profile view, the distance is always horizontal.

- Type a point ID to point ID (e.g. 1>2), to recall the distance between two points.
- Type a distance using mathematical operators or an expression to calculate the distance. The valid operators are + - * / and () for expressions.
- Right-click in a graphic view, select a snap command from the context menu, and specify the necessary parameters.

  **Note:** In commands where the direction is not determined, the cursor will "rubber band" as a circle. The center point is the anchor point, and the circle is drawn through the second point.

**Related topics**

- [COGO Controls](#COGO Controls) (see "Understanding COGO Controls" on page 95)
- [COGO Expressions, Units, and Entry Formats](#COGO Expressions, Units, and Entry Formats) (on page 97)
- [Snaps Modes and Commands](#Snaps Modes and Commands) (on page 98)

**Distance + Distance Snap (distance)**

Use this command to calculate a distance by adding two distances. Either distance can be negative.

**Distance + Distance Snap** can be used in these controls:
- **Distance** (see "Enter a Distance" on page 129)
- **Offset** (see "Enter an Offset" on page 137)

To use a **Distance + Distance Snap**:

1. While in a distance or offset control, right-click in a graphic view, and select **Distance + Distance Snap** from the context menu. The **Distance + Distance Snap** command pane displays.

2. Pick two points or a line segment, or type a value in the **Distance 1** box.

3. Pick two more points or a line segment, or type a value in the **Distance 2** box. The distance is recorded, and the command pane returns to the previous command.

**Related topics**

- Understanding COGO Controls (on page 95)
- COGO Expressions, Units, and Entry Formats (on page 97)
- Snaps Modes and Commands (on page 98)

**Factor of Distance Snap (distance)**

Use this command to calculate a distance by applying a multiplication factor to a distance.

**Factor of Distance Snap** can be used in these controls:
Calculate and Enter Values

- **Distance** (see "Enter a Distance" on page 129)
- **Offset** (see "Enter an Offset" on page 137)

To use a Distance Factor Snap:

1. While in a distance or offset control, right-click in a graphic view, and select *Factor of Distance Snap* from the context menu. The *Factor of Distance Snap* command pane displays.

2. Pick two points, or a line segment in the view, or type a value in the **Distance** box.

3. Type a factor value greater than zero (>0) in the **Multiplication Factor** box. For example, type 2 for 200% of the distance.

4. Click **OK**. The distance is recorded, and the command pane returns to the previous command.

Related topics

- [Understanding COGO Controls](on page 95)
- [COGO Expressions, Units, and Entry Formats](on page 97)
- [Snaps Modes and Commands](on page 98)

**Point to Point Snap (distance)**

Use this command to calculate the distance between two points.

*Point to Point Snap* can be used in these controls:
Calculate and Enter Values

- **Bearing** (see "Enter a Bearing" on page 103)
- **Distance** (see "Enter a Distance" on page 129)
- **Offset** (see "Enter an Offset" on page 137)

To use a Point to Point Snap:

1. While in a distance control, right-click in a graphic view, and select **Point to Point Snap** from the context menu. The **Point to Point Snap** command pane displays.
2. Pick a point in the view, or type a coordinate or point ID in the **From point** box.
3. Pick a point, or type a coordinate or point ID in the **To point** box. The distance is recorded, and the command pane returns to the previous command.

Related topics
- Understanding COGO Controls (on page 95)
- COGO Expressions, Units, and Entry Formats (on page 97)
- Snaps Modes and Commands (on page 98)

**Radius of Arc Snap (distance)**

Use this command to calculate a distance based on the radius of an arc.

**Radius of Arc Snap** can be used in these controls:
Calculate and Enter Values

- **Distance** (see "Enter a Distance" on page 129)
- **Offset** (see "Enter an Offset" on page 137)

To use a Radius of Arc Snap:

1. While in a distance or offset control, right-click in a graphic view, and select Radius of Arc Snap from the context menu. The Radius of Arc Snap command pane displays.
2. Pick an arc in the view. The arc's radius is recorded, and the command pane returns to the previous command.

Related topics

- Understanding COGO Controls (on page 95)
- COGO Expressions, Units, and Entry Formats (on page 97)
- Snaps Modes and Commands (on page 98)

**Enter an Elevation**

Use the Elevation control to specify an elevation. You can snap to any 3d object to specify the elevation. "Elevation" appears in the status bar when the control is active.

Elevation control gives you access to these commands on the context menu:
Calculate and Enter Values

- **Elevation Undefined Snap** (see "Undefined Snap" on page 135)
- **From Surface Snap** (on page 135)

**To specify an elevation:**

- Pick an object in a graphic view to use its elevation. If you pick a line, the elevation will be interpolated along the slope of the line, based on the position you pick.
- Type a value or a point ID in the **Elevation** box.
- Right-click in a graphic view, select a snap command from the context menu, and specify the necessary parameters.

**Related topics**
- **COGO Controls** (see "Understanding COGO Controls" on page 95)
- **COGO Expressions, Units, and Entry Formats** (on page 97)
- **Snaps Modes and Commands** (on page 98)

**Undefined Snap**

Use this command to specify that the elevation is undefined. Use it when no elevation is required.

**Undefined Snap** can be used in these controls:

- **Elevation** (see "Enter an Elevation" on page 134)

**To use an Undefined Snap:**

1. While in an elevation control, right-click in a graphic view, and select **Undefined Snap** from the context menu. The **Elevation** box is filled with a ? to show that the elevation is valid as undefined.
2. Click **OK**, if necessary.

**Related topics**
- **Understanding COGO Controls** (on page 95)
- **COGO Expressions, Units, and Entry Formats** (on page 97)
- **Snaps Modes and Commands** (on page 98)

**From Surface Snap**

Use this command to calculate the elevation of a point on a 3D surface. The elevation of the X,Y position on the surface will be used as the Z value.

**From Surface Snap** can be used in these controls:
Calculate and Enter Values

- **Elevation** (see "Enter an Elevation" on page 134)

**To use a From Surface Snap:**

1. While in an elevation control, right-click in a graphics view, and select **Point to Point Snap** from the context menu. The **Point to Point Snap** command pane displays.

2. Pick a surface in the view, or select one from the Surface list.

1. Pick a point on the selected surface, or type a coordinate in the Point box. The elevation at that point on the surface is recorded, and the command pane returns to the previous command, if necessary.

**Related topics**

- **Understanding COGO Controls** (on page 95)
- **COGO Expressions, Units, and Entry Formats** (on page 97)
- **Snaps Modes and Commands** (on page 98)

**At Point Snap**

Use this command to specify an elevation using the elevation of a named point.

**At Point Snap** can be used in these controls:

- **Elevation** (see "Enter an Elevation" on page 134)

**To use an At Point Snap:**

1. While in an elevation control, right-click in a graphic view, and select **At Point Snap** from the context menu. The **At Point Snap** command pane displays.

2. Pick a named point in the view, or type a point ID in the Point box. The elevation of the point is recorded, and the command pane returns to the previous command.
Along Line Snap

Use this command to specify an elevation using the elevation at a location along a 3D line.

Along Line Snap can be used in this control:

- Elevation (see "Enter an Elevation" on page 134)

To use an Along Line Snap:

1. While in an elevation control, right-click in a graphic view, and select Along Line Snap from the context menu. The Along Line Snap command pane displays.

2. Pick a 3D line in the view. A "rubber-band" line appears between your cursor and the line.

3. Using the rubber-band line, pick a point along the line, or type a distance from the beginning point of the line (in station format) in the Distance Along box. The elevation at that location is recorded, and the command pane returns to the previous command, if necessary.

Enter an Offset

Use the Offset control to specify an offset from a given line. "Offset" appears on the status bar when the control is active.
Offset control is used in these commands:

- [Offset Line Snap](on page 122)
- [Offset Segment Snap](on page 123)

Offset control gives you access to these commands on the context menu:

- [Distance + Distance Snap](see "Distance + Distance Snap (distance)" on page 130)
- [Distance Snap](on page 139)
- [Factor of Distance Snap](see "Factor of Distance Snap (distance)" on page 131)
- [Point ID Snap](see "Offset at Point Snap" on page 141)
- [Point to Point Snap](see "Point to Point Snap (distance)" on page 132)
- [Radius of Arc Snap](see "Radius of Arc Snap (distance)" on page 133)

**To specify an offset:**

- Pick a point in a graphic view to define the coordinate through which the offset will pass. The control uses the perpendicular distance from the line to the specified position to calculate the offset distance.
- Type a distance value in the Offset box. From the end of the line closest to where it was picked, looking to the other end, positive offsets are to the right and negative offsets are to the left of the line.
- Right-click in a graphic view, select a snap command from the context menu, and specify the necessary parameters. The At Point Snap command gives you the ability to use any of the point snap modes to specify the offset distance from a specific point to the line.

**Related topics**

- [COGO Controls](see "Understanding COGO Controls" on page 95)
- [COGO Expressions, Units, and Entry Formats](on page 97)
- [Snaps Modes and Commands](on page 98)

**Distance + Distance Snap (offset)**

Use this command to calculate an offset by adding two distances. Either distance can be negative.

*Distance + Distance Snap* can be used in these controls:
- **Distance** (see "Enter a Distance" on page 129)
- **Offset** (see "Enter an Offset" on page 137)

To use a Distance Plus Distance Snap:

1. While in a distance or offset control, right-click in a graphic view, and select **Distance + Distance Snap** from the context menu. The **Distance + Distance Snap** command pane displays.

2. Pick two points or a line segment, or type a value in the **Distance 1** box.

Related topics
- **Understanding COGO Controls** (on page 95)
- **COGO Expressions, Units, and Entry Formats** (on page 97)
- **Snaps Modes and Commands** (on page 98)

1. Pick two more points or a line segment, or type a value in the **Distance 2** box. The total distance is recorded, and the command pane returns to the previous command.

**Distance Snap**

Use this command to calculate an offset based on the distance between two points, or based on the length of a line segment.

**Distance Snap** can be used in these controls:
- **Offset** (see "Enter an Offset" on page 137)

To use a Distance Snap:

1. While in an offset control, right-click in a graphic view, and select **Distance Snap** from the context menu. The **Distance Snap** command pane displays.
2. Pick two points or a line segment in the view, or type a value in the *Distance* box. The distance or length of the line segment is recorded.

3. Click **OK**. The command pane returns to the previous command.

**Related topics**
- [Understanding COGO Controls](on page 95)
- [COGO Expressions, Units, and Entry Formats](on page 97)
- [Snaps Modes and Commands](on page 98)

**Factor of Distance Snap (offset)**

Use this command to calculate an offset by applying a multiplication factor to a distance.

**Factor of Distance Snap** can be used in these controls:
- **Distance** (see "Enter a Distance" on page 129)
- **Offset** (see "Enter an Offset" on page 137)

To use a **Factor of Distance Snap**:

1. While in a distance or offset control, right-click in a graphic view, and select **Factor of Distance Snap** from the context menu. The **Factor of Distance Snap** command pane displays.

2. Pick two points or a line segment in the view, or type a value in the *Distance* box.

3. Type a factor value greater than zero (>0) in the *Multiplication Factor* box. For example, type \(2\) for 200% of the distance.

4. Click **OK**. The offset distance is recorded, and the command pane returns to the previous command.
Related topics
- Understanding COGO Controls (on page 95)
- COGO Expressions, Units, and Entry Formats (on page 97)
- Snaps Modes and Commands (on page 98)

Offset at Point Snap

Use this command to specify an offset from a line by picking a point at a distance away from the line.

*Offset at Point Snap* is used in these controls:
- Offset (see "Enter an Offset" on page 137)

To use an Offset at Point Snap:

1. While in an offset control, right-click in a graphic view, and select *Offset at Point Snap* from the context menu. The *Offset at Point* command pane displays.
2. Pick a point in the view, or type a point ID or coordinate in the *Point* box using one of the standard formats. The command pane returns to the previous command.

Related topics
- Understanding COGO Controls (on page 95)
- COGO Expressions, Units, and Entry Formats (on page 97)
- Snaps Modes and Commands (on page 98)

Point to Point Snap (offset)

Use this command to compute the offset between one point and another point.

*Point to Point Snap* can be used in these controls:
- Offset (see "Enter an Offset" on page 137)

To use a Point to Point Snap:

1. While in an offset control, right-click in a graphic view, and select *Point to Point Snap* from the context menu. The *Point to Point Snap* command pane displays.
2. Pick a point in the view, or type a coordinate or Point ID in the *From point* box.
3. Pick a point, or type a coordinate in the *To point 2* box. The offset distance is recorded, and the command pane returns to the previous command.

Related topics
- Understanding COGO Controls (on page 95)
- COGO Expressions, Units, and Entry Formats (on page 97)
- Snaps Modes and Commands (on page 98)
Radius of Arc Snap (offset)

Use this command to calculate an offset based on the radius of an arc.

**Radius of Arc Snap** can be used in these controls:

- **Distance** (see "Enter a Distance" on page 129)
- **Offset** (see "Enter an Offset" on page 137)

To use a Radius of Arc Snap:

1. While in a control, right-click in a graphic view, and select **Radius of Arc Snap** from the context menu. The **Radius of Arc Snap** command pane displays.
2. Pick an arc in the view. The arc's radius is recorded, and the command pane returns to the previous command.

Related topics

- [Understanding COGO Controls](on page 95)
- [COGO Expressions, Units, and Entry Formats](on page 97)
- [Snaps Modes and Commands](on page 98)

Enter a Station

Use the Station control to specify a station on a selected alignment. The station is calculated from the specified point to a perpendicular point on the alignment. "Station" appears on the status bar when the control is active.

Station control is used in these commands:

- **Offset Line Snap** (on page 122)
- **Offset Segment Snap** (on page 123)

Station control gives you access to this command on the context menu:
Calculate and Enter Values

- **Station at Point Snap** (on page 143)
- **Station From Line Snap** (on page 144)

**To specify a station:**

- Pick a point along an alignment in a graphic view.

  **Note:** When the station control is active the cursor will "rubber-band" from a horizontal alignment (HAL).

- Type a value in the **Station** box, using any of the standard entry formats. Check and set the entry format in the **Project Settings** by selecting **Project > Project Settings > Units > Station**.

  If you have defined an alignment and station equations, you can enter the station and segment. If there is more than one roadway that uses the alignment, only the first one found is used. An alignment with two station equations has three segments: one before the first equation, one between the two equations and one after the second equation. To define the station and segment enter "(station):(segment)" e.g., 14000:3. If no segment is specified, the first segment containing the specified station will be used. You can also specify an absolute distance along an alignment, regardless of station equations or beginning station, by typing zero (0) for the segment number, e.g., 14000:0.

- Right-click in a graphic view, select a snap command from the context menu, and specify the necessary parameters.

**Related topics**

- **COGO Controls** (see "Understanding COGO Controls" on page 95)
- **COGO Expressions, Units, and Entry Formats** (on page 97)
- **Snaps Modes and Commands** (on page 98)

**Station at Point Snap**

Use this command to calculate a station based on a point. You must pick the point in a profile view.

**Station at Point Snap** is used in these controls:

- **Station** (see "Enter a Station" on page 142)

**To use a Station at Point Snap:**

1. While in a station control, right-click in a graphic view, and select **Station at Point Snap** from the context menu. The **Station at Point Snap** command pane displays.

2. Pick a point in a profile view, or type a coordinate or point ID in the **Point** box. The coordinate or point ID is recorded, and the command pane returns to the previous command.
Station from Line Snap

Use this command to calculate a station value from a point perpendicular to an alignment or line.

Station from Line Snap is used in these controls:
- Station (see "Enter a Station" on page 142)

To use a Station from Line Snap:

1. While in a station control, right-click in a graphic view, and select Station from Line Snap from the context menu. The Station from Line Snap command pane displays.
2. Pick a line in a graphic view.
3. Pick a point along the line, or type a value in the Station box, to specify a station. The station is recorded, and the command pane returns to the previous command.

Measure Values Between Points

Calculate and report values between points in your project.
- In the plan view, the command measures bearing and distance.
- In the profile view, it measures the delta station, slope, and slope distance.
- In the cross-section and surface slicer views, it measures delta offset, slope, and slope distance.

To measure values between two points:

1. Do one of the following:
   - Click the icon on the toolbar.
   - Select Tools > Measure.
   The Measure command pane displays.
2. Pick the first point in a graphic view or type a point ID or coordinate (in the format X,Y) in the From box.

   **Note:** You can also right-click in the view to access COGO controls (see "Understanding COGO Controls" on page 95) and snaps (see "Snaps Modes and Commands" on page 98) when picking points.

3. Pick another point or type a point ID or coordinate in the To box. The measured values appear in the Results group.

4. To measure other values, continue picking From and To points.

   **Note:** You can change to a different graphic view between measurements.

5. Click Close.

Related topics

- Measure Options (on page 145)
- Calculate the Inverse Between Points (on page 283)
- Customize and Run a Report (see "Customize a Report" on page 481)

---

**Measure Options**

Use these options to calculate and report the bearing, distance, slope, slope distance, delta offset, and delta station between any two points, depending on which graphic view you use. They are available in the Measure command pane.

**Options**

**From/To**

Pick points in graphic views, or type point IDs or coordinates (in the format X,Y) in the boxes, and click Measure or press [Enter].

**Results**

This shows the values between the selected points:

- **Slope** - In the cross-section view, the slope is relative to the centerline. In the surface slicer view, the slope is relative to the first point of the line.

- **Offset** - In the cross-section view, the offset is relative to the centerline. In the surface slicer view, the offset is relative to the first point of the line.

**Measure**

When you type in To and From points, this acts as the [Enter] key, calculating the Results.

Related topics

- Measure Values Between Points (on page 144)
Measure Angles

Measure the angle between three selected locations and/or named points (points with IDs).

![Diagram of angle measurement](image)

**To measure an angle:**

1. Select **Survey > Measure Angle**. The **Measure Angle** command pane displays.
2. Verify the correct measurement type is selected in the **Options** box.
3. Click in the **Start point** box and select the point or location in **Plan** view. The point or coordinate you selected is displayed in the **Start point** box and the cursor moves to the **Pivot point** box.
4. Select the pivot point or location in **Plan** view. The point or coordinate you selected is displayed in the **Pivot point** box and the cursor moves to the **End point** box.
5. Select the end point or location in **Plan** view. The point or coordinate you selected is displayed in the **End point** box and the measure angle is displayed in the **Result** box.

You can continue to select different points or locations for the end point to display additional angles in the **Result** box.

**Note:** As an alternative to selecting points and/or locations in the **Plan View**, you can type point IDs or coordinates directly in the point boxes.

You can click the **Reset** icon located at the top of the pane to clear all measurements and results.

You can click the **Clear** button located beneath the **Result** box to remove all angles displayed in the **Result** box.
Related topics

- Measure Angle Options (on page 147)

Measure Angle Options

Use these options to measure the angle between three selected locations and/or named points (points with IDs). They are available in the Measure Angle command pane.

Options

Start point
Click in the box and then select the start point in Plan View, or type the point ID or coordinate in the box.

Pivot point
If you selected the start point by selecting it in Plan View, the cursor automatically moves to this box. If you typed the point ID or coordinate in the Start point box, click in this box.

Select the pivot point in Plan View, or type the point ID or coordinate in the box.

End point
If you selected the pivot point by selecting it in Plan View, the cursor automatically moves to this box. If you typed the point ID or coordinate in the Pivot point box, click in this box.

Select the end point in Plan View, or type the point ID or coordinate in the box.

The measured angle is displayed in the Result box.

You can continue to select different points or locations for the end point to display additional angles in the Result box.

Options
Select the appropriate measurement method.

Result
Displays the measured angle.

Related topics

- Measure Angles (on page 146)
Set Up Projects

Choose Application Options

Use the *Options* dialog to set program-wide options, such as startup preferences, default file locations, Internet download parameters, and display properties.

Related topics
- [Choose Local Site Settings](on page 178)
- [Choose Project Settings](on page 155)

Startup and Display Options

Set startup and display options to control whether a project or start page automatically open when you start the program, and to specify program-wide preferences for the graphical user interface.

**To access these settings:**

1. Select **Tools > Options**. The *Options* dialog displays.
2. Click **Startup and Display** in the left pane.

These options are available:
Set Up Projects

Startup options

Starting state

No project - Select this to have no projects and no start page open when the software starts.

Last project - Select this to open only the most recent project when the software starts.

Open project command - Select this to initiate the Open Project command, which enables you to select any project to open, when the software starts.

Display start page - Select this to display only the start page when the software starts.

The start page is a view that lists features of the software and links to tours, tutorials, release notes, and other documentation to help you get started. By default, the start page appears when you launch the software, and closes when you start or open a project.

Start page

Type a path or click the button to navigate to an alternate HTML page to use as the start page, which will display when you have Display start page selected in the Starting State box (see above).

Recently-used file list

Enter the number of recent project files to list at the bottom of the File menu, allowing you quick access to these projects.

Graphics window options

Display data tips

Check this box to display more detailed information when you hover over objects in a graphic view.

Note: This may conflict with the data list that appears when you graphically select an area with multiple objects.

Background color

Click an option to set the color of the background used in the graphics view.

Pick aperture

Enter a size (in pixels per side) for the box displayed on various cursors. This is the box within which an object can be picked.

Examples of cursors with pick apertures:

Application display options
Set Up Projects

Window display mode

Tabbed views (SDI) - Select this to display each created data view (for example, a plan view or point spreadsheet) as a tabbed pane, enabling you to access each by clicking a tab, and allowing views to be split. In addition, data listings can be "floated", meaning that they can be displayed as undocked, movable windows.

Multiple window views (MDI) - Select this to display each created data view in a separate window, allowing windows to be tiled or cascaded.

Related Topics

- Choose Application Options (on page 148)
- File Location Options (on page 150)
- Internet Download Options (on page 154)

File Location Options

This command displays the Options dialog, which shows file management preferences.

To access these settings:

1. Select Tools > Options. The Options dialog displays.
2. Click File Locations in the left pane.

These options are available:
## Set Up Projects

### Project Management

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project management folder</td>
<td>Select or browse for the folder to use as a default for saved project files.</td>
</tr>
<tr>
<td>Use project subfolders</td>
<td>Enable to have the program create project folders and subfolders, and organize your files in them. If you disable <em>Use project subfolders</em>, the root folder remains the default file location for projects, imported, and exported data until you change the path.</td>
</tr>
<tr>
<td>Export folder</td>
<td>Specify the folder to use as a default for exported files.</td>
</tr>
<tr>
<td>Download and import folder</td>
<td>Specify the folder to use as an archive for files that are downloaded and imported from field devices or the Internet.</td>
</tr>
</tbody>
</table>

**Note:** When the Office Synchronizer application is used to transfer data between the computer and a field device, the Office Sync root folder is used.

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy imported files to import folder</td>
<td>Enable to have imported files duplicated in the import folder you specify. This option is automatically enabled when <em>Use project subfolders</em> is enabled, but can also be set if you are not using the project subfolders option. This option can be enabled from the Import command pane as well.</td>
</tr>
</tbody>
</table>

**Tip:** Disable *Copy imported files to import folder* when you are simply reviewing data or importing large files that you do not want to save in your Import folder.

### Templates

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Template folder</td>
<td>Specify the folder to use as the default file location for all projects that are saved as template projects. Projects stored in this folder appear in the list of templates when you create a new project.</td>
</tr>
</tbody>
</table>

### Data

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Synchronizer root folder</td>
<td>Specify the data synchronization area (also known as the System root sync folder). This folder is used by Office Synchronizer to store data transferred between the computer and field devices</td>
</tr>
</tbody>
</table>

### Related Topics

- Choose Application Options (on page 148)
- Internet Download Options (on page 154)
Set Up Projects

- [Results of Default Folder Locations](on page 153)
- [Startup and Display Options](on page 148)
- Set Default Folder Locations

**Change the Template Folder**

The template folder contains all templates shipped with the office software and any templates you have created.

*Note:* If you change the template folder, the existing templates remain in the original folder location. To move the templates, use Windows® Explorer.

**To change the template folder:**

1. Select **Tools > Options**. The **Options** dialog displays.
2. Select **File Locations**.
3. In the **Template group**, type a path for the location to which you want to save templates, or click the icon to browse folders.
4. In the **Browse for Folder** dialog, select the folder in which to store templates and then click **OK**.
   *Note:* Select **Make New Folder** to create a new template folder.
5. Click **OK**.

When you create a new template, it will automatically be saved to the folder you selected.

**Related topics**

- [File Location Options](on page 150)
- Set Default Folder Locations

**Set Default File Locations**

Projects can contain a variety of files, including imported raw data files, a project file with edited data, and exported data files. One way to manage projects more easily and logically is to specify where each file is saved by default. In the **Options** dialog, **Use project subfolders** is enabled by default. This option creates project folders and subfolders, and organizes your project files in them.

1. When you install this software, a new folder named **Trimble Business Center** is created. The default path for the folder depends on your operating system:
   - In Windows® XP or earlier: \*C:\Documents and Settings\(username)\My Documents\Trimble Business Center\.
   - In Windows Vista™: \*C:\Users\(user name)\Documents\Trimble Business Center\.
2. When you create a new project, and import or export data, a new folder called Unnamed is created in the Trimble Business Center folder. If you create a project, but do not import or export data, the folder is not created.

3. If you save the current project, the Unnamed folder is renamed to the project name, and the project file is created at the same level.

**Warning:** If you do not save the current project, the Unnamed folder and subfolders will be discarded when you close the project.

4. As you create and save additional projects, they and their subfolders are also saved at the same level, so you can easily find and open them.

**To disable Use project sub-folders**

The *Use project subfolders* option is a project setting. You can change it from project to project, but once you create a new project, the mode can’t be changed for that project. The project will use the same mode, regardless of the options setting. Therefore, if you do not want to use project subfolders, you must disable the option before creating a project.

1. Select **Tools > Options**. The **Options** dialog appears.

2. Click **File Locations** in the left pane.

3. Uncheck **Use project subfolders** in the **Project Management** group box. The **Export folder** box, **Download and import folder** box, and **Copy Imported files to import folder** option become editable.

4. Click **OK**.

**Note:** When you enable **Use project subfolders**, the **Copy Imported files to import folder** option is enabled also, but you can also set it independently if you are not using project subfolders.

**Tip:** You can manually create additional subfolders based on how your data is organized. For instance, if you have multiple field crews collecting data on multiple days, you may want to create subfolders based on those crews or days.

**Related Topics**

- [File Location Options](on page 150)
- [Results of Default Folder Locations](on page 153)

**Results of Default Folder Locations**

Results of file operations when **Use project subfolders** is enabled:
## Set Up Projects

<table>
<thead>
<tr>
<th>Operation</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>New Project</strong></td>
<td>A new project file is created, and a new subfolder called <em>Unnamed</em> is created when data files are copied. If the project is not saved, this subfolder is deleted.</td>
</tr>
<tr>
<td><strong>Save Project</strong></td>
<td>If the project is saved for the first time, the <em>Unnamed</em> subfolder will be renamed to the name of the project file. If the subfolder is empty, it is deleted.</td>
</tr>
<tr>
<td><strong>Save Project As</strong></td>
<td>The project file is saved with the new name. If the project has associated data, the project subfolder is copied and saved with the new name.</td>
</tr>
<tr>
<td><strong>Download file</strong></td>
<td>Downloaded data is saved in the project’s import subfolder.</td>
</tr>
<tr>
<td><strong>Export file</strong></td>
<td>Exported data is saved in the project’s export subfolder.</td>
</tr>
<tr>
<td><strong>Import file</strong></td>
<td>Imported data is saved in the project’s import subfolder.</td>
</tr>
</tbody>
</table>

### Related Topics

- File Location Options (on page 150)
- Set Default Folder Locations

### Internet Download Options

This command displays the **Options** dialog, which shows Internet download preferences.

To access these settings:

1. Select **Tools > Options**. The **Options** dialog displays.
2. Click **Internet Download** in the left pane.

These options are available:
Choose Project Settings

Use the Project Settings dialog to set various parameters for your projects, including settings for coordinate systems, units, computations, and views. For a description of any setting, click the name of the setting. The description appears in the information box at the bottom of the dialog. For explanations of terms, see the Glossary.

**Tip:** Save time and effort, and make your projects more consistent, by choosing project settings and then saving the project as a template from which to begin other projects. You can also save baseline processing and network adjustment settings as "styles", which are similar to templates. Share templates and styles with co-workers to ensure consistency across your company.

**To choose project settings:**

1. Do one of the following:
   - Select Project > Project Settings.
   - Click the icon on the toolbar.
   
   The Project Settings dialog appears.

2. Click a section to view the settings. When you click in a property, a description displays in the info box at the bottom of the dialog.

3. Edit the settings as needed, and click OK.

**Note:** Settings with gray text are read-only; settings with black text can be edited.
Set Up Projects

Related topics
- Choose Application Options (on page 148)
- Create a Project Template (on page 182)
- Local Site Settings (see "Choose Local Site Settings" on page 178)

General Information Settings

Use general information settings to:
- Review the project's file properties
- Add a reference number and description of the project
- Add your company's contact information

**Add the names of the field and office staff associated with the project To access the settings:**

1. Do one of the following:
   - Select Project > Project Settings.
   - Click the icon on the toolbar.
     The Project Settings dialog displays.
2. Click General Information in the left pane.

Related topics
- Choose Project Settings (on page 155)

Coordinate System Settings

Use coordinate system settings to:
- Review the current coordinate system and datum transformation

**Note:** To select or create a different coordinate system, click Change at the bottom of the dialog.
- Change the geoid model and specify its quality
- Review the local site location and coordinates
- Check the network adjustment transformation parameters
- Review projection, vertical datum, and site calibration details

**See the shift grid name and filename To access the settings:**

1. Do one of the following:
   - Select Project > Project Settings.
Set Up Projects

1. Click the icon on the toolbar.

   The *Project Settings* dialog displays.

2. Click *Coordinate System* in the left pane.

Related topics

- [Change the Coordinate System](on page 157)
- [Choose Project Settings](on page 155)

**Change the Coordinate System**

Choose the appropriate coordinate system and geoid model for your project by selecting one that you have used recently. Up to ten of the most recently used systems are stored.

**To select an existing coordinate system:**

1. Do one of the following:
   - Select *Project > Change Coordinate System*.
   - Select *Project > Project Settings > Coordinate System*, and click *Change*.

   The *Select Coordinate System* dialog displays.

   **Note:** The *Select Coordinate System* dialog is part of the *Coordinate System Manager*, a separate application. When only the dialog is open, pressing [F1] does not open online help. To view help for the *Coordinate System Manager*, click *Tools > Coordinate System Manager* to open the application. Then press [F1] for help.

2. Select *Recently Used System*.

3. Click or , or press [PageUp] or [PageDown], to view the available coordinate systems.

4. When the coordinate system that you want is displayed, click *Finish*. The coordinate system project settings are updated, and your project is recomputed using the new coordinate system.

**Caution:** To avoid problems or unexpected results in your project, do not change the coordinate system after you import data.

Related topics

- Coordinate System Manager
- [Coordinate System Settings](on page 156)
- [Define a New Coordinate System](on page 158)
Define a New Coordinate System

Define parameters for a new coordinate system if the one you need doesn’t appear in the list of recently used systems.

To define a new coordinate system:

1. Do one of the following:
   - Select Project > Change Coordinate System.
   - Select Project > Project Settings > Coordinate System, and click Change.
   The Select Coordinate System dialog displays.
2. Select New System, and click Next.
3. To define a default project based on Transverse Mercator parameters:
   - Click Default Projection, and click Next.
   - Enter the Transverse Mercator parameters that are requested, and click Next.
4. To define a projection based on a coordinate system group and zone:
   - Click Coordinate System and Zone, and click Next.
   - Select the coordinate system group from the list on the left, and select the zone from the list on the right and click Next.
5. Select the geoid model you want to use and click Finish. Your project is recomputed using the new coordinate system.

Related topics

- Coordinate System Manager
- Coordinate System Settings (on page 156)
- Change the Coordinate System (on page 157)
- Define a Projection (on page 195)

Restore the Original Coordinate System File

If you have previously installed Trimble® Geomatics Office™ (TGO), you may have an existing current.csd file which stores recently-used or custom coordinate systems. During the installation of the software, any existing current.csd file is renamed current.csd.date.xx-xx-xx.

To restore the Current.csd file:

1. Open Windows® Explorer and browse to one of these locations, depending on your operating system:
Set Up Projects

- In Windows XP or earlier:  
  \( C:\{\text{Documents and Settings}\}\{\text{All Users}\}\{\text{Application Data}\}\{\text{Trimble}\}\{\text{GeoData}\} \) unless you have previously installed TGO. If you have installed TGO and then this software, the path is \( C:\{\text{Program Files}\}\{\text{Common Files}\}\{\text{Trimble}\}\{\text{GeoData}\} \).

  **Note:** Due to network security, you may not be able to edit this path unless you have administrative rights.

- In Windows Vista™:  
  \( C:\{\text{ProgramData}\}\{\text{Trimble}\}\{\text{GeoData}\} \) or \( C:\{\text{Program Files}\}\{\text{Common Files}\}\{\text{Trimble}\}\{\text{GeoData}\} \).

  2. Rename `current.csd` to `current-TBCC.csd`.
  3. Rename the `current.csd.date.xx-xx-xx` to `current.csd`.

Related topics

- Change the Coordinate System (on page 157)

Unit Settings

Use unit settings to review and change project units and unit display formats for:

- Coordinates
- Distances
- Angles and vertical angles
- Azimuths
- Pressure
- Temperature
- GPS time (specifically, not GNSS time)
- Stationing

**Area and volumes To access the settings:**

1. Do one of the following:
   - Select **Project > Project Settings**.
   - Click the ![Folder icon](folder-icon.png) icon on the toolbar.

   The **Project Settings** dialog displays.

2. Click **Units** in the left pane.
**Entering units**

When you edit unit format settings, you are changing how the units display in views, spreadsheets, and commands. You can, however, enter units in any of the valid display formats that you see in the format settings. These are converted to the display format for the unit.

**Converting units**

If your project units are set to one type, such as *International foot*, you can still enter other types of units by including a character for the type. For example, you can enter 3m to specify 3 meters. The unit you enter is converted to the project units.

**Caution:** If you change the units of your project, it will be recomputed when you click **OK**. It is recommended that you exit **Project Settings** immediately after changing units, before changing other project settings.

**Related topics**

- Change Project Units (on page 160)
- Choose Project Settings (on page 155)

**Change Project Units**

Edit unit settings to control what units are used, and how they display in views, spreadsheets, and commands. Regardless of which unit display format you choose, you can enter units in any of the available formats that you see.

**Note:** If your project units are set to one type, such as *International foot*, you can still enter other types of units by including a character for the type. For example, you can enter 3m to specify 3 meters. The unit you enter is converted to the project units.

**Note:** You can also enter feet and inches by typing the two numbers with a space in between. For example, type 4_8 for 4 feet, 8 inches.

**To change the project units:**

1. Select **Project > Project Settings**. The **Project Settings** dialog displays.
2. Click **Units**, and then click the type of units you want to change in the left pane.
   
   **Note:** To change project units from feet to meters, click Distance and then select Meters in the Display box.
3. Select the box for which you want to change the units or format.
4. Make the desired changes.
5. To save and apply the changes, click **OK**.
Caution: If you change the units of your project, it will be recomputed when you click OK. It is recommended that you exit Project Settings immediately after changing units, before changing other project settings.

Related topics

- COGO Expressions, Units, and Entry Formats (on page 97)
- Unit Settings (on page 159)

View Settings

Settings are available for the various types of graphic, spreadsheet, and other views in which your project data is displayed. Use view settings to:

- Specify whether to include 2D data in the 3D view
- Choose the input method for horizontal and vertical alignment segments
- Control graphic view display characteristics, such as plot scales and vertical exaggeration
- Control annotation text, and gridline intervals, colors and line styles in views

Note: You can also click the icon on the toolbar to turn gridlines on and off.

- Show and hide individual columns for data on spreadsheet views
- Set the default view filter used when you open new graphic views

Note: If you delete a view filter that you have set as the default, the Default View Filter will revert to the All view filter, which cannot be deleted.

Tip: If your project has a lot of data, you may want to select a default view filter other than All so that graphic views refresh more quickly.

To access the settings:

1. Do one of the following:
   - Select Project > Project Settings.
   - Click the icon on the toolbar.

The Project Settings dialog displays.

2. Click View in the left pane.

3. Click any of the view types to display and edit individual settings.

Related topics

- Choose Project Settings (on page 155)
**Change the Gridline Display**

Display gridlines in the plan view to understand a project's scale and location.

**To display or hide gridlines:**

- Click the icon on the toolbar.

**To change gridline properties:**

1. Select **Project > Project Settings**. The **Project Setting** dialog displays.
2. Click the **View** folder.
3. Expand **Plan View**, and click **Grid Line Definition**.
4. Click in the boxes and edit the properties as needed.
5. Click **OK**.

Example with grid lines On.
Example with gridlines Off (same data, same scale).

Related topics
- View Settings (on page 161)

**Toggle Line Marking**

Display or hide markers and labels for horizontal and vertical values along linestrings in 2D views to make viewing, understanding, and editing them easier. Markers are symbols that distinguish between horizontal segment end points, vertical control points and the overall line's end points. Labels are annotations that indicate the elevation of vertical control points.

**To show or hide line markings:**
- Click the 🗝️ icon on the toolbar.
- Select View > Toggle Line Marking.

**To set which line markings are shown:**
1. Do one of the following:
   - Select Project > Project Settings.
   - Click the 📜 icon on the toolbar.

The Project Settings dialog displays.
2. Click **View** in the left pane, and click **Display Options**.

3. Edit individual settings in the **Marking** section.

**Related topics**

- Change the Gridline Display (on page 162)
- View Settings (on page 161)

---

**Computational Settings**

Use computational settings to:

- Review and set horizontal and vertical tolerances for computed survey data, including points of varying quality, and meaned GPS vectors.

  **Note:** If computation results on data fall outside these tolerances, the data is flagged in the **Project Explorer** and graphic views, and a message appears in the **Flags** pane.

- Select a level of confidence for displayed error values.
- Specify the horizontal and vertical tolerances to enforce when creating surface breaklines from 3D alignments.
- Set the maximum edge length and angle defaults for creating surface triangles.

**To access the settings:**

1. Do one of the following:
   - Select **Project > Project Settings**.
   - Click the ![icon](icon.png) icon on the toolbar.

   The **Project Settings** dialog displays.

2. Click **Computational Settings** in the left pane.

**Related topics**

- Choose Project Settings (on page 155)
- Project Computations (on page 165)
Project Computations

The *Compute Project* command enables you to compute your project after you make changes to the data. The computation applies the changes made to all affected observations and determines the coordinates for points in the chronological sequence a surveyor would typically expect. If conflicting data is available for the computation of a coordinate, the software gives preference to higher quality data over lower quality data.

**Note:** When you import data into a project, change project settings, or change the coordinate system, the project is automatically computed for you.

Related topics
- Compute Project Command

Run a Project Computation Report

Generate a computation report to see a summary of the errors and warnings that occurred during the last computation of your project data.

**To run a Project Computation Report:**


**To customize the report:**

2. Select **Project Computation Report** in the list.
3. Expand sections and specify output settings in the *Settings* group as needed.
4. Click **Apply** if you want to customize additional reports, or **OK** to close the command pane.

Related topics
- **Project Computations** (on page 165)
- **Customize and Run a Report** (see "Customize a Report" on page 481)

Baseline Processing Settings

Use baseline processing settings to configure how baselines are processed.

**To access the settings:**

1. Do one of the following:
Select **Project > Project Settings**.

Click the icon on the toolbar.

The **Project Settings** dialog displays.

2. Click **Baseline Processing** in the left pane.

**Note:** The minimum time required for a static observation to be used in a session is 10 seconds.

**Note:** If you accidentally recorded any static observations as kinematic, use the Force Static command to change them.
## Options

### Baseline processing styles

See [Apply a Baseline Processing Style](on page 303).

### General

#### Auto start processing

**Yes** - Select this to have processing start as soon as the Baseline Processing menu item or toolbar icon is selected.

**No** - Select this to prevent automatic processing when the command begins.

#### Store continuous as trajectory

**Yes** - Select this to combine individual vectors into a single object called a trajectory, preserving system memory and processing speed.

**No** - Select this to store each vector separately.

See [Trajectories and Vectors](on page 300).

#### Event interpolation type

Specify which kind of curve (linear, quadratic, or cubic) will be fit through the nearest points in time in order to interpolate event positions.

#### Event interpolation points

Type the number of points to use in the curve fit. It must be at least 2 for linear, 3 for quadratic, or 4 for cubic.

#### Start automatic ID numbering

Type a starting point ID to use when automatically naming points in trajectories.

This is needed when the associated file from the field software is not present with the raw GNSS data file.

#### Antenna model

**Automatic** - Select this to let the application determine the antenna phase center models based on the antennas used at either end of each session.

**Trimble** - Select this if Trimble antennas are used in all of the sessions.

**US NGS** - Select this if only US NGS antenna models are available for the antennas used.

**IG Absolute** - Select this if only IG Absolute antenna models are available for the antennas used.

---

**Warning:** If the antenna model you select does not cover all of the antennas used in your project, only the sessions using the selected model at both ends are processed.
### Set Up Projects

**Ephemeris type**

- **Automatic** - Select this to process data using precise ephemeris when available, and broadcast ephemeris for all other data.
- **Broadcast** - Select this to process all data using only broadcast ephemeris.
- **Precise** - Select this to process only data for which precise ephemeris is available.

**Warning:** If the ephemeris type you select does not cover all of the data in your project, only the data it covers is processed.

**Processing**

**Solution type**

- **Fixed** - Select this to allow either fixed or float solutions, based on how the processor is able to resolve the integer ambiguity search.
- **Float** - Select this to allow float solutions only.

**Frequency**

- **L1 only** - Select this to process only L1 GPS data. Any L2 GPS data or GLONASS data in your project is ignored.
- **Multiple frequencies** - Select this to process all GNSS data in your project.

**Note:** This option is available only if you are licensed for multi-frequency processing.

**Generate residuals**

- **Yes** - Select this to generate a residual file for each processed session.
- **No** - Select this to prevent residual files from being generated.

**Quality**

**Acceptance criteria**

Uncheck either box to keep horizontal or vertical precision from being used in passing or failing a baseline (acceptance criteria).

If you keep the criteria enabled, type tolerance values in the **Flag** and **Fail** boxes in the format `constant unit + parts per million unit` to specify the required horizontal and vertical precision to use for flagging or failing a processed baseline.

If a baseline fails, it will be deselected, and cannot be saved in the project.

**Use optional acceptance criteria**

Check this box to open the **Optional Acceptance Criteria** boxes, if needed.
Optional acceptance criteria

**If Ratio <** - Uncheck this to keep Ratio from being used in acceptance criteria.

Ratio is a measure of how well the processor is able to determine fixed integer solutions; higher numbers are considered better.

**If RMS (L1 only) >** - Uncheck this to keep Root Mean Square (RMS) from being used in acceptance criteria for L1 only data.

**If RMS (dual frequency) >** - Uncheck this to keep RMS from being used in acceptance criteria for L1/L2 data.

RMS is a measure of noise in the measurements; smaller values for RMS are considered better.

**Note:** This option is available only if you are licensed for multi-frequency / GLONASS processing.

Satellites

Elevation mask

Type a vertical angle (in degrees) below which satellite data should be ignored during processing.

Adjust this mask as necessary based on any obstructions in the project area.

GPS and GLONASS

Uncheck satellites numbers on these tabs to ignore their data during processing. If a satellite was unhealthy during the survey, uncheck the box.

Trimble receivers automatically pass unhealthy status messages to this software. RINEX files, however, may not properly indicate unhealthy status. In this case, use these setting to ignore unhealthy satellites during processing. This is also useful if a satellite with a lower elevation is causing a noisy solution.

**Note:** The GLONASS tab is available only if your software supports GLONASS processing.

All

None

Related topics

- [Choose Project Settings](#) (on page 155)
- [Create a Project Template](#) (on page 182)
Use network adjustment settings to control how networks of processed baselines are adjusted.

**To access the settings:**

1. Do one of the following:
   - Select **Project > Project Settings**.
   - Click the icon on the toolbar.
     The **Project Settings** dialog displays.
2. Click **Network Adjustment** in the left pane.
3. Click each section and view or select options as shown in the following table.
4. When you are done, click **OK**.
### Options

**Network adjustment styles**

See [Apply a Network Adjustment Style](on page 354).

**General**

**General**

**Maximum iterations** - Enter the highest number of computations allowed for the adjustment to meet the defined residual tolerance.

**Terrestrial**

**Perform Vertical Adjustment** - Specify whether or not to compute delta elevations from total station observations.

**Covariance Display**

**Horizontal**

**Express precision as** – Select the method of expressing horizontal (2D) precision ($P$) as proportional errors. For horizontal precision, distance is the horizontal distance between points. Select one of these options:

- **Ratio** - Select this to express horizontal precision in units of one part in $X$ (where $X = \text{distance} \div P$).
- **PPM** - Select this to express horizontal precision in units of $X$ parts per million, where $X = \text{distance} \times P \times 1.0e^{-06}$.
- **None** - Select this to disable the display of horizontal precision.

**Propagated linear error ($E$)** - Select the horizontal (two-dimensional) propagated linear error for the network adjustment style. The computed propagated linear error is at 1-sigma, regardless of the Univariate and Bivariate Sigma Scalars. Select one of these options:

- **US** - Select this option to use the standard error of adjusted horizontal (2D) or slope (3D) distance.
- **Canadian** - Select this option to use the largest semi-major axis of the 2D or 3D relative error ellipsoid.
- **Bomford** - Select this option to use the square root of the sum of the 2D or 3D relative error variances.
- **Spherical** - Select this option to use the mean of the 2D or 3D relative standard errors.

**Constant term ($C$)** - Type a value in current project units. The term must range from 0.0 m (0.0 US ft) to 0.1 m (0.3 US ft).
Three-Dimensional

Express precision as - Select the method of expressing three-dimensional (3D) precision (P) as proportional errors. For three-dimensional precision, distance is the slope distance between points. Select one of these options:

- **Ratio** - Select this option to express horizontal precision in units of one part in X (where X = distance ÷ P).
- **PPM** - Select this option to express horizontal precision in units of X parts per million, where X = distance × P × 1.0e-06).
- **None** - Select this option to disable the display of horizontal precision.

Propagated linear error (E) - Select the three-dimensional propagated linear error for the network adjustment style. The computed propagated linear error is at 1-sigma, regardless of the values specified for the Univariate and Bivariate Sigma Scalars. Select one of these options:

- **US** - Select this to use the standard error of adjusted (horizontal (2D) or slope (3D)) error.
- **Canadian** - Select this to use the largest semi-major axis of the 2D or 3D relative error ellipse.
- **Bomford** - Select this to use the square root of the sum of the 2D or 3D relative error variances.
- **Spherical** - Select this to use the mean of the 2D or 3D relative standard errors.

Constant term (C) - Enter a value in current project units. The term must range between 0.0m (0.0 US ft) to 0.1m (0.3 US ft).

General

Scalar on linear error (S) - This displays the factor used to scale precisions to the desired level of confidence. For scaling relative covariance matrices, the propagated linear error is squared.

Covariance display for horizontal scalars
For the US, Bomford, and Spherical methods, these options are available:

- 1.000 1-sigma
- 1.969 (95%)
- 2.575 (99%)

For the Canadian method, these options are available:

- 1.000 (39%)
- 2.447 (95%)
- 3.035 (99%)
Covariance display for 3D scalars

For the US, Bomford, and Spherical methods, these options are available:

- 1.000 1-sigma
- 1.969 (95%)
- 2.575 (99%)

For the Canadian method, these options are available:

- 1.00 (20%)
- 2.80 (95%)
- 3.37 (99%)

**Note:** Set the precision confidence level in the **Confidence Level Display** section of the **Computational Settings** (on page 164).
Set Up Projects

Restrict to observed lines

- **Yes** - Select this to limit the display of covariant terms. When this is selected, there is no effect on final adjustment results, except for preventing the display of covariant terms between points not connected by observations.

- **No** - Select this to compute covariant terms between every possible permutation of point pairs in the network.

For large networks, the list of covariant terms in the *Network Adjustment Report* could become very long.

Transformations

**GNSS**

- **Compute latitude and longitude deflections** - Select *Yes* to use latitude and longitude deflections to transform GNSS vectors to the local datum.

- **Compute azimuth rotation** - Select *Yes* to use the azimuth rotation to transform GNSS vectors to the local datum.

- **Compute scale factor** - Select *Yes* to use the scale factor to transform GNSS vectors to the local datum.

**Terrestrial**

- **Compute azimuth rotation** - Select *Yes* to use the azimuth rotation to transform azimuths to the local datum.

- **Horizontal scale factor** - Type a value for the factor to apply to horizontal distances from terrestrial measurements.

Related topics

- [Adjust a Network](on page 356)
- [Choose Project Settings](on page 155)

Default Standard Errors Settings

A "standard error" is a statistical estimate of error, according to which 68 percent of an infinite number of observations will theoretically have absolute errors less than or equal to this value. Use default standard errors settings to determine whether or not to use default standard error values, and to view and edit those values.
To view and edit default standard error settings:

1. Do one of the following:
   - Select Project > Project Settings.
   - Click the icon on the toolbar.
   The Project Settings dialog displays.

2. Select Default Standard Errors in the left pane.

3. Click each section and view or select options as shown in the following table.

4. When you are done, click OK.
Set Up Projects

Options

General

General

Specify whether or not you want to always use default standard errors.

Total Station

Default Standard Errors

View and edit default standard error values for horizontal angles, vertical angles, and the constant and length-dependent part of slope distances.

Default Setup Errors

View and edit default setup error values for the instrument height, target height, and centering of the total station and target over the survey point.

Leveling

Leveling

View and edit the default standard error value for 1 km of double leveling.

GNSS

Default Standard Errors

View and edit the constant and length-dependent part of horizontal and vertical errors.

Default Setup Errors

View and edit default setup error values for the antenna height and centering of the antenna over the survey point.

Antenna height errors typically range from 0.000 to 0.004m (0.000 to 0.013 sft). The default is 0.000m (0.000 sft).

Centering errors typically range from 0.000 to 0.002m (0.000 to 0.007 sft). The default is 0.000 m (0.000 sft).

Azimuth

Azimuth

View and edit the default standard error value.

Confidence Level Display

Confidence Level Display

View and edit the confidence level for displaying error values (1-sigma, 99%, or 95%) for the entire project.

Related topics

- Choose Project Settings (on page 155)
- Adjust a Network (on page 356)
- Verify Static and Kinematic Data (on page 280)
- Workflow for Total Station Data (on page 320)
- Workflow for Leveling Data (see "Workflow for Level Data" on page 333)

Feature Code Processing Settings

Use feature processing settings to configure how feature codes are processed.
To specify feature processing settings:

1. Do one of the following:
   - Select **Project > Project Settings**.
   - Click the 📜 icon on the toolbar.
   
   The **Project Settings** dialog displays.

2. Select **Feature Code Processing** in the left pane.

3. Click each section and set the options as shown in the following table.

4. Click **OK**.

   **Options**

   **General**

   **Process feature codes on import**

   **Prompt** - Select this option if you want to be prompted on whether or not to process feature codes during data import. If you select to process feature codes during import and a feature definition (.fxl) file has not been specified in the project settings, you will be prompted to specify it at the time of import.

   **Yes** - Select this option if you want feature codes to be automatically processed during data import without prompting you. If a feature definition (.fxl) file has not been specified in the project settings, you will be prompted to specify it at the time of import.

   **No** - Select this option if you never want feature codes to be processed during data import.

   **Decimal precision**

   Specify the number of decimals to display with a numeric attribute (real number) when no feature definition (.fxl) file is specified.

   **Processing**

   **Feature definition file**

   Specify the feature definition (.fxl) file you want to use to process feature codes in the project. This is required if you want to process feature codes.

**Related topics**

- Choose Project Settings (on page 155)
- Understanding Feature Data (on page 455)
- Workflow for Feature Data (on page 457)
- Enter, Edit, and Delete Feature Code Strings (on page 459)
- Process Feature Codes (on page 463)
Abbreviation Settings

Use abbreviation settings to control notations for horizontal and vertical alignment classifications in the *Alignment Geometry Report*.

**To access the settings:**

1. Do one of the following:
   - Select **Project > Project Settings**.
   - Click the ![icon] icon on the toolbar.
   
   The **Project Settings** dialog displays.

2. Click **Abbreviations** in the left pane.

Related topics

- Choose Project Settings (on page 155)

Choose Local Site Settings

Enter local site settings to create a ground coordinate system to accommodate elevation differences between your site and the ellipsoid. The scale factor can be calculated for you.

You should define local site settings for the project location at the start of the project because this information is used in calculations. The application uses:

- The project latitude to calculate the earth's radius
- The project latitude and longitude to define the grid scale factor

**The project height as the default elevation and to calculate the elevation factor** To specify local site settings:

1. Select **Project > Local Site Settings**. The **Local Site Settings** command pane displays.

2. Select a coordinate system to display in the **Coordinate type** list. Any changes take effect immediately.

   If you select **Grid**:

   1. Click in the **Northing** box.
   2. Pick a point in a graphic view, right-click for options, or type coordinates in the **Northing** and **Easting** boxes to specify the location for the local site.
3. Pick a point in a graphic view, right-click for options, or type a value in the **Elevation** box.

If you select **Local** or **Global**:

1. Click in the **Latitude** box.
2. Pick a point in a graphic view, right-click for options, or type coordinates in the **Latitude** and **Longitude** boxes to specify the location for the local site.
3. Pick a point in a graphic view, right-click for options, or type a value in the **Height** box.

4. Type a value in the **Ground scale factor** box, or check **Compute ground scale factor from project location** to have the value computed.

4. To close the dialog, click **OK**.

**To view the local site settings:**

1. Select **Project > Project Settings**. The **Project Setting** dialog displays.

2. Select **Coordinate System** and then **Local Site**. The read-only **Local Site** settings display.

**Related topics**

- [Coordinate System Settings](#) (on page 156)
- [Calibrate a Site](#) (on page 203)

**Local Site Setting Options**

Use these options to define the current project’s local site. They are available in the **Local Site Settings** command pane.
Set Up Projects

Options

Project location

Coordinate type

Grid - Select this to enter planar northing, easting, elevation, and height values in a grid system.

Local - Select this to enter ellipsoidal latitude, longitude, height, and elevation values on a local datum.

Global - Select this to enter global ellipsoidal longitude, height, and elevation values on a global datum.

Ground coordinates

Ground scale factor

Type a factor by which to convert grid distances to ground distances.

Compute ground scale factor from project location

Check this to have the ground scale factor calculated for you. The value will be a product of the grid factor (determined from the horizontal project location) and the height scale factor (determined from the vertical project location).

Note: When Compute ground scale factor is checked, the Ground scale factor box is unavailable.

Coordinate Display

False Northing offset

Type a value for the distance to offset from the northing and easting values.

For example, if you enter:

- False northing offset: -6,540,000

Then a northing of 6,542,111 becomes: 2,111

Create a New Project

You can create a new project using the default template, or you can select a new template from which to create a project.
To create a new project using the default template:

- Click the icon. This is the quickest way to create a new project.

To create a new project by choosing a template:

1. Do one of the following:
   - Select File > New Project.
   - Press [Ctrl] + N.
2. In the New Project dialog, select a template.
3. Click OK.

To create a new project upon starting the application:

1. Select Tools > Options. The Options dialog displays.
2. Select General > Startup and Display.
3. Select Open new default project in the Starting state list.
4. Click OK. Each time you start this software, a new project will be started using the default template.

**Note:** Creating a new project closes any project that is currently open.

**Related topics**

- Choose Application Options (on page 148)
- Choose Project Settings (on page 155)
- Change the Default Template (on page 183)
- Startup and Display Options (on page 148)

**Use a Project Template**

Several default templates are provided so you can start projects with consistent distance units. It is even more efficient, however, to create your own templates. In your own templates, you can save additional project settings, including:
Set Up Projects

- Company, user, and file information, such as field and office operators, contact numbers, and addresses
- Coordinate system information, such as a datum transformation and geoid model
- Units settings, such as coordinate formatting
- View settings, such as a plot scale and grid line definition
- View filters and selection sets
- Computational settings, such as horizontal and vertical tolerances

When you start projects using your own templates, any settings you specified are included, saving you time and effort, and making your projects more consistent. You can even share templates with co-workers to ensure consistency across your company.

Related topics
- Create a Project Template (on page 182)

Create a Project Template

When you save a project as a template, all project settings and data are saved in the new template file, and the new name is added to the template list.

**Warning:** Saving data that requires computation in project templates is not recommended; the data may not recompute properly.

**Note:** It is a good idea to create a template for each set of coordinate system/project units you commonly use.

To create a project template using an existing project:

1. Open, or create, a project that you want to save as a template.
2. Review and modify project settings as needed.
3. Create layers and view filters that you want to be available in future projects.
4. Remove any unnecessary data from the project.
5. Select **File > Save Project as Template**. The **Save Project as Template** dialog displays.
6. In the **Name** field, type a name for the template.
7. If you want this template to be used when you create a project by clicking the icon, check the **Save project as default template** box.
8. Click **OK**. The template is saved in the template folder. When select **File > New Project**, the template appears among the other templates.
To delete a project template:

1. Select File > Save Project as Template. The Save Project as Template dialog displays.
2. Click in the left column for template you want to delete.
3. Click Delete. A confirmation message displays.

Note: You cannot delete the template that is set as the default. If you want to delete the default template, set another as the default.
4. Click Yes.
5. Click OK.

Related topics
- Change the Default Template (on page 183)
- Change the Template Folder (on page 152)
- Define a New Coordinate System (on page 158)
- Create a View Filter (on page 82)
- Save a Project (on page 184)
- Save Project As Command

Change the Default Template

When you create a new project by clicking the icon on the toolbar, the default template is used.

To change the default template:

1. Select File > Save Project as Template.
2. Select the template you want to use as a default.
3. Click Set as default.
4. Click OK.

Related topics
- Create a Project Template (on page 182)
- Change Template Folder (see "Change the Template Folder" on page 152)

Open an Existing Project

Use these commands to quickly open a recent project, or browse to another previous project.

1. Do one of the following:
   - Select File > Open Project.
Set Up Projects

- Click the 📜 icon on the toolbar.
- Press [Ctrl] + O.

The Open File dialog displays, showing a list of available projects in the folder last opened.

2. Select a project from the list, or browse to locate a project in a different folder.
3. Click Open.

To open a recent project:
- Select File, and then select a project from the list of recent projects (at the bottom of the File menu). The project opens.

Note: Opening a project closes any project that is currently open.

Related topics
- Create a New Project (on page 180)
- Startup and Display Options (on page 148)

Save a Project

You can save a project, rename a project/save a project to a different path or filename.

To save a project:
1. Do one of the following:
   - Select File > Save.
   - Press [Ctrl] + S.
   - Click the 📜 icon on the toolbar.
2. Select the folder where you want to save the file, and assign a file name.
3. Click Save.

To rename an existing project:
1. Select File > Save As. The Save As dialog displays.
2. Select the folder in which you want to save the file in the Save in box.
3. Type a name in the File name box.
4. Click Save.

Note: You cannot overwrite an existing project by naming a project the same name as an existing project.
Archive a Project

Use this command to save a project (.vce) file and its associated subfolder in a compressed (.zip) file of the same name. This enables you to quickly compile all parts of a project into a smaller file that is suitable for sending to a colleague or archiving.

Note: File archiving only works if you have Use project subfolders checked in the File Locations section of the Options dialog.

To archive a project:

1. Make sure the project you want to archive is closed.
2. Select File > Archive Project. The Archive a Project dialog displays.
3. Select the file you want to archive in the Save in box.
4. Click Save. The .zip file appears, next to the project file and subfolder.

Print a View or Report

You can print a graphic view to any Windows-supported printing device. You can also print a report using your default Web browser's print command.

To select a printer:

2. In the Page Setup dialog, set the paper size, orientation, and margins.
3. Click Printer. The second Page Setup dialog appears.
4. In the Name list, select the printer you require.
5. Click OK in both dialogs.

Note: You can also select a printer within the Print command.
To preview a print job:

1. Click the view you want to print to make it active.
2. Do one of the following:
   - Select File > Print Preview.
   - Click the icon.
   The Print preview dialog opens.
3. In the Print preview dialog, you can:
   - View the plan view of your project
   - Zoom to view less or more detail
   - Select the page layout
   - Click the icon to print, or Close.

Note: You cannot cancel a print job if you use this option.

To print:

1. Do one of the following:
   - Select File > Print
   - Press Ctrl + P
   - Click the icon.
2. Select the printer, page range and number of copies to print.
3. Click OK.

Related topics
- Page Setup Command
- Print Preview Command

Troubleshoot a Project Problem

Before calling Support, use any applicable solutions to known issues below.
## Troubleshoot a Program Freeze

Before calling Support, use any applicable solutions to known issues below.

<table>
<thead>
<tr>
<th>Symptom</th>
<th>Possible Cause</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>Program freezes when selecting many objects.</td>
<td>The <strong>Properties</strong> pane is open. When you select many objects with the <strong>Properties</strong> pane open, it looks for the properties common to all of the objects, slowing the program down and making it look frozen.</td>
<td>Close the program. If you have trouble reopening the project, check the directory where the .vce file is stored. If there is a lock (*,.lk) file with the same name as the project, delete it and reopen the project. Close the <strong>Properties</strong> pane before reselecting the objects.</td>
</tr>
<tr>
<td>Program doesn’t respond in the expected way; nothing seems to work.</td>
<td>The mouse may be set to a mode other than <strong>Select</strong>.</td>
<td>Check your mouse mode on the <strong>Mouse</strong> toolbar. If needed, reset it to <strong>Select</strong>.</td>
</tr>
<tr>
<td>The program freezes.</td>
<td>Toolbars are corrupted.</td>
<td>Consider contacting Technical Support. Otherwise, remove the application data folder located at <code>C:\Documents and Settings\&lt;user name&gt;\Application Data\Trimble\Trimble Business Center\&lt;version&gt;</code></td>
</tr>
</tbody>
</table>

**Note:** If you do not see the **Application Data** folder at the path listed above, it may be hidden. To show hidden folders, in Windows® Explorer, select...
Set Up Projects

Tools > Folder Options.
Click the View tab and select Show hidden files and folders in Advanced Settings. Then click OK.

The program appears to freeze when you float a pane or try to open a dialog.

If you are running the program on a secondary monitor, and you float a pane or use a command that launches a dialog, the pane or dialog might appear out of either monitor’s visible range. It will be located off of the primary monitor, in the space opposite the secondary monitor, causing Trimble Business Center to appear ‘frozen’.

Program appears to freeze when you are trying to e-mail SCS files.

If you are running the program on a secondary monitor, and you attempt to e-mail SCS files using the Compress/E-mail SCS Files command, your e-mail program may open a dialog confirming the operation out of either monitor’s visible range. The dialog will be located off of the primary monitor, in the space opposite the secondary monitor, causing the program to appear ‘frozen’.

To reach the dialog or pane, right-click the application’s name on the Windows Taskbar and select Move. Then, press the appropriate arrow key to move the dialog into your primary’s monitor’s visible range.

To reach the dialog and confirm the e-mail operation, right-click the e-mail application’s name on the Windows Taskbar and select Move. Then, press the appropriate arrow key to move the dialog into your primary’s monitor’s visible range.
Set Up Geodetic Reference Data

Understanding Geodetic Reference Data

This software uses a coordinate system to transform measurements on a curved surface (the earth) to a flat surface (a map or plan). For example, a coordinate system is used to calculate grid coordinates for a point measured using GPS (GPS measurements are made on the WGS-84 ellipsoid).

A coordinate system can consist of the following elements:

- A datum transformation (between the WGS-84 ellipsoid and the local ellipsoid)
- A projection
- A geoid model
- A GPS site calibration (consisting of an horizontal adjustment and a vertical adjustment)

You must select a coordinate system for every project. If you do not have a system, or do not know which system to select, use the default projection.

Note: Make sure that the points in a project are within a reasonable distance from the projection origin according to the properties of the projection used.

Coordinate system database

The coordinate system database is stored as a file called Current.csd. It contains all of the coordinate system information. The office software supplies an extensive set of published coordinate systems from around the world. To define or edit coordinate systems, zones, sites, datum transformations, ellipsoids, and geoid models, use the Coordinate System Manager (on page 192).

Related topics

- Change the Coordinate System (on page 157)
- Coordinate System Manager
- Define a New Coordinate System (on page 158)
- Restore the Original Coordinate System File (on page 158)
Define the Coordinate System

Change the Coordinate System

Choose the appropriate coordinate system and geoid model for your project by selecting one that you have used recently. Up to ten of the most recently used systems are stored.

To select an existing coordinate system:

1. Do one of the following:
   - Select Project > Change Coordinate System.
   - Select Project > Project Settings > Coordinate System, and click Change.

   The Select Coordinate System dialog displays.

   Note: The Select Coordinate System dialog is part of the Coordinate System Manager, a separate application. When only the dialog is open, pressing [F1] does not open online help. To view help for the Coordinate System Manager, click Tools > Coordinate System Manager to open the application. Then press [F1] for help.

2. Select Recently Used System.

3. Click or , or press [PageUp] or [PageDown], to view the available coordinate systems.

4. When the coordinate system that you want is displayed, click Finish. The coordinate system project settings are updated, and your project is recomputed using the new coordinate system.

Caution: To avoid problems or unexpected results in your project, do not change the coordinate system after you import data.

Related topics
- Coordinate System Manager
- Coordinate System Settings (on page 156)
- Define a New Coordinate System (on page 158)

Define a New Coordinate System

Define parameters for a new coordinate system if the one you need doesn’t appear in the list of recently used systems.

To define a new coordinate system:

1. Do one of the following:
Set Up Geodetic Reference Data

- Select Project > Change Coordinate System.
- Select Project > Project Settings > Coordinate System, and click Change. The Select Coordinate System dialog displays.

2. Select New System, and click Next.

3. To define a default project based on Transverse Mercator parameters:
   - Click Default Projection, and click Next.
   - Enter the Transverse Mercator parameters that are requested, and click Next.

4. To define a projection based on a coordinate system group and zone:
   - Click Coordinate System and Zone, and click Next.
   - Select the coordinate system group from the list on the left, and select the zone from the list on the right and click Next.

5. Select the geoid model you want to use and click Finish. Your project is recomputed using the new coordinate system.

Related topics
- Coordinate System Manager
- Coordinate System Settings (on page 156)
- Change the Coordinate System (on page 157)
- Define a Projection (on page 195)

Restore the Original Coordinate System File

If you have previously installed Trimble® Geomatics Office™ (TGO), you may have an existing current.csd file which stores recently-used or custom coordinate systems. During the installation of the software, any existing current.csd file is renamed current.csd.date.xx-xx-xx.

To restore the Current.csd file:

1. Open Windows® Explorer and browse to one of these locations, depending on your operating system:
   - In Windows XP or earlier: C:\Documents and Settings\All Users\Application Data\Trimble\GeoData unless you have previously installed TGO. If you have installed TGO and then this software, the path is C:\Program Files\Common Files\Trimble\GeoData.
     
     **Note:** Due to network security, you may not be able to edit this path unless you have administrative rights.
   - In Windows Vista™: C:\ProgramData\Trimble\GeoData\ or C:\Program Files\Common Files\Trimble\GeoData\.
2. Rename `current.csd` to `current-TBCC.csd`.
3. Rename the `current.csd.date.xx-xx-xx` to `current.csd`.

Related topics
- Change the Coordinate System (on page 157)

## Troubleshoot a Coordinate System Problem

Before calling Support, use any applicable solutions to known issues below.

<table>
<thead>
<tr>
<th>Symptom</th>
<th>Possible Cause</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>You cannot create or edit coordinate systems, or save sites.</td>
<td>You are running as a Limited User (non-administrator). Limited users do not have &quot;write&quot; permissions for the <code>current.csd</code> file, which means that you cannot create or edit coordinate systems, or save sites.</td>
<td>You must be granted &quot;write&quot; permissions for the <code>current.csd</code> file by an administrator. The location of that file depends on your operating system:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>In Windows® XP or earlier:</strong> C:\Documents and Settings\All Users\Application Data\Trimble\GeoData or C:\Program Files\Common Files\Trimble\GeoData.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>In Windows Vista™:</strong> C:\ProgramData\Trimble\GeoData or C:\Program Files\Common Files\Trimble\GeoData.</td>
</tr>
</tbody>
</table>

**Note:** This may be a non-issue if other Trimble software has been previously installed, and access rights have been resolved.

**Note:** If you do not see the Application Data folder at the path listed above, it may be hidden. To show hidden folders, in Windows® Explorer, select Tools > Folder Options. Click the View tab and select Show hidden files and folders in Advanced Settings. Then click OK.

## Coordinate System Manager

The **Coordinate System Manager** is a standalone utility that gives you access to your coordinate system database (Current.csd). Use the manager to create coordinate systems, or to determine which coordinate systems, geoid models, and sites are available for use in your project.
To open the Coordinate System Manager:

- Select **Tools > Coordinate System Manager**.

**Note:** The **Coordinate System Manager** has its own help system. Open the utility and select **Help > Help Topics**, or press **[F1]** within the software.

**Related topics**

- [Change the Coordinate System](#) (on page 157)
- [Coordinate Systems](#) (see "Understanding Geodetic Reference Data" on page 189)
- [Define a New Coordinate System](#) (on page 158)
- [Restore the Original Coordinate System File](#) (on page 158)

**Scale-Only Projection**

The software allows you to import survey data using a scale-only projection. Because the software cannot calculate global or local coordinates from grid positions in a scale-only projection, certain functionality is affected. Note the following when working with scale-only projection data:

- You can specify a scale factor for the scale-only projection when you import the data, and after import in the **Coordinate System** section of the **Project Settings** dialog.
- The **Create Point** and **Add Coordinate** commands allow to enter a grid point or coordinate in scale only.
- The **Local Site Settings** and **Site Calibration** commands are disabled.
- When using the **Inverse** command, only grid and ground distances are available.
- The **Point List** report includes only grid data.

When working with coordinate system data and scale-only projection data in the same project, note the following:

- When you import scale-only projection data into a project that already contains coordinate system data, the scale-only projection data is converted to the existing coordinate system.
- When you import coordinate system data into a project that contains scale-only projection data, the scale-only projection data is converted to the existing coordinate system.

**Use a Datum**

**Create a Datum Grid File**

If you have chosen a coordinate system for your project that uses a datum, and the datum hasn't been defined yet, you must create it before uploading to a field device.
To do this, find a coordinate system with the appropriate datum to use. If you know of a coordinate system that uses the datum you need, you can select it to combine its .dgf files into a single .cdg file suitable for uploading.

**Note:** When you download or import data into a project, the datum used by the imported data must correspond with the datum defined for the project's coordinate system.

**To create a datum grid:**

1. Select **Project > Project Settings**. The **Project Settings** dialog displays.
2. Click **Coordinate System** and then **Datum Transformation** in the left pane.
3. Review the parameters. You can only create a datum grid file if the **Latitude Grid File** and **Longitude Grid File** boxes are shown, and .dgf files are listed in them. If there are, click **OK**, and proceed to step 9.
4. If there aren't .dgf files shown, click **Change** at the bottom of the dialog. The **Select Coordinate System** dialog displays.
5. Select **Recently Used System**.
6. Click or , or press [PgUp] or [PgDn], to view the available coordinate systems.
7. When you find a coordinate system that uses the datum you need, click **Finish**. The **Project Settings** dialog updates.
8. Confirm that .dgf files are shown in the **Latitude Grid File** and **Longitude Grid File** boxes. These files will be combined into a datum grid file (.cdg) file that you can save and upload to a field device.
9. Click **OK** to close the **Project Settings** dialog.
10. Do one of the following:
   - Select **Project > Datum Gridding**.
   - In the **Device** pane, with a device connected, click **Tasks** and select **Upload datum grid (.dgf) file**.

   The **Datum Gridding** command pane displays. The .dgf files appear in the **Project Datum Grid** group.
11. Click **Create** at the bottom of the command pane. The **Save As** dialog displays.
12. Accept the default file name, and click **Save**. The datum grid file appears in the **Datum Grid Files (.cdg)** list. Now it can be uploaded to a field device.

**Related topics**

- [Upload a Datum Grid](#) (see "Upload a Datum Grid File" on page 273)
### Datum Grid Options

Use these options to select a datum file to upload to a field device. They are available in the **Datum Gridding** command pane.

<table>
<thead>
<tr>
<th>Options</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Folder</strong></td>
<td>Select, or navigate to, the folder in which the datum grid files (.cdg) are installed.</td>
</tr>
<tr>
<td><strong>Datum grid files (.cdg)</strong></td>
<td>This displays the names of the available datum grid files.</td>
</tr>
<tr>
<td><strong>Description</strong></td>
<td>This shows the regions covered by the datums.</td>
</tr>
<tr>
<td><strong>Size</strong></td>
<td>This displays the file sizes. Files larger than 1 MB may take a while to upload.</td>
</tr>
<tr>
<td><strong>Project/Selected datum grid</strong></td>
<td>If you have a datum grid file selected in the list, this displays details on it. If you do not have a datum grid file selected, this displays details on the datum used in your current project's coordinate system.</td>
</tr>
<tr>
<td><strong>Upload</strong></td>
<td>Click this to transfer the datum grid file to the connected field device.</td>
</tr>
<tr>
<td><strong>Create</strong></td>
<td>Click this to save a new datum grid file.</td>
</tr>
</tbody>
</table>

**Note:** Click the lower group header to switch between the current project's datum and a stored datum grid file.

**Project/Selected datum grid**

- If you **have** a datum grid file selected in the list, this displays details on it.
- If you **do not have** a datum grid file selected, this displays details on the datum used in your current project's coordinate system.

**Upload**

Click this to transfer the datum grid file to the connected field device.

**Create**

Click this to save a new datum grid file.

**Use project datum**

Check this before uploading if you want to upload a temporary copy of the current project’s datum, instead of selecting one of the permanently stored datum grid files in the list.

**Upload to Device** is also available from the context menu.

### Define a Projection

Use a false origin to define a projection when you import raw GNSS data for which you did not previously specify the projection.

**To define a projection:**

1. Import and check-in your raw GNSS data. If there is not associated projection, the **Projection Definition** dialog displays.

2. If needed, type grid coordinates in the **Northing** and **Easting** boxes to base the origin on the best known grid coordinates.
3. Click **OK**. The new coordinates become the projection's origin.

**Related topics**

- Check-In Raw GNSS Data (on page 220)
- Local Site Setting Options (on page 179)

### Use a Geoid

**Geoid Options**

Use these options to select a geoid file to upload to a field device. They are available in the **Geoid Sub-Gridding** command pane.

**Options**

**Click this to display the Select Coordinate System dialog, where you can choose a recently-used coordinate system, or define a new one to use in your project.**

**Folder**

Select, or navigate to, the folder in which the geoid grid files (.ggf) are installed.

**File (.ggf files)**

This displays the names of the available geoid grid files. If any geoid sub-grid files have been defined, they display beneath the name of the complete geoid grid file.

**Description**

This shows the regions covered by the geoids.

**Size**

This displays the file sizes. Files larger than 1 MB may take a while to upload.

**Upload**

Click this to transfer the geoid grid file to the connected field device.

**Note:** This is only available if you have a field device connected and accessed the command through the **Tasks** button.

**Create sub-grid**

Click this to define a sub-area of the geoid file to save upload time and field device memory.

**Related topics**

- Define a Geoid Subgrid (see "Define a Geoid Sub-Grid" on page 196)
- Upload a Geoid File to a Field Device (see "Upload a Geoid File" on page 273)

### Define a Geoid Sub-Grid

If the geoid file you want to use for data collection is too large, define a subsection of the area to use before uploading to a field device. This saves upload time and field device memory.
Set Up Geodetic Reference Data

**Note:** When you download or import data into a project, the geoid sub-grid used by the imported data must correspond with the geoid defined for the project’s coordinate system.

**To create a geoid sub-grid:**

1. Do one of the following:
   - Select *Project > Geoid Sub-Gridding*.
   - In the *Device* pane, with a device connected, click *Tasks* and select *Upload geoid (.ggf) file*.

   The *Geoid Sub-Gridding* command pane displays.

2. If needed, select the folder containing the installed geoid files in the *Folder (ggf)* list, or click the icon and navigate to the folder.

   **Note:** The default location for .ggf files depends on your operating system:
   In Windows® XP or earlier: `C:\Documents and Settings\All Users\Application Data\Trimble\GeoData` unless you have previously installed Trimble® Geomatics Office™ (TGO). If you have installed TGO and then this software, the path is `C:\Program Files\Common Files\Trimble\GeoData`.
   In Windows Vista™: `C:\ProgramData\Trimble\GeoData` or `C:\Program Files\Common Files\Trimble\GeoData`.

3. Select a geoid file in the *Geoid File (.ggf)* list.

4. Right-click and select *Create sub-grid* from the context menu. The *Create Geoid Grid File* dialog displays. The whole globe is visible, and the geoid is centered. In the *Geoid File Properties* group, the size of the whole geoid appears in the *Size* box.

5. In the *Suffix to Append* box, type text to attach to the end of the original geoid file name to define the sub-grid. The complete file name appears as you type the suffix. For example, if you will be collecting data in Baja, Mexico, add Baja as the suffix to the geoid `Mexico97.ggf` to create the file `Mexico97Baja.ggf`.

6. If needed, uncheck borders or rivers in the *Globe Properties* group to simplify the display.

7. Click the icon to zoom in to the extents of the geoid. For explanations of the other viewing tools, see *Geoid Sub-grid Options*.

8. Click the icon, and window around the portion of the geoid that you need to create a sub-geoid. The size of the geoid sub-grid appears in the *Size* box.

   **Note:** You cannot adjust the sub-grid window that you draw, but you can redraw it multiple times.

9. Click *Save*. The *Save Geoid Grid File As* dialog displays.
10. Click **Save** again. The geoid sub-grid file appears in the geoid list just below the original geoid file.

**Related topics**

- [Geoid Subgrid Options](#) (see "Geoid Sub-Grid Options" on page 198)
- [Upload a Geoid File to a Field Device](#) (see "Upload a Geoid File" on page 273)

**Geoid Sub-Grid Options**

Before uploading to a field device, use these options to define a sub-area of a larger geoid file to save upload time and field device memory. They are available in the **Create Geoid Grid File** dialog.
**Options**

**Geoid file properties**

**Geoid**

This displays the name of the geoid on which the sub-grid will be based.

**File name**

This displays the geoid’s file name.

**Suffix to append**

Type text to attach to the end of the original geoid file name to identify the sub-grid.

**Size (KB)**

Shows the original geoid size until you draw the sub-grid. Then it shows the geoid sub-grid’s size.

**Sub-grid properties**

**First latitude**

These display the coordinates of the first corner of the window you pick when drawing a sub-grid.

**First longitude**

**Second latitude**

These display the coordinates of the opposite corner of the window you pick when drawing a sub-grid.

**Second longitude**

**Globe properties**

**Cursor latitude**

These display the coordinates of the current cursor location. If the cursor is not over the globe, they display the point at which the cursor left the globe.

**Cursor longitude**

**US state borders**

Uncheck this to hide state boundaries in the United States.

**National borders**

Uncheck this to hide boundaries of nations.

**Major rivers**

Uncheck this to hide major waterways.

Click this to activate the selection tool. Then click and drag to draw a window within the current geoid to define the opposite corners of a geoid sub-grid.

Any portion of the sub-grid that you draw outside of the geoid boundary is ignored.

---

**Note:** To erase a sub-grid, click anywhere off of the globe.

**Tip:** After you window to create a sub-grid, you can click within the sub-grid to zoom in.
Set Up Geodetic Reference Data

Click this to activate the pan tool. Then click and drag on the globe to move to different locations.

Click this to zoom in to the extents of the geoid. Then click it again to zoom in by an increment (x2), or pick a point on the globe to center it and zoom in on that point.

Click this to activate the zoom out tool. Then click it again to zoom out by an increment (x2), or pick a point on the globe to center it and zoom out from that point.

Click this to zoom to the extents of the globe, and center the current geoid.

Related topics

- Define a Geoid Subgrid (see "Define a Geoid Sub-Grid" on page 196)

Calibrate a Site

Understanding Site Calibration

The site calibration process establishes the relationship between WGS-84 data collected by GNSS receivers and local control positions (expressed as a local map grid with elevations above sea level). This relationship is defined by a series of mathematical transformations. Site calibration enables you to pair up GNSS and local control points to be used in the calibration. (GNSS coordinates must be derived from GNSS points and observations, and grid points must be derived from grid points and terrestrial observations). This software then computes and applies the mathematical transformations using least squares.

The mathematical transformations that are applied in order to convert WGS-84 positions to grid coordinates are:
1. A datum transformation to convert the WGS-84 latitude, longitude, and ellipsoidal height coordinates to latitude, longitude, and ellipsoidal height coordinates relative to the ellipsoid of the local map grid.

2. A map projection to convert the local ellipsoid latitude and longitude coordinates into local map grid northing and easting coordinates (the height value is not altered in this process).

3. A geoid model to WGS-84 height to get approximate elevation above sea level.

4. A horizontal adjustment of the transformed grid coordinates to best fit local control data. This adjustment allows for any local variations in the projection system that cannot be accommodated in the overall datum transformation.

5. A height adjustment to convert the heights above the local ellipsoid or elevations derived from the geoid to local control elevations above sea level.

The horizontal and vertical adjustment are stored as part of the coordinate system definition for the project. All GNSS points in the database are updated using the calibration parameters, resulting in more accurate local grid coordinate values.

You can save the new coordinate system definition (which includes the calibration parameters) as a site for use in future projects in the same area.

If you save a calibration as a site with the intention of using the site in another project, make sure that the project area is fully enclosed by the points used in the calibration. For example, in the following diagram, it is valid to use the site definition for project B, but not for project C.

1. Project C area
2. Project B area
3. Points used in calibrating Project A

If you use the Here key in Trimble® Survey Controller™ to start a Real Time Kinematic (RTK) base, and transfer the Survey Controller (.dc) file to this software, the base position, and therefore all rover points from the base, are of unknown quality (for all components, horizontal, height, and elevation).
Note: After performing a site calibration, if you apply local site settings, the calibration you have defined will become invalid and be removed. An error message warns you that continuing will remove the site calibration.

Using Geoid Models

If the coordinate system for the project defines the use of a geoid model for point elevation determination, then elevations are determined directly off the WGS-84 heights by interpolation on the geoid model grid. However, it is still possible to apply a height adjustment on top of the elevations produced by a geoid model to allow for small local variations that a large scale geoid model cannot take into account. Elevations determined from a vertical calibration are given a survey quality.

Rules for ensuring a useful calibration

- WGS-84 coordinates must be relatively correct.

It is possible to generate autonomous GNSS points. However, you should not use more than one autonomous WGS-84 point in a calibration, for example make sure that only a single base station has been set up using the Here key in Trimble Survey Controller. Other base stations should be set up on positions measured by a GNSS vector in terms of the autonomous base station. This defines the relationship between them and allows you to perform a calibration with points used from either base station correctly. This is described below:

The following figure shows no relationship between the base stations:

![No relationship between base stations](image)

Points from Base 1 and Base 2 should not be used for calibration.

In the following figure, a relationship is defined between the base stations by occupying the second base station using the first base station:

![Relationship between base stations](image)
Points from Base 1 and Base 2 can be used for a calibration.

- The best possible WGS-84 coordinates should be used for the initial base station in a survey.

The precision of GNSS vectors (real-time or postprocessed) is affected by the accuracy of the base coordinate. An error of up to one part per million (1 ppm) can be introduced for each ten meters of error in the base coordinates. For example, if your primary WGS-84 reference point has an error of one hundred meters and your baseline is two kilometers long, you may have an unnecessary extra error of two centimeters in your GNSS vectors.

**Related topics**

- [Calibrate a Site](on page 203)

**Calibrate a Site**

Calibrate sites to minimize residuals between WGS-84 RTK data you collect and local control coordinates. For a calibration, associate GNSS points with grid points at the same positions. These point pairs are used to compute and apply mathematic transformations (using least squares) to find the transformation that gives the adjustment parameters that best fit the control grid coordinates when applied to GNSS positions.

Calibrate a site if you:

- Did not calibrate in the field
- Need a report of quality control records
- Want to transfer a calibration to Trimble® Survey Controller™

Need to add extra points to a calibration in Trimble Survey Controller Horizontal calibrations consist of three parameters:
Translation (move)
Rotation (turn)
Scale (shrink or stretch)

Vertical calibrations consist of two parameters:

- Lift (raise or lower)
- Tilt (change the northing and easting incline of the geoid or local plane)

Site calibration creates a set of local site settings. When a site calibration is complete, the site settings are used in the computation of all other imported GNSS data.

**To calibrate a site:**

1. Import or add your grid points using the *Add Point* command.
2. Import your GNSS data.
3. Do one of the following:
   - Click the 🛡️ icon on the toolbar.
   - Select *Survey > GNSS Site Calibration*.

   The *Site Calibration Calculation* command pane displays.
4. Click the *Calibration Settings* tab.
5. To compute a horizontal shift consisting of translations in the north/south and east/west directions, a rotation around a defined origin and a scale factor, leave the *Horizontal Calibration* box checked.
6. Check the *Set scale factor to 1* box if you want to maintain the scale of your horizontal distances.
7. To compute a vertical shift at a defined origin, leave the *Vertical Calibration* box checked.
8. Select *Vertical Shift + Incline Plane* in the list if you need to include inclinations in the north and east directions in the vertical calibration.
9. Click the 🛡️ icon to display the *Project Settings* dialog, where you can define a geoid model, if needed.
10. Click the *Point List* tab to select the calibration point pairs that will be used in the calibration computations.
11. Click in the *GNSS Point* box.
12. Pick a GNSS point in a graphic view, right-click for options, or type a point ID in the box.
Note: The point you select must have global coordinates. Points with local coordinates cannot be selected as GNSS points. Point coordinates must be computed from global coordinates.

Note: Click to expand a group if you want to view coordinate information on the selected point.

13. Click in the Grid Point box.

14. Pick a grid point (at the same location as the GNSS point) in a graphic view, right-click for options, or type a point ID in the box.

15. Select an option in the Type list to specify how the pair of points is to be calibrated. The calibration type you select must be valid for the points. For example, if the grid point does not have an elevation, you cannot set the type to Horizontal and vertical.

16. Repeat steps 11 - 15 to add additional pairs of points, if needed.

Note: There is no limit to the number of pairs that may be defined to compute a calibration. Adding a more pairs will not always improve the calibration results, but it will provide additional checks on the validity of the computed parameters. At minimum, you need three pairs of points for a horizontal calibration, and four pairs of points for a vertical calibration with an incline shift.

17. Click Compute to compute the GNSS calibration parameters. The Results tab appears, summarizing the transformation and listing the horizontal and vertical residuals for each pair of points. The narrow image indicates the vertical magnitude and direction of the shift, and the square image indicates the horizontal.

18. Click Save As Site if you want to make the calibrated site available to use as a coordinate system. The Save Coordinate System as Site command pane displays. Type a name for the site and click OK.

19. Click Assign. The calibration is recomputed to update all of the GNSS points, and the coordinate system details are updated with the calibration parameters.

Note: Sites can be recalibrated at any time.

To remove a site calibration:

- Select Survey > Remove Site Calibration. The calibration is removed, and the project is recomputed.

Related topics

- Choose Local Site Settings (on page 178)
- Site Calibration Options (on page 206)
Site Calibration Options

Use these options to establish a relationship between the WGS-84 RTK data you collected and local control coordinates. They are available in the Site Calibration Calculation command pane.

Options

Click this to display the GNSS Calibration Report, showing details of the calibration computation, all the computed parameters, and a listing of the computed control point coordinates compared with their known positions and individual residual values.

Click this to display the Site Calibration section of the Project Settings.

Click this to display the Local Site Settings command pane, where you can define the local site’s coordinate type, scale factor, and offsets.

Click this to display the Add Point command pane, where you can create a new office-entered point.
Set Up Geodetic Reference Data

Calibration settings

**Horizontal calibration**
Check this to compute a horizontal shift consisting of translations in the north/south and east/west directions, a rotation around a defined origin and a scale factor.

The transformation parameters are computed using least squares methods to find the transformation that gives the adjustment parameters that, when applied to the GNSS positions, best fit the control grid coordinates.

The horizontal adjustment reduces any residual error between the control coordinates and the grid coordinates calculated from the GPS positions.

**Set scale factor to 1**
Check this to prevent your horizontal distances from being scaled.

*Tip:* It is wise to first compute a horizontal adjustment without the scale factor set to one to check the computed scale factor. If the computed scale factor is not close to one, it could indicate a problem in the selected calibration point pairs.

**Vertical calibration**
Check this to perform an inclined plane adjustment consisting of a vertical shift at a defined origin and inclinations in the north and east directions.

The parameters for this adjustment are computed using least squares methods to find an adjustment plane that best fits the elevations derived from the GNSS heights with the control point elevations. This requires three three-dimensional calibration point pairs. With a single three-dimensional calibration point pair, only the vertical shift parameter can be computed. If there are two three-dimensional calibration point pairs available the system defines a correction plane that exactly fits these pairs.

If the project uses a geoid model, then the vertical adjustment is computed and applied on top of the geoid model corrections.

**Geoid model**
This shows the name of the geoid model that is part of the coordinate system definition.

To change the geoid model (see "Change the Coordinate System" on page 157), click the icon to display the Project Settings dialog.

**Vertical shift** - Select this to simply compute a vertical shift at a defined origin.

**Incline plane** - Select this to include inclinations in the north and east directions in the vertical shift.

**Compute**
Click this to compute the GNSS calibration parameters after you have changed the calibration settings. Results are summarized in the Computation Summary on the Calibration Settings tab.
Save as site

Click this to display the Save as Site dialog, in which you can save the current calibration and coordinate system details in the coordinate system database as a site definition.

You can use this site definition as the coordinate system definition for future projects.

Computation summary

This shows a summary of the last calibration computation.

Use it to confirm that the computed calibration is valid without having to look at the detailed computation report.

Point list

GNSS point

Click in the box. Then pick a GNSS point in a graphic view, right-click for options, or type a point ID that you want to calibrate with the grid point in the next box.

**Note:** The point you select must have global coordinates. Points with local coordinates cannot be selected as GNSS points. Point coordinates must be computed from global coordinates.

Grid point

Click in the box. Then pick a grid point in a graphic view, right-click for options, or type a point ID that you want to calibrate with the GNSS point in the previous box.

**Note:** Click if you want to view coordinate information on the selected point.

Type

**Horizontal and vertical** - Select this when the point pair is suitable for determining both horizontal and vertical adjustments.

**Horizontal** - Select this when the point pair is suitable only for determining a horizontal adjustment (the elevation value for the grid point is not reliable).

**Vertical** - Select this when the point pair is suitable only for determining a vertical adjustment (the northing and easting values for the grid point are not reliable).

**Ignored** - Select this when the point pair is not to be used in the computation of any transformation parameters.

This option is useful if you have a problem in your calibration computation and are trying to locate a suspect calibration point pair. You can use this to remove a calibration point pair temporarily from the computation to see if the results are improved.

Results
(summary)  

**Horizontal scale factor** - This displays the computed scale factor for the horizontal adjustment. If you check the Set scale factor to 1 box, this displays “1”.

Use this to confirm that the computed scale factor is close to 1. If it is not, there may be a problem with one or more of the calibration point pairs.

**Horizontal rotation**

**Maximum slope of inclined plane** - This shows the maximum inclination for the computed height adjustment, based on the computed slope north and slope east values.

**Vertical shift at origin**

**Residuals**

**Maximum horizontal residual** - This shows the highest horizontal difference between paired points.

**Maximum vertical residual** - This shows the highest vertical difference between paired points.

The residuals for each pair of points are represented by the images shown below.

These images indicate the relative magnitude of the vertical shift. Investigate and resolve the reported point pairs with the longest arrows first.

These images indicate the relative magnitude and direction of the horizontal shift.

Investigate and resolve the reported point pairs with the longest arrows and directions that do not match the other residuals first.

**Assign**

Click this to recompute so that all GNSS points are updated using the calibration parameters. The coordinate system details are also updated.

**Related topics**

- Calibrate a Site (on page 203)

**Save a Calibrated Site as a Coordinate System**

After you perform a site calibration, you can name and save the site so it is available to use as a coordinate system.

**To save a site as a coordinate system:**

- Click Save As Site at the bottom of the Site Calibration command pane.

  The Save Coordinate System as Site command pane displays.

**Related topics**

- Calibrate a Site (on page 203)
- Change the Coordinate System (on page 157)
Separate Global and Grid/Local Coordinate Points for Site Calibration

If you import GNSS data and optical data into your project and one or more coordinates in the GNSS data have the same point ID as one or more coordinates in the optical data, points will be created under the Points node that includes both global and grid/local coordinates. In this case, a site calibration cannot be performed using these points. You must first rename the coordinate point IDs in the imported optical data file. Then, you must disable any remaining grid and/or local coordinates listed beneath points defined by global coordinates.

To separate global and grid/local coordinate points for site calibration:

1. In the Project Explorer, change the point ID for each coordinate included in the optical data that has the same ID as a point included in the GNSS data:
   a. Beneath the optical data file node, right-click the coordinate whose point ID you want to change, and select Properties from the context menu. The Properties pane displays.
   b. In the Properties pane, enter a new point ID for the observation in the Point ID field and press [Enter].
      For example, if the original point ID is "a", you might enter a new point ID of "a_grid".
      The new point is created for the coordinate beneath the Points node in the Project Explorer.
   c. Repeat these steps for each coordinate point ID you want to rename.

2. Select Survey > Site Calibration.
   If there are no grid and/or local coordinates listed beneath points defined by global coordinates, the Site Calibration pane displays. You are now ready to calibrate the site (see "Calibrate a Site" on page 203).
   If there are grid and/or local coordinates listed beneath points defined by global coordinates, a message displays identifying the points. You should disable the grid and/or local coordinates for these points before performing the site calibration. Proceed with the next step in this procedure.

3. In the Project Explorer, disable any grid and/or local coordinates listed beneath points defined by global coordinates:
Set Up Geodetic Reference Data

a. Beneath the the **Points** node, click the icon to expand the point you want to view.

b. Right-click the grid or local coordinate you want to disable, and select **Properties** from the context menu. The **Properties** pane displays.

c. In the **Properties** pane, select "Disabled" in the **Status** list.

d. Repeat these steps for each coordinate you want to disable.

4. When you are done, do either of the following to compute the project:
   - Select **Project > Compute Project**.
   - Click the icon on the status bar.

   You are now ready to calibrate the site (see "Calibrate a Site" on page 203).

Related topics

- Understanding Site Calibration (on page 200)
- Calibrate a Site (on page 203)

Run a Site Calibration Report

After you calibrate a site, generate a **Site Calibration Report** to see details on the local site settings, horizontal and vertical calibration parameters, and residual differences between GNSS and grid points in your project.

**To run a Site Calibration Report:**

- Select **Reports > Site Calibration Report**.

  The **Site Calibration Report** displays in your default Web browser.

**To modify the report:**

- Select **Reports > Report Options**. Select **Site Calibration Report** in the command pane, and click **OK**.

  In the **Settings** group at the bottom of the command pane, you can specify the header and footer data to display.

Related topics

- Customize and Run a Report (see "Customize a Report" on page 481)
Import Data

After you browse for a folder within the Import command, the files in that folder are analyzed to match a file type with an importer. The analyzer looks for identifying information within the file, the format of the file, and the file extension to assign an importer to the file. If an ASCII file is marked as "unknown", you may need to create a custom importer for that file.

**To import data:**

1. Open an existing or new project.
2. Do one of the following:
   - Select File > Import.
   - Click the icon on the toolbar.
   The Import dialog displays.
3. Select a folder in the Import Folder list, or click the icon to browse for a folder. The default is the folder that you last imported from. The files contained in the selected folder appear in the Select File area. The file names and file types are listed. File type is the name of the importer that is used to read the file.
4. Select the file(s) that you want to import in the Select File group.
   
   **Note:** The order in which you import data can affect the computation results.  
   **Note:** If you need to set a custom importer, right-click on a file to set the file type.
5. Click Import. The data displays in graphic views and in the Project Explorer.
   
   **Tip:** You can also double-click, or drag and drop (see "Drag and Drop to Import" on page 213), files to import them.
6. To view an Import Summary (see "Run an Import Report" on page 261) report, select Reports > Import Summary.
**Import Data**

**Note:** To view the file, click the icon. This will open the file in Notepad or another text editor program.

**Note:** To display only those files that the converter recognizes, click the icon on the pane's toolbar. The icon functions as a toggle switch.

**Note:** To change the file type, right-click the file, and select an option from the Set File Type list. The options that are offered are based on internal scanning of the file. The file extension is also used as a clue.

**Note:** To import more than one file, use [Ctrl] + click or [Shift] + click.

**Note:** To change the file type, right-click, select Set File Type, and select one of the options in the drop-down list. The options that are offered are based on internal scanning of the file. The file extension is also used as a clue.

**Related topics**

- Drag and Drop to Import (on page 213)
- Import Data (on page 212)
- Import Data Formats (see "Importable Data Formats" on page 214)
- Import Data in a Custom Format (on page 236)
- Run an Import Summary Report (see "Run an Import Report" on page 261)

## Drag and Drop to Import

You can import data by dragging files from your desktop, Windows® Explorer, or the Import command pane's file list, into a data view.

**To drag and drop a file into a project:**

1. Open a project.
2. Do one of the following:
   - Locate the files that you want to import on your desktop or in Windows® Explorer.
   - Open the Import command pane and browse to the folder that contains the file(s) to import.
3. Click and drag the file(s) onto a data view.

**Caution:** The software allows you to set import properties when importing certain types of files. These properties are displayed in the Import command pane when you select File > Import and select the file type. If you choose to import one of these types of files using the drag-and-drop method rather than the Import command pane, you will not be able to see the default import properties or change them.

**Related topics**

- Import Data (on page 212)
Importable Data Formats

Bring data into your project using the Import, Internet Download, and Device pane commands. The supported file formats are listed below. In addition, you can download any other files, such as NGS data sheets, to reference outside of this software.

**Note:** The file types listed may only be supported in specific commands or by certain field software. See file-specific topics for details.

**Note:** Downloadable formats that can be extracted include: .exe, .gz, .z, .zip, .tar, .tgz, .tar.gz, .taz, .tar, .z, and .d.

<table>
<thead>
<tr>
<th>By field software</th>
<th>Importable file formats</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Trimble® Survey Controller™</strong></td>
<td>• .dc</td>
</tr>
<tr>
<td></td>
<td>• .job</td>
</tr>
<tr>
<td></td>
<td>• .jxl</td>
</tr>
<tr>
<td></td>
<td>• .xml</td>
</tr>
<tr>
<td><strong>Spectra Precision® Field Surveyor</strong></td>
<td>• ASCII</td>
</tr>
<tr>
<td></td>
<td>• .asc (Nikon NEH)</td>
</tr>
<tr>
<td></td>
<td>• .dat</td>
</tr>
<tr>
<td></td>
<td>• .xml</td>
</tr>
<tr>
<td><strong>TDS Interlock™</strong></td>
<td>• .ilj</td>
</tr>
<tr>
<td><strong>TDS Survey Pro™</strong></td>
<td>• .job</td>
</tr>
<tr>
<td></td>
<td>• .raw</td>
</tr>
<tr>
<td></td>
<td>• .xml</td>
</tr>
<tr>
<td><strong>Trimble® Digital Fieldbook™</strong></td>
<td>• .job</td>
</tr>
<tr>
<td>(v2, v3, and v5)</td>
<td>• .dc</td>
</tr>
<tr>
<td></td>
<td>• .xml</td>
</tr>
<tr>
<td><strong>Trimble® Survey Manager™</strong></td>
<td>• ASCII</td>
</tr>
<tr>
<td></td>
<td>• .jxl</td>
</tr>
<tr>
<td><strong>GNSS receivers/Survey devices</strong></td>
<td>• .dat</td>
</tr>
<tr>
<td></td>
<td>• t00/.t01</td>
</tr>
</tbody>
</table>
## Import Data

<table>
<thead>
<tr>
<th>By file format</th>
<th>Data types</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>.asc</strong></td>
<td>ASCII, Nikon NEH, TDEF, raw data files</td>
</tr>
<tr>
<td><strong>.cal</strong></td>
<td>Calibration files</td>
</tr>
<tr>
<td><strong>.crd, .mos, .txt</strong></td>
<td>GENIO (see &quot;Import GENIO Files&quot; on page 218) files</td>
</tr>
<tr>
<td><strong>.csv (custom import)</strong></td>
<td>ASCII text, point files</td>
</tr>
<tr>
<td><strong>.dat</strong></td>
<td>GNSS, DiNi files</td>
</tr>
<tr>
<td><strong>.dc</strong></td>
<td>Trimble Survey Data Collector (see &quot;Import Data Collector Files (.dc)&quot; on page 216) files</td>
</tr>
<tr>
<td><strong>.dgn</strong></td>
<td>MicroStation (see &quot;Import MicroStation Files (.dgn)&quot; on page 230) design files</td>
</tr>
<tr>
<td><strong>.dx, .dwg</strong></td>
<td>CAD files</td>
</tr>
<tr>
<td><strong>.ds, .htm</strong></td>
<td>NGS data sheets</td>
</tr>
<tr>
<td><strong>.ilj</strong></td>
<td>TDS Interlock job files</td>
</tr>
<tr>
<td><strong>.job</strong></td>
<td>GNSS Job (see &quot;Import GNSS Job Files (.job)&quot; on page 225) files</td>
</tr>
<tr>
<td><strong>.jxl</strong></td>
<td>JobXML files</td>
</tr>
<tr>
<td><strong>.pts (custom import)</strong></td>
<td>ASCII point, DTM files</td>
</tr>
<tr>
<td><strong>.raw</strong></td>
<td>TDS, raw data files</td>
</tr>
<tr>
<td><strong>.06o</strong></td>
<td>RINEX (see &quot;Import RINEX Data&quot; on page 233) (GPS base files)</td>
</tr>
<tr>
<td><strong>.sp3, .sp3c</strong></td>
<td>Precise ephemeris files</td>
</tr>
<tr>
<td><strong>.ttm</strong></td>
<td>Trimble surface (see &quot;Import Trimble Surface Files (.ttm)&quot; on page 234) files</td>
</tr>
</tbody>
</table>

### Related topics
- [Import Data](#) (on page 212)
- [Import Data in a Custom Format](#) (on page 236)
- [Download and Import Data from the Internet](#) (see "Download and Import Data Automatically" on page 242)
- [Prepare to Connect a Field Device](#) (on page 263)
Import ASCII Files

ASCII files give you the flexibility to import data from a variety of sources, or even to create a file using a text editor. When you import an ASCII file, the Import Format Editor may display, prompting you to create a custom importer to accommodate the file. You can also access the editor any time by clicking the icon on the Import command pane toolbar.

**Note:** You can import Nikon NEH files (.asc) from Field Surveyor.

**Tip:** ASCII point files (.pts) can be imported as a surface.

Related topics

- Import Data (on page 212)
- Import Data in a Custom Format (on page 236)
- Run an Import Summary Report (see "Run an Import Report" on page 261)

Import Data Collector Files (.dc)

Import data collector files from a variety of field devices, including:

- Trimble® Survey Controller™ (up to version 10t; for files that have been converted)
- Trimble® Digital Fieldbook™ (v2, v3, and v5)

Related topics

- Import Data (on page 212)
- Run an Import Summary Report (see "Run an Import Report" on page 261)

Import CAD Files (.dxf/.dwg)

CAD .dwg and .dxf files are drawing files used in architecture, civil engineering, design, and mapping industries. At the bottom of the import pane, you can specify settings that affect the imported data.
Importable properties and objects:

- 3D Face (as a CAD 3D Face)
- 3D Polyline (as a CAD 3D Poly Line)
- Arc (as a CAD Arc)
- Attribute (as a CAD Attribute Definition)
- Attribute Reference (as a CAD Attribute Reference)
- Block Reference (as a CAD Block Reference)
- Circle (as a CAD Circle)
- Coordinate (as a Coordinate)
- Ellipse (as a CAD Ellipse)
- Hatch (as a CAD Hatch)
- Leader (as a CAD Leader)
- Lightweight polyline (as a CAD Lightweight Polyline)
- Line (as a CAD Line)
- M Line (as a CAD Multi-line)
- M Text (as a CAD Multi-line Text)
- Point (as a CAD Point)
- Point (as a Point)
- Polyline (as a CAD PolyLine)
- Ray (as a CAD Ray)
- Shape (as a CAD Shape)
- Solid (as a CAD Solid)
- Spline (as a CAD Spline)
- Text (as a CAD Text)
- Trace (as a CAD Trace)
- Xline (as a CAD XLine)

Non-importable properties and objects:

- 3D solid
- Dim 3 Point Angular (importer)
- Dim Aligned (importer)
- Dim Angular (importer)
Import Data

- Dim Diametric (importer)
- Dimension (importer)
- Dim Ordinate (importer)
- Dim Radial (importer)
- Dim Rotated (importer)
- Polyface mesh
- Polygon mesh
- Raster image
- Region
- Tolerance

Related topics
- Import Data (on page 212)
- Run an Import Summary Report (see "Run an Import Report" on page 261)

Import GENIO Files

Import GENIO data to create alignments. There are three types of GENIO strings that contain varying amounts of data and can be used in different ways.
Import Data

File Type

**GENIO 3D string**
- X, Y, and Z coordinates
- 2D lines
These can be used as reference data for manually creating horizontal alignments, but they do not import as alignments, and cannot be converted into alignments.

**GENIO 6D string**
- X, Y, and Z coordinates
- 2D lines
- Station data
- Instantaneous tangencies and radii
These can be converted into alignments with horizontal and vertical components after import.

**GENIO 12D string**
- X, Y, and Z coordinates
- 3D lines
- Station data
- Tangencies and radii with additional parameters
These import as alignments with horizontal and vertical components.

Related topics
- Create an Alignment from a GENIO String (on page 393)
- Import Data (on page 212)
- Run an Import Summary Report (see "Run an Import Report" on page 261)
- Workflow for Importing Alignments (see "Workflow for Using Imported Alignments" on page 383)

Import GNSS Files (.dat)

Import GNSS Data

If you import data from third-party receivers (e.g. RINEX), the files are automatically converted to .dat format during download.

To import GNSS data:

1. Do one of the following:
   - Click the icon on the toolbar.
   - Select File > Import.
   The *Import* command pane displays.
2. Select a folder in the Import Folder list, or click the icon to browse for a folder. The default is the folder that you last imported from. The files contained in the selected folder appear in the Select File area. The file names and file types are listed. File type is the name of the importer that is used to read the file.

3. Select the file(s) to import, and then click OK. The Receiver Raw Data Check-in dialog displays.

   **Note:** To join separate files if they represent a single occupation, make sure to multi-select and import them at the same time. They must have the same point ID and sequential end/start times.

4. Check and edit the raw data and click OK to check it in. The Projection Definition dialog may display. If needed, enter values in the Northing and Easting boxes to create a false origin for the data.

5. Click OK.

6. To view an Import Summary (see "Run an Import Report" on page 261) report, select Reports > Import Summary. If there are errors, a warning flag appears on the status bar.

   **Note:** If you import a controller job file, any associated .dat files are automatically imported as well.

   **Note:** Continuous files from CORS stations are often logged, and import, in one-hour increments. Once they have been imported, however, they are concatenated (joined sequentially) into the single session they represent.

**Related topics**
- [Import Data](on page 212)
- [Check-In Raw GNSS Data](on page 220)
- [GNSS Baseline Data Sources](on page 293)

### Check-In Raw GNSS Data

Before using imported GNSS data in your project, you can verify it and correct field errors in the raw data in the Receiver Raw Data Check In dialog. For example, you can remove bad observations due to a field crew not setting up over the correct point, having to start over, etc.

**Note:** For multiple files to be concatenated into the single occupation they represent, the point ID, antenna data, and other information must be the same for each file, so be careful about what you edit during the raw data check-in.

**To check-in raw GNSS data:**

1. Click the **Point** tab. The point table displays.

2. Verify, correct and select the data required for your project.
### Import Data

**Note:** If you need to change a roving segment to continuous after import, use the Force Continuous command.

3. Click the **Point** tab.

4. Uncheck any points in the **Import** column that you do not want to import. When a roving segment is selected, the **Point ID** column changes to **Continuous Segment**.

5. Click in any available cells and edit the point data as needed.

**Note:** Columns can be sorted in ascending or descending order by clicking on the column heading. You may also rearrange columns by dragging and dropping the column header to the desired location.

6. Click the **Antenna** tab. Verify that the antenna data is correct to increase the accuracy of your baselines. The baseline processor uses different antenna offset and slant corrections based on the antenna type. This information is stored in a library that contains corrections for all antenna types.

7. Click in any available cells and edit the antenna data as needed. To quickly edit the antenna height for multiple segments, see **Editing multiple antenna heights.**

   (see "Edit Multiple Values" on page 224)

**Note:** If you select **Unknown** for the manufacturer, be sure to select the antenna phase center method for the antenna height.

8. Select an antenna phase center model in the **Antenna Model** list.

9. Click the **Receiver** tab. Verify that the receiver data is correct to increase the precision of your baselines. The baseline processor uses a different noise model based on the receiver type. This information is stored in a library containing information on all receiver types.

10. Click in any available cells and edit the receiver data as needed.

11. To add the corrected raw receiver data to your project, click **OK**.

**To reset corrections:**

To reset (undo) all the corrections made in all three tables:

- Click **Reset**. All edits are undone and the default import selections are restored.

After this data is checked in, your selections can no longer be changed.

If the grid reference values used to orient your project on the display grid have not been set (they should be set up in your project template), the **Projection Definition** dialog displays. To set these values, see **Define a Coordinate System** (see "Define a New Coordinate System" on page 158).
To cancel without importing any data:

To close the dialog, canceling all changes and not importing any data:
- Click **Cancel**.

To verify data after import:

- After check-in, the data is ready to **verify** (see "Verify Static and Kinematic Data" on page 280).

Related topics

- Define a Projection (on page 195)
- Force Continuous Command
- Force Static Command
- Process Baselines (on page 305)
- Raw Data Check-In Options (on page 222)

Raw Data Check-In Options

Use these options to verify, correct and select raw GNSS data before importing it into your project. They can be found on the three tabs of the **Receiver Raw Data Check In** dialog, which displays when you import GNSS data.
**Point tab options**

**Import**
Uncheck this to prevent the point from importing.

**Point ID**
- If the data is static, this displays the name of the point. Edit the name, if needed.
- If the data is kinematic, this indicates the type data imported.
  - **Roving Segment** - Indicates a segment in which the receiver was in roving mode. The check box in the Import column remains unchecked by default. If this segment contains continuous data and needs to be imported, check the Import checkbox. The description changes to **Continuous**.
  - **Continuous Segment** - Indicates a roving segment selected for processing.

**Filename**
Identifies the imported file.

**Start time**
Displays the time of the occupation.

**End time**

**Duration**

**Feature code**
Displays the code applied to the point feature. Edit or add a new feature code, if needed.

**Antenna tab options**

**Import**
Uncheck this to prevent the point from importing.

**Point ID**
Displays the name of the point. Edit the name, if needed.

**Manufacturer**
Displays the name of the company that made the antenna.
Select a different manufacturer from the list, if the entry is incorrect.

**Type of antenna**
Displays the antenna brand, based on the manufacturer selected.
Select a different type from the list, if the entry is incorrect.

**Note:** If you need to change a roving segment to continuous after import, use the Force Continuous command.

**Note:** Point IDs are **not** case sensitive.
### Method of measuring antenna height

- **Antenna Phase Center** - Select this if you used different antenna models on the base and rover receivers.

- **Bottom of Antenna Mount** - Select this if the antenna height was measured to the bottom of the mount.

**Note:** Generally, you will set this based on what is noted in the field log.

### Height of antenna

Displays the distance from the point to the bottom of the antenna mount or the antenna phase center.

To edit the antenna height for multiple segments, see [Editing multiple antenna heights](#), (see "Edit Multiple Values" on page 224)

### Serial Number

Displays the serial number of the antenna. Edit the number if necessary.

### Antenna model

Select an antenna phase center model.

### Receiver tab options

- **Import**
  
  Uncheck this to prevent the point from importing.

- **Filename**
  
  Displays the name of the imported file.

- **Survey mode**
  
  Displays the static or kinematic collection type.

- **Start time**
  
  Displays the time of the occupation.

- **End time**
  
  Displays the time of the occupation.

- **Manufacturer**
  
  Displays the name of the company that made the receiver.

  Select a different manufacturer from the list, if the entry is incorrect.

- **Type**
  
  Displays the receiver brand, based on the manufacturer selected.

  Select a different type from the list, if the entry is incorrect.

- **Serial #**
  
  Displays the serial number of the antenna. Edit the number if necessary.

### Related topics

- [Check-In Raw GNSS Data](#) (on page 220)

### Edit Multiple Values

**To set the value of several cells to the same value:**

1. Make sure that one of the cells is set to the value that you want to use for the others. If not, click in the cell and correct the value.

2. Press [Ctrl] and click the first column of each row you want to edit. The selected rows highlight.
3. Position the cursor over the cell containing the correct height, and right-click. A context menu displays two choices (as shown below):
   - Use <value> for all points
   - Use <value> for selected points
4. Select the correct value. The value in the selected rows updates.

Related topics
- Raw Data Check-In Options (on page 222)

Define a Projection

Use a false origin to define a projection when you import raw GNSS data for which you did not previously specify the projection.

To define a projection:
1. Import and check-in your raw GNSS data. If there is not associated projection, the Projection Definition dialog displays.
2. If needed, type grid coordinates in the Northing and Easting boxes to base the origin on the best known grid coordinates.
3. Click OK. The new coordinates become the projection’s origin.

Related topics
- Check-In Raw GNSS Data (on page 220)
- Local Site Setting Options (on page 179)

Import GNSS Job Files (.job)

Import GNSS files from the following field devices:
Import Data

- TDS Survey Pro™ (Survey Pro Jobs)

**Note:** You can also import .raw (raw data files) from TDS Survey Pro.

- Spectra Precision® Field Surveyor
- Trimble® Survey Manager™
- Trimble® Digital Fieldbook™ (v2, v3, and v5)
- Trimble® Survey Controller™ (versions 11 and later)

**To force a kinematic occupation to process as static:**

1. When importing a GNSS data file, select the file in the **Import** command pane **Files** list.
2. Select **Yes** in the **Force Static** box in the **Settings** group. The selected occupation is converted to static data, as indicated in the **Project Explorer**.

**Related topics**
- Force Continuous Command
- Force Static Command
- Import Data (on page 212)
- Run an Import Summary Report (see "Run an Import Report" on page 261)
- Run a Job File Report (on page 476)

**Import LandXML Files (.xml)**

LandXML is an open XML file format. The format was principally created by and for the survey, civil engineering, and transportation industries. LandXML format supports points, surfaces, and alignments when imported. This software supports version 1.0 of the LandXML standard.

When you import a LandXML file, the data is previewed for conflicts. If there are no conflicts, the file is imported and the data appears in the graphic views. If conflicts are found, the **LandXML Import Conflicts** (see "Resolve LandXML Conflicts" on page 228) dialog displays, enabling you to resolve the conflicts. The import process continues afterwards. If there are errors after the import process, a warning flag appears on the status bar.

When you import LandXML files, the points, alignments, and surfaces are handled in these ways:
LandXML Import Results

**Points**

LandXML files can contain any number of points (referred to as COGO points in the LandXML format). When points are imported:

- They become points, with associated coordinates, and can be edited. These points can be referenced by a surface.
- They are placed on a layer named after the "points" section of the file. (If a layer does not exist, it is created.)
- Their point IDs are based on the "name" fields in the file.
- Their feature codes are based on the "desc" fields in the file.

**Alignments**

LandXML files can contain any number of alignments. The required component of an alignment object is a geometric definition of the horizontal alignment.

Required attributes are name, alignment length, and beginning station value.

Optional attributes are station equations, profile, and cross-section components.

When alignments are imported:

- They are placed on new layers if the "alignment" sections of the file have unique names.
- Their names are based on the "name" fields in the file.
- Their geometric definitions are used to create alignments, with the geometry defining the horizontal component of the alignment. Horizontal alignment geometry can consist of lines, arcs, and spirals.
- If the "name" attribute exists in the geometric definition, it is used to name the horizontal alignment.
- The starting station value from the alignment object is used to station the horizontal alignment.

The alignment may also contain one or more vertical alignments (profiles). If a vertical alignment exists:

- It is used to create a representation of the vertical alignment in the profile view.
- The "name" attribute is used to name the vertical alignment.

If the alignment contains stored cross-sections:

- The stored cross-sections appear in both the plan view and the cross-section view.
- A surface is automatically created using the cross-section station values, offsets, and elevations upon import. The surface is named using the file name.
Import Data

Surfaces

LandXML files can contain any number of surfaces.

A surface can be defined in the file in either (or both) of two ways:

- **Source Data** - Includes the points, point lists, boundaries, breaklines, and contours used to create the surface. This data imports as objects that are separate from the surface, meaning that you can add or remove them from the surface, or edit their properties.

- **Definition** - Includes 3D points and triangles defining the surface. This data imports as an integral part of the surface. This method can support holes and islands in surfaces.

Related topics

- [Resolve LandXML Conflicts](on page 228)
- [Results of Importing LandXML Files](#)

Resolve LandXML Conflicts

During the LandXML import process, if any objects in the file are ambiguous, the *LandXML Import Conflict* dialog displays. LandXML objects that do not conform to the import format will be reported as conflicts or discarded if:

- The file is corrupted.
- A surface is only defined by a watershed.
- A surface contains one or many point files.
- A surface has both Source data and Definition data description.
- An alignment profile contains a gap.
- An alignment profile contains a spiral that is not a clothoid.
- The components of an alignment profile are not in the proper order.

To resolve conflicts in LandXML objects:

1. Select a conflict in the *List of conflicts*. Options for resolving the conflict appear in the *Selected conflict* area. The description and options in this depend on the selected conflict.
2. Click an option for resolving the conflict.
3. Click *Resolve this conflict*. A check mark appears in the *Status* column next to the conflict, indicating that the conflict is resolved. The next conflict in the list is automatically selected.
4. Repeat the steps above until all of the conflicts are resolved.
5. Click **Import** to finish the import process. When the file finishes importing, the LandXML objects appear in the project explorer as points, surfaces, or alignments. Discarded objects and the reasons for the discard are listed as **Errors** in the **Import Summary**.

**Notes:** You can change the resolution for solved conflicts any time before importing.

Related topics

- **Import LandXML Files (.xml)** (on page 226)
- **LandXML Conflict Resolution Options** (on page 229)

### LandXML Conflict Resolution Options

Use these options to resolve ambiguities in the import of LandXML files. They are available in the **LandXML Import Conflicts** dialog. There are two general types of LandXML conflicts.
**Import Data**

**Columns**

**Status**
- ✓ Resolved conflict
- ? Unresolved conflict

#
Shows the conflict number in the list

**Description**
Displays the type of object and the reason for the conflict

**Resolution Options**

**Conflict type**

*Triangle-based definition* - Select this when you only want to import the triangles defining the surface. This data becomes the surface and cannot be edited.

Select this only when you do not need to edit the data, and want a smaller file size and faster speed. This option also handles holes and islands in the data.

*Point/Breakline-based source data* - Select this to import the points, point lists, boundaries, breaklines, and contours used to create the surface. This data defines the surface, but remains separate from it, enabling you to edit the data to modify the surface.

If you are unsure, select this option to retain the ability to edit the data.

**Conflict type**

*Use a new name* - Select if you want to save the original imported object, and import an identical one with a new name. Type a new name in the box.

*Overwrite existing surface* - Select if you want to discard the existing surface of the same name, and replace it with this one.

**Caution**: If you overwrite the existing surface, all related observed objects are deleted, even they are not from a LandXML import.

**Related topics**

- Resolve LandXML Conflicts (on page 228)

**Import MicroStation Files (.dgn)**

MicroStation .dgn files are design files used in civil engineering, design, mapping, and architecture industries. At the bottom of the import pane, you can add a prefix to the layer (level) names, and specify whether to create a selection set comprised of the imported data.
Import Data

Importable properties and objects:

- Arc (as an open CAD Ellipse or a CAD Arc (when minor and major axes are equal))
- B-spline (as a CAD Spline if header denotes a spline (includes non-uniform and rational B-spline))
- Cell (as individual CAD Lines and other CAD objects)
- Color (maps to default colors and bylayer for bylevel)
- Complex chain (as separate CAD Lines, 3D Polylines, Arcs, and Splines)
- Complex shape (as separate CAD Lines, 3D Polylines, Arcs, and Splines)
- Curve (as a CAD Spline)
- Ellipse (as a CAD Ellipse or a CAD Circle (when minor and major axes are equal))
- Level (as a layer)
- Line (as a CAD Line)
- Line string (as a CAD 3D Polyline)
- Line style (maps to one of the eight pre-defined line styles and to bylayer; all others map to solid)
- Multiline (as a CAD Multi-line)
- Point string (as CAD Points (if detached) or a CAD 3D Polyline (if contiguous))
- Shape (as a CAD 3D Polyline)
- Shared cell and cell reference (as a CAD Block and CAD Block Reference)
- Tag (as CAD Text)
- Text (as CAD Text)
- Text node (as separate CAD Text objects)

Non-importable properties and objects:

- 3D surface
- 3D solid
- B-spline (if header denotes a surface)
- Boundary
- Cone
- Conic
- Dimension
- External reference files
import data

- meshes
- raster data
- raster header

related topics
- [import data](#) (on page 212)
- [run an import summary report](#) (see "run an import report" on page 261)

**import rangefinder observation (laser) data**

Files with the extension .pbj can contain ranging (laser) data. Upon import, these observations are automatically assigned mapping quality. In the *Project Explorer*, a laser base is identified by an 🐌 icon and a laser observation is identified with an ⚠️ icon.

**data quality**

The quality of the *To* point coordinates calculated from laser data depends, in order, on the quality of the:

- Corresponding *From* points
- Quality of the laser observations

The lowest quality of any of these determines the quality of the final *To* point.

**feature codes**

Feature codes can be added to laser data within the *Properties* (see "Properties Pane" on page 12) pane.

related topics
- [flags pane](#) (on page 13)
- [import data](#) (on page 212)
- [import data in a custom format](#) (on page 236)
- [run an import summary report](#) (see "run an import report" on page 261)

**import reb files (.reb)**

Import REB files to use as road model data, including alignments and surfaces, and/or surface data. REB data is separated into different files for these types of data: horizontal alignment, vertical alignment, cross-sections, points/coordinates, surface triangles, and breaklines.
You can select one or more REB files to import at the same time. Since different types of REB data are stored in separate files, if any data is dependent upon another type of data, both files must be imported at the same time. For example, you cannot add a vertical alignment file without concurrently adding the horizontal alignment file it is dependent upon.

Although REB files often use the .reb extension, they also use numeric extensions, such as: *.021, *.040, *.066, *.66, *.D21, *.D30, *.D40, *.D45, *.D49, *.D58, and *.D66. REB extensions indicate the type of data the files contain:

- **.D21 and .021** - vertical alignment data
- **.D30** - point/coordinate data (GAEB)
- **.D40 and .040** - horizontal alignment data
- **.D45** - point/coordinate data
- **.D49** - breakline data (GAEB)
- **.D58** - surface triangle data (GAEB)
- **.D66 and .66** - cross-section data

**Note:** Cross-sections from REB data are converted into breaklines when they are imported.

**Note:** You can also import Wirth YXZ cross-section data in conjunction with an REB alignment file to create a road model.

**Note:** REB is a data specification most-commonly used in Germany.

### Related topics
- [Import Data](on page 212)
- [Import Wirth YXZ Files (.yxz)](on page 234)
- [Run an Import Summary Report](see "Run an Import Report" on page 261)

## Import RINEX Data

Import data from any field software supporting the receiver-independent exchange (RINEX) format. The frequencies of data that you can process depend on your software license.

### Related topics
- [Import Data](on page 212)
- [Run an Import Summary Report](see "Run an Import Report" on page 261)

## Import NGS OPUS Data (.xml)

Import an .xml file containing position solution data from the NGS OPUS website.

In the [Settings](on page 212) box, select the appropriate [Coordinate Type](on page 212): Local or Global.
Import Trimble Surface Files (.ttm)

Import triangulated terrain models to visualize surfaces and compute volumes between surfaces.

**Note:** You can also import ASCII point files (.pts) as surfaces using a custom format created in the Import Format Editor (see "Import Data in a Custom Format" on page 236).

Import Wirth YXZ Files (.yxz)

Import cross-section data in a Wirth YXZ (.yxz) file to create a surface.

Import DiNi Digital Level Files (.dat)

DiNi digital level .dat (M5) files contain level data recorded in the field using a Trimble DiNi Digital level.

**To import DiNi Digital level .dat files:**

1. Do one of the following:
   - Click the icon on the toolbar.
   - Select File > Import.
   The Import command pane displays.
2. Do one of the following:
   - Select a folder in the Import Folder list.
• Click the icon to browse for a folder.

The default is the folder that you last imported from. The files contained in the selected folder appear in the Select File(s) area. The file names and file types are listed.

3. Select the DiNi digital level .dat file(s) you want to import.

1. In the Settings section at the bottom of the Import command pane, change the Automatically Numbered Points properties if necessary.

These properties help the software identify which points were auto-numbered by the DiNi level and which point IDs were entered by the user. Auto-numbered points typically are not points of interest and should not be created as points in the project.

• Starting Point - Specifies the first point ID number of the range of point ID numbers in the file you want to specify as automatically numbered points that should not be created in the project.

• Maximum Points - Specifies the maximum number of points in the file you want to be included in the range.

• Increment - Specifies the increment to be used when identifying point numbers in the range.

• Ending Point - Specifies the calculated ending point for the point range based on the other specified properties.

2. When you are done, click Import. The Level Editor dialog displays. In this dialog, you can see which level points were entered by the user (points of interest) and will be created in the project, and which points were automatically numbered by the DiNi and will not be created in the project. If necessary, you can make changes by checking or unchecking any point to include or not include it in the project. For instructions, see View and Edit Level Data (on page 336).

Note: If you import a text file with "Unknown" or "Mapping" coordinate quality into a project that already contains level point data, duplicate points will be created for points in the text file (lightweight points (see "Understanding Point Types" on page 364)) and points already in the project (normal points (see "Understanding Point Types" on page 364)) that have the same ID (that is, points will not merge as expected). To avoid this problem, import the text file first to create the lightweight points in the project, then import the level point data. The lightweight points from the text file will merge with the normal points from the other point data to create normal non-duplicated points. For more information, see Understanding Point Types (on page 364).

Related topics

- Import Data (on page 212)
- View and Edit Level Data (on page 336)
Import Data in a Custom Format

Use the *Import Format Editor* to define a custom format for importing an ASCII file with a specifically defined format. The converters created with this editor are used within the Import command to import ASCII files with a non-standard format.

You can create a converter to import any of the following:

- Delimited files containing ASCII data that is separated by a specific character (e.g. `.csv` files)
- Fixed-width files containing ASCII data that is in pre-defined columns
- Files with ASCII data that is defined by a string of text
- Files with ASCII data that can be defined by a *regular expression* (see "Reference: Regular Expressions" on page 240)

**To import a custom format:**

1. Do one of the following:
   - Select *File > Import Format Editor*.
   - In the *Import* dialog, click the icon.

   The *Import Format Editor* opens and displays the *Select Definition* (see "Definition Options" on page 237) dialog.

   **Note:** If you try to import an ASCII format that is not recognized by any importers, the *Import Format Editor* may display automatically.

2. Select a custom format in the definition list.
3. Click *Next* and select options in the *Description and Search Type* (see "Definition Options" on page 237) dialog.
4. Click *Next* and select options in the *General Properties* (see "General Properties Options" on page 238) dialog.
5. Click *Next* and select options in the *Fields* (see "Fields Options" on page 240) dialog.
6. Click *Finish* to create the importer file.

**Tip:** For each format type, you can select to show or not show the *Import Format Editor* automatically, every time you import an ASCII non-standard file. Set this option in the *Select general properties* (see "General Properties Options" on page 238) dialog of the editor. When checked, the *Test* section displays the actual contents of the file and a sample of how it will be parsed using the selected format. For details, see *Fields Options* (on page 240).
To test a custom format importer:

1. Select a custom format in the definition list.
2. Click Test in any of the four Import Format Editor dialogs. The dialog expands.
3. Click Read File and select the number of lines you want the importer to read. If you select View File, it will open in a text editor.
4. Click the icon and navigate to the type of file you want to import, and click Open. The importer will read the file and highlight any values that it is unable to convert.

   Note: The file must have the same file extension as the importer you chose.

5. Select a different importer or edit the file to accommodate the reported errors.

Related topics

- Definition Options (on page 237)
- Description and Search Type Options (on page 238)
- General Properties Options (on page 238)
- Fields Options (on page 240)
- Import Data Formats (see "Importable Data Formats" on page 214)
- Reference: Regular Expressions (on page 240)

Definition Options

Use these options to create new format definitions. These buttons appear to the right of the list of definitions on the first dialog of the Import Format Editor.

Options

- **New**
  Click this to enter a new definition name in the list. A unique name is required; a descriptive name is recommended. Click any other definition row to finish.

- **Copy**
  After you click on description (listing on left), click Copy to enter a definition name. A unique name is required; a descriptive name is recommended. Click OK to return.

- **Rename**
  Select the name of one of the custom formats you have created, and click this to edit the name.

- **Delete**
  After you click on a description (listing on left), click this to remove the definition from the list.

   Note: To remove a description as an import option, you can click the Enable checkbox until no green check appears. If you would do not want to display these disabled descriptions, enable Only show enabled definitions at the bottom left of the dialog box.

Related topics

- Description and Search Type Options (on page 238)
- General Properties Options (on page 238)
Import Data

- **Fields Options** (on page 240)
- **Import Data in a Custom Format** (on page 236)
- **Reference: Regular Expressions** (on page 240)

**Description and Search Type Options**

Use these options to define the type of custom importer you want to create, and add a description. They are available in the second dialog of the **Import Format Editor**.

**Options**

<table>
<thead>
<tr>
<th>Description</th>
<th>Enter a descriptive string to describe this importer (optional).</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>Select the option that describes the file you want to import:</td>
</tr>
<tr>
<td><strong>Delimited</strong></td>
<td>this file contains data that is separated by a specific character.</td>
</tr>
<tr>
<td><strong>Fixed Width</strong></td>
<td>this file contains data that is in pre-defined columns.</td>
</tr>
<tr>
<td><strong>Search for Text</strong></td>
<td>this file contains data marked on either side by a text string.</td>
</tr>
<tr>
<td><strong>Regular Expression</strong></td>
<td>this file contains data that can be identified with a regular expression (see &quot;Reference: Regular Expressions&quot; on page 240).</td>
</tr>
</tbody>
</table>

**Related topics**

- **Definition Options** (on page 237)
- **General Properties Options** (on page 238)
- **Fields Options** (on page 240)
- **Import Data in a Custom Format** (on page 236)
- **Reference: Regular Expressions** (on page 240)

**General Properties Options**

Use these options to define how you want the file delimited and saved, and the data stored. They are available in the third dialog of the **Import Format Editor**.
Import Data

Options

Delimiter
Select the character that separates the fields from drop-down list. If you select <other>, you must specify the required character.
This can be one of the following: _ ) ( * & ^ % $ # @ ! ~ `.

Store points as
Surface - creates a surface model from the points; no individual points are stored in the project.
Points - creates individual points in the project.

Default file extension (recommended)
Enter the default extension for the import format. The import analyzer uses this extension to help it decide what conversion options to offer the user in the context menu. This field is optional. If left blank, a default extension of *.txt* is assumed.

Show editor on import
Check to automatically open the Import Format Editor when importing a non-standard ASCII file.

Text qualifier
Enter a special character to identify the beginning and ending of the string, for example ".

Skip number of header lines
Enter the number of lines to skip at the beginning of the file before reading the data to import.

Start undefined ID numbering
Enter a number to use as the starting ID when auto-generating IDs for unidentified points during import.
If no number is entered, this software will not assign a number to unidentified points during import.

Undefined elevation
Enter a character or value to indicate that an elevation has not been assigned.

Coordinate quality
Select a coordinate quality to assign to the imported data. Control quality data is fixed, mapping and survey quality data is weighted, and unknown quality data is not used during the computation of the project.

Tip: For large point files, select unknown quality; the program will perform faster.

Note: If you want to be able to edit the point quality within the software, select control or survey quality on import.

Related topics
- Definition Options (on page 237)
- Description and Search Type Options (on page 238)
- Fields Options (on page 240)
- Import Data in a Custom Format (on page 236)
- Reference: Regular Expressions (on page 240)
Fields Options

Use these options to define the fields that you want to import, and their field order, and units. The options vary slightly based on the type of converter you are creating. They are available in the fourth dialog of the Import Format Editor.

Options

Fields

Click Fields to display a drop-down list of data properties. Select one and a tag appears as a field in the row of data. Continue to select all the fields that you want to import.

Note: If you select the properties out of order, you can click and drag them into the proper order.

Units

To select the distance units for all data, select the units and enable the Apply to all check box. You can also disable the Apply to all check box, and select a unit for each exported field.

For Fixed Width (only)

Click on each field, and enter a Start and End value or a Start and Width value - the third value will be filled in automatically.

For Search for Text (only)

Click on each field, and enter text values to search for the Start and End the field.

Note: Spaces will not be visible in the Start and End fields, but you can see them in the Preview area.

For Regular expression (only)

Click Next to display the dialog box for entering a regular expression (see "Reference: Regular Expressions" on page 240).

Test

Enter file name

Click Test to open the testing display area. To test the current format on a specific file:


5. Click Read file to view the results.

You can continue to modify the format setting and Read file the results until you are satisfied.

Related topics

- Definition Options (on page 237)
- Description and Search Type Options (on page 238)
- General Properties Options (on page 238)
- Import Data in a Custom Format (on page 236)
- Reference: Regular Expressions (on page 240)

Reference: Regular Expressions

A regular expression is a formula composed of characters and operators that represent a specific pattern. This formula is used to locate text strings that match this pattern.
A simple example is searching your computer for a list of all the files that have the .txt extension. To do this, you use the substitution formula *.txt where * represents any alphanumeric characters A-Z or 0-9. Similarly, regular expressions allow you to create a formula that represents the text pattern to search for.

Regular expressions can be simple or very complex. For example, you can write expressions to search for a:

- specific sequence of characters
- specific format such as (999)999-9999 to find phone numbers
- special characters such as spaces or tabs
- repeated words (or any text string)
- one text string always followed by another text string

By using operators in your expression, you can find text that matches a pattern or text that does NOT match the pattern.

For a quick tutorial on regular expressions, visit:

Syntax

The syntax for writing regular expressions is comprised of several subsets, including:

- **Substitutions** - characters and operators used in replacement patterns
- **Character Classes** - used to match Unicode, white-space characters, non-word characters, etc.
- **Regular Expression Options** - for modifying how a pattern is matched
- **Character Escapes** - used to indicate that a special character is to be matched
- **Quantifiers** - used to specify the number of matches to find

**Grouping Constructs** - used to match groups and sub-groups of text strings Syntax details are located at:
http://en.wikipedia.org/wiki/Regular_expression
http://en.wikipedia.org/wiki/Regular_expression

Related topics

- **Definition Options** (on page 237)
- **Description and Search Type Options** (on page 238)
- **General Properties Options** (on page 238)
- **Fields Options** (on page 240)
- **Import Data in a Custom Format** (on page 236)
Download and Import Internet Data

After you have imported raw data and processed the baselines, download and import additional data from various Internet resources. To find data relevant to your project, the **Internet Download** command:

- Uses a radial search based on the coordinates in your project
- Can import file formats used by most GPS manufacturers, as well as the receiver-independent RINEX format
- Automatically converts time differences and finds overlapping session times

Related Topics

- [Add Predefined Data Providers](on page 257)
- [Download and Import Data Automatically](on page 242)
- [Manage the List of Data Providers](on page 250)
- [Add New Data Providers](on page 252)

Download and Import Data Automatically

After you have created or opened a project and processed baselines using only your raw data, there are two ways in which you can download data from Internet providers: **Automatic** and **Manual**. In most cases, you will be able to use the automatic method.

**Note**: Internet download converts local time to GPS time.

To download and import data from the Internet

1. Do one of the following:
   - Select **File > Internet Download**.
   - Click [ ] on the toolbar.

   The **Internet Download** command pane displays, listing the default data providers.

   **Note**: You can expand or collapse the groups in the list by right-clicking and selecting **Expand All** or **Collapse All** from the context menu.

2. Double-click a web site in the list to start an automatic download. Alternately, you can select a site and click **Automatic**, or right-click and select **Automatic Download** from the context menu. The **Download Parameters** dialog displays.

   **Note**: Reference stations use **Manual** download only.

3. Set download parameters (see "Set Download Parameters" on page 246) as needed.
4. Click **OK** to start the download process. A new tab appears, showing the download sequence and status. At the bottom of the command pane, a message and progress bar show the download status. As files finish downloading, their names appear in the **File Name** list.

**Tip:** You can download from multiple sites concurrently. Once you begin a download, click the **Start** tab, select another provider web site, and begin another download.

5. After downloading, click each cell in the **Action** list, and select a way to handle the downloaded file.

6. Click **Import** to start the import process. The tabbed page closes. Files that you set to **Import** will import into the current project, display in the plan view, and appear in the **Project Explorer**.

**Note:** If none of the files are importable, the button will read **OK**, instead of **Import**.

7. If you have downloaded from multiple sites, click each tab and repeat steps 5 and 6 for each tabbed page.

**Note:** Continuous files from CORS stations are often logged, and import, in one-hour increments. Once they have been imported, however, they are concatenated (joined sequentially) into a single file.

**Related Topics**

- [Internet Download Options](#)
- [Download Parameter Options](#)
- [Download and Import Data Manually](#)

**Internet Download Options**

Use these options to select the type of data you want to download from the Internet. They are available on the **Start** tab of the **Internet Download** command pane.
### Site type | Data type
---|---
**Reference Stations** (and Virtual Reference Station) | Base station (Manual only)
**Precise Orbits** | File
**Control Coordinates** | File
**GNSS almanac files** | File
**Ionospheric Models** | File

These enable you to download base station or virtual RTK data from a local base station (or a virtual base station) using a manual search. For example, NGS CORS reference stations permit you to download RINEX data, and almanac information.

These let you download orbit data from the NGS or IGS. For example, NGS CORS stations permit you to download precise ephemeris data in two formats: SP3 and EF18.

These enable you to download data sheets from the National Geodetic Survey. For example, NGS CORS reference stations permit you to download control coordinates.

These enable you to download GNSS planning data. For example, NGS CORS reference stations let you download almanac information.

These allow you download ionospheric information from the CDDIS archives and other academic institutions. For example, the University of Bern lets you to download ionospheric maps.

**Related Topics**
- Download and Import Data Automatically (on page 242)
- Download and Import Data Manually (on page 249)
- Download Parameter Options (see "Set Download Parameters" on page 246)
- Import Data (on page 212)
IGate Download Options

Use these options to select reference stations from which to download. They are available in the Select Reference Stations to Download dialog when you download reference station data using the iGate protocol.

iGate is a rare protocol that can retrieve a network of multiple reference stations. Using the iGate protocol, you can download different types of data, such as observation and ephemeris, concurrently.

Options

Select
Leave this checked to download the reference station. Uncheck stations you do not want to download.

Station name
This identifies the reference station, which may or may not indicate its geographic location.

Interval (sec)
This displays the sample rate in seconds. Click the drop-down arrow to select a different interval.

Note: If you select a higher rate than the rate at which the data was collected, you may not receive data. Experiment with lower rates if you think this is the case.

Ephemeris
Click the drop-down arrow to select an ephemeris type.

Low accuracy - Select when none of the IGS orbit types are available.

IGS Precise orbit - Select for the highest quality orbit data. This data is used for the IGS reference frame.

IGS Rapid orbit - Select when IGS Precise orbit is unavailable. For many applications, IGS rapid orbit data is almost as good as IGS precise orbit data.

IGS Ultra rapid orbit - Select when neither precise or rapid orbit data is available.

For more information, see the International GNSS Service's web site.

Note: If the server does not have the ephemeris type you select, no file is downloaded.

Distance
This displays the distance from the station to the center of your current project data.

Related topics

- Internet Download Options (on page 154)
Set Download Parameters

When you start an automatic download, the Download Parameters dialog displays. Set the geographic center and limits, and time scope of the download, so you get the data most relevant to your project.

To set download parameters:

1. Set the geographic center of the download in the Coordinate group.
2. Set the time limits of the download in the Timespan group.
3. Set the geographic scope of the download in the Search Radius group.
4. Click OK to start the download.

Disable the Download Parameters dialog if your projects always contain the parameters that data providers need.

To disable the Download Parameters dialog:

1. Do one of the following:
   - Select Tools > Options.
   - Click Options on the Internet Download Configuration dialog.
     The Options dialog displays.
   - Click Internet Download.
2. Disable Always show the Download Parameters dialog. Then, when you click Automatic, the Download Parameters dialog will not display unless the project spans more than 8 hours. If your project extents are longer than 8 hours, the dialog will open, prompting you to specify a smaller segment of time for faster downloading.

   **Note:** If your project doesn't include the parameters needed by the data provider site, the Download Parameters dialog will still display, even if you have the option toggled.

Related Topics

- Download and Import Data Automatically (on page 242)
- Download and Import Data Manually (on page 249)
- Internet Download Options (on page 243)

Download Parameter Options

Use these options to set parameters for the geographic and time scope of your download of Internet data. They are available in the Download Parameters dialog. This dialog may look different each time you open it because the parameters it includes are based on the requirements of the data provider’s web site.
**Location code**

**4 Character Name**
Type or select a reference station’s 4-digit location code.
They are selectable if you previously entered them on the Site Properties dialog’s Station Location tab.

**Coordinate**

**User Input**
For NGS data, a radial search is done, based on the coordinates of your current project.

**Project Center**
Select this to use the geographic center of your project’s data for the download.

**Point in Project**
Select this to open the Point ID box, where you can enter the name of one of the points in your project as the center of the download.

**Point ID**
Type the name of the point you want to use as the center of the radial download.

**Coordinate type**
- **Grid** - Select this to use northing, easting, and elevation coordinates when you specify the center of the download.
- **Local** - Select this to use latitude, longitude, and height coordinates.
- **Global** - Select this to use latitude, longitude, and height coordinates.

**Northing, easting and elevation or Latitude, longitude, and height**
Type coordinates for the download center.

**Time span**

**Session**
By default, data covering the entire time span of your current project will be downloaded.

- **Project time span** - Select this to download data covering all of the occupation times in your project.
- **User Input** - Select this to open the Start time and End time boxes, where you can set the exact time span to download.

(Project time span broken into segments) - Select one of these when the project spans more than an eight-hour period.
Import Data

**Start time**
Set the time span within which to download.

and

**End time (local)**
Set the time span within which to download. Generally, GPS files are in UTC time, not local time.

**Note:** Some reference stations provide segmented data, meaning that it is stored in one hour increments. When you download segmented data, you will notice multiple files being transferred for any sessions in your project that span multiple segments.

**Sample interval**
Select an option to download data using an interval equal to or lower than the interval in your project. If the base station has used a collection interval higher than the occupations in your project, the download process will decimate (reduce the base station data) down to the level you set.

**Search radius**

**Kilometers**
Type the radial distance from the center of your project within which to search for data. You can enter units different from the project units, and they will be converted.

Related topics

- [Set Download Parameters](on page 246)
Post-download File Options

Use these options to specify what you want to do with downloaded files. They are available on the numbered tabs of the Internet Download command pane after you have successfully downloaded data.

Options

**Import**
Select this to add the file to the current project, display the data in the plan view, and place the file on your hard drive in the folder you specified in the Download and import folder box in the Options dialog.

This is the default option for files that the Import command recognizes.

The file formats supported are listed in Import Data Formats (see "Importable Data Formats" on page 214).

**Save**
Select this to place the file on your hard drive in the folder you specified in the Download and import folder box in the Options dialog.

Saving the file does not import the data into your project.

**Delete**
Select this to discard the file.

This is the default option for files that the Import command does not recognize.

Related topics

- Download and Import Data Automatically (on page 242)
- Download and Import Data Manually (on page 249)

Download and Import Data Manually

The Manual download method simply connects you to a data provider's web page, without beginning a download process. This function helps you by keeping an organized list of your data providers so that you can access their sites quickly while working in your project. In addition, it is helpful to have manual sites saved in case they become configurable for the automatic download method, or if the automatic download stops working due to a change within a site.

To manually download data from the Internet:

1. Do one of the following:
   - Select File > Internet Download.
   - Click on the toolbar.

   The Internet Download command pane displays.

2. Select a web site in the Providers list.

3. Click Manual, or right-click and select Manual Download on the context menu.
   Your Internet browser opens to the page of the provider you selected.

4. Navigate through the appropriate web pages, and enter the parameters needed to start a download process.
Import Data

Related Topics

- [Download and Import Data Automatically](on page 242)
- [Internet Download Options](on page 243)
- [Download Parameter Options](see "Set Download Parameters" on page 246)

Manage the List of Data Providers

Disable web sites in your Providers list to control which data providers you or your colleagues can choose from, without having to delete sites. When you disable a site, its name is removed from the list of providers in the Internet Download command pane.

Add new groups to organize your data provider web sites into logical sets. When you add a new group to the list of providers, the group shows up as a new data type in the Internet Download command pane. You can modify the default group structure so it suits your needs.

To disable data provider sites:

1. Click the icon on the Internet Download command pane's toolbar. The Internet Download Configuration dialog opens.
2. To disable (or enable) a specific data provider, uncheck (or check) the box next to the name.
3. Click OK to close the Internet Download Configuration dialog. The name is removed from the list of providers in the Internet Download command pane.

**Note:** To permanently remove a specific site or an entire category (folder) of providers, select the name in the list and click Delete. A warning message will prompt you to confirm the deletion.

To add or edit provider groups:

1. Click the icon on the Internet Download command pane toolbar. The Internet Download Configuration dialog displays.
3. Enter a new folder name in the Name box.
4. Select a download type for the group in the Type list box.
5. In the Presets list, select a folder in which you want to place the downloaded, imported, and saved files for the group.
6. If you selected User Defined Folder in the Presets list, type that path or click the to browse for the download folder.
7. Click OK, and OK again to close the Internet Download Configuration dialog.
To set Internet download options:

1. Click on the **Internet Download** command pane toolbar. The **Internet Download Configuration** dialog displays.
2. Click **Options**. The **Options** dialog displays.
3. Check or uncheck the options as necessary.
4. Click **OK**, and **OK** again to close the **Internet Download Configuration** dialog.

Related Topics

- Add New Data Providers (on page 252)
- Add Predefined Data Providers (on page 257)
- Data Provider Group Options (on page 251)

Data Provider Group Options

Use these options to define the type of group you are creating. They are available in the **Group Properties** dialog. Different Internet protocols are used for the different download types.
Options

Group information

Type

File download - Select this to download types of data other than GNSS, such as control coordinates.

Reference station download - Select this to download GNSS data from any official base station.

Virtual reference station download - Select this to download GNSS data from any other GNSS data provider to use in place of an official base station.

Download folder

Presets

Project download folder - Select this to import into the default download and import folder, as defined in the File Locations section of the Options dialog.

Trimble planning utility folder - Select this to download to the Planning utility's default folder.

My Documents Folder - Select this to download to:

- C:\Documents and Settings\(username)\My Documents\ in Windows® XP or earlier.
- C:\Users\(username)\Documents\ in Windows Vista™.

User-Defined Folder - Select this to open the Folder box, where you can browse for a different folder.

Folder

Type a path, or click the icon for a different folder in which to save downloaded files.

Related Topics

- Internet Download Options (on page 154)
- Manage the List of Data Providers (on page 250)

Add New Data Providers

Add web sites that you regularly use to the list of data providers. If your projects are consistently in the same geographic area, configuring and adding local providers can make accessing Internet data very efficient.

Note: Before adding a new data provider site, make sure that you have selected the correct group (folder) for the site, or create a new group for it; the site you add cannot be moved into a different group after it is added.
For Automatic download to work:

- The site must have a valid URL specified on the Providers tab in the Site Properties dialog.
- The correct protocol must be set on the Providers tab in the Site Properties dialog.
- The box next to the site name must be checked in the Internet Download Configuration dialog.

To add or edit a data provider:

1. Click on the Internet Download command pane toolbar. The Internet Download Configuration dialog displays.
2. Select a group into which to add the new site.
3. Click New Site. The New Site dialog may display, depending on the type of group you selected.
4. If necessary, click Enter the details yourself.
5. Click OK. The New Site Properties dialog displays. The tabs that appear on this dialog will vary, depending on the type of site you are adding.
6. Click through the tabs, entering parameters as necessary (see New Provider Options (on page 254)).
7. Click OK.

Tip: Once you have added the web sites you need to your list of providers, the site information is saved in a file named INetDownload.xml. Share your list of sites with colleagues by copying this .xml file from your computer into the equivalent directory in their computers. The location of this file depends on your operating system:

- In Windows® XP or earlier: C:\Documents and Settings\(username)\Application Data\(software brand name)\(software product name)\(version number)\AppData\Roaming\(software brand name)\(software product name)\(version number)\ INetDownload.xml

Note: The file that contains the default site list is named cg_list.csv. After the application accesses this list the first time, it switches to accessing the .xml list stored in the same location. Any changes you make to the list of providers will be retained in the .xml file mentioned above. If you reinstall or update the program, different file entries will be merged into your .xml list; it will not be overwritten.

Related Topics
- Reference: URL Parameters (on page 258)
- New Provider Options (on page 254)
New Provider Options

Use these options to configure new web sites that you want to add to your list of Internet data providers. They are available in the New Site Properties dialog. Since sites have different requirements, only the tabs necessary to configure the site appear.

Providers options

<table>
<thead>
<tr>
<th>Site name</th>
<th>Type a unique identifier for the site.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Manual Connection</td>
<td>Type a URL to be used to visit the site.</td>
</tr>
<tr>
<td>Host URL/Address</td>
<td>Click this to open the web page in your default browser, or starts the manual download for the site.</td>
</tr>
</tbody>
</table>

Automatic Connection

| Host URL/Address          | Type a URL to be used for automatic downloads (see Reference: URL Parameters (on page 258)). |
| Protocol                  | Select the method used to transfer data from the web site to your computer. |
| FTP/HTTP                  | Select this to download reference station, virtual reference station, and file data. Most of sites you encounter will accept this protocol. |
| Explorer                  | Select this to download reference station, virtual reference station, and file data, and view the file in your default Internet browser. |
| iGate                     | Select this to download reference station and virtual reference station data. |
| None                      | Select when you want to access the site using Manual only; this setting disables the Automatic method. |

URL Wizard

| URL Wizard                | Click this to display the URL Wizard dialog, where you can build a valid URL. |

The Contact tab on the Site Properties dialog enables you to view or edit more information on the provider. All information on this tabbed page is optional.
**Import Data**

**Contact options**

**Organization, Postal Address, Contact Name, E-mail Address, Telephone, FAX**

Enter information about the data provider and ways to contact them.

**BBS**

Type a link to a bulletin board service.

**Send Mail**

Click this to open your default e-mail program and insert the e-mail address specified in the *E-mail Address* box.

**Security options**

**Public Access**

Select this when no username and password is required.

**Restricted Access**

Select this when a username and password is required. It opens those text boxes.

**User Name**

Type a unique identifier. When using the automatic download method, this information is transferred with your download request so that you do not have to manually enter it.

**Anonymous**

Select this when no username is required. It prompts you to enter the anonymous password provided by the web site's administrator.

**Password**

Type your e-mail address as the password. When using the automatic download method, this information is transferred with your download request so that you do not have to manually enter it each time you visit the site.

**Save Password**

Select this to retain the password so you do not have to retype it each time you visit the site.

**Reference Station options**

**Station Location, Receiver Type, Station Type, Other Information**

Enter information about the base station.

**Location Tab options**
**Code (4 characters)**

Type the location code for the station. This is not automatically filled in from the Trimble **Predefined Reference Station Provider** list (cbs_list.csv). Visit the web site using the **Manual** download method to determine which codes to use.

**Description**

Enter additional information to help you identify the site.

---

**IGate Tab options**

**Remote Port**

Specify the port number of the iGate server. Most iGate sites use 3456, which is the default. Some sites have firewalls that block certain ports, so it may be necessary to have this port opened as an outgoing port. It’s hard to tell the difference between a blocked port, a wrong port, and a server that is down, so it’s wise to check the firewall.

---

**Related Topics**

- Add New Data Providers (on page 252)
- Reference: URL Parameters (on page 258)
- URL Wizard Options (on page 256)

---

**URL Wizard Options**

Use these options to build an Internet URL in a valid format for certain kinds of web sites. They are available in the **URL Wizard** dialog when you are adding a new data provider web site. The URL created in this dialog populates the **Host URL/Address** box on the **Providers** tab of the **New Site Properties** dialog.

**Tip:** If you have an IP-enabled receiver set up as a reference station, you can add it, and download data from it like any other Internet data provider’s web site.
## Options

### Connect to

**Trimble NetR5 Receiver** - Select this to retrieve the serial number if the site is connected to a NetR5 receiver.

*Note:* This is the only type of receiver currently supported.

### ftp://

Type the web site or IP-enabled receiver’s IP address or domain name.

### Port

Specify a new port number if the receiver doesn’t use the standard: Port 21.

### Receiver serial number

Type the receiver’s serial number if the receiver is offline. At least the last four digits of the number are required.

### Request

Click this to retrieve the serial number if the receiver is online. The **Receiver Serial Number** box is filled if the request receives a response.

### Storage medium

**External memory** - Select this if the receiver is saving data to external storage.

**Internal memory** - Select this if the receiver is storing data internally.

### Complete URL

This shows the resulting URL.

## Related topics

- Add New Data Providers (on page 252)
- New Data Provider Options (see "New Provider Options" on page 254)

## Add Predefined Data Providers

One way to add web sites to the list of data providers is to select from Trimble’s *Predefined Reference Station Provider* list. This up-to-date list gives you quick access to web sites that are already configured. In addition, they are sorted by geographic distance from the center of your current project, so the most relevant data providers will be at the top of the list.

*Note:* Before adding a new data provider site, make sure that you have selected the correct group (folder) for the site, or create a new group for it; the site you add cannot be moved into a different group after it is added.

### To add a new provider from Trimble's pre-defined list:

1. Click 🌐 on the **Internet Download** command pane toolbar. The **Internet Download Configure** dialog displays.
2. Select the **Reference Stations** group in the **Providers** list.
3. Click **New Site**. The **New Site** dialog displays.
4. Click **Select from the pre-defined list**.
**Note:** The first time you access the pre-defined list of Internet sites in your current project, the option *Download the most up-to-date list from Trimble’s Internet site* is enabled by default.

**Tip:** Since the CBS list is sorted by distance from project data, you should have data in your project prior to adding pre-defined sites.

5. Click **OK**. The *File Download* dialog displays, showing the download progress. When the download is complete, the *Add Pre-defined Reference Station Provider* dialog displays.

6. In the *Pre-defined Reference Station Provider* list, select any data provider sites you want to add. Press **CTRL** while selecting to add multiple sites or to deselect unneeded sites.

7. Click **OK** to close the dialog. The sites you selected appear in the *Internet Download Configuration* dialog’s *Providers* list.

**Related Topics**

- [Predefined Data Provider Options](on page 258)

**Predefined Data Provider Options**

Use these options to select pre-configured web sites to add to your data providers list. They are available in the *Add Predefined Reference Station Provider* dialog.

**Options**

<table>
<thead>
<tr>
<th>Provider</th>
<th>This shows the official name of the reference station.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Location</td>
<td>This displays the city, county, state, province, or other entity in which the base station is located.</td>
</tr>
<tr>
<td>Public</td>
<td>This designates that the site is accessible and free to the public. Sites that are unchecked (private) are likely to require a username and password obtained through a paid subscription.</td>
</tr>
<tr>
<td>Distance</td>
<td>This shows the radial distance from the geographic center of the current project.</td>
</tr>
</tbody>
</table>

**Related Topics**

- [Add Predefined Data Providers](on page 257)

**Reference: URL Parameters**

When you configure provider sites to automatically download data from the Internet, you will need to provide specific information to reach the final URL. For example, if you want to download reference station data from a CORS site, you will need to specify the download parameters within the URL itself. The URL below contains a template for start time, duration, year, day of year and a four-character site name.

```plaintext
http://www.ngs.noaa.gov/cgi-cors/ufcors2.prl?newstart=%HH%&duration=%LL%&year=%YYYY%&yearday=%DDDD%&siteselection=%CC%&epic="As Is"&datasheets=no&compr=pkzip
```
When configuring URLs, you will need to manually substitute the appropriate values for the masks to obtain the final URL, which initiates the download of files. The table below defines the address formats you should use for substitution.

| Note: FTP addresses are case sensitive. |
### URL Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>%YYYY%</td>
<td>Year (2001)</td>
</tr>
<tr>
<td>%YY%</td>
<td>Year (01)</td>
</tr>
<tr>
<td>%Y%</td>
<td>Year (1)</td>
</tr>
<tr>
<td>%MMMMMM%</td>
<td>Month (JA, FE, MR, ... DE)</td>
</tr>
<tr>
<td>%MMMM%</td>
<td>Month (January, February, ..., December)</td>
</tr>
<tr>
<td>%MMM%</td>
<td>Month (Jan, Feb, ..., Dec)</td>
</tr>
<tr>
<td>%MM%</td>
<td>Month (00, 01, ..., 12)</td>
</tr>
<tr>
<td>%M%</td>
<td>Month (0, 1, ..., 12)</td>
</tr>
<tr>
<td>%GGGG%</td>
<td>GPS week (0000, 0001, ... 1147)</td>
</tr>
<tr>
<td>%DDDDD%</td>
<td>Day of year (001, 002, ..., 366)</td>
</tr>
<tr>
<td>%DD%</td>
<td>Day of month (00, 01, ..., 31)</td>
</tr>
<tr>
<td>%D%</td>
<td>Day of month (0, 1, ..., 31)</td>
</tr>
<tr>
<td>%TTTT%</td>
<td>Day of week (Sunday, Monday, ..., Saturday)</td>
</tr>
<tr>
<td>%TTT%</td>
<td>Day of week (Sun, Mon, ..., Sat)</td>
</tr>
<tr>
<td>%T%</td>
<td>Day of week (0, 1, ..., 6)</td>
</tr>
<tr>
<td>%HH%</td>
<td>Hour (00, 01, ..., 23)</td>
</tr>
<tr>
<td>%H%</td>
<td>Hour (0, 1, ..., 23)</td>
</tr>
<tr>
<td>%HrAsLetter%</td>
<td>Hour (a, b, ... x)</td>
</tr>
<tr>
<td>%HrAsCapLetter%</td>
<td>Hour (A, B, ... X)</td>
</tr>
<tr>
<td>%LL%</td>
<td>Duration (01, 02, ..., 24)</td>
</tr>
<tr>
<td>%RR%</td>
<td>Sampling Rate (01, 05, 10, 15, 30, 60)</td>
</tr>
<tr>
<td>%CCCCC%</td>
<td>Location Code (ark1, cms1, etc.) 4 character description</td>
</tr>
<tr>
<td>%LAT%</td>
<td>Latitude of project center, HDDMMSS</td>
</tr>
<tr>
<td>%LON%</td>
<td>Longitude of project center, HDDDMSS</td>
</tr>
<tr>
<td><strong>H - hemisphere</strong></td>
<td>N or S for latitude, W or E for longitude</td>
</tr>
<tr>
<td><strong>D - Degrees</strong></td>
<td></td>
</tr>
<tr>
<td><strong>M - Minutes</strong></td>
<td></td>
</tr>
<tr>
<td><strong>S - Seconds</strong></td>
<td></td>
</tr>
<tr>
<td>%R1%</td>
<td>Radius, km</td>
</tr>
<tr>
<td>%R2%</td>
<td>Radius, miles</td>
</tr>
</tbody>
</table>

**TIP:** When configuring a new URL, you should test that the parameter substitutions are correct. Use the Explore protocol and precede the address with /T. This will display the resolved address in a message box without starting the download.
Run an Import Report

Generate an Import Report to see a project summary, details on imported files, and any associated errors or warning messages.

**To run an Import Report:**

- Select Reports > Import Report.
- Select Reports > Report Options. Select Import Report in the command pane, and click OK.

The Import Report displays in your default Web browser.

**Tip:** Click a file name in the report to jump to the creation and import dates and times.

Troubleshoot an Import Problem

Before calling Support, use any applicable solutions to known issues below.

<table>
<thead>
<tr>
<th>Symptom</th>
<th>Possible Cause</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>LandXML data imports in the wrong location or configuration.</td>
<td>Project units are not set correctly.</td>
<td>Check the units shown on the status bar. If they are not correct, undo the import. Then, click the units name to open the Project Settings dialog. Change to the correct type of units, and reimport the file.</td>
</tr>
<tr>
<td>A LandXML file will not import. The program’s importer says it is a LandXML file, but when you try to import it, a message says the file is invalid.</td>
<td>The file is valid XML, but not valid LandXML.</td>
<td>Open the file in your default Web browser. If it is corrupt, you will get an error message. If you do not get a message, it may be valid XML, but not valid LandXML, in which case the file needs to be recreated in a valid LandXML format.</td>
</tr>
<tr>
<td>Custom point data (.csv) imports at the wrong location.</td>
<td>1. Your project units are not set correctly. 2. The wrong custom import definition was used to import the file.</td>
<td>1. Make sure that your project units are set correctly. 2. Check the custom import definition you used to import the file.</td>
</tr>
</tbody>
</table>
Import Data

<table>
<thead>
<tr>
<th>Duplicate points were created for points in an imported text file and points already in the project that have the same ID (that is, points were not merged as expected).</th>
<th>If you import a text file with &quot;Unknown&quot; or &quot;Mapping&quot; coordinate quality into a project that already contains point data, duplicate points will be created for points in the text file (lightweight points (see &quot;Understanding Point Types&quot; on page 364)) and points already in the project (normal points (see &quot;Understanding Point Types&quot; on page 364)) that have the same ID.</th>
<th>Import the text file into the project first to create the lightweight points, then import the other point data. The lightweight points from the text file will merge with the normal points from the other point data to create normal non-duplicated points.</th>
</tr>
</thead>
</table>

selected; the northing and easting order are reversed. points. If you accidentally selected the definition with the northing and easting reversed, undo the import and reimport with the correct definition.
Transfer/Synchronize Data

Prepare to Connect a Field Device

Transfer and synchronize data between field devices and your computer using one of two methods: Direct connection via the Device pane, or Office Synchronizer via the data synchronization area.

Options

Device pane (on page 10)  Use this and a direct connection to update files directly on the field device and to import data directly from the field device.

Office Synchronizer and the data synchronization area (see "Office Synchronizer" on page 264)  Use these to manually or automatically synchronize data between a field device and your computer. Using the data synchronization area allows you to prepare field data and create export files without physical connection to the field device. The upload process is a separate automated step.

To prepare for using a direct connection:

1. If necessary, install Microsoft® ActiveSync® software. If this wasn't done during installation, then do so now. (Enter ActiveSync as a search topic on the http://www.microsoft.com/downloads http://www.microsoft.com/downloads site.)

   **Note:** For Microsoft Vista users, ActiveSync technology is not required. The communication functionality needed is included with Vista.

2. Start this software.

3. Connect the field device to the computer using a USB connection or a serial connection.

4. If the device asks if you want to be connected, click Yes. The Device pane appears, listing the files on the field device.
To prepare for data synchronization:

1. If necessary, install Microsoft® ActiveSync® software. If this wasn't done during installation, then do so now. (Enter ActiveSync as a search topic on the http://www.microsoft.com/downloads site.)

2. If necessary, install Office Synchronizer. If this wasn't done during installation, then install it from this software's installation CD.

3. Run Office Synchronizer, and select Tools > Synchronizer Options. Verify the following options:
   - Sync options tab > Sync Mode = Manually
   - Display tab > Check Set ActiveSync to work in "Guest Only" mode

4. Connect the field device to the computer using a USB connection or a serial connection. When you connect a device for the first time, enter the following data:
   - Device name - a unique name to be associated with the device
   - Field crew information (optional)
   - System root folder location - a folder on the computer or network location accessible to the computer. This folder will store the synchronized data. This data is stored on the field device.

Related topics

- Upload Files (via Direct Connect) (see "Upload Files (via Direct Connection)" on page 267)
- Download Files (via Direct Connect) (see "Download Files (via Direct Connection)" on page 267)
- Upload Files (via data synchronization) (on page 270)
- Download Files (via data synchronization) (on page 269)

**Office Synchronizer**

Office Synchronizer is a separate utility that transfers data files between your computer and your CE-based field device/site controller, and verifies that the data in both locations is the same, or synchronized.
Data synchronization area

The data synchronization area (also known as the synchronizer root folder) is the folder structure that stores synchronized field data on your computer or computer network. This folder is used by the Office Synchronizer utility, any field devices that have been synchronized with the Office Synchronizer, and this software. Files to be uploaded to field devices and files downloaded from field devices are located in the folder.

If necessary, you can enter, change, or verify the location of the data synchronization area by selecting Tools > Options and clicking General and File Locations. Check the Synchronizer root folder path.

Related topics
- Export Data Formats (see "Export and Upload Data Formats" on page 487)
- File Location Options (on page 150)
- Import Data Formats (see "Importable Data Formats" on page 214)
- Prepare to Connect a Field Device (on page 263)

Device Pane

The Device pane enables you to directly access Microsoft® Windows® CE-based field devices or the data synchronization area (also known as the root sync folder in the Office Synchronizer utility), which contains the files maintained by Office Synchronizer.

To display the Device pane:

Do one of the following:

- Click the icon on the toolbar.
- Select View > Device Pane.
- Press [F10] on the keyboard.

The Devices pane displays, docked on the left side of the application window, or where you positioned it last.

To connect to a field device:

1. Connect the field device to the computer using a USB or serial connection.
2. If the device asks if you want it to be connected, click **Yes**. The **Device** pane displays, showing a list of files on the device.

```
Device: Direct Connection
```

```
SurveyPro
   05-04-2005.job
   22feb2.job
   Feb25FS.job

Other Files:
```

3. As needed, **upload** (see "Upload Files (via Direct Connection)" on page 267) or **download** (see "Download Files (via Direct Connection)" on page 267) files via this direct connection.

**To connect to field data in the data synchronization area:**

In Office copy mode, the **Device** pane points to a folder on your office computer that contains the data previously synchronized from the field device, using the **Office Synchronizer utility** (see "Office Synchronizer" on page 264).

```
Device: Office Copy
```

```
SurveyPro
   05-04-2005.job
   22feb2.job
   Feb25FS.job

Other Files:
```

1. To verify that data in the synchronization area is selected, click the icon, and verify that **Office Copy** is checked in the drop-down list. The contents of the synchronizer root folder display.

2. As needed, **upload files** (see "Upload Files (via data synchronization)" on page 270), **upload tasks** (see "Upload Tasks (via data synchronization)" on page 271), or **download files** (see "Download Files (via data synchronization)" on page 269) from the data synchronization area.

**Related topics**

- **Office Synchronizer** (on page 264)
- **Pane and Data View Positioning** (on page 37)
- **Prepare to Connect a Field Device** (on page 263)
**Direct Connection**

**Download Files (via Direct Connection)**

Download files to copy them from a connected field device to your office computer.

**To download a file and import it into a project:**

1. Open a project, or start a new project.
2. Connect the field device to the computer using a USB connection or a serial connection.
3. If the device asks if you want it to be connected, click **Yes**. The **Device** pane displays, listing the files on the field device.
4. Select one or more files to download from the device.
5. Do one of the following to import into the project:
   - Click the **icon on the toolbar.
   - Click and drag the selected file(s) into the plan view of the project.

**Related topics**

- [Import Data Formats](see "Importable Data Formats" on page 214)
- [Prepare to Connect a Field Device](on page 263)
- [Upload Files (via Direct Connection)](on page 267)

**Upload Files (via Direct Connection)**

Upload files to copy them from your office computer to a connected field device.

**To upload a file:**

1. Open the project from which you want to export data.
2. If the field device is not connected:
   - Connect the field device to the computer using a USB connection or a serial connection.
   - If the device asks if you want it to be connected, click **Yes**. The **Device** pane appears within this office software, and lists the files currently on this field device.
3. Click the ** icon on the **Device** pane toolbar. The **Export** pane displays, listing compatible formats in the **File Format** list.
4. Select the format to export.
5. If data has not been selected, select it, or click **Options** for selection options.
6. Verify the default file name is correct, or enter a different name for the exported file in the **File Name** box.

7. Select any file specific settings in the **Settings** group.

8. Click **OK**. The exported file is converted to the appropriate format and uploaded to the field device. The file list in the **Device** pane updates, showing the new file name.

**Related topics**

- [Export Data Formats](#) (see "Export and Upload Data Formats" on page 487)
- [Select from Plan View](#) (see "Select from 2D Views" on page 50)
- [Select via Command](#) (see "Selection Methods and Options" on page 49)
- [Prepare to Connect a Field Device](#) (on page 263)
- [Download Files (via Direct Connection)](#) (on page 267)

**Upload Tasks (via Direct Connection)**

Upload files to field devices using the **Task** list on the **Device** pane toolbar. You can upload to:

- Trimble® Survey Controller™
- Trimble® Digital Fieldbook™

These file types can be uploaded:

- Feature code library (.fxl) files (converted to .fal files for Survey Controller versions prior to 11.3)
- Data dictionary (.ddf) files (converted to .fal files for Survey Controller versions prior to 11.3)
- Antenna (.ini) files
- Geoid (.ggf) files (including sub-grids)
- Datum grid files (.dgf)

**To upload a file:**

1. Connect the field device to the computer using a USB connection or a serial connection.

2. If the device asks if you want it to be connected, click **Yes**. The **Device** pane displays in this software.
3. Select the device to which you want to export the file in the Device list. If there is only one device available, this is not necessary.

4. Click Tasks, and select the file type from the list. The Open dialog displays for .fxl, .ddf, and .ini files. For .dgf files, the Select Datum Grid Files for Upload dialog displays, and for .ggf files, the Geoid Sub-Gridding command pane displays.

5. Browse to the file you wish to upload, and click OK, or click Upload in the Geoid Sub-Gridding command pane.

6. Click the icon on the Device pane toolbar to see the exported file list.

Related topics
- Prepare to Connect a Field Device (on page 263)
- Download Files (via Direct Connection) (on page 267)
- Upload Files (via Direct Connection) (on page 267)

Data Synchronization

Download Files (via data synchronization)

Before you download files, use Office Synchronizer (on page 264) to synchronize the field device from which you are importing a file.

Downloading a file creates an export file, and copies it to the data synchronization area for synchronizing.

To download a file and import it into a project:

1. Open the project into which you want to download the file, or start a new project.

2. Open the Device pane by doing one of the following:
   - Select View > Device Pane.
   - Click the icon.
   - Press [F10].

   The Device pane displays.
Transfer/Synchronize Data

Note: If a field device is directly connected, you will not be able to continue. Disconnect the device and start over.

3. Click the ✎ icon, and verify that **Office Copy** is checked in the drop-down list. The contents of the data synchronization area display.

4. Select the device from which to import the files.

5. Select the files to import and do one of the following to import into the project:
   - Click the ✎ icon.
   - Click and drag the selected file(s) to the plan view of the project.

Related topics
- **Import Data Formats** (see "Importable Data Formats" on page 214)
- **Prepare to Connect a Field Device** (on page 263)
- **Upload files (via data synchronization)** (on page 270)

Upload Files (via data synchronization)

Upload files to copy them from your office computer to the data synchronization area. The synchronizer root folder is created when you synchronize field devices using the **Office Synchronizer utility** (see "Office Synchronizer" on page 264).

Note: To view or change the location of your data synchronization area, select **Tools > Options > File locations**.

To upload a file:

1. Open the project from which you want to export data.
2. Open the **Device** pane by doing one of the following:
   - Select **View > Device Pane**.
   - Click the ✎ icon on the toolbar.
   - Press **[F10]**.

   The **Device** pane displays.
3. Click the ✎ icon and verify that **Office Copy** is checked in the drop-down list.
4. Select the device to which you want to export the file.

5. Select the data to export.

6. Click the icon on the Device pane toolbar. The Export pane opens and displays a list of possible formats.

7. Select the file format to export. If data has not been selected, select it.

8. Verify the default file name is correct, or enter a different file name for the exported file.

9. Verify the settings options.

10. Click OK, and then close the Export pane to view the Device pane underneath.

11. Click the icon on the Device pane toolbar to see the exported file list.

Note: Before taking the field device out to the field, the Office Synchronizer must synchronize the field device to which you are exporting a file.

Related topics
- Prepare to Connect a Field Device (on page 263)
- Download files (via data synchronization) (on page 269)
- Export Data Formats (see “Export and Upload Data Formats” on page 487)

Upload Tasks (via data synchronization)

Upload files to field devices using the Task list on the Device pane toolbar. You can upload to:

- Trimble® Survey Controller™
- Trimble® Digital Fieldbook™

Note: To activate the Tasks drop-down list, you must first synchronize (see “Office Synchronizer” on page 264) your field device.

These file types can be uploaded:
Transfer/Synchronize Data

- Feature code library (.fxl) files (converted to .fal files for Survey Controller versions prior to 11.3)
- Data dictionary (.ddf) files (converted to .fal files for Survey Controller versions prior to 11.3)
- Antenna (.ini) files
- Geoid (.ggf) files (including sub-grids)
- Datum grid files (.dgf)

To upload a file:

1. Open the Device pane by doing one of the following:
   - Select View > Device Pane.
   - Click the icon on the toolbar.
   - Press [F10].
   The Device pane displays.

2. Click the icon, and verify that Office Copy is checked in the drop-down list.
   The contents of the folder display.

3. Select the device to which you want to export the file.

4. Click Tasks, and select the file type from the list.
   - For .fxl, .ddf, and .ini files, the Open dialog displays.
   - For .dgf files, the Select Datum Grid Files for Upload dialog displays.
   - For .ggf files, the Geoid Sub-Gridding command pane displays.

5. Browse to the file you wish to upload, and click OK, or click Upload in the Geoid Sub-Gridding command pane.

6. Click the icon on the Device pane toolbar to see the exported file list. The new file will be copied to the field device the next time you synchronize.

Related topics
- Prepare to Connect a Field Device (on page 263)
- Upload files (via data synchronization) (on page 270)
Upload Geodetic Reference Data

Upload a Datum Grid File

Select a datum grid file (.dgf) based on the datum used in the project coordinate system, and upload it to a field device.

To upload a datum grid file:

1. Connect the field device to which you want to upload a geoid. The Device pane displays.
2. On the pane's toolbar, click Tasks, and select Upload datum (.dgf) file. The Datum Gridding command pane displays.
3. If needed, select the folder containing the installed datum files in the Folder list, or click the icon and navigate to the folder.

**Note:** The default location for .dgf files depends on your operating system:

- In Windows® XP or earlier:  
  \Documents and Settings\All Users\Application Data\Trimble\GeoData unless you have previously installed Trimble® Geomatics Office™ (TGO). If you have installed TGO and then this software, the path is
  \Program Files\Common Files\Trimble\GeoData.
- In Windows Vista™:  
  \ProgramData\Trimble\GeoData\ or \Program Files\Common Files\Trimble\GeoData\.

4. Select a datum grid file in the Datum Grid Files (.cdg) list, if the datum you need isn’t in the list, create a datum grid file (on page 193).
5. Click Upload. The datum file appears in the Other Files folder of the Device pane's tree.

**Note:** If you use the datum associated with your project’s coordinate system, but do not create a datum grid file, it will not be saved in the list of datum grid files available the next time you upload. If it is a datum you will need again, create a datum grid file that will be saved.

Related topics
- Create a Datum Grid File (on page 193)
- Datum Grid Options (on page 195)
- Upload Tasks (via Direct Connection) (on page 268)

Upload a Geoid File

Select a geoid grid file (.ggf) based on the geoid used in the project coordinate system, and upload it to a field device.

1. Connect the field device to which you want to upload. The Device pane displays.
2. On the pane's toolbar, click Tasks, and select Upload geoid (ggf) file. The Geoid Sub-Gridding command pane displays.

3. If needed, select the folder containing the installed geoid files in the Folder list, or click the icon and navigate to a folder containing .ggf files.

4. Select a geoid file in the Geoid File list.

5. Click Upload. The geoid file appears in the Other Files folder of the Device pane’s tree.

**Note:** If the geoid grid file is larger than 1 MB, a confirmation message displays, asking if you really want to upload it. Consider defining a sub-grid (see "Define a Geoid Sub-Grid" on page 196) of the geoid to make the file smaller.

Related topics

- [Geoid Options](#) (on page 196)
- [Define a Geoid Subgrid](#) (see "Define a Geoid Sub-Grid" on page 196)
- [Upload Tasks (via Direct Connection)](#) (on page 268)

**Troubleshoot a Data Transfer/Synchronization Problem**

Before calling Support, use any applicable solutions to known issues below.

<table>
<thead>
<tr>
<th><strong>Symptom</strong></th>
<th><strong>Possible Cause</strong></th>
<th><strong>Solution</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Active Sync 4.5 will not run.</td>
<td>You are running as a limited user. Active Sync 4.5 is not compatible with limited user accounts.</td>
<td>Change you permissions to the administrator level, or download and use Active Sync 4.0. <strong>Start &gt; Control Panel &gt; User Accounts &gt; User Accounts.</strong> In the <em>User Accounts</em> dialog, select your user name in the list and click <strong>Properties.</strong> In the <em>Properties</em> dialog, click the <strong>Group Membership</strong> tab. Select <strong>Other,</strong> and <strong>Administrators</strong> in the list. Click <strong>OK</strong> twice to close the dialogs.</td>
</tr>
</tbody>
</table>
Work with GNSS Data

Occupation Spreadsheet

The occupation spreadsheet view lists the GNSS occupations in the current project, enabling you to easily edit the data. The plan view and the Properties pane reflect all changes made to data in the spreadsheet view.

**Note:** To change the data that is displayed in the occupation spreadsheet, use the Project Settings command.

**Using the spreadsheet**

- **To select an occupation,** click in the left column for that row.

- **To display more detail** on a occupation in the Properties pane, select the occupation and press [F11], or right-click and select Properties.

- **To edit a cell,** select it by clicking on the cell and make the edit. The edits will be applied when you leave the row.

  **Note:** Grayed out cells are not editable.

- **To sort the entries,** click on a column heading. Up or down icons appear on the selected column heading, indicating the current sort order (ascending or descending).

- **To filter data,** click on the **icon at the top of the column and select an option from the drop-down menu.**

  **Note:** If the filter for a column is on, the icon **appears blue.**
To copy data to a text editor, such as Microsoft® Notepad, select data, and copy and paste by using the right-click menu or by pressing [Ctrl] + C to copy and [Ctrl] + V to paste. You can select all data by pressing [Ctrl] + A.

To change the order of columns across the spreadsheet, click and drag the column heading to a new location.

Related topics
- Data View Display Formats (on page 38)
- Pane and Data View Positioning (on page 37)
- Select from Spreadsheet Views (on page 52)
- Tabbed View Arrangement (on page 40)

Vector Spreadsheet

The vector spreadsheet lists the vectors in the current project. Except for enabling and disabling the Vector Status, the spreadsheet data cannot be edited. The data can, however, be sorted by clicking at the top of any column. The plan view and the Properties pane reflect all changes made to data in the vector spreadsheet view. For details on columns in the vector spreadsheet, see View Settings (on page 161).

To create a new vector spreadsheet:

Do one of the following:
- Select View > New Vector Spreadsheet.
- Click the icon.

A new vector spreadsheet appears listing the processed vectors in the project.

To navigate the spreadsheet:

- To select a vector, click in the left column for that row.
To display vector details:

- Select the vector (click on the left edge of the row) and press [F11] or right-click and select Properties. The Properties pane displays.

| Note: | The Delta X, Y, and Z values in the Vector Spreadsheet and the Vector List report reflect the distance from survey marker to survey marker, so Vector Length shows the distance of the ground slope. To see the Delta X, Y, and Z between antenna phase centers, view the vector’s properties in the Properties pane. |

To sort entries:

- Click on a column heading. An up ▲ or down ▼ icon appears in the selected column heading, indicating the current sort order (ascending or descending).

To copy data:

- Select data, and copy and paste it to a text editor (such as Microsoft® Notepad) by using the context menu or by pressing [Ctrl] + [C] to copy and [Ctrl] + [V] to paste. You can select all data by pressing [Ctrl] + [A].

To manage column display:

- Select Project > Project Settings. Then click View and Vector Spreadsheet. For each type of data, select to Show or Hide the column in the spreadsheet. To change the order of columns across the spreadsheet, click and drag the column heading to a new location.

Related topics

- Data View Display Formats (on page 38)
- Pane and Data View Positioning (on page 37)
- Select from Spreadsheet Views (on page 52)
- Tabbed View Arrangement (on page 40)
Time-Based View

The time-based view displays your data in a chronological format that makes it easy to visualize how session and occupation times relate to each other, helping you check for valid sessions.
Elements of the Time-Based View

1 - Timeline
Displays the span of one or more occupations in GPS time. The default view shows the time span for all project data, from the first occupation's start time to the end time of the last occupation. When you zoom to specific session data, the timeline changes to reflect the new time span.

The current time format is displayed on the status bar. Click it to access GPS time settings in the Units section of the Project Settings dialog.

2 - Sessions list
Lists all of the sessions in chronological order, from the earliest to the latest session in the project. This list is similar to the session tree in the Project Explorer.

Each session is defined by two concurrent or overlapping occupations.

Note: Continuous files from CORS stations are often logged, and import, in one-hour increments. Once they have been imported, however, they are concatenated (joined sequentially) into the single observation they represent.

3 - Session icon
Indicates whether the session is a static or kinematic session

- static
- kinematic

4 - Point ID of Upper Occupation
Identifies the upper occupation in the session. In the example, it is the blue bar in the view.

The same occupation can be represented in multiple sessions.

5 - Point ID of Lower Occupation
Identifies the lower occupation in the session. In the example, it is the green bars in the view.

6 - Chronological view
Plots each of the sessions, from start time to end time, in relation to the timeline.

When you move the cursor in the chronological view, the timeline displays the exact time represented by the pointer's position.
7 - Static occupation

Each occupation is graphically represented from start time to end time, in relation to the timeline and its session.

When you hover over an occupation in the chronological view, a tooltip displays the point ID and the duration of the occupation.

Clicking an occupation highlights and adds a border to it in all sessions, enabling you to see the relationship between sessions.

For static sessions, each bar represents a single occupation.

8 - Kinematic session display

The bar is broken to show stop-and-go occupations and/or continuous segments.

Occupation colors

<table>
<thead>
<tr>
<th>Color</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Blue</td>
<td>Static occupation, generally at the base station</td>
</tr>
<tr>
<td>Green</td>
<td>Static occupation, generally at the rover</td>
</tr>
<tr>
<td>Yellow</td>
<td>Kinematic occupation - continuous segment</td>
</tr>
<tr>
<td>White</td>
<td>Kinematic occupation - roving segment</td>
</tr>
</tbody>
</table>

Related topics

- Check Sessions (on page 286)
- Time-Based View Options (on page 286)
- Session Editor (on page 34)

Planning Utility

Use the Planning utility to plan and schedule a GPS project based on good and bad satellite coverage information.

To access the utility:

- Select Tools > Planning.

Note: The Planning software has its own help system. Open the utility and select Help > Index from the Planning menu or press [F1] within the software.

Check GNSS Data

Verify Static and Kinematic Data

After importing and checking-in your GNSS data, verify that it meets the quality acceptance criteria set in the Project Settings. Data not meeting the criteria is flagged in views, and listed in the Flags pane.
Identifying data in the Project Explorer

After data check-in, sessions are identified by specific icons.

<table>
<thead>
<tr>
<th>Data type</th>
<th>Icons</th>
</tr>
</thead>
<tbody>
<tr>
<td>Static</td>
<td><img src="image" alt="Static Data Icons" /></td>
</tr>
<tr>
<td>Kinematic</td>
<td><img src="image" alt="Kinematic Data Icons" /></td>
</tr>
</tbody>
</table>

To view point derivations:

1. Select one or more points from the Flags pane, the Project Explorer, or a data view.
2. Right-click and select **Point Derivation Report** from the context menu. The Point Derivations report (see "Run a Point Derivation Report" on page 282) displays detailed information about each point.

To remove a bad point from your project:

1. Select one or more points from the Flags pane, the Project Explorer, or a data view.
2. Right-click and select **Delete** from the context menu.

To view a summary of imported files:

- Select Reports > Import Summary. The Import Summary report displays.

Related topics
- Flags Pane (on page 13)
Run a Point List Report

Generate a *Point List* to see a simple summary of the coordinates for each point in your project.

**To run a Point List report:**

- Select **Reports > Point List**.

  The *Point List* displays in your default Web browser.

**To modify the report:**

- Select **Reports > Report Options**. Select *Point List* in the command pane, and click **OK**.

- In the *Settings* group at the bottom of the command pane, you can specify the type of coordinates (grid, local, or global), and the type of data to display. The data options include quality control information such as scale factors and convergence angle.

  **Tip:** Click a point ID in the report to select the point in graphic views and the *Project Explorer*.

**Related topics**

- [Customize and Run a Report](#) (see "Customize a Report" on page 481)

Run a Point Derivation Report

Generate a *Point Derivation Report* to see details on the survey data used to calculate the final coordinates of points in your project.

**To run a Point Derivation Report:**

- Select **Reports > Point Derivation Report**.

- Select **Reports > Report Options**. Select *Point Derivation Report* in the command pane, and click **OK**.

  The *Point Derivation Report* displays in your default Web browser.

  **Tip:** Click a point ID or coordinate in the report to select the point in graphic views and the *Project Explorer*.

**Related topics**

- [Customize and Run a Report](#) (see "Customize a Report" on page 481)
Calculate the Inverse Between Points

Calculate and report inverse values between any two points in your project, such as:

- Grid distance
- Change in elevation

Geodetic azimuth To calculate the inverse between two points:

1. Do one of the following:
   - Click the icon on the toolbar.
   - Select Survey > Inverse.
   
   The Inverse command pane displays.

2. Select Sequential to calculate values from point to point in series (as if drawing a multi-segment line), or Radial to calculate values from one point to multiple other points (as if drawing a fan).

   **Note:** You can switch between Sequential and Radial after picking any pair of points.

3. Pick the first point in a graphic view, or type a point ID in the From box.

   **Note:** You can also right-click in the view to access COGO controls (see "Understanding COGO Controls" on page 95) and snaps (see "Snaps Modes and Commands" on page 98) when picking points.

4. Pick another point, or type a point ID in the To box. The point IDs appear in the Reported Points group, and the inverse values appear in the Details group.

   **Note:** If Free appears in the Reported Points list, no point with a point ID was within the pick aperture. To prevent picking where there are no points, click the icon on the Inverse command pane's toolbar. In the Snap Mode dialog, uncheck Free, and click OK.

5. To calculate additional inverses, continue picking To points.

6. To review the details for any inverse, click in the first column of the Reported Points list.

7. To change inverse report options, click the icon to display the Report Options command pane. When you are done, click OK to return to the Inverse command.

8. To generate the Inverse Results report, click the icon at the top of the Reported Points group. The Inverse Results report displays in your default web browser.

   **Note:** If no coordinate system is defined, the Select Coordinate System dialog displays. Define a coordinate system and run the report again.

9. Click Close.
Related topics

- Customize and Run a Report (see "Customize a Report" on page 481)
- Inverse Options (on page 284)
- Measure Values Between Points (on page 144)

Inverse Options

Use these options to calculate and report the azimuth, distance, and other relationships between any two points. They are available in the Inverse command pane.
Options

Inverse
From/To

Pick points in graphic views, or type point IDs in the boxes and click Apply or press [Enter].

Note: If Free appears in the Reported Points list, no point with a point ID was within the pick aperture. To prevent picking where there are no points, click the icon on the Inverse command pane's toolbar. In the Snap Mode dialog, uncheck Free, and click OK.

Sequential – Data is collected in a line, and you want to verify distances around the traverse.
- For example, you will need to click on:  
  A to B, B to C, C to D, D to E, and E to A.

Radial – Data is collected in a ray, and you want to check distance from the base station.
- For example, you will need to click on:  
  A to B, A to C, A to D, and A to E.

Reported points

Click this to display the Inverse Results report in your default web browser.

Click this to display the Report Options command pan, in which you can specify heading, footer, and format settings for the Inverse Report.

From point ID/To point ID

Details

This shows the azimuths, changes in elevation and height, and three distances of the selected inverse:
- Grid
- Ellipsoidal
- Ground

Apply

This acts as the [Enter] key, when specifying points, moving the focus between From, To, and Reported Points.

Related topics
- Calculate the Inverse Between Points (on page 283)
Check Sessions and Occupations

Check Sessions

After you have imported GPS data, the time-based view displays your data in a chronological format that makes it easy to visualize how session and occupation times relate to each other, helping you check for valid sessions. In addition, you can select individual sessions or occupations in the view and edit their properties or process baselines.

To check sessions in the time-based view:

2. Select an occupation in the chronological view.
3. Right-click and zoom, or view occupation properties, as needed.
4. Select a session in the Sessions list.
5. Right-click and select an edit option, as necessary.

Related topics

- Session Editor (on page 34)
- Time-Based View (on page 32)
- Time-Based View Options (on page 286)

Time-Based View Options

Use these options to view, verify, and edit your session data. You can access them by right-clicking a session or occupation in the time-based view, and selecting from the context menu.
Options (for Sessions)

**Delete**  
Select this to remove the pair of occupations from the *Session* list.

**Session Editor**  
Select this to display the *Session Editor*, in which you can mark satellite data for the baseline processor to ignore, or disable all data from an individual satellite.

**Process baselines**  
Select this to run the *Process Baselines* command to produce vectors from the raw session data.

All selected sessions will be processed. Multiple sessions can be selected by pressing `[Ctrl]` when selecting.

**Properties**  
Select this to display the *Properties* pane, enabling you to edit the occupation, antenna, and position properties common to both occupations in the session.

Options (for occupations)

**Zoom occupation**  
Select this to scale the timeline to the extents of the selected occupation.

**Zoom session**  
Select this to scale the timeline to the extents of the session (overlap of the occupations).

**Zoom time extents**  
Select this to scale the timeline to the extents of all sessions in the project.

*Note:* The current time format displays on the status bar. Click it to access the *Units* section of the *Project Settings* dialog, where you can change the time format.

**Properties**  
Select this to open the *Properties* pane, enabling you to change the occupation, antenna, and position properties for the individual occupations.

Related topics

- Check Sessions (on page 286)
- Session Editor (on page 34)
- Time-Based View (on page 32)

Edit Sessions

Visually analyze the quality of the raw satellite data in your sessions, and use the *Session Editor* to:
Cross-out small regions of GPS observations, such as areas containing large numbers of cycle slips. You can also finely adjust cross-out times.

Disable problematic data when performing trial-and-error tests to improve baseline solution quality. If you find no improvement in baseline processing results after disabling a satellite, re-enable it.

**Note:** Satellites, GPS observations, and selected regions of GPS observations can be disabled and enabled, but some elements are protected and cannot be disabled directly. Items, such as ephemeris and station icons can only be disabled when their parent items are disabled.

**Note:** Disabling a satellite also disables all GPS observations associated with the satellite. It is possible to disable individual GPS observations and selected regions of a GPS observation.

**To edit sessions:**

1. Do one of the following:
   - Select a session in the plan view or **Project Explorer**, right-click and select **Session Editor** from the context menu.
   - Select **View > New Time-Based View**. In the time-based view, select a session in the **Sessions** list. Right-click and select **Session Editor** from the context menu.

   The **Session Editor** displays.

**To cross-out sections of data:**

1. Scan the occupations for gaps, and identify any sections of satellite data that you want to cross-out.

2. Window around each bad section of an occupation to cross out the data.

3. To adjust your cross-out, click it. Use the [Shift] or [Ctrl] keys, to multi-select cross-outs. The **Selected Time Slot** boxes display the begin and end cross-out times.

4. Edit the times in the **Start time** and **End time** boxes as needed. Click the **Apply Time Edits** button to apply the start and end times all at once.

5. To **clear or reset crossed-out sections**, right-click a satellite in the **Satellites** list and select **Remove All Time Slots** from the context menu. Use the [Shift] or [Ctrl] keys, to multi-select cross-outs.

**To disable a satellite:**

**Caution:** Before disabling a satellite, ensure that the geometry of the satellite constellation will not be adversely affected by removing that satellite.
1. Scan the occupations for gaps. Gaps in the L1 and L2 carriers could indicate satellite signal cycle slips, invalid range errors, and other signal loss problems.

2. Identify any satellites that you want to entirely disable.

3. Select a satellite in the **Satellites** list, right-click and select **Disable Satellite** in the context menu. You can also click on the satellite name on the right side. The line of data turns gray when disabled.

4. Reprocess the baseline and compare the processing results with the results from an earlier processing session.

5. After comparing the results of the two processing sessions, do one of the following:
   - If the baseline has improved, save the baseline solution to your project.
   - If there is no improvement in baseline quality, re-enable the satellite, and reprocess the baselines.

6. Click **OK**.

**Related topics**

- Check Sessions (on page 286)
- Session Editor (on page 34)
- Session Editor Options (on page 291)

**Session Editor**

When you find gaps in your GPS data in the time-based view, encounter sessions that won't process in the **Baseline Processor**, or have floating lines reported on the **Processor Report**, use the **Session Editor** to visually analyze the quality of the raw satellite data in a session. Gaps in the data could indicate antenna measurement errors, satellite signal cycle slips, invalid range errors, and other signal loss problems. To improve the quality of your processed baselines, use the **Session Editor** to:
Work with GNSS Data

- Disable unhealthy satellites
- Mask bad sections of satellite data
- Adjust occupation times

**Elements**

**Title bar**
This shows the name of the session you are viewing.

**Timeline**
This displays the times for each of the satellites used in the session. The default view shows the time span for all of the satellites, from the first occupation's start time to the end time of the second occupation. When you zoom to specific data, the timeline changes to reflect the new span.

**Satellite list**
This lists the satellites that contributed data to the session.

- GPS satellite names begin with G.
- GLONASS satellite names begin with R.

**Satellite ID**
This shows the name of the satellite.

**Time slot information**

- **Satellite** - This displays the name of the satellite you are editing.
- **Start time** - Edit the beginning of the cross-out.
- **End time** - Edit the end of the cross-out.

Click the **Apply Time Edits** button for these changes to take effect.

**Chronological view**
This plots each of the satellites, and the times they were visible in each of the two occupations in the session. Tick marks denote the beginnings of segments within occupations.

When you move the cursor in the view, the timeline displays the exact time represented by the cursor's position.

**Disabled satellite**
Gray indicates that a satellite has been disabled so it will not be considered in baseline processing.

**Time slot**
Cross-outs indicate that a section of the satellite data has been masked so it will not be considered in baseline processing.

**View session extents**
Enable this to display only the extent of the session (overlap of the occupations).

**Color Key**

- **Blue bar**
  Static occupation, generally at the base station

- **Green bar**
  Static occupation, generally at the rover

**Related topics**
- Check Sessions (on page 286)
- Edit Sessions (on page 287)
- Session Editor Options (on page 291)
- Time-Based View (on page 32)
Session Editor Options

Use these options to view and edit your data for an individual session. You can access them by right-clicking a satellite or occupation in the Session Editor, and selecting from the context menu.

Options

View session extents
Check this to scale the timeline to just the extent of the session (overlap of the occupations).

Right-click on a satellite in the Satellites list to access the context menu.

Options

Remove all time slots
Select this to clear all cross-outs from the satellite data.

Enable satellites
Select this to re-add both frequencies of the satellite data to the session so it is used in baseline processing.

Disable satellites
Select this to remove both frequencies of the satellite data from the session so it is not used in baseline processing.

Related topics

- Edit Sessions (on page 287)

Process Baselines

Workflow for Processing Baselines

1. Import (see "Import GNSS Files (.dat)" on page 219) or download your raw GNSS survey data.
2. Review and edit the data in the Raw Data Check-in (see "Check-In Raw GNSS Data" on page 220) dialog.
3. Download additional reference station or precise ephemeris data from the Internet (see "Download and Import Data Automatically" on page 242), as needed.
4. Check your occupations in the Occupations Spreadsheet (see "Points Spreadsheet" on page 28), and baselines in the plan view.
5. Use the Time-based View (see "Check Sessions" on page 286) to review how occupations and sessions relate to each other, and disable any baselines that should not be processed.
6. Cross-out sections of poor data, or disable entire satellites in the Session Editor (see "Edit Sessions" on page 287).
7. **Review** (see "Baseline Processing Settings" on page 165) and edit the baseline processing settings, and save a **settings style** (see "Apply a Baseline Processing Style" on page 303) in the Project Settings dialog.

8. **Process** (see "Process Baselines" on page 305) all or selected baselines in your project, changing the **processing order** (see "Change the Baseline Processing Order" on page 304), if needed.

9. Review the processing details in the Baseline Processing dialog.

10. Run summary and detailed **Baseline Processing Reports** (see "Run a Baseline Processing Report" on page 308) for one or more sessions.

11. Use vector statistics, tracking summaries, and residual plots in the processing reports to determine why certain baselines were flagged, or failed to process.

12. Run a **Point Derivation Report** (see "Run a Point Derivation Report" on page 282), **Loop Closure Report** (see "Run a Loop Closure Report" on page 310), or **Vector List Report** (see "Run a Vector List Report" on page 312), if you need more information.

13. Revisit the Time-Based View, Session Editor, and Baseline Processing settings to disable bad data and adjust acceptance criteria.

   **Note:** If you disable a baseline that has been processed, the associated vector result will be cleared.

14. Reprocess the baselines.

15. Run the **Loop Closure** (see "Run a Loop Closure Report" on page 310) command and review the Loop Closure Results. Repeat steps 4-15 as necessary.

16. Work through the **network adjustment workflow** (see "Workflow for Adjusting a Network" on page 352).

---

**Understanding Baseline Processing**

After you have imported and checked-in your GNSS data, you are ready to begin processing baselines to determine and use the highest quality coordinates for each point in your project. Prior to processing, you can specify the antenna model, and ephemeris type to use in the **Project Settings**. The baseline processor:
Work with GNSS Data

- Looks for overlaps in occupation times. If an overlap is determined to be long enough, it processes the baseline and creates a vector. Overlaps are shown in the Sessions section of the Project Explorer.
- Determines the processing order for generating the most accurate result. You can override the optimal order, if you choose.
- Calculates the mean of the coordinates for each individual occupation. The longer the occupation, the more accurate the solution.
- Processes both static and kinematic occupations, including "stop and go" sessions and continuous sessions.

Note: Kinematic segments cannot be processed using other kinematic data.

Related Topics
- Check-In Raw GNSS Data (on page 220)
- Process Baselines (on page 305)
- Workflow for Processing Baselines (on page 291)

GNSS Baseline Data Sources

The baseline processor uses measurements made by GNSS receivers to compute baselines. These measurements can be stored and referenced in a variety of file formats that are outlined in Import Data Formats (see "Importable Data Formats" on page 214) and Export Data Formats (see "Export and Upload Data Formats" on page 487), as well as formats from other manufacturer’s receivers (RINEX).

In addition to GNSS measurements, these sources also provide information that is used to determine how the GNSS measurements should be processed, such as when a receiver is stationary at a point, or when it is roving. This allows the baseline processor to categorize the GNSS measurements as shown below:

- Static / FastStatic
- Roving and continuous kinematic data
- Stop and go kinematic data

Baseline Collection Methods
Total measurement time of the occupations
Work with GNSS Data

**Static**

A long, stationary occupation over a single point

![Static Diagram]

**FastStatic**

Shorter, stationary occupations over multiple points with no data collected between them

![FastStatic Diagram]

**Kinematic**

Short, stop and go occupations with roving or continuous data between them

![Kinematic Diagram]

**Trimble data collector files**

These files typically contain information obtained during conventional surveys. The Trimble data collector files can be used to reference GNSS measurements used for post-processing when radio communication is not possible. In this case, the point information is stored in the data collector file and raw GNSS measurements are stored in a related .dat file for later processing. The GNSS measurements referenced by the data collector file are used by the baseline processor to compute baselines that could not be solved in real time.

Although the GNSS measurements are stored in separate .dat files, they can be loaded automatically by the import procedure because of the references in the data collector file itself. They do not have to be loaded as independent files.

Data collector files can include measurements collected during several survey sessions, each session potentially using different survey methods.

**Trimble receivers**

These files contain the measurements obtained by a Trimble receiver. These files are typically recorded to the receiver memory board, or to a memory card in a Trimble data collector. These files are downloaded from the survey device for processing. The measurements contained in these files are used by the processor to compute baselines using static, FastStatic and kinematic techniques.
Other receiver manufacturers

These files contain measurements obtained by a GNSS receiver. They are similar in content to .dat files, but are stored in the Receiver INdependent EXchange format (RINEX). The RINEX format is an ASCII representation of GNSS data collected by receivers. RINEX files include observation, navigation, and meteorological data.

RINEX files are typically obtained from base stations, such as from the IGS Tracking Network, the Continuously Operating Reference Stations (CORS) in the United States, or from other manufacturers’ software. The processor uses these files just as it does .dat files to obtain vector baseline solutions.

Related topics
- GNSS Data Collection Methods (on page 295)

GNSS Data Collection Methods

Static/FastStatic GNSS data

The following distinctions exist between the data collected during a Static survey session and FastStatic survey session.

For Static sessions, the receiver is assumed to:
- Remain stationary over a single point
- Collect data for a longer period of time than for FastStatic (30 minutes to several hours)

For FastStatic sessions, the receiver is assumed to:
- Collect data at several points during a session,
- Remain stationary while collecting data at each point
- Not collect data while the receiver is moving between points
- Collect data for a shorter period of time than for a static session

The most important distinction between Static and FastStatic is the minimum time required for the receiver to record data (the occupation time).

Static occupation times can range from 30 minutes to several hours or more in length for applications requiring the highest levels of precision and repeatability.
In general, longer baselines require longer occupation times. As occupation times increase, so does the confidence in the computed result. The time required to remain on station depends on the satellite constellation. The occupation time decreases as the number of satellites in view increases. Occupation times also depend on the length of the baseline being observed. Longer baselines, in general, require longer occupation times, regardless of the satellite constellation.

Static and FastStatic survey methods offer the highest possible GNSS precisions. Best results are usually achieved when you plan in advance to use Static and FastStatic data collection sessions in conjunction with one another.

**Kinematic vs. Static\FastStatic data**

The distinction between a Kinematic survey session and Static or FastStatic sessions is the mobile or roving action of the receiver while data is collected; receivers generally do not remain stationary while collecting kinematic data.

Another important distinction between Kinematic and Static/FastStatic survey methods is the occupation time. In Kinematic surveying, the station occupation time is dramatically shortened (after initialization). It can vary from minutes down to seconds, depending on the application. This allows for a highly productive survey; many data points can be collected in a short period of time.

However, this increased productivity has a disadvantage: the attainable precisions are lower than with the Static/FastStatic methods and the shorter occupations are more susceptible to multipath because of the smaller amount of data. The precisions associated with Kinematic surveying limit its use to GNSS applications where high precision is not a requirement.

Kinematic surveying requires an initialization step to solve for the unknown integer ambiguity in the GNSS signal when lock on the satellite is acquired. This ambiguity must be solved for during processing to obtain the high precision results required for survey applications.

Once initialization occurs, you can use short occupations at survey points. During processing, the initialization is applied to subsequent solutions. Therefore, once initialization occurs you only need an occupation time with enough data to obtain the new position.

**Roving and continuous kinematic data**

Continuous kinematic surveying lets you perform these operations:
- Map topographic features, such as profiles, cross sections, and contours
- Map the paths of moving vehicles, such as airplanes or boats

Continuous kinematic surveying has the same restrictions as Stop & Go Kinematic surveying. In Continuous Kinematic surveys, however, the baseline processor can solve for the receiver’s position not only when it is stationary, but also for each GNSS observation made while the rover is moving. Topographic surveys, for example, can be performed by logging data continuously over a project area, provided proper attention is paid to antenna heights.

**Note:** The baseline processor automatically assigns point IDs to **each of the continuous points**.

**Related topics**
- [GNSS Baseline Data Sources](#) (on page 293)

**Baseline Initialization Methods**

Initialization is the process in which a receiver initially acquires its location and stores almanac data.

**Known Point Initialization**

Known Point Initialization (KPI) is the fastest and most reliable of all the initialization types. Both the base and roving receivers are set up on known or previously surveyed points, and the rover stays stationary for at least 30 seconds on its point. The baseline processor uses the known coordinates as additional information during initialization.

**Postprocessed On-the-Fly initialization**

On-The-Fly (OTF) initialization requires maintaining a lock on five satellites. The base receiver is placed on a known point and collects GNSS measurements. The rover collects measurements for this same time period, but the rover is not required to remain stationary on any point for any specified length of time. The baseline processor can use this data for initialization, even if the rover was moving during the entire time the data was collected.
**Static initialization**

Static initialization requires the base receiver to occupy a known reference point while the rover occupies any other point. The rover stays stationary on its point for the amount of time required for a normal FastStatic occupation. The occupation time will vary according to the number of satellites available and the type of receivers used in the survey. Consider FastStatic occupation time recommendations and your own experience, based on satellite availability and local conditions.

**Reoccupation initialization**

Reoccupation initialization is similar to Known Point Initialization, except that the point occupied by the rover is not known ahead of time. Instead the rover occupies a point that was previously occupied in the same kinematic field session. An assumption is made that the baseline processor will be able to solve the baseline from the base to the rover for the previous occupation of that same point. If this assumption proves true, then that previous baseline solution can be used later for initialization. The rover should remain stationary over the previously occupied point for at least 30 seconds.

**Known Distance Initialization (Initializer Bar)**

Known Distance Initialization (KDI) is used during kinematic surveys and must be selected in the field software. Refer to your field software documentation for details.

**Related topics**

- [GNSS Data Collection Methods](on page 295)
- [GNSS Baseline Data Sources](on page 293)

**Enable and Disable Baselines**

Turn baselines off or on. Disabled baselines are not processed.

**To disable baselines:**

- Select one or more baselines in the **Project Explorer**, right-click and select **Disable**.
- Pick one or more baselines in a graphic view, right-click and select **Disable**.

**Note:** If a baseline has been processed and subsequently disabled, the resulting vector is cleared.
To enable baselines:

- Select one or more baselines in the Project Explorer, right-click and select Enable.
- Pick one or more baselines in a graphic view, right-click and select Enable.

To select and disable baselines by duration:

1. Deselect all objects by clicking a blank space in a graphic view.
2. Select Select > Advanced Select. The Advanced Select dialog displays.
3. In the Apply This Selection To group, specify whether to select from the currently selected objects or from all data, and whether to replace or add to the current selection.
4. Select Baselines in the Data type list.
5. Click Data with the following property and select Duration in the list.
6. Type the shortest duration that you want to use for processing baselines in the This value box.

   Note: The duration must be in the time format used by your computer's operating system, which is likely HH:MM:SS (Hours:Minutes:Seconds).

7. Click Apply to preview the results, or OK to make the selection and close the Advanced Select dialog.

Related topics

- Compute Project Command

Disable Dependent Baselines Before Network Adjustment

Network adjustment results should be based on a set of independent vectors. The number of independent baselines is equal to n-1, where n is the number of receivers recording data simultaneously. Since the number of possible baselines is (n(n-1))/2, a surveyor must identify the dependant baselines and use one of the procedures below to disable them.

Disable dependent baselines before processing

1. Download and import all receiver data.
2. Open the time-based view and click on a single session. Then [Ctrl]-click to select all the baselines using that session.
3. Open a plan view to view the highlighted baselines of session you are focusing on. You can identify the baselines to use in network adjustment.

**Tip:** Use the View Filter Manager to create two user-defined filters, one to display enabled baselines only and another to display disabled baselines only.

4. Use the context menu to disable dependent baselines.

5. Run Process Baselines using the independent baselines (enabled).

**Disable dependent vectors after processing**

1. Download and import all receiver data and, after appropriate quality assurance, process baselines.

2. You can use the time-based view to identify baselines created during a single session, or the vector spreadsheet and the plan view to view vectors associated with a single session.

3. Identify the vectors with worst processing statistics (in the vector spreadsheet) and change the status of the least desirable vectors to disabled. In a session with 3 receivers only one vector would be dependent.

4. All independent vectors marked as 'enabled' or 'enabled as check' are used in loop closure report. All 'enabled' vectors are tentatively used in the network adjustment.

**Tip:** You can either disable a dependent vector (created for each processed baseline) or you can disable the associated baseline. If you disable the baseline, the vector is deleted from the project.

**Note:** As it works now, baselines are selected from the time-based view. In the first workflow, the use can change baseline status in the time-based view. In the second workflow, the sessions can be viewed using the time-based view and the dependent vectors would be selected either from the plan view or the vector spreadsheet.

---

**Trajectories and Vectors**

A trajectory is a set of vectors, processed from continuous data, combined and stored as a single object. Using trajectories, instead of individual vectors, lets you select data more quickly, and lets the software display data more efficiently. This is important if your data contains hundreds or thousands of vectors. In addition, if vectors are combined into a trajectory, they can be manipulated as a single object.
Trajectories are created from individual vectors by default. There are times, however, when you may want to store trajectories as individual vectors, such as when you need to delete certain vectors, but not the entire set. You can disable using trajectories in Project Settings.

**Note:** Although using trajectories is a project setting, it can be changed before processing any set of data. The same set of data, however, cannot be processed as both a trajectory and individual vectors.

If you process individual vectors, instead of a trajectory, only the total number of vectors are reported. The individual processed or unprocessed vectors that would have been in the trajectory are not reported. Events are reported, regardless of whether you are using trajectories or individual vectors.

**Exporting Trajectories**

When you export a trajectory, this data is included:

- Vector components (vector list)
- Point positions (ASCII points)

**Related topics**

- **Store Continuous Data as Individual Vectors** (on page 302)
Store Continuous Data as Individual Vectors

Store individual vectors instead of combining them into a single trajectory when you need the ability to manipulate them separately.

**To store trajectories as individual vectors:**

1. Do one of the following:
   - Click **Settings** in the *GNSS Process Baselines* dialog.
   - Select **Project > Project Settings**. The *Project Settings* dialog displays.

2. Click **Baseline Processing** in the left pane.

3. Click **General**, and set **Store continuous as trajectory** to **No**.

4. Click **OK**.

**Related topics**

-  [Trajectories and Vectors](on page 300)
-  [Trajectory Options](on page 302)

Trajectory Options

Use these properties to control how trajectories display. They are available in the *Properties* pane when you select a trajectory.

**Options**

- **Trace**: Select this to show the points connected to form a line. No vectors are shown.
- **Points**: Select to show only points in the trajectory.
- **Vectors**: Select to show all of the points and their vectors.

**Related topics**

-  [Store Continuous Data as Individual Vectors](on page 302)
-  [Trajectories and Vectors](on page 300)
Apply a Baseline Processing Style

Use baseline processor styles to save processing settings in templates. Then you can quickly apply these styles to projects as needed. Styles are specific to your user name, so you can tailor them to your needs without affecting other users. Although processor styles appear under Project Settings, they are truly application settings; they can applied to any open project.

To apply a baseline processing style:

1. Do one of the following:
   - Select Project > Project Settings, and click Baseline Processing in the left pane.
   - Click Settings in the Process Baselines dialog.

   The Baseline Processing section of the Project Settings dialog displays.

2. Select a style in the Baseline Processing Styles list, and click Load.

3. Click OK in the confirmation message.

4. To change the style, click an option:
   - To create a new style based on the loaded style, change the settings, click Baseline Processing again, click New, and type a name and description in the New Style dialog.
   - To copy a style, retain the settings of the loaded style, click New, and type a name in the New Style dialog.
   - To rename a style, retain the settings of the loaded style, click New, and type a different name for the style in the New Style dialog. Click OK. Then, select the original style and click Delete. Click Yes.
   - To edit a style, change the settings, and click Save. You are prompted to confirm the save because the existing style will be overwritten and Undo is not available. Click Yes.
   - To remove a style from the list, click Delete. You are prompted to confirm the deletion because Undo is not available. Click Yes.
   - To change the current settings to those that were saved in the style, click Load. There is no “current style”. Loading a style simply changes the current state of the project settings in the dialog.

5. Click OK. The settings in the loaded style are applied to the project.
Related topics

- Baseline Processor Settings (see "Baseline Processing Settings" on page 165)
- Change Baseline Processor Settings (on page 304)

Change Baseline Processor Settings

Use baseline processing settings to control which baselines are processed, how processing is handled, which vectors are accepted, and how they are stored.

To change baseline processor settings:

1. Do one of the following:
   - Select Project > Project Settings.
   - Select Survey > Process Baselines to display the Process Baselines dialog, and then click Settings.

   The Project Settings dialog displays.

2. Select the Baseline Processing folder in the left pane.

3. Click each section and set the options as needed.

4. Click OK.

Related topics

- Apply a Baseline Processing Style (on page 303)
- Baseline Processor Settings (see "Baseline Processing Settings" on page 165)

Change the Baseline Processing Order

Change the processing order of baselines if you want to override the order determined by the application.

**Warning:** This software performs careful analysis of coordinate qualities to determine the optimal processing order. Changing the processing order is not recommended.

**Note:** The order in which you import data can affect the computation results.

To set the baseline processing order:

1. If baseline processing has begun automatically, click Stop in the Process Baselines dialog.

2. Click Order.
3. Select a row by clicking in the far left column.

4. Click the Top, Up, Down, or Bottom navigation buttons to reposition the selected row in the processing order. Baselines are processed from the top of the list to the bottom.

5. Click OK to save the new order, or Cancel to restore the optimal order. The Process Baselines dialog redisplay.

Related topic
- Process Baselines (on page 305)

Process Baselines

Process baselines to determine and promote the highest quality coordinates for each point in your project. Vectors are created from baselines using these points. You can process all of your project's baselines at once or select a subset to process.

Depending on your software license, you can process L1 data, or multi-frequency data.

To process baselines:

1. Pick the baselines that you want to process in a graphic view or in the Project Explorer. To select unprocessed sessions, select Select > Select Unprocessed Sessions. To process all of the baselines in your project, do not select anything. Selected baselines are highlighted in graphic views and the Project Explorer.

2. Do one of the following:
   - Click on the toolbar.
   - Select Survey > Process Baselines.

   The Process Baselines dialog displays, and processing begins. During processing, data for each baseline appears in the dialog.

   **Note:** The columns in the table can be sorted in ascending or descending order by clicking the column heading. You can also rearrange the table by clicking and dragging the column headings to new locations. When processing completes, the Save button appears.

3. To halt processing any time, click Stop. To resume, click Process. You can also set baseline processing not to automatically start in Project Settings.

4. To view the optimal processing order, click Order. To change the order, see Change the Baseline Processing Order (on page 304).
5. Click **Report** to view the *Baseline Processing Report*. If the processing results are unsatisfactory, edit the sessions and reprocess the baselines.

6. Click **Save** to compute the project and display the processed vectors. The points update with the new coordinate values. When you are done processing baselines, you are ready to proceed to loop closure and network adjustment.

**To view processed vectors:**

In graphic views, unprocessed baselines are blue-green, and processed baselines/vectors are blue. Vectors appear in the *Project Explorer* underneath their associated sessions. You can also select **Baselines** or **Processed Vectors** in the *View Filter* to see your results more clearly.

For a detailed list of all the processed and saved vectors, use the **Vector Spreadsheet** (on page 30). This is helpful if you need to process vectors in groups instead of all at once. To view a list of all the processed vectors in the project, you can also run a **Vector List** (see "Run a Vector List Report" on page 312) report.

**To clear previously saved processing results:**

- Select **Survey > Clear Processing Results**. The saved results for the last group of vectors processed are deleted, and the vectors are removed from graphic views and the Project Explorer.

**Related topics**

- [Baseline Processing Settings](#) (on page 165)
- Clear Processing Results
- **Vector Spreadsheet** (on page 30)
- **Run a Loop Closure Report** (on page 310)
- **Understanding Network Adjustment** (on page 351)

**Baseline Processing Options**

Use these options to review baselines after processing, or to access the processing order, settings, or report. They are available in the *Baseline Processing* dialog, which you can sort by any column.
Options

Save
After processing, uncheck the results that you do not want to save.

If a single vector is checked, the detailed report displays when you click Report.

Observation
This displays the IDs of the "from" and "to" points in the baseline.

Solution type
- **Fixed** - This denotes that the processor was able to resolve the integer ambiguity with enough confidence to select one set of integers over another.
- **Float** - This denotes that the processor was unable to resolve the integer ambiguity with enough confidence to select one set of integers over another.
- **X/X** - The numbers (Xs) denote the epochs processed/total epochs for the selected trajectories (roving segments).

Use this ratio to decide if the solution is of sufficient quality to use.

Horizontal precision (95%)
Shows the horizontal precision of the observation.

Vertical precision (95%)
Shows the vertical precision of the observation.

This denotes that the precision fell outside of the Flag acceptance criteria, as set in the Quality section of baseline processing settings (on page 165).

This denotes that the precision fell outside of the Fail acceptance criteria.

RMS
This shows the quality of the solution as a root mean square, based solely on the measurement noise of the satellite ranging observations, independent of satellite geometry.

Ratio
This shows the ratio of the variance of the second best solution divided by the variance of the best solution.

The baseline processor compares the two solutions with the lowest variance.

Only fixed solutions have ratios.

Length
This displays the distance between antenna phase centers for the processed vector.

Process/Stop/Save
Click Process to initiate or resume baseline processing.
Click Stop to halt processing.
Click Save to close the dialog, compute the project, and display the processed vectors. The points update with the new coordinate values.

Cancel
Click this to close the dialog and clear the results.
Work with GNSS Data

Order
Click this to display the Processing Order dialog, where you can see the optimal processing order and change it if needed.

Report
Click this to display the Baseline Processing Report, which shows the processing results.
If a single vector is selected, the detailed report displays when you click Report.

Settings
Click this to display the Project Settings dialog, where you can change baseline processing settings.

Related topics
- Process Baselines (on page 305)

Run a Baseline Processing Report

After you have processed baselines in your project, generate a Baseline Processing Report to review the solution types, precisions, and an acceptance summary for the processed baselines. Detailed reports are available for each processed session as well. Use these reports to determine which baselines need to be disabled or investigated further, and which settings may need to be adjusted before reprocessing.

To create and save a Baseline Processing Report:

1. Select Reports > Report Options. Select Baseline Processing Report in the command pane, and verify the column display and section display settings. See section display settings below. (optional)

2. Select one or more vectors in the project. To report on all of the processed baselines (vectors), make sure nothing is selected. To report on individual vectors, pick them in a graphic view, from the Project Explorer, or from the Vector spreadsheet.


4. To save the report, use the browser’s File > Save As feature.

Note: This is the only way to return to a report without regenerating it.
Baseline Processing Report - Summary

Summary report sections

Session details
Click one of these links to see a detailed baseline processing report on the vector.

Processing summary
This displays the number of baselines processed and the number of baselines that failed to process due to insufficient data that meets the acceptance criteria.

Note: A baseline that fails to process cannot be saved in the project.

Acceptance summary
This shows the acceptance criteria settings for this project, and the number of baselines passed, flagged, or failed against the criteria. The elevation mask setting is also shown. If data from specific satellites is set to be ignored, the satellite numbers are listed here.

Caution: A baseline that fails the acceptance criteria is not checked for saving by default.

Results table
This section includes a row for each processed baseline, including From and To points, the solution type (fixed or float), and a summary of the solution.

Observation: This column includes an assigned baseline identifier, such as "B1".

Failed sessions
This shows details on failed kinematic segments.

Failed baselines
This provides details the baselines that failed processing. The occupation status column indicates the reason for the failure.

Baseline Processing Report

Section options

Session details
This summarizes the observation or trajectory and how it was processed.

Baseline components
This section details coordinates of the baseline, and delta values from survey mark to survey mark.

Standard errors

Covariance matrix
This shows the covariance information.

Occupations
This lists receiver and antenna details for the points at either end of the session.

Note: The antenna phase center (APC) value is calculated based on the antenna type.
Work with GNSS Data

Tracking summary
This plot indicates the quality and continuity of the tracking of the L1 and L2 signals received from each satellite. For trajectories, multiple tracking summaries are shown. Gaps in the data indicate cycle slips (loss of lock).

Note: This may vary, depending on whether you are licensed for multi-frequency processing.

Residuals
This displays a residual plot for each the satellites used during processing, indicating the amount of noise in the solution. To display residuals, select Reports > Report Options. In the Settings group of the Report Options command pane, select Show in the Residuals box. Then rerun the report.

Note: Computing the residuals is CPU-intensive.

Messages
Messages report the ephemeris type used in processing and which satellites were below the elevation mask (and therefore not used).

Processing style
This shows the settings of the baseline processing style as set in Project Settings.

Related topics
- Baseline Processing Settings (on page 165)
- Customize and Run a Report (see "Customize a Report" on page 481)
- Process Baselines (on page 305)

Run a Loop Closure Report

After all the baselines in your project have been processed and saved, run Loop Closure to generate a Loop Closure Results report to identify any bad vectors. To ensure that the loop closure results are useful, structure your network so that the baselines create small closed figures. If all the baselines in a loop are from the same session, station setup errors that are common to all the baselines in that session cannot be detected.

The settings used for computing loop closure are set in Report Options.
To run a Loop Closure Results report:

1. Do one of the following:
   - Select Survey > Loop Closure.
   - Click \(\text{on the Survey toolbar.}\)

The Loop Closure Results report displays in your default Web browser.

**Caution:** Be sure no objects are selected before running loop closure; otherwise, you may get erroneous results.

2. Review the failed loop results to determine if there are any bad vectors. Bad lines can be disabled to ensure the quality of your project. If possible, replace a disabled line with a redundant line.

3. To disable a bad vector:
   - In the vector spreadsheet (on page 30), hover over the status column for the vector you are going to disable. On the drop-down menu, select Disabled. You can also disable a vector using the Properties pane. The status updates immediately.
   - To disable several vectors at once, multi-select them, and use the Disable Vectors command.

4. If necessary, disable vectors using different solutions until you are satisfied with the loop closure results. At this point, you are ready to move on to network adjustment.

To set the loop closure computation parameters:

1. Select Reports > Report Options.
2. Select Loop Closure Results in the Reports list.
3. Expand the Report Setting section in the Settings group.
4. Edit the report settings as needed.

**Note:** When you set the number of legs to use in each loop, if you select a number greater that 3, all loops with 3 or more legs (up to the number specified) are used in the loop closure computation.
Loop closure results

Summary

On the left are links that will take you directly to specific sections in the report.

This shows the number of loops, loops that passed, failed, and the pass/fail criteria.

Worst - Click this to select the worst loop in the project (of all those that failed).

Note: The number of legs to use per loop and the pass/fail criteria are set in Report Settings in the Report Options command pane.

Failed Loops

This provides details for each loop that failed the criteria.

Note: Click a vector name or point ID in any of the report sections to select it in the Project Explorer and graphic views.

Observations in Failed Loops

This lists the observations in failed loops and the number of occurrences in each loop.

Occupations in Failed Loops

This shows details about occupations in failed loops and the number of occurrences (the number of lines with bad occupations). This information can assist you in determining if you have a problem with an occupation, perhaps due to an incorrect antenna height.

Click a link in the Point column to select the point and all of the lines in failed loops derived from this point's occupation.

Click a link in the Observations column to select vector that was in a failed loop from this point's occupation.

Related topics

- Adjust a Network (on page 356)
- Customize and Run a Report (see "Customize a Report" on page 481)

Run a Vector List Report

Generate a Vector List to review the solution types and precisions for all the vectors created from processed baselines in your project. You can customize the report layout as desired, selecting what information to show. You can also select a trajectory and run the report to review the included vectors.

To run a Vector List:

- Select Reports > Vector List.
- Select Reports > Report Options. Select Vector List in the command pane, and click OK.

The Vector List displays in your default Web browser.
To customize the Vector List:

- In the Report Options command pane, select Vector List. In the Settings group, expand the Column selection section, and select Show or Hide for each type of data to control which columns show in the report.

Related topics

- Customize and Run a Report (see "Customize a Report" on page 481)

Understanding Baselines and Vectors (for TGO Users)

For those familiar with Trimble® Geomatics Office™ (TGO), it may be useful to understand the terminology used in this software. Unlike TGO, this software defines baselines as separate objects from vectors. Prior to processing baselines are created based on synchronous observations at two locations. After these baselines are processed, vectors are created. Here are some of the differences between baselines and vectors:

- Baselines appear as green lines; vectors appear as blue lines.
- Disabled baselines are not processed.
- Vectors are created from baselines that have been processed.
- When you clear processing results, the vectors are removed from the project.
- If a baseline has been processed and is subsequently disabled, it will have its vector result removed from the project.
- Disabled vectors are not used during network adjustment.

Process Event Data

When performing a kinematic or static GNSS survey, the user can use a receiver’s external trigger channel to record the time of one or more events during the survey. These are referred to as "event markers". Each event marker represents the precise time for which the user wants to determine a location (for example, when an aerial photograph is taken). Because event markers do not typically coincide with receiver measurement times, the position for the event marker must be calculated by interpolation during baseline processing in the software.
When a data file containing event data is imported into the software and baselines are processed, the software uses the event data to calculate positions for the event markers, which are displayed as diamond symbols in a trajectory in the Plan View. Following is an example of Plan View showing event markers in "Trace" display mode.

Note: If you import event data from a static GNSS survey, you must force the data to be processed as continuous data using the Force Continuous command.

Before processing event markers, be sure to set baseline processing settings (on page 165) appropriately for the type of event marker interpolation you want performed.

For instruction on exporting event data, see Export Event Data (on page 492).

Related topics
- Baseline Processing Settings (on page 165)
- Export Event Data (on page 492)
Work with Total Station Data

Understanding Total Station Data

Survey data acquired in the field using a total station and contained in a data file can be imported into the software and integrated, as necessary, with other data collected as part of a survey project (for example, GNSS or leveling data).

Total station data is displayed in the following areas of the software:

- **Project Explorer**
  
  Imported data is displayed in expandable nodes displayed beneath the *Import Files* node. Data used to define points is displayed in expandable nodes displayed beneath the *Points* node. You can expand and collapse nodes as necessary to view information. For more information, see [View Total Station Data in Project Explorer](on page 322).

- **Properties** pane
  
  Click any node in the *Project Explorer* to display its properties in the *Properties* pane. You can edit certain properties in the pane.

- **Mean Angle Residuals** dialog
  
  Right-click any mean angle node in the *Project Explorer* and select *Mean Angle Residuals* to view residuals for the mean angle and, if you want, disable any outlying observations. For more information, see [View and Edit Mean Angle Residuals](on page 330).
Work with Total Station Data

- **Mean Angle Report**
  
  Select **Reports > Mean Angle Report** to view details of how each mean angle was computed. For more information, see Run a Mean Angle Report (on page 331).

- **Graphical and spreadsheet views**
  
  View point information in any of the available graphic or spreadsheet views.

The type of total station data displayed in the software depends on the station setup type (see "Total Station Setup Types" on page 316) and measurement types (see "Total Station Measurement Types" on page 318) used for the survey.

**Related topics**

- Total Station Setup Types (on page 316)
- Total Station Measurement Types (on page 318)
- Workflow for Total Station Data (on page 320)
- View Total Station Data in Project Explorer (on page 322)
- View and Edit Mean Angle Residuals (on page 330)
- Run a Mean Angle Report (on page 331)

**Total Station Setup Types**

The software supports any of the following types of station setups in the imported total station data file. The different station setups support specific geometrics of known points for orientation.
### Work with Total Station Data

<table>
<thead>
<tr>
<th>Station setup type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>single backsight</strong></td>
<td>The coordinate for the occupied point must be keyed in, previously measured, or filled in at a later time. The coordinate for the backsight or the azimuth to the backsight must be keyed in or previously measured. All horizontal angles are measured relative to the backsight.</td>
</tr>
<tr>
<td><strong>station setup plus (multiple backsight)</strong></td>
<td>The coordinate for the occupied point must be keyed in, previously measured, or filled in at a later time. The coordinates for the backsights or the azimuths to the backsights must be keyed in or previously measured. All horizontal angles are measured relative to the first backsight. This setup has redundant information so it is easy to detect errors in the backsight coordinates, azimuths, or instrument setup.</td>
</tr>
<tr>
<td><strong>standard resection</strong></td>
<td>This setup type requires at least two backsight points. The coordinates for the backsights or the azimuths to the backsights must be keyed in or previously measured. All angles are measured relative to the first backsight. This setup can have redundant information so it is easy to detect errors in the backsight coordinates, azimuths, or instrument setup.</td>
</tr>
<tr>
<td><strong>Helmert resection</strong></td>
<td>This setup type is a variation of a standard resection setup type. Instead of using least squares to find the best fit of known points and observed data, a Helmert coordinate transformation is used.</td>
</tr>
<tr>
<td><strong>refline</strong></td>
<td>This setup type requires two points on a line, or one point and the azimuth of the line. The coordinate for the first point on the line must be keyed in, previously measured, or filled in at a later time. The azimuth to the second point or the coordinate for the second point must be keyed in or previously measured.</td>
</tr>
</tbody>
</table>
Total Station Measurement Types

The software supports any of the following types of measurements in the imported total station data file.
### Work with Total Station Data

<table>
<thead>
<tr>
<th>Measurement type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>distance offset</td>
<td>The surveyor measures to a convenient point near the object and enters Left/Right, Up/Down and In/Out position offsets so the object position can be calculated from the measured point. You can edit the three offset values and direction after importing the data.</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>horizontal angle offset</td>
<td>The surveyor measures to the side of the object, then he turns a horizontal angle to the center. The offset is a combination of the slope readings taken to a prism and the horizontal angle after aiming the instrument to the center of the measured object. Because these are measured values, you cannot edit them after importing the data.</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>vertical angle offset</td>
<td>The surveyor measures to a point above or below the object, then he turns a vertical angle to the center. The offset is a combination of the slope readings taken to a prism and the vertical angle after aiming the instrument to the center of the measured object. Because these are measured values, you cannot edit them after importing the data.</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>angle offset</td>
<td>The surveyor measures to a point to the side of the object and above/below the object, then he turns a horizontal and vertical angle to the center. The offset is a combination of the slope readings taken to a prism and the angles after aiming the instrument to the center of the measured object. Because these are measured values, you cannot edit them after importing the data.</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>circular object</td>
<td>The surveyor measures to a point directly in front of a circular object, then he turns an angle to either edge. The center and radius are calculated from these two measurements. Because these are measured values, you cannot edit them after importing the data.</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>dual prism offset</td>
<td>The surveyor measures to prism A and then to prism B. The position of the rod point is calculated from these measurements and from the B-C distance (the distance from the rod point to the nearest prism) the surveyor keys in.</td>
</tr>
</tbody>
</table>
You can edit the B-C distance and prism constants after importing the data.

Related topics
- Understanding Total Station Data (on page 315)
- Total Station Setup Types (on page 316)
- Workflow for Total Station Data (on page 320)
- View Total Station Data in Project Explorer (on page 322)
- View and Edit Mean Angle Residuals (on page 330)
- Run a Mean Angle Report (on page 331)

**Workflow for Total Station Data**

Use the following steps as a guideline for working with total station data you have imported into a project:

1. **Import** (see "Import Data" on page 212) the total station data file into your project. The data is displayed as **nodes** (see "View Total Station Data in Project Explorer" on page 322) located beneath the **Imported Files** node and the **Points** node in the **Project Explorer**.

2. Click **Reports > Import Report** to view information about the import and any related messages. The **Import Summary** report displays in a browser window.

3. Run a **Survey Report** to view complete information about imported total station data contained in a .job or .jxl file. For instructions, see **Run a Job File Report** (on page 476). Be sure to select the **Survey Report** style sheet for the report.

4. In **Project Explorer**, click the new imported data file node, which is located beneath the **Imported Files** node, and verify job information in the **Properties** pane. (See **View Total Station Data in Project Explorer** (on page 322).)
5. If necessary, fill in any coordinates from standard references.

6. Review the chronology and correctness of the imported data in the Project Explorer.

   Expand the nodes under the Imported Files node and review in chronological order (top to bottom) to ensure data was gathered correctly and good survey practices were followed.

7. As necessary, view information in the Project Explorer and in the Properties pane to verify information is correct.

   In the Properties pane, you can edit data entered manually in the field. But, you cannot edit measurements made by the device. If you find an error that cannot be corrected because the Properties pane field is read-only, the field crew must re-survey that portion of the project. You can delete the old station nodes that contain errors and import the file that contains the re-surveyed stations. If necessary, you can delete any redundant information.

   **Tip:** If a coordinate or azimuth appears to be missing, look for it earlier in the file. It could have been keyed in as part of an earlier setup or it may have been determined from a resection. Coordinates determined as part of a traverse appear later in the file because they can only be determined after the traverse is complete.

   **Tip:** To determine the angle between two observations, expand the nodes under the station from which the first observation is made. Click on that observation to view the horizontal angle to the first backsight. Then, click on the station setup node to view the orientation angle of the first backsight. Add these two numbers to determine the orientation angle of the first observation. Repeat this procedure for the second observation and subtract the two orientation numbers.

8. In Project Explorer, right-click any mean angle node and select Mean Angle Residuals from the context menu to display the Mean Angle Residuals dialog.

   Use this dialog to view and edit mean angle residuals (on page 330).

9. Select Reports > Mean Angle Report to view details (see "Run a Mean Angle Report" on page 331) of how each mean angle was computed.

10. Select Reports > Point Derivation Report to see how multiple observed measurements to the same point are being used by the software to compute the resultant coordinate, and how the measurements compare to each other.

    **Tip:** When viewing the Point Derivation Report, you are especially looking for unacceptably high residuals.

After total station data is imported into your project, you can view it in the graphical and spreadsheet views.
Related topics

- Understanding Total Station Data (on page 315)
- View Total Station Data in Project Explorer (on page 322)
- View and Edit Mean Angle Residuals (on page 330)
- Run a Mean Angle Report (on page 331)

CHAPTER

View Total Station Data in Project Explorer

Total station data is displayed as individual nodes under two top-level nodes in Project Explorer:

- **Imported Files** node
  
  This top-level node includes one or more data file nodes, each specifying a file containing GNSS, total station, and/or level field data that has been imported into the project. Individual total station nodes display beneath the file node(s) for imported total station data. Total station nodes are typically listed in the same chronological sequence as data was gathered in the field. For more information, see Total Station Nodes Sequence in Project Explorer (on page 328).

- **Points** node
  
  This top-level node includes a node for each point in the project. Individual total station nodes are displayed as appropriate beneath the points to which they pertain.

You can double-click any node to display its properties in the Properties pane. You can right-click any node to display a context menu that includes other options, depending on the node type.

For a description of how total station nodes are displayed in the Project Explorer, see the following topics:

- View Imported Total Station Data in Project Explorer (on page 323)
- View Total Station Data Associated with a Point in Project Explorer (on page 326)

Related topics

- Understanding Total Station Data (on page 315)
Each imported total station data file displays as an expandable node located beneath the *Imported Files* node in *Project Explorer* (select **View > Project Explorer**).

The types of nodes displayed beneath the data file node depend on the station setup type and measurement types contained in the file.

The sequence of nodes (top to bottom) displayed beneath the imported data file node reflects the chronological order in which data was gathered in the field. For more information, see **Total Station Nodes Sequence in Project Explorer** (on page 328).

The following table shows the possible node types and their relative position beneath the *Imported Files* node in *Project Explorer*.

**Note:** The following table is not intended to represent a single data file.

<table>
<thead>
<tr>
<th>Node type example</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Imported Files" /> Test.jxl</td>
<td>This is the Imported Files node. This is the imported data file node. The icon represents the source of the data. It is followed by the name of the file.</td>
</tr>
<tr>
<td><img src="image" alt="100 (S1)" /></td>
<td>This is a station node. The icon represents the survey instrument type. It is followed by the point ID and an &quot;S&quot; number in parenthesis that uniquely identifies the station.</td>
</tr>
<tr>
<td><img src="image" alt="Used last station setup" /></td>
<td>This is a note node. The icon is followed by the first few words of the note.</td>
</tr>
<tr>
<td><img src="image" alt="Single Backsight (99)" /></td>
<td>This is the station setup node. The icon is followed by the setup type (in this example, &quot;single backsight&quot;) and the associated backsight point ID(s) in parenthesis.</td>
</tr>
</tbody>
</table>
Nodes displayed beneath this one are typically coordinate and azimuth nodes, which show data that was keyed in during station setup.

This is a coordinate node.

The icon is followed by a coordinate point ID.

This node is typically displayed beneath a station setup node.

This is a coordinate node from a benchmark. The icon is followed by a coordinate point ID.

**Note:** To preserve the integrity of raw field data, you cannot edit coordinate properties for an imported coordinate displayed beneath the Imported Files node. However, you can edit coordinates displayed beneath the Points node.

This is an azimuth node.

The icon is followed by the occupation point ID, a dash, and the observed point ID. This is followed by an "A" number in parenthesis that uniquely identifies the azimuth.

This node is typically displayed beneath a station setup node.

This is a backbearing node.

The icon and name are followed by the point ID of the first backsight point. This is followed by an "R" number in parenthesis that uniquely identifies the backbearing.

Nodes displayed beneath this one are typically related observation nodes.

These are face 1 and face 2 total station observation nodes.

The icon is followed by the occupation point ID, a dash, and the observed point ID. This is followed by a "T" number in parenthesis that uniquely identifies the observation.

These are face 1 and face 2 backsight observation nodes.
100-99 (T53) The icon is followed by the occupation point ID, a dash, and the observed point ID. This is followed by a "T" number in parenthesis that uniquely identifies the observation.

201-202 (T54) This is a dual prism observation node. The icon is followed by the occupation point ID, a dash, and the observed point ID. This is followed by a "T" number in parenthesis that uniquely identifies the observation.

220-221 (T22) These are distance, angle, and circle offset nodes.

110-111 (T5) The icon is followed by the occupation point ID, a dash, and the observed point ID. This is followed by a "T" number in parenthesis that uniquely identifies the observation.

198-199 (T28) This is a mean angle node. It represents the combining and averaging of redundant observations to the same point.

99-100-200 (M3) This is a mean angle node. It represents the combining and averaging of redundant observations to the same point.

The icon is followed by the backsight point ID, a dash, the occupation point ID, another dash, and the observed point ID. This is followed by an "M" number in parenthesis that uniquely identifies the mean angle.

For more information on viewing and working with mean angles, see View and Edit Mean Angle Residuals (on page 330) and Run a Mean Angle Report (on page 331).

Rounds This is a rounds node. The icon is followed by the word "Rounds". Displayed beneath it are two or more sets of observations, which are represented by set nodes.

Set 1 This is a set node. It is nested under a rounds node. The icon is followed by the word "Set" and a number that identifies the set. Displayed beneath it are nodes representing observations made during the set.
Related topics

- Understanding Total Station Data (on page 315)
- Workflow for Total Station Data (on page 320)
- View Total Station Data in Project Explorer (on page 322)
- View Total Station Data Associated with a Point in Project Explorer (on page 326)
- Total Station Nodes Sequence in Project Explorer (on page 328)
- View and Edit Mean Angle Residuals (on page 330)
- Run a Mean Angle Report (on page 331)

View Total Station Data Associated with a Point in Project Explorer

Individual point nodes are displayed beneath the Points node in Project Explorer.

Beneath each point node, all total station, GNSS, and/or level data used to define the point are displayed as individual nodes. For total station data, this includes observation, mean angle, coordinate, and azimuth nodes.

**Note:** Station, station setup, backbearing, round, and set nodes, which are displayed beneath the Imported Files node, are not displayed under the Points node in Project Explorer.

The following table shows the possible node types and their relative nested position beneath the Points node in Project Explorer.

<table>
<thead>
<tr>
<th>Node type example</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>🕒 Points</td>
<td>This is the points node.</td>
</tr>
<tr>
<td>🕒 100</td>
<td>This is an individual point node. The icon is followed by the point ID. Observations to and from the point are listed as observation nodes beneath it. See the Point Derivation Report (Reports &gt; Point Derivation Report) to see how observations were used to establish the point.</td>
</tr>
</tbody>
</table>

If a point ID is displayed in red, there is a computational error associated with the point. For instructions on viewing computational error messages, see Select from the Flags Pane (on page 54). For a description of total station errors that can cause a red point ID, see Total Station Data Errors (on page 329).
Work with Total Station Data

- **Grid (Single Backsight.jxl)**
  This is a coordinate node.
  The icon is followed by the coordinate type and the source of the coordinate in parenthesis.

- **100-99 (A1)**
  This is an azimuth node.
  The icon is followed by the occupation point ID, a dash, and the observed point ID. This is followed by an "A" number in parenthesis that uniquely identifies the azimuth.

- **99-100-200 (M3)**
  This is a mean angle node. It represents the combining and averaging of redundant observations to the same point.
  The icon is followed by the backsight point ID, a dash, the occupation point ID, another dash, and the observed point ID. This is followed by an "M" number in parenthesis that uniquely identifies the mean angle.
  For more information on viewing and working with mean angles, see View and Edit Mean Angle Residuals (on page 330) and Run a Mean Angle Report (on page 331).

- **100-200 (T41)**
  This is a face 1 observation node.
  The icon is followed by the occupation point ID, a dash, and the observed point ID. This is followed by a "T" number in parenthesis that uniquely identifies the observation.

- **100-99 (T52)**
  This is a face 1 backsight observation node.
  The icon is followed by the occupation point ID, a dash, and the observed point ID. This is followed by a "T" number in parenthesis that uniquely identifies the observation.

- **201-202 (T54)**
  This is a dual prism observation node.
  The icon is followed by the occupation point ID, a dash, and the observed point ID. This is followed by a "T" number in parenthesis that uniquely identifies the observation.

- **220-221 (T22)**
  These are distance, angle, and circle offset
Total Station Nodes Sequence in Project Explorer

The sequence of nodes (top to bottom) nested beneath the imported data file node in the Project Explorer reflects the chronological order in which data was gathered. For example, the station setup node is above observations nodes because this is the sequence of events in the field.

Mean angle nodes are beneath rounds and backbearing nodes because observations must occur before calculations.

Even a backbearing node follows this rule, although it may appear not to. Consider a station setup plus in which observations to the backsight points are made to establish the orientation. It may seem as though the observations are collected first and then a backbearing is determined from them. But, what actually happens is very much like a surveyor setting the horizontal plate of a theodolite before making observations. This fixes or establishes the horizontal circle reading until the next time he changes it. Each plate change coincides with a backbearing node.

Performing a new setup is also like changing the plate because the instrument may not be put back exactly the same as a previous setup. Survey Controller will reset the horizontal circle reading to a user value under certain circumstances. This, of course, means a new backbearing node.

In a single backsight setup, this occurs whenever a face 1 observation to the backsight is made. In other setup types, different rules apply.
Total Station Data Errors

If a point ID is displayed in red in the Project Explorer, there is a computational error associated with the point. For instructions on viewing computational error messages, see Select from the Flags Pane (on page 54).

The following total station-related computational errors can occur:

<table>
<thead>
<tr>
<th>Error message</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Setup failed to compute</td>
<td>An undefined problem caused all setup computations to fail. No further information is possible.</td>
</tr>
<tr>
<td>Using check observation to backsight as fallback</td>
<td>This error occurs when there is only one check observation available to the backsight and it is being used to define the backsight. (Typically, the software does not use check observations for any real computations.)</td>
</tr>
<tr>
<td>Azimuth to backsight missing or not computable</td>
<td>This error occurs when the backsight azimuth is not present or some coordinates defining the azimuth are disabled.</td>
</tr>
<tr>
<td>Some backsight observations are missing or disabled</td>
<td>This error occurs when some or all backsight observations are either disabled or not present.</td>
</tr>
<tr>
<td>Resection computation not possible</td>
<td>This error occurs when numerical problems occurred in the resection mathematics.</td>
</tr>
</tbody>
</table>

Related topics

- Understanding Total Station Data (on page 315)
- Workflow for Total Station Data (on page 320)
- View Total Station Data in Project Explorer (on page 322)
- View Imported Total Station Data in Project Explorer (on page 323)
View and Edit Mean Angle Residuals

A mean angle represents the combining and averaging of redundant observations to the same point. You can view residuals for any mean angle and, if you want, disable any outlying observations.

**Note:** For mean angle residuals, all angles are normalized to the range of 0 to 360 degrees expressed in project units. All distances are displayed in project units.

**Note:** If you delete a mean angle from your project (that is, right-click the mean angle node in the Project Explorer and click **Delete**), all observations associated with the mean angle are also deleted.

**To view and edit residuals for a mean angle:**

1. To display the **Mean Angle Residuals** dialog, do either of the following:
   - Right-click the mean angle node icon in Project Explorer and select **Mean Angle Residuals** from the context menu.
   - Select the mean angle node icon in Project Explorer and select **Survey > Mean Angle Residuals**.

2. In the **Mean Angle Residuals** dialog, review the read-only data displayed in the various boxes in the top half of the dialog.

3. In the table, review the observations used to compute the mean angle and their residual values.

4. If necessary, uncheck the box in the **Enabled** column for any observation that you do not want used in the computation of the mean angle.

   If an unchecked observation has an opposite face observation in the same set, the opposite face observation should also be unchecked to ensure maximum accuracy.

   As you enable or disable observations, the means and residuals are re-calculated so you can immediately see the effects of the change. However, these changes are temporary and do not apply to the project until you click **OK**.

5. Optionally, click **Report** to view the **Mean Angle Report** (see "Run a Mean Angle Report" on page 331).

6. When you are done, click **OK**.

**Note:** Mean angles are computed differently in the software than in Survey Controller. In the software, turned angles are displayed with their standard errors. In the Survey Controller, they are displayed with residual and standard errors of backsight and foresight circle readings. This is not a problem, except that it makes comparisons of the two values impossible.
Run a Mean Angle Report

Run a *Mean Angle Report* to view details of how each mean angle was computed.

**To run a Mean Angle Report:**

- Select **Reports > Mean Angle Report**.
- Right-click a mean angle node icon in **Project Explorer** and select **Mean Angle Report** from the context menu.
- Click the **Report** button in the **Mean Angle Residuals** dialog.

The **Mean Angle Report** displays in your default Web browser.

**Note:** In the **Mean Angle Report**, all angles are normalized to the range of 0 to 360 degrees expressed in project units. All distances are displayed in project units.

The **Mean Angle Report** includes a separate table for each mean angle in the project. At the top of each table, the point ID, station ID, and backsight ID are displayed. Beneath that, the table includes a row of information for each enabled observation used to compute the mean angle. Information includes observed readings and residual values for the horizontal angle, vertical angle, and slope distance. The last row in the table displays the computed horizontal angle, vertical angle, and slope distance for the mean angle point.

**Tip:** Click any point in the report to select it in the **Project Explorer** and graphical and spreadsheet views, and display its properties in the **Properties** pane.

Related topics

- **Understanding Total Station Data** (on page 315)
- **Workflow for Total Station Data** (on page 320)
- **View Total Station Data in Project Explorer** (on page 322)
- **Run a Mean Angle Report** (on page 331)
Understanding Level Data

Level data acquired in the field using a Trimble DiNi level and contained in a data file can be imported into the software and integrated, as necessary, with other data collected as part of a survey project (for example, GNSS or total station data). During and after import, you can edit the level data as necessary.

The following diagram shows four segments in a typical level run.

Key to diagram:

- ✟ identifies a control point (point of interest).
- 1 ✟ identifies a benchmark control point.
- 2 ✟ identifies a control point used for a foresight for the preceding segment and a backsight for the following segment.
- 3 ✟ identifies an intermediate control point.
- 4 identifies a turning point that is used as a foresight for the preceding segment and a backsight for the following segment.
5 identifies a control point that is used as a foresight for the preceding segment. This could also be a benchmark.

Level data is displayed in the following areas of the software:

- **Project Explorer**
  
  Imported data is displayed in expandable nodes nested beneath the *Import Files* node. Point data is displayed in expandable nodes located beneath the *Points* node. You can expand and collapse nodes as necessary to view information. (See View Level Data in Project Explorer (on page 342).)

- **Properties** pane
  
  Click any node in the *Project Explorer* to display its properties in the *Properties* pane. You can edit certain properties in the pane.

- **Level Editor** dialog
  
  Right-click the level data file node in the *Project Explorer* pane and select *Level Editor* from the context menu to view and edit level data in the *Level Editor* (see "View and Edit Level Data" on page 336) dialog.

- **Graphical and spreadsheet views**
  
  Points computed from level data are displayed in graphic (if they include x and y coordinates) and spreadsheet views.

### Related topics

- [Workflow for Total Station Data](on page 320)
- [View and Edit Level Data](on page 336)
- [View Level Data in Project Explorer](on page 342)
- [Adjust Level Runs](on page 347)

### Workflow for Level Data

Use the following steps as a guideline for working with level data:

1. **Import** (see "Import DiNi Digital Level Files (.dat)" on page 234) the level data file into your project.
2. Review the imported level data in the Level Editor (see "View and Edit Level Data" on page 336) dialog, which displays automatically immediately following import, and make changes as necessary. For example, you can determine which points you want to create for the project, and enable or disable observations.

Tip: You can also display the Level Editor dialog any time after import by right-clicking the level data file node in the Project Explorer pane and selecting Level Editor from the context menu.

3. Review the Import Summary report to identify any errors, warnings, or messages associated with the import that require corrective action.

4. Review the chronology and correctness of the imported data in the Project Explorer.

Expand the nodes under the Imported Files node and review in chronological order (top to bottom) to ensure data was gathered correctly and good survey practices were followed. (See View Level Data in Project Explorer (on page 342).)

If necessary, edit leveling data properties in the Properties pane.

If you find an error that cannot be corrected because the Properties pane field is read-only, the field crew must re-survey that portion of the project. You can delete the old station nodes that contain errors and import the file that contains the re-surveyed stations. If necessary, you can delete any redundant information.

After level data is imported into your project, you can view the points computed from it in the graphic (if the points include x and y coordinates) and spreadsheet views.

Related topics

- Understanding Level Data (on page 332)
- View and Edit Level Data (on page 336)
- View Level Data in Project Explorer (on page 342)
- Adjust Level Runs (on page 347)

Import DiNi Digital Level Files (.dat)

DiNi digital level .dat (M5) files contain level data recorded in the field using a Trimble DiNi Digital level.

To import DiNi Digital level .dat files:

1. Do one of the following:

   - Click the icon on the toolbar.
   - Select File > Import.
The Import command pane displays.

2. Do one of the following:
   - Select a folder in the Import Folder list.
   - Click the icon to browse for a folder.

The default is the folder that you last imported from. The files contained in the selected folder appear in the Select File(s) area. The file names and file types are listed.

3. Select the DiNi digital level .dat file(s) you want to import.
   1. In the Settings section at the bottom of the Import command pane, change the Automatically Numbered Points properties if necessary.

   These properties help the software identify which points were auto-numbered by the DiNi level and which point IDs were entered by the user. Auto-numbered points typically are not points of interest and should not be created as points in the project.

   - Starting Point - Specifies the first point ID number of the range of point ID numbers in the file you want to specify as automatically numbered points that should not be created in the project.
   - Maximum Points - Specifies the maximum number of points in the file you want to be included in the range.
   - Increment - Specifies the increment to be used when identifying point numbers in the range.
   - Ending Point - Specifies the calculated ending point for the point range based on the other specified properties.

2. When you are done, click Import. The Level Editor dialog displays. In this dialog, you can see which level points were entered by the user (points of interest) and will be created in the project, and which points were automatically numbered by the DiNi and will not be created in the project. If necessary, you can make changes by checking or unchecking any point to include or not include it in the project. For instructions, see View and Edit Level Data (on page 336).
**Note:** If you import a text file with "Unknown" or "Mapping" coordinate quality into a project that already contains level point data, duplicate points will be created for points in the text file (lightweight points (see "Understanding Point Types" on page 364)) and points already in the project (normal points (see "Understanding Point Types" on page 364)) that have the same ID (that is, points will not merge as expected). To avoid this problem, import the text file first to create the lightweight points in the project, then import the level point data. The lightweight points from the text file will merge with the normal points from the other point data to create normal non-duplicated points. For more information, see Understanding Point Types (on page 364).

**Related topics**
- Import Data (on page 212)
- View and Edit Level Data (on page 336)

**View and Edit Level Data**

The **Level Editor** dialog is displayed automatically immediately after you import level data. You can also display it any time after import by right-clicking the level data file in the **Project Explorer** pane and selecting **Level Editor** from the context menu. The **Level Editor** dialog enables you to do the following:
Work with Level Data

- View all level readings from the field, and select any reading to be "enabled" (used for computation of level adjustment) or "disabled" (not used for computation of level adjustment).
- Select which points to import.
- Select to use raw or adjusted elevations in the project.
- View the sums of backsight distances and foresight distances.
- View the total misclosure and individual residuals for benchmarks and coordinates.
- View the elevation type for each point (benchmark, computed, or coordinate), including the start and end points, and change the elevation type as necessary.
- Manually enter benchmark heights and qualities.
- Assign an elevation coordinate already in the project that specifies height and quality that cannot be changed.
- Adjust level runs to spread any misclosure proportionately throughout all the measurements.
- Merge level runs.
- Specify whether or not to allow a network adjustment to the level data after import (that is, specify whether level data is imported as observations or coordinates).

Before you get started:

Import level data into the project as described in Import DiNi Digital Level Files (.dat) (on page 234).

To get started:

1. When you import a level data file (see "Import DiNi Digital Level Files (.dat)" on page 234), the Level Editor dialog automatically displays. Otherwise, you can display it at any time by doing either of the following:
   - Right-click the imported level data file in the Project Explorer and select Level Editor from the context menu.
   - Click Survey > Level Editor and select the imported level data file in the Select Leveling Files dialog.

   The Level Editor dialog displays a tab for each level run in the data file, allowing you to view and/or edit each run individually.

2. If more than one Run tab is displayed, select the tab whose run you want to view or edit.
At the top of the tab, you can view the sum of backsight distances and foresight
distances and the total misclosure to identify issues that might require corrective
action.

**To select options:**

1. At the top of the tab, select one of the following options:
   - Select **Use Adjusted Elevations** to use elevations in the project that have been
     adjusted for misclosure. When you select this option, the **Correction** column is
     displayed in the table instead of the **Misclosure** column. The **Correction** column
     shows the correction used for the computation of the elevation for each point
     based on the misclosure value associated with that point.
   - Select **Use Raw Elevations** to use elevations that have not been adjusted. When
     you select this option, the **Misclosure** column is displayed in the table instead
     of the **Correction** column. The **Misclosure** column shows the misclosure value
     for each benchmark or coordinate in the run.

2. If necessary, change the name of the run in the **Run Name** box.

3. In the **Columns** box in the lower left section of the dialog, select the columns you
   want to display in the table.

4. In the **Creation Options** box in the lower section of the dialog, select one of the
   following options:
   - **Allow Network Adjustment** – Select this option if you want all elevations of
     interest imported as delta elevations and, therefore, adjusted as part of a
     network adjustment.
   - **Prevent Further Adjustment** – Select this option if you want all elevations of
     interest imported as control coordinates and, therefore, not adjusted as part of
     a network adjustment.

**To work with data in the table:**

Each station point in the run is displayed in a table, along with the following
information about the point (assuming all **Columns** boxes are checked in the lower left
are of the dialog):
- The point ID
- Backsight, foresight, and/or intermediate rod readings associated with the point
- The change in elevation for the point based on the rod reading
- The raw elevation of the point based on the rod reading
- If the **Use Adjusted Elevation** box is checked, the correction required for the computation of the elevation for the point based on the associated misclosure value
- If the **Use Raw Elevations** box is checked, the misclosure value for each benchmark or coordinate in the run
- The adjusted elevation
- The type of elevation used for the point: benchmark, coordinate, or computed
- The distance from the instrument to the level rod for each reading
- If applicable, a description entered for a reading associated with the point

1. Ensure the boxes in the **Create** column are checked appropriately.
   - Points you want imported into the project (for example, control points) should be checked.
   - Points you do not want imported into the project (for example, turning points) should not be checked.

   See the following diagram for an example of control points (1, 2, 3, and 5) and a turning point (4).

2. If necessary, edit any point IDs in the **Point ID** column.
   
   If the icon displays following a point ID, the point ID is common to multiple runs. This can occur when the surveyor intentionally references the same point in multiple runs, in which case, no correction is required. It can also occur unintentionally when point IDs are automatically assigned in the level device for each run. In this case, you might need to rename one or more of the duplicate point IDs with unique point IDs, as necessary.

3. Ensure the enable/disable boxes in the **BS** (backsight), **IS** (intermediate), and **FS** (foresight) columns are checked appropriately.
Work with Level Data

- Readings you want included in the computation of a level adjustment should be checked (enabled).
- Readings you do not want included in the computation of a level adjustment should not be checked (disabled).

**Note:** Readings that were aborted in the field are imported as disabled (not checked).

*Note:* For each point, there must always be at least one backsight reading and one foresight or intermediate reading. Therefore, you can disable a reading for a point only if the point includes additional readings of the same observation type. For example, if a point includes two backsight readings, you can disable one of them, but not both.

4. If necessary, in the *Elevation Type* column change the type of elevation used for any point:
   - **Benchmark** – Select this option to specify that the elevation for the point be a manually entered benchmark elevation. Any point in the run can be designated as a benchmark.
   - **Coordinate** – Select this option to specify that the elevation for the point be a coordinate already assigned to the point in the project. A coordinate can be assigned to a point only if there is a corresponding point already in the project with a coordinate elevation.
   - **Computed** – Select this option to specify that the elevation for the point be computed based on rod readings, benchmark and coordinate elevations entered for the run, and any adjustments performed on the run.

5. If necessary, for any points assigned a *Benchmark* elevation type, do the following:
   a. Enter or change the value in the *Elevation Type* column.
   b. Click the **Quality** icon and select the appropriate quality option.

6. If necessary, enter or change any descriptions in the **Description** column.

**To adjust one or more of the level runs contained in the import file:**

When a level run is adjusted, any misclosures are distributed proportionately throughout all the measurements in the run.

**Note:** When multiple intermediate (IS) observations exist for the same point ID in a level run, the software includes the intermediate readings in the level adjustment (the IS boxes will be checked in the *Level Editor* dialog), just as it is done during a network adjustment. If you do not want these intermediate readings to be included in the level adjustment, either uncheck the IS boxes or rename the associated point IDs so they are not the same.

1. Click **Adjust Runs**. The **Adjust Runs** dialog displays.
2. In the Adjust Runs dialog, select the runs you want to adjust.
   
   These runs will all be adjusted simultaneously as one network. When runs have points in common, the recommended procedure is to adjust them together.

3. Click OK.

**To merge level runs contained in the import file:**

You can merge two level runs into one run if the last point ID in the first run selected for the merge matches the first point ID in the second run selected for the merge. For example, if the first run selected ends on point "1", the second run selected must start on point "1". This is helpful if two or more level runs were accidentally specified in the field for what should have been a single run (for example, one of the runs does not include a benchmark point). If necessary, you can merge another existing run with the newly created merged run using the same guidelines, and repeat as necessary.

1. Click Merge Runs. The Merge Runs dialog displays.

2. In the New Run Name box, enter the name for the new run.
   
   You can enter the name of one of the runs you are merging, or you can enter a new name.

3. In the Start With list, select the run whose observations you want to use for the first part of the new run.

4. In the Add This list, select the run whose observations you want to use for the second part of the new run.

5. Click OK. The Merge Runs dialog closes and the newly created run tab replaces the two merged run tabs in the Level Editor dialog.
   
   If necessary, you can now merge another existing run with the newly created merged run using the same guidelines and instructions.

**To complete viewing and editing:**

1. Repeat the preceding procedures as appropriate for each run you want to view and/or edit.

2. When you are done working in the Level Editor dialog, click OK.
   
   If the Level Editor dialog was displayed as part of a data file import, the import process completes and an Import Summary report displays, showing details of the import. Be sure to review any messages, warnings, or errors contained in the report to determine if any corrective action is required.

**Related topics**

- [Understanding Level Data](on page 332)
- [Workflow for Level Data](on page 333)
View Level Data in Project Explorer

Level data is displayed as individual nodes under two top-level nodes in Project Explorer:

- **Imported Files** node
  This top-level node includes one or more data file nodes, each specifying a file containing GNSS, total station, and/or level field data that has been imported into the project. Individual level nodes display beneath the file node(s) for imported level data. Level nodes are typically listed in the same chronological sequence as data was gathered in the field.

- **Points** node
  This top-level node includes a node for each point in the project. Individual level nodes are displayed as appropriate beneath the points to which they pertain.

You can double-click any node to display its properties in the Properties pane. You can right-click any node to display a context menu that includes other options, depending on the node type.

For a description of how leveling nodes are displayed in the Project Explorer, see one of the following topics:

- View Imported Level Data in Project Explorer (on page 342)
- View Level Data Associated with a Point in Project Explorer (on page 345)

Related topics

- Understanding Level Data (on page 332)
- Workflow for Level Data (on page 333)
- View and Edit Level Data (on page 336)

View Imported Level Data in Project Explorer

Each imported level data file displays as an expandable node located beneath the Imported Files node in Project Explorer (select View > Project Explorer). The way level data is displayed beneath the level data file node depends on whether the Allow Network Adjustment or Prevent Further Adjustment option was selected in the Level Editor dialog (see View and Edit Level Data (on page 336)).
For the following examples, assume the file being imported is named "test.dat" and contains one level run. The run began on BM1 and ended on BM2. In addition to the benchmarks, the surveyor specified three control points: 1, 2, and 100. The survey went in the direction of 1 toward 2 with 100 as an IS point between 1 and 2.

**Example 1: Allow Network Adjustment option selected in Level Editor dialog**

This option should have been selected if you want all elevations of interest to be left as delta elevation observations and, therefore, adjusted as part of a network adjustment. The data would display in Project Explorer as follows:

**Node type example**

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Imported Files</td>
<td>This is the Imported Files node.</td>
</tr>
<tr>
<td>Test.dat</td>
<td>This is the imported leveling data file.</td>
</tr>
<tr>
<td>BM1</td>
<td>This is a coordinate node from a benchmark.</td>
</tr>
<tr>
<td>BM2</td>
<td>This is a coordinate node from a benchmark.</td>
</tr>
<tr>
<td>BM1-BM2 (H1)</td>
<td>The icon is followed by the run's first coordinate point ID, a dash, and the last coordinate point ID. This is followed by an &quot;H&quot; number in parenthesis that identifies the run. Observation nodes are nested beneath it in chronological order. The data file can include multiple run nodes.</td>
</tr>
<tr>
<td>BM1-1 (E1)</td>
<td>This is a delta elevation observation node, which represents the change of elevation between two control points. The icon is followed by the backsight point ID, a dash, and the foresight or intermediate point ID. This is followed by an &quot;E&quot; number in parenthesis that identifies the observation.</td>
</tr>
<tr>
<td>1-100 (E2)</td>
<td>This is a delta elevation observation node.</td>
</tr>
<tr>
<td>1-2 (E3)</td>
<td>This is a delta elevation observation node.</td>
</tr>
<tr>
<td>2-BM2 (E4)</td>
<td>This is a delta elevation observation node.</td>
</tr>
</tbody>
</table>

**Example 2: Prevent Further Adjustment option selected in Level Editor dialog**
This option should have been selected if you want all elevations of interest to be converted from delta elevation observations into coordinates and, therefore, not adjusted as part of a network adjustment. The data would display in Project Explorer as follows:

### Node type example

<table>
<thead>
<tr>
<th>Node type example</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Imported Files</td>
<td>This is the Imported Files node.</td>
</tr>
<tr>
<td>Test.dat</td>
<td>This is the imported leveling data file. The icon is followed by the name of the file.</td>
</tr>
<tr>
<td>BM1</td>
<td>This is a coordinate node from a benchmark. The icon is followed by a coordinate point ID.</td>
</tr>
<tr>
<td>BM2</td>
<td>This is a coordinate node from a benchmark.</td>
</tr>
<tr>
<td>BM1-BM2 (H1)</td>
<td>This is a run node. The icon is followed by the run's first coordinate point ID, a dash, and the last coordinate point ID. This is followed by an &quot;H&quot; number in parenthesis that identifies the run. Observation nodes are nested beneath it in chronological order. The data file can include multiple run nodes.</td>
</tr>
<tr>
<td>1</td>
<td>This is a coordinate node from an adjustment. The icon is followed by the point ID.</td>
</tr>
<tr>
<td>100</td>
<td>This is a coordinate node from an adjustment.</td>
</tr>
<tr>
<td>2</td>
<td>This is a coordinate node from an adjustment.</td>
</tr>
</tbody>
</table>

**Note:** To preserve the integrity of raw field data, you cannot edit coordinate properties for an imported coordinate.

### Related topics

- [Understanding Level Data](on page 332)
- [Workflow for Level Data](on page 333)
- [View and Edit Level Data](on page 336)
- [View Level Data in Project Explorer](on page 342)
- [View Level Data Associated with Point in Project Explorer](see "View Level Data Associated with a Point in Project Explorer" on page 345)
View Level Data Associated with a Point in Project Explorer

The way imported level data is displayed beneath points in the Points node depends on whether the Allow Network Adjustment or Prevent Further Adjustment option was selected in the Level Editor dialog (see View and Edit Level Data (on page 336)).

**Example 1: Allow Network Adjustment option selected in Level Editor dialog**

This option should have been selected if you want all elevations of interest to be left as delta elevation observations and, therefore, adjusted as part of a network adjustment. The data would display in Project Explorer as follows:

<table>
<thead>
<tr>
<th>Node type example</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>❌ Points</td>
<td>This is the Points node. All point nodes are located beneath it.</td>
</tr>
<tr>
<td>❌ 1</td>
<td>This is an individual point node. The icon is followed by the point ID. Observation nodes associated with the point are nested beneath it.</td>
</tr>
<tr>
<td>✎ BM1-1 (E1)</td>
<td>This is a delta elevation observation node, which represents the change of elevation between two control points associated with point 1. The icon is followed by the backsight point ID, a dash, and the foresight or intermediate point ID. This is followed by an &quot;E&quot; number in parenthesis that identifies the observation.</td>
</tr>
<tr>
<td>✎ 1-100 (E2)</td>
<td>This is a delta elevation observation node.</td>
</tr>
<tr>
<td>✎ 1-2 (E3)</td>
<td>This is a delta elevation observation node.</td>
</tr>
</tbody>
</table>

**Example 2: Prevent Further Adjustment option selected in Level Editor dialog**

This option should have been selected if you want all elevations of interest to be converted from delta elevation observations into coordinates and, therefore, not adjusted as part of a network adjustment. The data would display in Project Explorer as follows:
### Node type example

<table>
<thead>
<tr>
<th>Node Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Points</td>
<td>This is the Points node. All point nodes are nested beneath it.</td>
</tr>
<tr>
<td>1</td>
<td>This is an individual point node. The icon is followed by the point ID. Observation nodes associated with the point are nested beneath it. If a point ID is displayed in red, there is a computational error associated with the point. For instructions on viewing computational error messages, see Select from the Flags Pane (on page 54). For a description of level errors that can cause a red point ID, see Level Errors (see &quot;Level Data Errors&quot; on page 346).</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Node Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>This is a coordinate node from an adjustment. The icon is followed by the point ID.</td>
</tr>
</tbody>
</table>

**Related topics**

- Understanding Level Data (on page 332)
- Workflow for Level Data (on page 333)
- View and Edit Level Data (on page 336)
- View Level Data in Project Explorer (on page 342)
- View Imported Level Data in Project Explorer (on page 342)

### Level Data Errors

If a point ID is displayed in red in the Project Explorer, there is a computational error associated with the point. For instructions on viewing computational error messages, see Select from the Flags Pane (on page 54).

The following level-related computational errors can occur:

<table>
<thead>
<tr>
<th>Error message</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Misclosure out of tolerance</td>
<td>This error occurs when there is enough redundancy in the leveling run to determine that the elevations computed in the run are out of tolerance. The usual reason for this is a misclosure that exceeds a limit.</td>
</tr>
</tbody>
</table>
Some delta elevation observations are missing or disabled

This error occurs when the elevation for a point cannot be determined because there is no path back to a benchmark. The usual reason is that an observation has been disabled or deleted.

Related topics
- Understanding Level Data (on page 332)
- Workflow for Level Data (on page 333)
- View and Edit Level Data (on page 336)
- View Level Data in Project Explorer (on page 342)

Adjust Level Runs

A level run can be adjusted during or after import to spread any misclosure proportionately throughout all the measurements in the run. You use the Level Editor dialog to adjust level runs.

**Note:** When multiple intermediate (IS) observations exist for the same point name in a level run, the software will include the intermediate readings in the level adjustment (the IS boxes will be checked in the Level Editor dialog). If you do not want these intermediate readings to be included in the level adjustment, either uncheck the IS boxes or rename the associated point IDs so they are not the same.

**To adjust level runs:**

1. When you import a level data file, the Level Editor dialog automatically displays. Otherwise, you can display it at any time by doing either of the following:
   - Right-click the imported level data file in the Project Explorer and select Level Editor from the context menu.
   - Click Survey > Level Editor and select the imported level data file in the Select Leveling Files dialog.

   The Level Editor dialog displays a tab for each run in the data file, allowing you to view and/or edit each run individually.

2. Click Adjust Runs. The Adjust Runs dialog displays.

3. In the Adjust Runs dialog, select the runs you want to adjust.

   These runs will all be adjusted simultaneously as one network. When runs have points in common, the recommended procedure is to adjust them together.
4. Click **OK**.

   **Note:** Performing an adjustment replaces any previously adjusted elevations, such as those from the instrument.

   You can view the adjusted results in the **Level Editor** dialog by selecting the **Use Adjusted Elevations** option in the upper left area of the tab.

5. When you are done working in the **Level Editor** dialog, click **OK**.

   For additional instructions on using the **Level Editor** dialog, see [View and Edit Level Data](on page 336).

   **Related topics**
   - Understanding Level Data (on page 332)
   - Workflow for Level Data (on page 333)
   - View and Edit Level Data (on page 336)
   - View Level Data in Project Explorer (on page 342)

### Merge Level Runs

You can merge two level runs into one run if the last point ID in the first run selected for the merge matches the first point ID in the second run selected for the merge. For example, if the first run selected ends on point "1", the second run selected must start on point "1". This is helpful if two or more level runs were accidentally specified in the field for what should have been a single run (for example, one of the runs does not include a benchmark point). If necessary, you can merge another existing run with the newly created merged run using the same guidelines, and repeat as necessary.

   **Note:** If a level data file you are importing includes a run that does not include a benchmark, see this note (see "Note on Level Runs Without Benchmarks" on page 349).

**To merge level runs contained in the import file:**

1. When you import a level data file, the **Level Editor** dialog automatically displays. Otherwise, you can display it at any time by doing either of the following:
   - Right-click the imported level data file in the **Project Explorer** and select **Level Editor** from the context menu.
   - Click **Survey > Level Editor** and select the imported level data file in the **Select Leveling Files** dialog.
The **Level Editor** dialog displays a tab for each run in the data file, allowing you to view and/or edit each run individually.

2. Click **Merge Runs**. The **Merge Runs** dialog displays.

3. In the **New Run Name** box, enter the name for the new run.

   You can enter the name of one of the runs you are merging, or you can enter a new name.

4. In the **Start With** list, select the run whose observations you want to use for the first part of the new run.

5. In the **Add This** list, select the run whose observations you want to use for the second part of the new run.

6. Click **OK**. The **Merge Runs** dialog closes and the newly created run tab replaces the two merged run tabs in the **Level Editor** dialog.

   If necessary, you can now merge another existing run with the newly created merged run using the same procedure.

7. When you are done working in the **Level Editor** dialog, click **OK**.

   For additional instructions on using the **Level Editor** dialog, see [View and Edit Level Data](on page 336).

**Related topics**

- [Understanding Level Data](on page 332)
- [Workflow for Level Data](on page 333)
- [View and Edit Level Data](on page 336)
- [View Level Data in Project Explorer](on page 342)

---

**Note on Level Runs Without Benchmarks**

If a level data file you are importing includes a level run that does not include a benchmark, the software will attempt to use a computed value for the first point in that run. It does this by locating the most recent point ID in a preceding run that matches the first point ID in the run that is missing a benchmark. If it finds a matching point ID, it copies the elevation from that point to the first point ID in the run that is missing a benchmark as a computed elevation.
For example, if the first point ID in the run that is missing a benchmark is 100, and the most recent previous instance of a point ID of 100 is found at the end of the preceding run, the elevation for point 100 in the preceding run is copied to the elevation for point 100 in the run that is missing a benchmark as a "Computed" value. In this case, you may not need to merge the runs.

Related topics

- [Understanding Level Data](on page 332)
- [Workflow for Level Data](on page 333)
- [View and Edit Level Data](on page 336)
- [View Level Data in Project Explorer](on page 342)
Adjust Networks

Understanding Network Adjustment

Use network adjustment to perform a least squares adjustment of your network of processed vectors. The purpose of the adjustment is to:

- Estimate and remove random errors
- Provide a single solution when there is redundant data
- Minimize corrections made to the observations
- Detect blunders and large errors

Generate information for analysis, including estimates of precision. After a least squares adjustment is successfully performed, you can determine that:

- There are no blunders and systematic errors in the observations and control points.
- Any remaining errors are small, random, and properly distributed.

A least squares adjustment ensures good positional closures and estimates of repeatability; thus, it ensures the reliability of your current and future measurements.

To complete a successful adjustment, a least squares network must meet these criteria:
- The network must close geometrically and mathematically.
- The sum of the weighted squares of the residuals must be minimized.

**The network adjustment process**

All adjustment iterations are performed automatically when the process begins. Coordinates are shifted based on a fixed point, within tolerance levels that are set to limit the shift and end iterations. Once the residuals of the observations pass the criteria to end iterations, the adjustment stops (converges), and these functions are performed:

- The adjusted values for each point in the network are saved to the project as the current coordinate values, with qualities of *Adjusted* or *Fixed in network adjustment*.
- An additional coordinate is created for each adjusted point. The adjusted coordinate is promoted as the final value for the point.
- The adjusted values for each point appear in the *Properties* pane. You can analyze the results in the *Network Adjustment Report*.

**Related topics**

- [Adjust a Network](#) (on page 356)
- [Workflow for Adjusting a Network](#) (on page 352)

**Workflow for Adjusting a Network**

1. Work through the baseline processing workflow (see "Workflow for Processing Baselines" on page 291).
2. Review and edit the Network Adjustment settings (on page 170), and save a settings style in the Project Settings dialog.
3. Open the network adjustment (see "Adjust a Network" on page 356) command.
4. Fix control quality coordinates.
5. Add additional control coordinates (see "Add a Coordinate to a Point" on page 367) to your project if needed.
6. Adjust the network.
7. Review the adjustment results (see "Network Adjustment Options" on page 358) and error ellipses in the plan view to determine horizontal and vertical residuals.
8. Revisit the Network Adjustment settings to edit setup errors and other parameters, as needed.
9. Apply **scalars** (see "Network Adjustment Options" on page 358) to variance groups for the next adjustment.

10. Readjust the network.

11. Run the **Network Adjustment Report** (see "Run a Network Adjustment Report" on page 361) to review the final results.

## Enable and Disable Vectors

Turn vectors off or on. Disabled vectors are not used during network adjustment.

**To disable vectors:**

- Select vectors in the **Project Explorer**, right-click and select **Disable**.
- Pick vectors in a graphic view, right-click and select **Disable**.

**To enable vectors:**

- Select vectors in the **Project Explorer**, right-click and select **Enable**.
- Pick vectors in a graphic view, right-click and select **Enable**.

**To select and disable vectors by duration:**

1. Deselect all objects by clicking a blank space in a graphic view.
2. Select **Select > Advanced Select**. The **Advanced Select** dialog displays.
3. In the **Apply This Selection To** group, specify whether to select from the currently selected objects or from all data, and whether to replace or add to the current selection.
4. Select **Vectors** in the **Data type** list.
5. Click **Data with the following property** and select **Duration** in the list.
6. Type the shortest duration that you want to use for processing vectors in the **This value** box.

**Note:** The duration must be in the time format used by your computer's operating system, which is likely HH:MM:SS (Hours:Minutes:Seconds).

7. Click **Apply** to preview the results, or **OK** to make the selection and close the **Advanced Select** dialog.
Adjust Networks

- Press [F11] to display the Properties pane. In the Status box, select Disabled.

Related topics
- Compute Project Command

Apply a Network Adjustment Style

Use adjustment styles to save network adjustment settings in templates. Then you can quickly apply these styles to projects as needed. Styles are specific to your user name, so you can tailor them to your needs without affecting other users. Although styles appear under Project Settings, they are truly application settings; they can be applied to any open project.

To apply a network adjustment style:

1. Do one of the following:
   - Select Project > Project Settings, and click Network Adjustment in the left pane.
   - Click the icon on the Network Adjustment command pane's toolbar.
   
   The Network Adjustment section of the Project Settings dialog displays.
2. Select a style in the Network Adjustment Processing Styles list, and click Load.
   
   Note: If you load a network adjustment style that was created with an earlier version of the software, it may contain default GNSS error settings, which cannot be loaded with the other network adjustment settings. You can view and edit default GNSS error settings in the Default Standard Errors section of the Project Settings dialog.
3. Click OK in the confirmation message.
4. To change the style, click an option:
   - To create a new style based on the loaded style, change the settings, click Network Adjustment again, click New, and type a name and description in the New Style dialog.
   - To copy a style, retain the settings of the loaded style, click New, and type a different name for the style in the New Style dialog. Click OK. Then, select the original style and click Delete. Click Yes.
Adjust Networks

- To **edit a style**, change the settings, and click **Save**. You are prompted to confirm the save because the existing style will be overwritten and **Undo** is not available. Click **Yes**.

- To **remove a style** from the list, click **Delete**. You are prompted to confirm the deletion because **Undo** is not available. Click **Yes**.

- To **change the current settings** to those that were saved in the style, click **Load**. There is no "current style". Loading a style simply changes the current state of the project settings in the dialog.

5. Click **OK**. The settings in the loaded style are applied to the project.

**Related topics**

- [Change Network Adjustment Settings](#) (on page 355)
- [Network Adjustment Settings](#) (on page 170)

### Change Network Adjustment Settings

Use network adjustment settings to control how networks of processed baselines are adjusted.

**To change network adjustment settings:**

1. Do one of the following:
   - Select **Project > Project Settings**.
   - Click the ![Network Adjustment](icon) icon on the **Network Adjustment** command pane's toolbar.

   The **Project Settings** dialog displays.

2. Click **Network Adjustment** in the left pane.

3. Set **network adjustment settings** (on page 170) as needed.

4. Click **OK**.

**Related topics**

- [Apply a Network Adjustment Style](#) (on page 354)
- [Network Adjustment Settings](#) (on page 170)
Adjust Networks

Adjust a Network

Adjust your networks after you have processed the baselines and reviewed the Loop Closure Results report to ensure the quality of your project. You can adjust one network at a time. You need to fix at least one point horizontally and one point vertically to do a least squares adjustment. They do not have to be the same point, and the horizontal fix can be either latitude and longitude, or northing and easting. If you have control quality elevation and height for the same point, you can fix only one or the other (or neither). You cannot fix elevations for GNSS points unless you have a coordinate system with a geoid defined. With no geoid model, you can only fix a height. You can add new control coordinates and disable observations with the Adjust Network command open.

To adjust a network:

1. Do one of the following:
   - Select Survey > Adjust Network.
   - Click on the survey toolbar.

   The Adjust Network dialog displays.

   **Note:** Adjust Network computes final points using only vectors in an "enabled" state.

2. Click the Fixed Points tab to see the control quality coordinates in your network.

1. To fix a horizontal or vertical coordinate in the network, check its 2D, h (ellipsoid height), or e (elevation) boxes. Coordinate fixes that are not possible are unavailable. To add another coordinate to the network, use the Add Coordinate command.

   **Note:** The Fixed Points list is populated in real-time; you can leave the command pane open, and it will update as you add control coordinates to your project.

2. Click Adjust. The network is adjusted using the fixed coordinates. The status of the adjustment displays above the Adjust button, and the Results tab appears. Error ellipses (if any) appear in graphic views, showing the magnitude and direction of point errors.

   **Note:** If you have unresolved computation errors, revisit the Baseline Processing Report or Flags pane, and resolve or disable problematic baselines before adjusting the network.

3. Click the Results tab to view the status of the adjustment.
4. Pick points and vectors in a graphic view or the Project Explorer to review their errors and residuals in the Results tab. You can select a subset of the results in the drop-down list below the results summary.

5. For details, click the icon on the command pane’s toolbar to display the Network Adjustment Results (see "Run a Network Adjustment Report" on page 361) report in your default Web browser.

6. To set the error estimate scalars for the next adjustment based on the reference factor from the previous adjustment, click the Weighting tab. Scalar boxes are available for what is enabled in your project.

7. Type a value to multiply by in each of the Scalar boxes, as needed. The goal is to get the Reference Factor to 1.00.

8. Click the icon. In each variance group, the reference factor from the last network adjustment is multiplied by the scalar; the new value appears in the Scalar box.

9. Make changes to the network adjustment settings (see "3D View Settings" on page 44) as well, if needed.

10. Click Adjust again. Repeat the steps above until the adjustment results are satisfactory.

11. Click OK to save the network adjustment results to your project. To exit the command without performing an adjustment or without saving the adjustment results, click Cancel. After network adjustment completes, points that were adjusted are marked Adjusted in the Project Explorer, and are marked with an icon in the plan view and Properties pane.

12. Click OK to save the adjustment.

Caution: If you exit the command without clicking OK, the adjustment results are not saved.

To clear a network adjustment:

Select Survey > Clear Adjustment Results. All of the adjusted coordinate records are removed.

Related topics

- Network Adjustment Options (on page 358)
- Understanding Network Adjustment (on page 351)
Network Adjustment Options

Use these options to fix control points, apply error estimate scalars, and adjust a network of vectors. They are available on the three tabs of the Adjust Network command pane.
Options

- Click this to display the Network Adjustment Report in your default web browser.
- Click this to open the Project Settings dialog, where you can change the network adjustment settings.
- Click this to clear the adjustment transformation parameters, all coordinate fixes, and any adjustment flags. This also resets all weighting scalars to 1.00, removes the error ellipses from graphic views, and recomputes the project.
- Click this while in the Fixed Point tab to check the possible combinations of 2D, h, and e boxes, thereby fixing points in the available ways.

When multiple fix options exist, fixes will be applied in this order:

1. Grid
2. Local
3. Global

- Click this while in the Fixed Point tab to uncheck all of the 2D, h, or e boxes.
- Click this while in the Weighting tab to reset all scalars to 1.00.

Fixed coordinates tab

<table>
<thead>
<tr>
<th>Point ID</th>
<th>This shows the names of the control points that can be fixed.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Note:</td>
<td>This list is populated in real-time; you can leave the command open, and it will update as you add control coordinates.</td>
</tr>
<tr>
<td>Type</td>
<td>This shows whether the coordinate is based on grid, local, or global coordinates.</td>
</tr>
<tr>
<td></td>
<td>Global and local coordinates cannot be fixed for the same point at the same time.</td>
</tr>
<tr>
<td>2D</td>
<td>Check this to fix coordinates by northing and easting, or latitude and longitude.</td>
</tr>
<tr>
<td>h</td>
<td>Check this to fix the coordinate by its ellipsoid height.</td>
</tr>
<tr>
<td>e</td>
<td>Check this to fix the coordinate by its elevation.</td>
</tr>
</tbody>
</table>

Weighting tab

| Reference factor from last adjustment | This displays the variance used in the last network adjustment. |
|                                      | 1.00 appears in boxes for which there are no prior adjustment factors. |
**A priori factor for the next adjustment**

Type a value by which to scale the next adjustment, as compared to the last adjustment.

The goal is to get the **Reference Factor** to 1.00.

Click the icon to multiply the reference factor from the last adjustment by the scalar you entered. The new value appears in the scalar box.

**Geoid separations**

**Azimuths**

**RTK vectors**

**Imported postprocessed vectors**

**Postprocessed vectors**

**Results tab**

**Reference factor**

This shows the standard error of unit weight. Ideally, this will be 1.00 when you apply weight variances using scalars.

**Chi square test (95%)**

This displays whether the adjustment has passed or failed the overall statistical test of the network adjustment. It is a test of the sum of the weight squares of the residuals, the number of degrees of freedom and a critical probability of 95 percent or greater.

The purpose of this test is to reject or to accept the hypothesis that the predicted errors have been accurately estimated.

**Degrees of freedom**

This shows the remaining degrees of freedom, which are a measure of the redundancy in a network.

**(sub-selection filter)**

Select a subset of the results to shorten the list.

**(Point and vector list)**

This displays statistics and the status of the adjusted coordinates, including any warnings and errors. Outlying observations (based on the Tau criterion) are flagged. Investigate and resolve these issues.

Select objects in the **Project Explorer** or in a graphic view to add them to the list.

These error ellipse images indicate the relative magnitude and direction of the adjustment’s horizontal and vertical residuals.

Investigate and resolve the points with the largest ellipses first.
Adjust

Click this to start the network adjustment process using the fixed coordinates. The status of the adjustment displays, and error ellipses (if any) appear in graphic views, showing the magnitude and direction of point errors. The larger the error, the larger the ellipse.

Related topics

- Adjust a Network (on page 356)

Run a Network Adjustment Report

After you adjust a network, generate a **Adjust Network Report** to review successful adjustment statistics, such as the adjusted grid and geodetic coordinates, adjusted observations, and covariance terms. You can also use the report to review error ellipse and residual details to determine which vectors need to be disabled, how control points should be fixed, and which settings may need to be changed before re-adjusting the network.

**To run a Network Adjustment Report:**

- Click the icon on the **Network Adjustment** command pane toolbar.
- Select Reports > **Network Adjustment Report**.
- Select Reports > **Report Options**. Select **Network Adjustment Report** in the command pane, and click **OK**.
  
The **Network Adjustment Report** displays in your default Web browser. Click any link in the left pane to view a specific section.
## Report components

### Adjustment settings
This shows the set-up error values and covariance display formats as set in *Project Settings*.

### Adjustment statistics
This summarizes the number of iterations it took to adjust the network, and why the adjustment passed or failed.

*Reference factor* indicates how much adjustment was necessary, whether the random errors in the observations are acceptable, and if they match the estimated standard errors for those observations.

The reference factor should be about equal to 1.0. This value lets you know how well the adjustment a priori (pre-adjustment) errors are matching the a posteriori (post-adjustment) errors.

### Adjusted grid coordinates
This section shows the adjusted northing, easting, elevation, and computed standard errors for each grid point used.

The *Fixed* column indicates which point coordinates were fixed (constrained) during network adjustment.

### Adjusted geodetic coordinates
This shows the adjusted latitude, longitude, and height values.

The *Fixed* column indicates which point coordinates were fixed (constrained) during network adjustment.

### Error ellipse components
This section shows the magnitude and direction of the point errors.

### Adjusted GPS observations
This displays the adjusted observation components, including the standard error, residual (how much of an adjustment had to be made) and standardized residual.

The observations are sorted to display the worst standardized residual at the top.

**Note:** Observations with a standardized residual that fails the Tau criteria display in red. These observations are outliers. Examine these to justify keeping them in the network.

### Covariance terms
This shows the relative error in any pair of points in the project. The a-posteriori error and the horizontal (2D) and 3D precision are shown for each observation. The precision can be shown as a ratio or as ppm, depending on your project settings.

## Related topics
- [Adjust a Network](on page 356)
Adjust Networks

- Customize and Run a Report (see "Customize a Report" on page 481)
- Network Adjustment Settings (on page 170)
Understanding Point Types

The software supports two basic types of points:

- **Normal points** are created when you import into your project any type of point data other than coordinate point data contained in a text file (for example, .csv) with "Unknown" or "Mapping" quality. You can also create normal points manually using the **Point > Create Point** command.

  A normal point includes one or more coordinate and/or observation nodes nested beneath it in **Project Explorer** that are used to compute the coordinate for the point. You can edit values for coordinate nodes, or change the coordinate quality level, in the **Properties** pane. These changes are reflected in the non-editable coordinates displayed for the point in the **Properties** pane.

- **Lightweight points** are created only when you import a text file (for example, .csv) containing coordinate point data with "Unknown" or "Mapping" quality (for example, topographic points).

  A lightweight point does not include coordinate nodes nested beneath it in **Project Explorer**. A non-editable coordinate is displayed for the point in the **Properties** pane.

Note the following concerning lightweight points:

- You can add an editable coordinate to a lightweight point by right-clicking the point in **Project Explorer** and selecting **Add Coordinate**. This changes the lightweight point to a normal point.
If you import a text file with "Unknown" or "Mapping" coordinate quality into a project that already contains point data, duplicate points will be created for points in the text file (lightweight points) and points already in the project (normal points) that have the same ID (that is, points will not merge as expected). To avoid this problem, import the text file first to create the lightweight points in the project, then import the other point data. The lightweight points from the text file will merge with the normal points from the other point data to create normal non-duplicated points.

Related topics

- Create and Edit Points and Coordinates (see "Add and Edit Points and Coordinates" on page 365)

Add and Edit Points and Coordinates

Create a Point

Create a point in your project when you need to include one for control or stakeout that was not observed in the field or otherwise recorded and imported in a points file. When you create a point, in addition to the new point object, a coordinate object named 'Office entered' is created and appears in the Project Explorer. Each point can only have one office entered coordinate.

To create a point:

1. Do one of the following:
   - Select Point > Create Point.
   - Click the icon.
   
   The Create Point command pane displays.

2. Type a name for the point in the Point ID box. Point IDs are not case sensitive.

3. Type a code in the Feature Code box, if you need to use the point in feature code processing.

4. Select the type of point you want to create in the Coordinate type list (see Point Options (on page 366) for details).

5. Pick a location in the plan view, or type a coordinate in the Northing and Easting (or Latitude and Longitude) boxes, or right-click for coordinate geometry (COGO) (see "Understanding COGO Controls" on page 95) options.

Tip: Once you have specified northing and easting values, you can click in the Easting box and pick a new point in the graphics window to change the easting value, while retaining the northing.
6. Click the ▲ icon and select a planar quality for the coordinate. Qualities are used to determine the best point to use when multiple observations have been made at the same location.

7. Pick an object in a view to use its elevation at the location you pick, or type a value in the **Elevation** box, or right-click for options.

   **Note:** Elevation is measured from sea level.

8. Click the ▲ icon and select an elevation quality.

9. If needed, pick an object in a view, or type a value in the **Height** box, or right-click for options. Grid, local, and global coordinates appear at the bottom of the pane so you can check your new point's location in the other types.

   **Note:** Height is measured from the geoid.

10. Click the ▲ icon and select a height quality.

11. Select the appropriate point status from the **Status** list. The status determines whether and how the point is used during the computation process.

12. Click **OK**, or click **Apply** to continue creating additional points. The point and an office-entered coordinate appear in the **Project Explorer**, as shown.

   **Note:** Only office-entered coordinates can be edited. If you try to edit imported coordinates, an office-entered coordinate object with the new location is created.

**Related topics**

- Add a Coordinate to a Point (on page 367)
- Understanding COGO Controls (on page 95)
- Point Options (on page 366)

**Point Options**

Use these options to define a new point. They are available in the **Add Point** command pane when you are adding a new point to a project.
**Options**

**Point ID**
Type a unique identifier for the point.

**Feature code**
Type a code to use in feature code processing.

**Coordinate type**
- **Grid** - Select this to enter northing, easting, elevation, and height values.
- **Local** - Select this to enter latitude, longitude, height, and elevation values.
- **Global** - Select this to enter global longitude, height, and elevation values.

**Planar quality**
Click this and select a quality for the horizontal coordinate.
- **Control** - Select this for NGS surveyed coordinates of the highest quality.
- **Survey** - Select this for surveyed coordinates of the second highest quality.
- **Mapping** - Select this for coordinates of the low to average quality.
- **Unknown** - Select this for coordinates of the lowest or unverified quality.

**Ellipsoidal quality**
Click this and select a quality for the vertical coordinate.
See the quality descriptions above.

**Status**
- **Enabled** - Select this to include the point in project calculations.
- **Disabled** - Select this to exclude the point in project calculations.
- **Enabled as Check** - Select this to exclude the point in project calculations, but to include it in sideshot calculations.

**Related topics**
- [Create a Point](#) (on page 365)
- [Add a Coordinate to a Point](#) (on page 367)

**Add a Coordinate to a Point**
Add a coordinate to a point when you need to include a position for control or stakeout that was not observed in the field or otherwise recorded and imported in a points file. When you add a coordinate to a point, a coordinate object named 'Office entered' is created under the point object.
**Note:** Only add a coordinate when you are sure that you want to use this coordinate instead of an observed coordinate. During the computation of the project, added coordinates are used in preference to observations of the same quality. This ensures that a designed point is used in preference to a staked point.

**To add a coordinate to a point:**

1. Do one of the following:
   - Pick the point in a graphic view or select it in the *Project Explorer*, right-click and select *Add Coordinate* from the context menu.
   - When a point is selected, and the *Properties* pane is open, click the icon on the pane’s toolbar.
   
   The *Add Coordinate* command pane displays.

2. Select the type of coordinate you want to add in the *Coordinate Type* list (see *Coordinate Options* (on page 369) for details).

   **Note:** You can only enter one grid, local, and global coordinate for each point. If you already have each type, the icon is unavailable.

3. Pick a location in the plan view, or type a coordinate in the *Northing* and *Easting* (or *Latitude* and *Longitude*) boxes, or right-click for coordinate geometry (COGO) (see "Understanding COGO Controls" on page 95) options.

   **Tip:** Once you have specified northing and easting values, you can click in the *Easting* box and pick a new point in the graphics window to change the easting value, while retaining the northing.

4. Click the icon and select a planar quality for the coordinate. Qualities are used to determine the best coordinate to use when multiple coordinates exist for the same point.

5. Pick an object in a view to use its elevation at the location you pick, or type a coordinate in the *Elevation* box, or right-click for options. Grid, local, and global coordinates appear at the bottom of the pane so you can cross check your new coordinate’s location.

6. Click the icon and select an elevation quality.
7. Select the appropriate coordinate status from the drop-down Status list. The status determines whether and how the coordinate is used during the computation process.

8. Click OK. When you open the point in the Project Explorer, it displays the original observation data and the office-entered coordinate, as shown.

9. If the icon appears on the status bar, click it to recompute and update the coordinates in the project.

Note: You can only edit point coordinates that you added in this software, not those which were observed and imported. If you try to edit an imported point, a coordinate object named 'office-entered' is created.

Note: You can edit the coordinates for imported CAD points in the Properties pane, but CAD points are not used in computations.

Related topics
- Create a Point (on page 365)
- Compute Project Command
- Coordinate Options (on page 369)
- Project Explorer (on page 6)
- Properties Pane (on page 12)

Coordinate Options

Use these options to define a coordinate that you are adding to a point. They are available in the Add Coordinate command pane.
Options

Coordinate type

Grid - Select this to enter northing, easting, elevation, and height values.

Local - Select this to enter latitude, longitude, height, and elevation values.

Global - Select this to enter global longitude, height, and elevation values.

Click this and select a quality for the horizontal coordinate.

(Planar quality)

Control - Select this for NGS surveyed coordinates of the highest quality.

Survey - Select this for surveyed coordinates of the second highest quality.

Mapping - Select this for coordinates of the low to average quality.

Unknown - Select this for coordinates of the lowest or unverified quality.

Click this and select a quality for the vertical coordinate.

See the quality descriptions above.

(Ellipsoidal quality)

Status

Enabled - Select this to include the coordinate in project calculations.

Disabled - Select this to exclude the coordinate in project calculations.

Enabled as Check - Select this to exclude the coordinate in project calculations, but to include it in sideshot calculations.

Related topics

- Add a Coordinate to a Point (on page 367)

Point Coordinate Options

Use these options to edit point coordinates when the point is a member of a surface. The surface that references the edited member updates accordingly. These options are found in the Properties pane for a point coordinate.
## Properties that affect surfaces

<table>
<thead>
<tr>
<th>Member type</th>
<th>Coordinate</th>
<th>Session</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td><strong>Northing</strong> - Edit this to move a surface vertex north or south.</td>
<td><strong>Height</strong> (point) - Edit this to move a surface vertex up or down.</td>
</tr>
<tr>
<td></td>
<td><strong>Easting</strong> - Edit this to move a surface vertex east or west.</td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Elevation</strong> - Edit to move a surface vertex up or down, relative to sea-level.</td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Latitude</strong> - Edit this to move a surface vertex north or south.</td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Longitude</strong> - Edit this to move a surface vertex east or west.</td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Height</strong> - Edit this to move a surface vertex up or down.</td>
<td></td>
</tr>
</tbody>
</table>

### Rename Points

Rename points to ensure all the points in your project are unique. For example, if two rovers are set to automatic point numbering and contain identical points, use the *Rename Points* command to renumber one set of points. Points to be renamed can be selected before the command starts or within the command.

You can rename your points:
- Sequentially from a specific value
- By adding a prefix
- By adding a suffix

**By adding a constant To rename points:**

1. Select **Point > Rename Points**. The *Rename Points* dialog displays.
2. In the *Method* group, select a renaming option (see descriptions above).
3. If you do not want to generate a report, uncheck *Report*.
4. Select the points to rename.
5. To preview the results, click *Preview* to see the results of the settings before the command is run. Additional preview options are selectable using the icon.
6. Click *OK* to rename the points. To automatically generate and display a report, check *Report*. When renaming completes, the *Renamed Point* list displays.
Options

**Rename from**
Select this if you want to rename points using a specific starting number. Type the starting number in the box.

To use this method, the point ID you enter must end in a number. For example, if you type GPS100 and select three points, they will be renamed GPS100, GPS101, and GPS102.

**Add prefix**
Select this if you want to insert a constant character(s) at the beginning of the point ID for the points you select.

**Add suffix**
Select this if you want to insert a constant character(s) at the end of the point ID for the points you select.

**Add constant**
Select this if you want to enter a value to increase each point ID by. For example, if you type 2, point ID GPS101 becomes GPS103.

**Report**
Check this to generate the Renamed Point List report when you finish the command.

Related topics

- Run a Renamed Point List (on page 372)
- Merge Duplicate Points (on page 373)
- Merge Points (on page 374)
- Select Duplicate Points (on page 58)
- Select from 2D Views (on page 50)

Run a Renamed Point List

Generate a Renamed Point List to see a simple summary of the original and new names of points that you have renamed in your project.

2. Select Renamed Point List in the Reports list.
3. Edit options in the Settings group as needed.
4. Click the icon on the pane's toolbar. The Renamed Point List displays in your default web browser.

Related topics

- Customize and Run a Report (see "Customize a Report" on page 481)
When checking data in your project, you might find that the point ID for a station setup and/or backsight has been incorrectly labeled in the field. For example, the Plan view looks incorrect or a red flag indicates a point out of tolerance.

**To change the point ID for a station setup and/or backsight:**

1. To change the point ID for a station setup:
   a. In the *Imported Files* node in the *Project Explorer*, click to display properties in the *Properties* pane for the station setup whose point ID you want to change.
   b. In the *Point ID* box in the *Properties* pane, type the correct ID for the station setup.

   If the corrected ID is for a station you set up on previously or to a control point, no new point is created in the *Points* node (the station point is shared). Otherwise, a duplicate point is created in the *Points* node (local points are not shared). In this case, merge them as described in Merge Points (on page 374).

2. To change the point ID for a backsight:
   a. In the *Imported Files* node in the *Project Explorer*, click to display properties for the observation to the backsight whose point ID you want to change.
   b. In the *Point ID* box in the *Properties* pane, type the correct ID for the backsight observation. The software updates the backsight with the new point ID.

   If the corrected observation is to a station you set up on previously or to a control point, no new point is created in the *Points* node (the station point is shared). Otherwise, a duplicate point is created in the *Points* node (local points are not shared). In this case, merge them as described in Merge Points (on page 374).


**Merge Duplicate Points**

If you have multiple points with the same Point ID, you can merge them into a single point.

*Note:* This command can be run with the *Select Duplicate Points* command.

1. Select *Select > Select Duplicate Points*, with a distance tolerance and with *Point IDs identical* selected.
2. Select **Point > Merge Duplicate Points**. A list of the IDs with duplicate points appears.

3. Click **OK**.

**Caution:** Two points with the same ID but significantly different data may be the result of an error. Merging them may produce unexpected results.

## Related topics
- **Merge Points** (on page 374)
- **Rename Points** (on page 371)
- Select Duplicate Point IDs
- **Select from the 2D Views** (see "Select from 2D Views" on page 50)

## Merge Points

Use this command to create a single point from two or more points that share the same location data.

### To merge points (one set of points):

1. Select the points you want to merge together. Use the **Select Duplicate Points** command or select from the plan view or a spreadsheet view.

2. Select **Point > Merge Points**. If you have not selected points to merge yet, do it now. The points IDs and distance from the first listed point are displayed in the **Selected point** area.

3. Click on the points to merge. A green check displays.

4. (optional) Enter a point ID for the merged point. The default is the first listed point.

5. Click **OK**.

### To merge points (multiple sets of points):

1. Select the points that may be merged together. Use the **Select Duplicate Points** command to select all points that are within a defined distance from one another.

2. Select **Point > Merge Points**. The points IDs and distance from the first listed point are displayed in the **Selected point** area. If you have not selected points to merge yet, do it now. The points IDs and distance from the first listed point are displayed in the **Selected point** area.

3. Click on the points to merge. A green check displays.

4. (optional) Enter a point ID for the merged point. The default is the first listed point.

5. Click **Apply**. The checked points are merged together and removed from the list.
6. Repeat steps 1-5 until all points are merged. Click **OK** when you want to exit the command.

7. Click 🔍 if it appears on the status bar to recompute the project.

**Related commands**
- Select Duplicate Points
- Merge Duplicate Points (on page 373)
- Rename Points (on page 371)
- Select from the 2D Views (see "Select from 2D Views" on page 50)

**Calculate the Inverse Between Points**

Calculate and report inverse values between any two points in your project, such as:
- Grid distance
- Change in elevation

Geodetic azimuth To calculate the inverse between two points:

1. Do one of the following:
   - Click the ⚒️ icon on the toolbar.
   - Select **Survey > Inverse**.
   The **Inverse** command pane displays.

2. Select **Sequential** to calculate values from point to point in series (as if drawing a multi-segment line), or **Radial** to calculate values from one point to multiple other points (as if drawing a fan).

   **Note:** You can switch between **Sequential** and **Radial** after picking any pair of points.

3. Pick the first point in a graphic view, or type a point ID in the **From** box.

   **Note:** You can also right-click in the view to access **COGO controls** (see "Understanding COGO Controls" on page 95) and **snaps** (see "Snaps Modes and Commands" on page 98) when picking points.

4. Pick another point, or type a point ID in the **To** box. The point IDs appear in the **Reported Points** group, and the inverse values appear in the **Details** group.

   **Note:** If **Free** appears in the **Reported Points** list, no point with a point ID was within the pick aperture. To prevent picking where there are no points, click the 🔴 icon on the **Inverse** command pane’s toolbar. In the **Snap Mode** dialog, uncheck **Free**, and click **OK**.

5. To calculate additional inverses, continue picking **To** points.
6. To review the details for any inverse, click in the first column of the *Reported Points* list.

7. To change inverse report options, click the icon to display the *Report Options* command pane. When you are done, click **OK** to return to the *Inverse* command.

8. To generate the *Inverse Results* report, click the icon at the top of the *Reported Points* group. The *Inverse Results* report displays in your default web browser.

   **Note:** If no coordinate system is defined, the *Select Coordinate System* dialog displays. Define a coordinate system and run the report again.

9. Click **Close**.

**Related topics**

- [Customize and Run a Report](#) (see "Customize a Report" on page 481)
- [Inverse Options](#) (on page 284)
- [Measure Values Between Points](#) (on page 144)

**Inverse Options**

Use these options to calculate and report the azimuth, distance, and other relationships between any two points. They are available in the *Inverse* command pane.
Options

Click this on the Inverse command pane's toolbar to display the Snap Mode dialog, where you can enable and disable running snap modes.

Inverse From/To

Pick points in graphic views, or type point IDs in the boxes and click Apply or press [Enter].

**Note:** If Free appears in the Reported Points list, no point with a point ID was within the pick aperture. To prevent picking where there are no points, click the icon on the Inverse command pane's toolbar. In the Snap Mode dialog, uncheck Free, and click OK.

**Sequential** – Data is collected in a line, and you want to verify distances around the traverse.

- For example, you will need to click on:
  
  A to B, B to C, C to D, D to E, and E to A.

**Radial** – Data is collected in a ray, and you want to check distance from the base station.

- For example, you will need to click on: A to B, A to C, A to D, and A to E.

Reported points

Click this to display the Inverse Results report in your default web browser.

Click this to display the Report Options command pane, in which you can specify heading, footer, and format settings for the Inverse Report.

From point ID/To point ID Details

Click in the first column of any row to list details for the inverse of the points.

This shows the azimuths, changes in elevation and height, and three distances of the selected inverse:

- Grid
- Ellipsoidal
- Ground

Apply

This acts as the [Enter] key, when specifying points, moving the focus between From, To, and Reported Points.

Related topics

- Calculate the Inverse Between Points (on page 283)

Measure Values Between Points

Calculate and report values between points in your project.
• In the plan view, the command measures bearing and distance.
• In the profile view, it measures the delta station, slope, and slope distance.
• In the cross-section and surface slicer views, it measures delta offset, slope, and slope distance.

**To measure values between two points:**

1. Do one of the following:
   • Click the **Measure** icon on the toolbar.
   • Select **Tools > Measure**.  
The **Measure** command pane displays.

2. Pick the first point in a graphic view or type a point ID or coordinate (in the format X,Y) in the **From** box.

   **Note:** You can also right-click in the view to access **COGO controls** (see "Understanding COGO Controls" on page 95) and **snaps** (see "Snaps Modes and Commands" on page 98) when picking points.

3. Pick another point or type a point ID or coordinate in the **To** box. The measured values appear in the **Results** group.

4. To measure other values, continue picking **From** and **To** points.

   **Note:** You can change to a different graphic view between measurements.

5. Click **Close**.

**Related topics**

- **Measure Options** (on page 145)
- **Calculate the Inverse Between Points** (on page 283)
- **Customize and Run a Report** (see "Customize a Report" on page 481)

**Measure Options**

Use these options to calculate and report the bearing, distance, slope, slope distance, delta offset, and delta station between any two points, depending on which graphic view you use. They are available in the **Measure** command pane.
Options

From/To
Pick points in graphic views, or type point IDs or coordinates (in the format X,Y) in the boxes, and click **Measure** or press **[Enter]**.

Results
This shows the values between the selected points:

- **Slope** - In the cross-section view, the slope is relative to the centerline. In the surface slicer view, the slope is relative to the first point of the line.
- **Offset** - In the cross-section view, the offset is relative to the centerline. In the surface slicer view, the offset is relative to the first point of the line.

Measure
When you type in **To** and **From** points, this acts as the **[Enter]** key, calculating the **Results**.

Related topics
- [Measure Values Between Points](on page 144)

Points Spreadsheet

The points spreadsheet view lists the survey points in the current project, enabling you to easily edit the data. The plan view and the **Properties** pane reflect all changes made to data in the point spreadsheet view.

Using the spreadsheet

- **To select a point**, click in the left column for that row.
Work with Point Data

- **To display more detail on a point** in the Properties pane, select the point and press [F11], or right-click and select Properties.

- **To edit a point’s ID, coordinate, elevation, or feature code**, select it by clicking on the cell. You can also tab from cell to cell and simply type over the value in the cell.

- **To sort points based on a criteria**, click on a column heading. Up ▲ or down ▼ icons appear on the selected column heading, indicating the current sort order (ascending or descending).

- **To filter the point data**, click on the ▼ icon at the top of the column and select an option from the drop-down menu.

  **Note:** If the filter for a column is active, the icon ▼ appears blue.

- **To copy data to a text editor**, such as Microsoft® Notepad, select data, and copy and paste by using the right-click menu or by pressing [Ctrl] + C to copy and [Ctrl] + V to paste. You can select all data by pressing [Ctrl] + A.

- **To change the order of columns** across the spreadsheet, click and drag the column heading to a new location.

**Related topics**
- Data View Display Formats (on page 38)
- Pane and Data View Positioning (on page 37)
- Select from Spreadsheet Views (on page 52)
- Tabbed View Arrangement (on page 40)
- Create a Point (on page 365)

**Troubleshoot an Import Problem**

Before calling Support, use any applicable solutions to known issues below.

<table>
<thead>
<tr>
<th>Symptom</th>
<th>Possible Cause</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>Duplicate points were created for points in an imported text file and points already in the project that have the same ID (that is, points were not merged as expected).</td>
<td>If you import a text file with &quot;Unknown&quot; or “Mapping” coordinate quality into a project that already contains point data, duplicate points will be created for points in the text file (lightweight points (see “Understanding Point Types” on page 364)) and points already in the project (normal points (see &quot;Understanding Point Types&quot; on page 364)) that have the same ID.</td>
<td>Import the text file into the project first to create the lightweight points, then import the other point data. The lightweight points from the text file will merge with the normal points from the other point data to create normal non-duplicated points.</td>
</tr>
</tbody>
</table>
Work with Point Data
Work with Line Data

Create and Edit an Alignment

Understanding Alignments

An alignment defines a linear feature, such as a road centerline. Alignments consist of horizontal geometry (a path in a horizontal plane) and optional vertical geometry (a path in a vertical plane). Alignments can also include station equations.

You can import existing alignments from LandXML or GENIO string files, or create them by specifying their horizontal and vertical components, or converting them from vertices, lines, and polylines in your project.

You can create horizontal alignments using lines/tangents, arcs, and clothoid spirals. You can create vertical alignments with lines (constant slope), arcs, and parabolas. Each vertical alignment is associated with a horizontal alignment, and there can be multiple vertical alignments for each horizontal alignment. The values you can enter depend on the alignment settings for the project.

Usually, the goal in creating an alignment is to create a digital file of the design that you can upload to a field device for staking.
Save the effort of manually creating alignments by importing alignments created in other design applications. Alignments can be imported in GENIO or LandXML file formats.

The general workflow for using imported alignments is:

1. Import the file containing the alignment. The alignment appears as a single object in the Project Explorer.
2. Check the alignment to make sure it accurately reflects the design, and make edits as necessary.
   - Open the Alignment Editor and verify that coordinates, bearings, lengths, stations, and other values match the original paper or digital plan.
   - Open a new horizontal tab group and arrange your views to that you can see the Alignment Editor and the appropriate graphic view (either plan or profile) concurrently.
   - Edit horizontal, vertical, and station values as needed.
   - Open the Properties pane, and edit the alignment’s properties, such as the name, appearance, and layer, as needed.

Related Topics
- Create an Alignment (see "Understanding Alignments" on page 382)
- Import LandXML Files (.xml) (on page 226)
- Import GENIO Files (on page 218)

Workflow for Creating Alignments

Create alignments by manually entering values from digital or paper plans. Here is the general workflow:

1. Use the Create Alignment command to create a new, blank alignment, and open it in the Alignment Editor.
2. Open a new horizontal tab group and arrange your views so that you can see the alignment spreadsheet and the appropriate graphic view (either plan or profile) concurrently.
3. Enter horizontal values from the paper or digital plans, or using the imported data as a reference. If necessary, enter vertical and station values as well.
4. Open the Properties pane, and edit the alignment's appearance properties, as needed.

5. Export the alignment to another application or upload it to a field device. You can export alignments as .dxf/.dwg, GENIO, or LandXML files.

| Note: You can export an alignment to SCS software as a .dxf/.dwg foreground or background map (loses stationing and spirals), or you can export it to Terramodel as a 3D LandXML file, which you can then upload to SCS software. |
| Note: If you export an alignment as a .dwg and then import it into another application as a .dxf/.dwg, any vertical alignments in the file may not appear. |

Related Topics
- Create an Alignment (see "Understanding Alignments" on page 382)
- Create an Alignment from a GENIO String (on page 393)

Create an Alignment

Build alignments by entering values to define horizontal line, arc, and spiral segments. If needed, define station equations and vertical segments as well.

You can also create alignments by picking points in graphic views, but for precise values it is more likely that you will enter them using the keyboard.

To create an alignment:

1. Do one of the following:
   - Select Line > Create Alignment.
   - Click the icon on the toolbar.

2. In the Name box, type an identifier for the new alignment.

3. In the Layer list, select the layer on which you want the alignment to reside.

4. Click OK. The Alignment Editor displays.

5. Click the icon. The Project Settings dialog for alignments displays.

6. Change any setting formats to match the formats used in the design.

7. Click OK.

8. Referring to your design, type coordinate values in the North and East cells of the POB row. If you have station information, type it in the Station box.
### Work with Line Data

<table>
<thead>
<tr>
<th>Note: You can also pick a point, or right-click for snap options, in the graphic views to specify values.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Note: You can right-click in the active cell to access <strong>Undo</strong>, <strong>Cut</strong>, <strong>Copy</strong>, and <strong>Paste</strong> commands, or right-click at the beginning of a row to access <strong>Insert Row</strong>, <strong>Delete Row</strong>, <strong>Copy</strong>, <strong>Editor Settings</strong>, and <strong>Float View</strong> commands.</td>
</tr>
</tbody>
</table>

| 9. Press [Tab] or [Enter] to proceed to the next row. |
| 10. Select a segment type in the **Type** list. The type you select determines which values you can enter in the other cells of the row. |
| 11. Enter values for the available cells, based on the design. |
| 12. Repeat the previous steps until you have created segments for the entire horizontal component of the alignment. |

| Note: Check the alignment in the graphic views as you enter values. |

| 13. If the alignment has station equation information, click the **Station Equation** tab. |

| Note: Depending on how your data is arranged, you may want to enter station equations in between creating horizontal segments. |

| 14. Click **Create Stations** to make the cells available. |
| 15. Type values in the **Back** and **Ahead** cells. |
| 16. If the alignment has a vertical component, click the **Vertical** tab. |
| 17. Click **Create Profile** to make the cells available. |
| 18. Type coordinates in the **Station** and **Elevation** cells of the **POB** row. |
| 19. Press [Tab] to proceed to the next row. |
| 20. Select a segment type in the **Type** list, and enter values in the available cells. |

| Note: In the vertical alignment, you are defining the PVI type, and entering PVI stations and elevations. |

| 21. Press [Enter]. The alignment appears in the **Project Explorer**. |

**Related topics**

- View Settings (on page 161)

**Use Valid Segment Order**

When you are adding, inserting, deleting, or editing horizontal alignment segments, there are valid and invalid ways in which segment types can be connected. For instance, a combining spiral must be preceded and followed by an arc; it cannot connect to any other segment type. Some typical, and valid, sequences of segment types include:
Work with Line Data

- Residential streets: Line > Arc > Line >
- High speed-streets and ramps: Line > Spiral in > Arc > Spiral out > Line
- Unusual high-speed ramps: Line > Spiral in > Arc > Combining spiral > Arc > Spiral out > Line

Valid Segment Connections

<table>
<thead>
<tr>
<th>From</th>
<th>To</th>
<th>POB</th>
<th>Line</th>
<th>Arc</th>
<th>Spiral in</th>
<th>Spiral out</th>
<th>Combining spiral</th>
</tr>
</thead>
<tbody>
<tr>
<td>POB</td>
<td>—</td>
<td>OK</td>
<td>OK</td>
<td>OK</td>
<td>OK</td>
<td>OK</td>
<td>—</td>
</tr>
<tr>
<td>Line</td>
<td>—</td>
<td>OK</td>
<td>OK</td>
<td>OK</td>
<td>OK</td>
<td>—</td>
<td>OK</td>
</tr>
<tr>
<td>Arc</td>
<td>—</td>
<td>OK</td>
<td>OK</td>
<td>OK</td>
<td>OK</td>
<td>OK</td>
<td>OK</td>
</tr>
<tr>
<td>Spiral in</td>
<td>—</td>
<td>OK</td>
<td>OK</td>
<td>—</td>
<td>OK</td>
<td>—</td>
<td>OK</td>
</tr>
<tr>
<td>Spiral out</td>
<td>—</td>
<td>OK</td>
<td>OK</td>
<td>OK</td>
<td>—</td>
<td>—</td>
<td>—</td>
</tr>
<tr>
<td>Combining spiral</td>
<td>—</td>
<td>—</td>
<td>OK</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
</tr>
</tbody>
</table>

Note: Tangency is assumed when a line transitions into an arc or a spiral.

Related topics
- Alignment Editor (on page 36)
- Create an Alignment (see "Understanding Alignments" on page 382)
- Edit an Alignment (on page 386)
- Horizontal Alignment Options (on page 387)

Edit an Alignment

You can edit an alignment’s segment type and values, and you can also insert new segments into an alignment.

At the top of the Alignment Editor, there is a list of alignments in your project. Click the icon and the arrow to open the list. Once you have selected the alignment you want to edit, click the icon to lock the list again. This will prevent you from editing the wrong alignment.

To edit an alignment:

1. Do one of the following:
   - Click the icon on the toolbar.
   - Select Line > Alignment Editor.
   - Pick an alignment in a graphic view, right-click and select Alignment Editor from the context menu.
   - Select an alignment in the Project Explorer, right-click and select Alignment Editor from the context menu.
The Alignment Editor displays.

**Note:** You can only edit one alignment at a time. If you have multiple alignments selected, only the active alignment (indicated in bold in the Project Explorer) appears in the Alignment Editor.

2. Select **Window > New Horizontal Tab Group**. A second pane opens so that the alignment spreadsheet and graphic views are visible concurrently. You may need to right-click on a view tab and select **Move to Next Tab Group** from the context menu.

3. In the alignment spreadsheet, click the tab on which you want to edit data.

4. To edit values, click in a cell and specify a new value. The alignment updates in the graphic views as you make changes.

**Note:** If the spreadsheet requests values in different formats than those used in your plan, click **Settings** to access the Project Settings dialog, where you can change the display format and entry methods.

5. To change a segment type, click a cell in the Type column and select a new type from the list.

6. To insert or delete a segment, right-click at the beginning of a row.

7. Press [Enter] to save your changes.

**Related topics**

- Alignment Editor (on page 36)
- Create an Alignment (see "Understanding Alignments" on page 382)
- Edit an Alignment’s Properties (on page 391)

**Horizontal Alignment Options**

Use these options to define each segment of a horizontal alignment. They are available on the Horizontal tab of the Alignment Editor.

Entry formats are defined in Project Settings, which can be accessed by clicking Settings in the Alignment Editor, or by right-clicking the last row in the spreadsheet and selecting Editor Settings from the context menu. Depending on the entry format that is set, some of the options below may not be required.
Work with Line Data

Options

Type

**POB** (Point of Beginning) - Denotes the starting point for the alignment.
Define the station, and northing and easting coordinates.

**Line** - Select this to enter a straight segment.
Define the azimuth or bearing, and length.

**Arc** - Select this to enter a curved segment with a constant radius.
Define the azimuth or bearing, radius, side from POB, and length/delta/station.

**Spiral In** - Select this to enter a transitional segment (clothoid spiral) with a decreasing radius. Generally, use this to connect a line with an arc.
Define the azimuth or bearing, radius, side from POB, and length/station/A parameter.

**Spiral Out** - Select this to enter a transitional segment (clothoid spiral) with an increasing radius. Generally, use this to connect an arc with a line.
Define the azimuth or bearing, radius, side from POB, and length/station or A parameter.

**Combining Spiral** - Select this to spiral between two arcs with different radii.
Define the azimuth or bearing, side from the POB, radius 1, radius 2, and length/station/A parameter.

Azimuth

(North or South)

or

Bearing

Specify a bearing or an azimuth value at the beginning of the segment, or accept the default of **Tangent**, which is the bearing from the previous segment.
For lines, this is the bearing of the entire segment. For arcs and spirals, it is the tangent bearing into the segment.

Radius

Specify a radius value for an arc.

Left / Right

Select the direction an arc should curve, left of right in the direction from the POB.

Length

Specify the length or distance of the segment.
For arcs, and spirals, it is the actual length, not a chord length

Delta

Specify the central angle of the arc.

A Param

Specify the standard factor used as a roadway design criteria in establishing the required length of the spiral.
The A parameter reflects the rate of change of the radius, in relation to the distance along the spiral.

Station

Specify the station value at the end of the POB segment. For other segment types, this displays the station.
Work with Line Data

North
Specify the northing coordinate at the end of the POB segment. For other segment types, this displays the northing coordinate.

**Note:** The order of the north and east are dictated by the format set in *Project Settings*.

East
Specify the easting coordinate at the end of the POB segment. For other segment types, this displays the easting coordinate.

Related topics

- Create an Alignment (see "Understanding Alignments" on page 382)
- Horizontal Alignment Options (on page 387)
- Vertical Alignment Options (on page 389)

**Vertical Alignment Options**

Use these options to define each segment of a vertical alignment. They are available on the *Vertical* tab of the *Alignment Editor*. The entry formats are defined in *Project Settings*, which can be accessed by clicking the icon in the alignment spreadsheet.
## Options

**PI Type**

**POB** (Point of Beginning) - Denotes the starting point for the alignment.

Define the station and elevation.

**Grade Break** - Select this for PVIs that do not have a curve. Typically, this is used for small changes in grade, or for the end of the vertical alignment.

Define the station and elevation.

**Symmetrical vertical curve** - Select this to create a vertical curve when the curves on either side of the point of intersection (PI) are of equal length.

Define the station, elevation, and curve length/K factor.

**Asymmetrical vertical curve** - Select this to create a vertical curve when the curves on either side of the point of intersection (PI) are of unequal length.

Define the station, elevation, and approach and departure curve lengths.

**Vertical Arc** - Select this to enter a vertical curve with a constant radius.

Define the station, elevation, and radius/length.

<table>
<thead>
<tr>
<th>Station</th>
<th>Type a station value, or pick it in the profile view.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Elevation</td>
<td>Type an elevation value for the station, or pick it in the profile view.</td>
</tr>
<tr>
<td>Curve Length</td>
<td>Type a length for the vertical curve, or pick two points in the profile view to use the distance between them as the length.</td>
</tr>
<tr>
<td>Radius</td>
<td>Type a radius value for the arc.</td>
</tr>
<tr>
<td>K Factor</td>
<td>This displays the calculated ratio of change on the vertical curve.</td>
</tr>
<tr>
<td>Approach Curve Length</td>
<td>For asymmetric curves, type a value for the curve before the PVI (from PVC to PVI)</td>
</tr>
<tr>
<td>Departure Curve Length</td>
<td>For asymmetric curves, type a value for the curve after the PVI (from PVI to PVT)</td>
</tr>
</tbody>
</table>

**Note:** You can use the same station value for two consecutive PVIs (not just 0+00). This allows a vertical rise or fall in the alignment.

For example, if you need to model channel (drainage) flow-lines where you have a vertical drop, you can add the same station at different elevations.

<table>
<thead>
<tr>
<th>Station</th>
<th>Elevation</th>
</tr>
</thead>
<tbody>
<tr>
<td>2+25.00</td>
<td>125.00</td>
</tr>
<tr>
<td>2+25.00</td>
<td>120.00</td>
</tr>
</tbody>
</table>
This will draw the profile to elevation 125 when coming from the downstation, and elevation 120 when coming towards the upstation. The order of the entries in the editor determines the order in which they are used.

Related topics
- **Alignment Profile View** (see "Profile View" on page 25)
- **Alignment Stationing Options** (on page 391)
- **Create an Alignment** (see "Understanding Alignments" on page 382)
- **Create a Profile of a Surface** (see "Create and View a Surface Profile" on page 421)
- **Horizontal Alignment Options** (on page 387)

**Alignment Stationing Options**

Use these options to define an alignment's station values, generally when you add or remove curves. They are available on the **Stationing** tab of the **Alignment Editor**.

**Options**
**Station Equations**
- **Back**
  - Type a station back value.
- **Ahead**
  - Type a station ahead value.

**Station Zones**
- **Zone**
  - Denotes the section from one station to the next. The zone number also appears after the colon in the **Start Station** and **End Station** values.
- **Start Station**
  - Shows the station at which the zone begins. The first station segment's value is derived from the **Horizontal** tab's POB station.
- **End Station**
  - Shows the station at which the zone ends.
- **Progression**
  - Indicates whether the station value increases or decreases after the station equation.

Related topics
- **Create an Alignment** (see "Understanding Alignments" on page 382)
- **Horizontal Alignment Options** (on page 387)
- **Vertical Alignment Options** (on page 389)

**Edit an Alignment's Properties**

Change alignment names, display properties, and layers in the **Properties** pane.

**To edit an alignment's properties:**

1. Do one of the following:
   - Pick the alignment in a graphic view, right-click, and select **Properties** from the context menu.
Double-click the alignment in the Project Explorer, or right-click it and select Properties from the context menu.

The Properties pane displays.

2. Click in an available box, and make changes as necessary.

**Note:** If the scale of your alignment is small in a graphic view, some linestyles display as solid lines to improve performance.

3. Click Close. The alignment updates based on the changes.

**Related topics**

- Alignment Editor (on page 36)
- Edit an Alignment (on page 386)

**Alignment Properties**

Use these options to change alignment names, display properties, and layers. They are available in the Properties pane when an alignment is selected.
Options

Linestyle
Select an appearance for the line in graphic views.

**Note:** If the scale of your line is small in a graphic view, some linestyles display as solid lines to improve performance.

Color
Select a display color for graphic views.

Visible
**True** - Select this to display the alignment in graphic views.

**False** - Select this to hide the alignment in graphic views.

Layer
Select the layer on which you want the alignment to reside.

Reference Location Northing
Displays the north coordinate used in the alignment’s POB.

Reference Location Easting
Displays the east coordinate used in the alignment’s POB.

Reference Station
Display the station used in the alignment’s POB.

Related topics

- Edit an Alignment’s Properties (on page 391)

Create an Alignment from a GENIO String

GENIO strings are sets of 3D points connected to form linear features, such as street centerlines or curb lines. There are three types of GENIO strings that can be imported into Trimble® Business Center. Each type can be used in a different way.
GENIO string

3D Import these, and use them with other data to form a surface.
They do not import as alignments, and cannot be converted into alignments.

6D Import these, and convert them into alignments using the steps below.

12D Import these. They are automatically converted into alignments that appear in
graphic views and the Project Explorer.

To create an alignment from a 6D string:

1. Import a GENIO 6D string.
2. In a graphic view, pick the string.
3. Select Line > Create Alignment From a GENIO 6D String.

The alignment is created. It appears in graphic views (coincident with the original
string) and in the Project Explorer.

Note: After you convert a GENIO 6D string into an alignment, check the results
thoroughly.

Related topics

- Create an Alignment (see "Understanding Alignments" on page 382)
- Import GENIO Files (on page 218)

Run an Alignment Geometry Report

Generate an Alignment Geometry Report to see a simple summary or detailed listing of
the geometry of an alignment in your project. You can choose to report on just the
horizontal component or both the horizontal and vertical components of alignments.
If you have specified station equations, they will be reported as well.

To run an Alignment Geometry Report:

command pane displays.
2. Select an alignment in the Alignment list.
3. Click OK. The Alignment Geometry Report displays in your default Web browser.

To customize the report:

1. Do one of the following:
   - Click the icon on the Alignment Geometry Report command pane's toolbar.
   - Select Reports > Report Options.
Work with Line Data

The **Report Options** command pane displays.

2. Select **Alignment Geometry Report** in the list.

3. Expand sections and specify output settings in the **Settings** group as needed.

4. Click **Apply** if you want to customize additional reports, or **OK** to close the command pane.

**Tip:** You can also change the abbreviations used for horizontal and vertical alignment classifications in the **Alignment Geometry Report**. Select **Project > Project Settings**, and click **Abbreviations** in the left pane. Edit any of the abbreviations in the right column and click **OK**. Rerun the report to see your changes.

Related topics

- [Create an Alignment](#) (see "Understanding Alignments" on page 382)
- [Customize and Run a Report](#) (see "Customize a Report" on page 481)

Alignment Editor

The **Alignment Editor** enables you to edit the horizontal, vertical, and stationing values of existing alignments. The graphic views reflect all changes made to alignments in the editor.

Related topics

- [Edit an Alignment](#) (on page 386)
- [Data View Display Formats](#) (on page 38)
Create and Edit a Linestring

Create a Linestring

Create linestrings (versatile single or multi-segmented linear or curvilinear objects) to represent 2D or 3D linear objects. 3D lines can be defined and queried entirely from within the Plan View (on page 24), and they provide a unique and versatile way of establishing the line's elevation or its vertical alignment. You can create linestrings in this software, or you can convert imported lines, such as CAD polylines, into linestrings as you edit them. In creating a linestring, you specify the location of each point along the line, and how the connections (segments) between them are formed.

To create a linestring:

1. Do one of the following:
   - Select Line > Create Linestring.
   - Click the icon.

   The Create Linestring command pane displays.

2. In the Name box, type an identifier for the linestring as you want it to appear in the Selection Explorer and graphic views. You can also use the name to select the linestring in the Advanced Select command.

3. Select the layer on which you want the linestring to reside in the Layer list, or select <<New layer>> to create a new layer for the linestring.

4. Click OK. The Edit Linestring command pane displays. Continue to create the linestring using either of the options below.

To enter the first point by specifying a coordinate:

This option starts the linestring with the coordinate of any location (point) you pick, so that the linestring's geometry remains fixed at that point until you edit its coordinate.

1. In the Start Point group's Type list, select Coordinate.
2. Click in the Coordinate box, and pick a location in a graphic view, type a coordinate, or right-click for COGO coordinate options (see "Enter a Coordinate" on page 106).

3. Enter the elevation for the starting point in the Elevation box, or right-click for COGO elevation options (see "Enter an Elevation" on page 134).

4. Click Save or press [Enter]. The first point of the linestring is saved and you are prompted to add the second point, designating how the segment between them is formed.

5. Add the second point and the segment between them using the operations in Edit a Linestring's Horizontal Segments (on page 397).

To enter the first point by specifying a point ID:

This option starts the linestring with a named point (point with a point ID) so that the linestring's geometry always reflects the location of the point. If you edit the point, the linestring updates in response.

1. In the Start Point group's Type list, select Point ID.
2. Click in the Point ID box, and pick a named point in a graphic view or type a point ID. The elevation of the point you specified is automatically used.
3. Click Save or press [Enter]. The first point of the linestring is saved and you are prompted to add the second point, designating how the segment between them is formed.
4. Add the second point and the segment between them using the operations in Edit a Linestring's Horizontal Components (see "Edit a Linestring's Horizontal Segments" on page 397).

Related topics

- Edit a Linestring's Horizontal Segments (on page 397)

Edit a Linestring's Horizontal Segments

The linestring editing command provides one familiar tool with which you can edit a large array of imported CAD lines of many types, such as polylines, arcs, and splines, automatically converting them in the process to linestrings, and enriching them as needed with geometric attributes not otherwise supported by the source objects.

Edit linestrings by redefining their points and the connections (segments) between the points, as well as by adding, inserting, and deleting segments.

To define vertical points of intersection (independent of the segment end points) at specific distances along the linestring, add vertical control points using the operations in Edit a Linestring's Vertical Control Points (on page 405).
Work with Line Data

The current segment, end point, and direction of the linestring are indicated during editing. An X indicates the linestring's start point.

To access these options:

If you have just created a linestring, skip to one of the operations below. Otherwise, select a line or linestring and do one of the following:

- Select Line > Edit Linestring.
- Click the icon on the toolbar, or on the Properties pane toolbar when a linestring is selected.
- Right-click, and select Edit from the context menu.

The Edit Linestring command pane displays. Click the Horizontal tab.

To view and select each horizontal segment in sequence:

- Click the back and forward arrows on either side of the Current segment list, or move your cursor along the linestring in a graphic view and click to select the segment.

To add a straight segment:

1. In the Segment group’s Type box, select Straight.
2. Follow the steps in To specify a segment’s end (or start) point below.
3. Click Save or press [Enter]. The segment is saved and you are prompted to specify the end point for the next segment.

To add a curved segment:

1. In the Segment group’s Type list, select Arc or 3 Point Arc.
   - Arc - Select this to create a curved segment between two points. Then, specify the radius of the arc, whether it curves left or right from the previous segment, and whether to use the larger arc (> 180°) or smaller arc (> 180°) that is created between the points.
**3 Point Arc** - Select this to create a curved segment from the preceding endpoint, passing through a specified intermediate point, to a specified segment endpoint.

2. Follow the steps in To specify a segment's end (or start) point to specify the end point of the curved segment.

**To add a straight segment at a deflection angle from the preceding segment:**

1. In the Segment group's Type list, select Deflection.

2. For the Direction, select the perpendicular left (-90°), perpendicular right (90°), straight ahead (0°) deflection angle option, or select Specified angle to enter a specific deflection angle.

   **Note:** Positive deflection angles are measured clockwise from the direction of the previous segment.

3. Pick a point in the graphic view to specify the length, or type a value in the Length box.

4. Type an elevation for the end point in the Elevation box, and click Save or press [Enter].

**To specify a segment's end (or start) point:**

1. In the End Point (or Start Point) group's Type list, select Coordinate or Point ID.

2. Depending on the type you selected, click in either the Coordinate box or the Point ID box.

3. For a coordinate, pick a location in a graphic view, type a coordinate, or right-click for COGO coordinate options (see "Enter a Coordinate" on page 106). Then enter the elevation for the starting point in the Elevation box, or right-click for COGO elevation options (see "Enter an Elevation" on page 134).

4. For a point ID, pick a named point (point with an ID) in a graphic view or type a point ID. The elevation of the point you specified (if defined) is automatically used to establish a vertical point of intersection on the line at that point.

5. Click Save.

**To edit a segment:**

1. Select the segment by picking it in the plan view, selecting it in the Current segment list, or clicking and selecting it in the Browse Horizontal Segments list.

2. Modify any of the options for the segment, and click Save.
To remove a segment:

1. Select the segment by picking it in the plan view, selecting it in the Current segment list, or clicking \(\text{\textbullet}\) and selecting it in the Browse Horizontal Segments list.
2. Click the \(\text{\textbullet}\) icon. The segment and its end point are removed, and the adjoining segments' end points are joined.

Note: To delete a segment without joining the adjoining segments, use the Delete Line Segment (see "Delete a Line Segment" on page 412) command.

To insert a segment before the current segment:

1. Select the segment before which you want to insert a new segment by picking it in the plan view, selecting it in the Current segment list, or clicking \(\text{\textbullet}\) and selecting it in the Browse Horizontal Segments list.
2. Click the \(\text{\textbullet}\) icon.
3. Follow the steps in To specify a segment's end (or start) point above to specify the new segment's end point, which becomes the new location of the start point for the segment you selected. The new segment is inserted before the selected segment.

To insert a new first segment:

1. Select the linestrings 'start' coordinate or point by picking it in the plan view or selecting it in the Current segment list.
2. Click the \(\text{\textbullet}\) icon.
3. Follow the steps in To specify a segment's end (or start) point above to specify the start point for the new, first segment in the linestring.

To add a segment onto the end:

1. Select the last segment by picking it in the plan view or selecting it in the Current segment list.
2. Click the \(\text{\textbullet}\) icon.
3. Follow the steps in one of the To add a * segment operations above.

To view and select a segment in a list:

1. Click the \(\text{\textbullet}\) icon. The Browse Horizontal Segments dialog displays.
2. Select the segment you need, and click OK.
To reverse the segment order/switch the linestring's start and end points:

- Click the icon on the pane's toolbar. You can confirm the order by moving your cursor along the linestring in the graphic view. The direction of the linestring is shown in the plan view an arrow on the selected segment.

To convert two consecutive straight segments to a 3 point arc segment:

1. Select the segment whose end point will become the 'point on curve' by picking it in the plan view, selecting it in the Current segment list, or clicking and selecting it in the Browse Horizontal Segments list.
2. Click the icon. The selected segment and the one following it are converted to a 3 point arc.

**Note:** Since you must select the first of two segments to be used in the 3 point arc, a linestring's final segment cannot be selected for this function.

To convert a 3 point arc segment to two straight segments:

1. Select the segment that is currently defined as a 3 point arc by picking it in the plan view, selecting it in the Current segment list, or clicking and selecting it in the Browse Horizontal Segments list.
2. Click the icon. The selected segment is converted into two straight segments, joined at the previous 'point on curve' of the 3 point arc.

Related topics

- [Create a Linestring](on page 396)
- [Edit a Linestring’s Vertical Control Points](on page 405)
- [Horizontal Linestring Segment Options](on page 401)

**Horizontal Linestring Segment Options**

Use these options to create and edit horizontal linestring segments. They are available on the **Horizontal** tab of the **Edit Linestring** command pane. Linestring properties can be edited in the **Properties pane** (on page 12).
**Options**

- ![Properties](image)
  - Click this to display the properties of the selected linestring in the **Properties** pane.

- ![Create Linestring](image)
  - Click this to start the **Create Linestring** (see "Create a Linestring" on page 396) command.

- ![Reverse Order](image)
  - Click this to reverse the order of the linestring's segments and the start and end points.

- ![Set Line Elevation](image)
  - Click this to start the **Set Line Elevation** (see "Set a Line Elevation" on page 413) command.

- ![Break Line](image)
  - Click this to start the **Break Line** (see "Break a Line" on page 410) command.

**Horizontal tab**

**Current segment**

This shows the number, segment type, and end point type of the currently selected horizontal segment of the linestring. Click the back or forward arrow on either side of the listed segment (or scroll the mouse wheel) to select the previous or next segment.

A segment is defined by the location of its end point, the elevation of the point (if defined), and the type of connection to the previous segment's end point (or the linestring's starting point).

- ![Browse Horizontal Segments](image)
  - Click this to display the **Browse Horizontal Segments** dialog, a list in which you can view and select from all of the horizontal alignment segments in the linestring.

- ![Insert Segment](image)
  - Click this to insert a new segment before the selected segment or start point.

- ![Add Segment](image)
  - Click this to add a new segment onto the end of the linestring.

- ![Remove Segment](image)
  - Click this to remove the selected segment.
  
The segment and its end point are removed, and the adjoining segments' end points are joined.

- ![Convert Segments](image) or ![Convert Segments](image)
  - When displayed, click the icon to toggle between two states, depending on the current segment type.

  - Click ![Convert Segments](image) to convert a selected 3 point arc segment into two straight segments, converting the specified *point on curve* into a new segment's end point.

  - Click ![Convert Segments](image) to convert the selected segment and next segment into a 3 point arc, converting the end point of the first segment into the arc's *point on curve*.

**Start point**

This group appears only when you are specifying the beginning location of a linestring. Use the **Straight Segment Options** below.

**Segment type**

Select an option for how the current segment end point will be joined to the previous segment end point or the line's start point.
Work with Line Data

*Straight* - Select this to create a straight segment between the points.

*Arc* - Select this to create a curved segment defined by a radius between the points.

*3 Point Arc* - Select this to create a curved segment defined by a *point on curve* and an end point.

*Deflection* - Select this to add a straight segment at a deflection angle from the preceding segment.
Work with Line Data

**Straight segment/End point options**

**End point type**

- **Coordinate** - Select this to end the segment by specifying a fixed coordinate location.
- **Point ID** - Select this to end the segment by specifying a named point using a point ID. The linestring segment will be dynamically attached to that point object.

**Coordinate**
Pick a point in a graphic view, type a coordinate, or right-click for more options.

**Elevation**
Optionally, type an elevation for the end point of the segment. If you do, it establishes a vertical point of intersection on the line at the segment's end point.

**Point ID**
Pick a named point in a graphic view or type a point ID.

**Arc segment options**

- **Radius**
  Type a value for the radius of the arc.

- **Left/right**
  Select whether the arc should curve right or left, in relation to the direction of the previous segment.

- **Large/Small**
  Select whether to use the larger arc (> 180 °) or smaller arc (< 180 °) that is created between the points.

**3 Point arc segment options**

- **Coordinate**
  Select this to use any coordinate as the intermediate point ('point on curve') of the arc.

- **Point on curve**
  Pick a point in a graphic view, type a coordinate, or right-click for more options to specify a point through which the arc must pass.

- **Elevation**
  Optionally, type an elevation for the **point on curve** of the arc. If you do, it establishes a vertical point of intersection on the line at the segment's end point.

- **Point ID**
  Select this to use a named point as the intermediate point. Then, pick a named point in a graphic view or type a point ID in the box.

**Deflection segment options**

- **Direction**
  Select the perpendicular left (-90 °), perpendicular right (90 °), straight ahead (0 °) deflection angle option, or select **Specified angle** to enter a specific deflection angle.

  **Note:** Positive deflection angles are measured clockwise from the direction of the previous segment.

- **Length**
  Type a value in the box or pick a point in the graphic view to specify the length of the segment.

- **Elevation**
  Optionally, type an elevation for the end point of the segment. If you do, it establishes a vertical point of intersection on the line at the segment's end point.

- **Save**
  Click this to save the current segment.

You are prompted to specify the end point for the next segment.
Related topics

- [Edit a Linestring's Horizontal Segments](on page 397)
- [Edit a Linestring's Vertical Control Points](on page 405)
- [Vertical Linestring Options](on page 406)

**Edit a Linestring's Vertical Control Points**

If you need to define vertical points of intersection (VPIs) on a linestring that are located other than at the horizontal segment end points or the line's start point, add vertical control points along the linestring. A vertical control point is defined by its distance along the linestring, the elevation of the vertical point of intersection, and an indication as to whether a symmetrical parabolic vertical curve is involved at that VPI and if so, its length. Vertical points of intersection defined in this manner have no effect on the linestring's horizontal alignment.

**Note:** If a horizontal segment's end point and a vertical control point coincide, the elevation of the vertical control point overrides the elevation that may be assigned to the end point or to the point object to which it may be attached.

**To access these options:**

Select a line or linestring and do one of the following:

- Select **Line > Edit Linestring**.
- Click the ![icon](image) on the toolbar, or on the **Properties** pane toolbar when a linestring is selected.
- Right-click, and select **Edit** from the context menu.

The **Edit Linestring** command pane displays. Click the **Vertical** tab.

**To add a vertical control point with no vertical curve:**

1. Click the ![icon](image) icon.
2. In the **Curve** group’s **Type** box, select **No curve**.
3. Type a distance from the linestring's start point in the **Distance along** box, or pick a point along the linestring in the graphic view.
4. Type an elevation for the vertical control point in the **Elevation** box.
5. Click **Save** or press **[Enter]**. The vertical control point is added with simple, straight transitions from and to the point using the straight segments created by the point.

**To add a vertical control point with a parabolic curve:**

1. Click the ![icon](image) icon.
2. In the Curve group’s Type box, select Parabolic.

3. In the Length box, type a length for the parabolic vertical curve to be applied at the vertical control point.

4. Type a distance from the start point in the Distance along box, or pick a point along the linestring in the graphics view.

5. Type an elevation for the vertical control point in the Elevation box, and click Save or press [Enter]. The vertical control point is added with a parabolic curve.

To view and select a vertical control point in a list:

1. Click the icon. The Browse Vertical Information dialog displays.
2. Select the point you need, and click OK.

To step through each vertical control point in sequence:

- Click the back and forward arrows on either side of the Current vertical control point list.

To edit a vertical control point:

1. Select the point by selecting it in the Current VPI list or clicking and selecting it in the Browse Vertical Information list.
2. Modify any of the points options, and click Save.

To delete a vertical control point:

1. Select the point by selecting it in the Current VPI list or clicking and selecting it in the Browse Vertical Information list.
2. Click the icon. The point is removed, eliminating the affect of the vertical control point on the linestring’s vertical alignment.

Related topics
- Edit a Linestring’s Horizontal Segments (on page 397)
- Vertical Linestring Control Point Options (see "Vertical Linestring Options" on page 406)

Vertical Linestring Options

Use these options to create and edit vertical control points along a linestring. They are available on the Vertical tab of the Edit Linestring command pane. Linestring properties can be edited in the Properties pane (on page 12).
Work with Line Data

**Vertical tab options**

**Current VPI**

This shows the distance along the linestring and curve type of the currently selected vertical control point on the linestring. Click the back or forward arrow on either side of the listed point to select the previous or next point.

A vertical control point is defined by its distance along the linestring, the elevation of the point, and how the linestring's geometry vertically transitions at the point.

**Note:** The locations of vertical control points are independent of the locations and elevations of horizontal segment end points; when you move horizontal segments, vertical control points remain at the distance along the line at which they were defined. If a horizontal segment's end point and a vertical control point coincide, the elevation of the vertical control point overrides the elevation of the end point.

Click this to display the **Browse Vertical Information** dialog, a list in which you can view and select from all of the vertical control points in the linestring.

Click this to add a new a vertical control point.

Click this to remove the selected vertical control point.

**Curve type**

Select an option for how the linestring's geometry vertically transitions at the vertical control point.

- **No curve** - Select this to simply transition at the vertical control point using the two straight segments created by the point.

- **Parabolic** - Select this to transition more smoothly by rounding off the two straight segments created by the point using a parabolic curve.

**No curve type**

**Distance along**

Type a distance from the linestring's start point, or pick a point along the linestring in the graphic view.

**Elevation**

Type an elevation for the vertical control point.

**Parabolic curve type**

**Length**

Type a length for the parabolic curve that transitions the two straight segments into the vertical control point.

The parabolic curve is tangent to both incoming and outgoing segments.

**Save**

Click this to save the current vertical control point.

You are prompted to specify the location of the next vertical control point.

**Related topics**

- [Edit a Linestring's Horizontal Segments](on page 397)
Work with Line Data

- [ ] Edit a Linestring’s Vertical Components (see "Edit a Linestring’s Vertical Control Points" on page 405)
- [ ] Horizontal Linestring Options (see "Horizontal Linestring Segment Options" on page 401)

**Create and Edit a Simple Breakline**

Simple breaklines are simplified linestrings that help to define the shape of a surface as do other 3D line types that act as breaklines, by controlling how triangles in the surface mesh are formed. Triangles forming a surface never cross a breakline. Use breaklines of any type to more accurately reflect where surface topography changes.

Create a simple breakline is to add linestring segments between points where surface triangles converge (vertices), but you can also add simple breakline segments freely between any two locations on or near the surface. The addition, deletion or any edit to a 3D line serving as a surface breakline will cause the entire surface to be reformed. Unlike more complex linestrings, simple breaklines do not use vertical control points; you can enter elevations for each new vertex or derive elevations from existing vertices.

**To create a simple breakline:**

1. Do one of the following:
   - Select **Surface > Create Breakline**.
   - Click the icon on the toolbar.

   The **Create Breakline** command pane displays.

2. In the **Name** box, type an identifier for the linestring as you want it to appear in the **Selection Explorer** and in graphic views when you select from multiple objects. You can also use the name to select the linestring in the **Advanced Select** command.

3. Select a layer on which to create the linestring in the **Layer** list, or select <<New layer>> to create a new layer for the linestring.

4. Select an option for how smoothly the surface is rendered at this particular linestring in the **Surface sharpness** list.

5. Select the surface to which the linestring will be assigned as a member in the **Add to surface** list.

6. Click **OK**. The **Edit Linestring** command pane displays with reduced options appropriate for creating a simple breakline.

7. In the **Start Point** group’s **Type** list, select **Coordinate** to start the linestring at any location, or select **Point ID** to attach the linestring to a named point.
8. Click in either the Coordinate box or Point ID box (depending on what you chose for the starting point type), and use one of these ways to specify each point along the linestring:

- In a graphic view, pick a vertex on the surface, or pick a named point (which may be a member of the surface and therefore one of its vertices)
- Pick any location on or near the surface in the graphic view, and then type an elevation in the Elevation box. Then, click Save or press [Enter].
- Type a coordinate, press [Tab], and type an elevation in the Elevation box. Click Save or press [Enter].

The first point of the simple breakline is saved and you are prompted to add the second point and specify how the segment between them is formed.

**Note:** To use the elevation from a point you pick anywhere on a surface, right-click and select From Surface Snap from the context menu. You are prompted to pick the point in the From Surface Snap command pane. Then, click Save or press [Enter].

**Note:** To avoid picking points off of the surface (with no elevation), uncheck the Free snap in the Snap Mode (see "Snaps Modes and Commands" on page 98) dialog when you create a simple breakline or linestring. If you are prompted for an elevation, you may have missed the vertex point you were trying to pick.

**Note:** You can also draw a ‘freehand’ breakline without using any existing data. In fact, you do not even need to have a surface to create a breakline.

9. Keep adding segments to the linestring using one of the methods in step 8.

10. Click Close. The simple breakline appears on the surface in graphic views, but does not appear in the Project Explorer.

**Note:** Once created, linestrings can be graphically selected and added to other surfaces.

**Tip:** To view changes to your surface more clearly as you work, open a 3D view and move it to a new tab group next to your plan view so you can see both views concurrently.

**To edit a simple breakline:**

- Use the operations in Edit a Linestring's Horizontal Segments (on page 397).

**Related topics**

- Edit a Linestring's Horizontal Segments (on page 397)
- Create a Linestring (on page 396)
- Understanding Breaklines (on page 427)
Breakline Options

Use these options and those listed in *Horizontal Linestring Options* to create a breakline. They are available in the *Create Breakline* and *Edit Linestring* command panes. After creating a breakline, these properties and others can be edited in the *Properties* pane.

**Options**

| Name       | Type an identifier for the breakline.  
|------------|--------------------------------------------------------------------------------|
| Layer      | Select the layer on which you want the breakline to reside, or select `<<New layer>>` to create a new layer for the breakline. Segregating data onto logical layers makes it easier to filter your graphic views and select related data.  
| Surface sharpness | Select an option for how smoothly surface colors graduate at breaklines.  
| Add to surface | Select the surface that you want the breakline to modify.  

**Related topics**

- [Create and Edit a Breakline](#) (see "Create and Edit a Simple Breakline" on page 408)
- [Edit a Surface by Creating a Breakline](#) (on page 430)

Break a Line

Break a line to split it into two separate linestrings at the point you specify. The linestrings remain coincidental at the break point, but must be edited separately thereafter.

**Note:** This command and others used on lines, such as *Join*, *Edit*, and *Delete Line Segment*, convert the lines into linestrings. Linestrings are generic lines which offer more editable properties than the original lines. For more information on linestrings, see *Understanding Linestrings*.

**To break a line:**

1. Do one of the following:
   - Select **Line > Break Line**.
   - Click the ✎ icon on the toolbar.

   The **Break Line** command pane displays.
2. Pick a line in a graphic view. The line is converted into a linestring which is recorded in the Line box, and a "rubber-band" line appears between your cursor and the linestring.

3. Using the rubber-band line, pick a location along the linestring at which to break it, or distance from the beginning point of the line in the Location box and click Break. The linestring is broken at the point you specified.

4. To break another line, click in the Line box, or click Close to end the command.

Related topics
- Join Lines (on page 411)
- Create a Linestring (on page 396)
- Edit a Linestring’s Horizontal Segments (on page 397)

Join Lines

Join two or more contiguous lines into individual linestrings using manual and automated methods. When lines are joined, they are converted into linestrings, thereby increasing their versatility. The resulting linestring’s direction and properties are determined by the first (base) line that you choose.

There are two ways lines join:
- By making their end points coincident if they are within 0.0001 m of each other
- By drawing a straight segment between the nearest end points if they are further than 0.0001 m apart

**Note:** End points with different elevations cannot be joined.

**Note:** This command works on 2D data in the plan view; end points with an elevation of 0 (zero) are converted to 2D end points.

To join two lines manually:

1. Do one of the following:
   - Select Line > Join Lines.
   - Click the icon on the toolbar.
   
   The Join Lines command pane displays.

2. Select the Two lines option.

3. Pick a line in a graphic view. The line’s name is recorded in the Base line box.

4. Pick the line you want to join to the base line. The line’s name is recorded in the Line to join box. The lines are joined and converted into a single linestring.

5. To join additional pairs of lines, continue to pick lines to connect to the current base line.
6. Continue to join additional lines, or click Close.

**To join one line to many consecutive lines:**

1. After step 1 above, select the **One line to selection** option.
2. Pick a line in a graphic view. The line's name is recorded in the **Base line** box.
3. Pick a set of lines to join to the base line, or click **Options** and choose a selection option. The number of lines selected is recorded in the **Lines to join** box.
4. Press [Enter] or click **Join**. The command searches from the base line to each consecutive line, joining them until it reaches a break in the lines or a branch to multiple lines where it stops. The number of lines that were successfully joined to the base line is reported at the bottom of the pane.

**Note:** Lines that are not within the 0.0001 m tolerance of each other cannot be joined using this method.

**To join all consecutive lines:**

1. After step 1 in the first procedure, select the **All selected lines** option.
2. Pick a set of lines to join in a graphic view, or click **Options** and choose a selection option. The number of lines selected is recorded in the **Lines to join** box.
3. Press [Enter] or click **Join**. The command searches from each selected line to each consecutive line, joining them until it reaches a break in the lines or a branch to multiple lines where it stops. The number of lines that were successfully joined to the base line is reported at the bottom of the pane.

**Note:** Lines that are not within the 0.0001 m tolerance of each other cannot be joined using this method.

**Related topics**

- [Break a Line](on page 410)

**Delete a Line Segment**

Delete a segment from a multi-segmented line or linestring to form one or two linestrings, depending on whether you delete an interior or an end segment. If a line consists of only one segment, the entire line will be deleted.

**Note:** This command can be especially helpful in fixing crossing breaklines in a surface.

**To delete a segment:**

1. Do one of the following:
Work with Line Data

- Select **Line > Delete Line Segment**.
- Click the 🖍️ icon on the toolbar.

The **Delete Line Segment** command pane displays.

2. Pick a line or linestring in a graphic view. The name is recorded in the **Line** box, and a "rubber-band" line appears between your cursor and the line.

3. Using the rubber-band line, move along the line and pick the segment you want to delete. The segment disappears.

   **Tip:** You can also roll the mouse wheel to scroll through the line's segments.

4. Continue picking linestrings and then segments to delete, or click **Close**.

Related topics

- [Create a Linestring](#) (on page 396)
- [Edit a Linestring’s Horizontal Segments](#) (on page 397)

**Set a Line Elevation**

Apply a single, constant elevation to a 2D line to make it a 3D linestring. You can also specify a vertical offset from the elevation that you enter and a surface to which the linestring will be added.

**Note:** You cannot set a line elevation on a line that already has elevations. To modify the existing elevations, add vertical control points using the **Edit Linestring** command.

**Tip:** The **Set Line Elevation** command is especially efficient when you have annotations that contain elevations next to your lines. You can simply pick each object and annotation consecutively.

**Tip:** If you need to apply the same elevation to multiple consecutive linestrings, you may want to join them into a single linestring first using the **Join** command.

**To set a constant elevation on a linestring:**

1. Do one of the following:

   - Select **Line > Set Line Elevation**.
   - Click the 🖍️ icon on the toolbar.

The **Set Line Elevation** command pane displays.

2. To apply a standard vertical offset to each elevation you enter, type a value in the **Vertical offset** box.
Note: This can be especially helpful when elevation values are specified by clicking on a text object, and when the resulting value is to be above or below the elevation reflected on that text. This commonly occurs in setting building pad elevations where the finished floor elevation is labeled, and the top of pad is to be beneath that by a specified slab thickness.

3. To make each line you pick a member (see "Edit a Surface by Adding and Removing Members" on page 424) of a specific surface, select the surface in the Add to Surface list.

4. Pick a line in a graphic view. Any CAD line is converted to a linestring.

5. Pick another object, such as an elevation annotation or contour line, that has an elevation you want to use, or type a value in the Elevation box. The elevation is applied to the entire linestring after adding the specified vertical offset.

6. Repeat steps 4 and 5 to add elevations to additional objects as needed.

7. Click Close.

Related topics
- Join Lines (on page 411)
- Edit a Linestring’s Horizontal Segments (on page 397)

Explore an Object

Explore objects, such as lines and alignments, by viewing geometric values calculated at specific locations based on the position of the cursor on the object in a graphic view. Certain values are displayed dynamically at the cursor as you move it along the object. Additional values are displayed statically in the command pane when you click in the view to specify a fixed location.

To explore an object:

1. Do one of the following:
   - Select Tools > Explore Object.
   - Click the icon on the toolbar.
     The Explore Object command pane displays.

2. Pick an object in a graphic view. The object is recorded in the Object box and values appear to the right of the cursor.

3. Move the cursor to see values at various locations along the object.

4. Click a location to report additional values in the command pane.

5. Click Close.
Explode a Block

After you import CAD data, explode any blocks that contain objects that you want to move, modify, or delete individually. Exploding breaks apart group objects that contain multiple individual objects (and sometimes additional nested blocks).

**To explode a block using options:**

1. Select **Edit > Explode Blocks**. The **Explode Blocks** command pane displays.
2. Select a block object in the **Project Explorer**, **Selection Explorer**, or a graphic view, or click **Options** and select an option in the list.
3. Uncheck the **Delete blocks after exploding** box if you want to retain the original block, as well as its individual component objects, after exploding it.

   **Note:** It is unlikely that you will need or want to retain the original block.

4. Check the **Remove block definitions** box if you want to delete the hidden definition of the original block that you deleted by checking the **Delete blocks after exploding** box.

   **Note:** This box is unavailable if you do not delete the exploded blocks. Block definitions cannot be removed if your project still contains blocks that reference them.

5. Click **Apply** if you want to explode additional blocks, or **OK** to close the command pane.

**To explode a block automatically:**

1. Select a block in a graphic view or in the **Selection Explorer**.
2. Do one of the following:
   - Click the 🌟 icon on the toolbar.
   - Right-click and select **Explode Blocks** from the context menu.

   The selected block is exploded using the options defined in the **Explode Blocks** command pane.

**Related topics**

- **Import CAD Files (.dwg/.dxf)**
- **Import MicroStation Files (.dgn)** (on page 230)
Work with Surface Data

Create and Edit a Surface

Understanding Surfaces

A surface is a 3D digital representation of topography, formed by a mesh of contiguous triangles, which is known as a triangulated irregular network (TIN). The triangles are connected at their vertices, which are defined by points with horizontal positions (X and Y values) and elevations (Z values). You can either import surfaces, or create them using existing data in your project.

Use surfaces to:

- Visualize and analyze the topography at different phases in your project:
  - Existing/as built terrain
  - Work in progress terrain
  - Finished earth
  - Proposed terrain (design)
Work with Surface Data

- Compare one phase to another to generate volume reports for cut and fill earthwork operations.
- Represent stockpiles and depressions
- Create contour maps from topographic surveys.
- Upload a surface to a field device to check grades, or for accurate staking of an alignment or daylight boundary.

Related topics
- Create a Surface (on page 419)
- Workflow for Using Imported Surfaces (on page 417)
- Workflow for Created Surfaces (see "Workflow for Creating Surfaces" on page 418)

Workflow for Using Imported Surfaces

You may receive surface files in .ttm or .xml format from colleagues, clients, or field crews using field software. You can also create surfaces from point data when you import using the Import Format Editor. The general workflow for using imported surfaces is:

1. Import the file containing the surface. The surface is created as a single object, and appears in the Project Explorer.
2. Check the surface for quality to make sure it accurately reflects the project topography.
   - View the surface in plan view with contours.
   - Orbit and view the surface in 3D view.
   - Use the coordinate scroll to check the elevation at specific locations.
3. Edit surface properties, such as the classification, color, and other display characteristics.
4. Compute volumes by comparing the surface to another surface.
5. Upload the surface to a field device for staking, or export it to another application.

Related Topics
- Import LandXML Files (.xml) (on page 226)
- Import Terrain Model Files (.ttm) (see "Import Trimble Surface Files (.ttm)" on page 234)
- Check Imported Surfaces (on page 417)

Check Imported Surfaces

You can import surfaces existing in Trimble DTM (.ttm), LandXML files (.xml), or ASCII point files. Once you do, check the surface for quality and accuracy.
To check an imported surface:

1. Add contours to visualize the topography of the surface.
2. Spot check elevations. Pick a point in a graphic view to find the elevation of the surface at that location. The coordinate scroll also shows the elevation of the current cursor location.
3. In the 3D view, orbit around the surface and zoom in to see if everything looks valid. If it helps, change the vertical exaggeration.
4. Pick the surface and view its properties in the Properties pane.

Example of a surface with a point at an invalid elevation.

Related Topics

- Import LandXML Files (see "Import LandXML Files (.xml)" on page 226)
- Import TTM Files (see "Import Trimble Surface Files (.ttm)" on page 234)
- Create Surface Contours at Intervals (on page 439)
- Edit a Surface by Changing Its Properties (on page 434)
- 3D View Navigation (on page 43)

Workflow for Creating Surfaces

You can create surfaces from data in your project. Here is the general workflow:

1. Import the data from which you want to create a surface. Objects that can be used to create surfaces include:
   - Points
   - Feature coded points
   - CAD data
2. Check and prepare the data.
   - Delete unneeded objects.
   - Organize data onto layers.
   - Add elevations to 2D CAD data.
3. Create a surface.
   - Select objects by layer, by elevation, or by picking them in a graphic view.

4. Check the surface for quality to make sure it accurately reflects the project topography.
   - View the surface in plan view with contours.
   - View the surface in 3D view.
   - Use the coordinate scroll to check the elevation at specific locations.

5. Edit the surface.
   - Add or remove members that form the surface.
   - Edit properties, such as elevations, of surface members.
   - Add breaklines to the surface.
   - Edit triangles at the surface's edge.

6. Compute volumes by comparing the surface to another surface.

Related Topics

Prepare Layered Data for a Surface
- Add and Edit Elevations on a 2D Line
- Create a Surface (see "Understanding Surfaces" on page 416)
- Create Surface Contours (see "Create a Surface Boundary and Contours" on page 435)

Create a Surface

Certain types of objects in your data can be used to define a surface, including:
   - Points
   - Arcs, lines with elevation data, and polylines
   - Alignments
   - Sessions and vectors

When you create a surface, you select a set of these objects. These selected objects are called "members" of the surface. Members do not become part of the surface, they simply define it. The surface is created as a separate object. To change a surface, you add, remove, or edit the positions of members in the set. As a result, the surface object updates to reflect the changes.
To create a surface:

1. Do one of the following:
   - Select Surface > Create Surface.
   - Click the icon on the toolbar.

   The Create Surface command pane displays.

2. Type a name in the Name box.

3. Select a type in the Surface Classification list. This classification will be used to compare the surface to another surface with a different classification to calculate volumes for the Earthwork Report.

4. In a graphic view, pick objects to include as member of the surface, or click Options and select an option in the list.

   Note: If you have organized your project into layers, select ByLayer.

5. Click OK. The surface appears in the graphic views and the Project Explorer.

   Tip: To view surfaces more clearly, use a 3D view, and set your view filter to Surfaces.

6. Check the surface for quality to make sure it accurately reflects the project topography.
   - View the surface in a plan view with contours.
   - View the surface in 3D view.
   - Use the coordinate scroll to check the elevation at specific locations.

Related topics
- Prepare Layered Data for a Surface
- Surface Options (on page 420)
- Workflow for Creating Surfaces (on page 418)

Surface Options

Use these options to identify the state of a surface in the construction process. They are available in the Create Surface command pane.
Work with Surface Data

Options

Surface Classification

**Unclassified** - Select this when none of the classifications apply, or when you do not need to compare the surface to another classification of surface.

**Original** - Select this when the surface represents the current state of the site's topography, i.e. the existing terrain.

**Work-in-progress** - Select this when the surface represents a state in between the other, more defined, states.

**Finished earth** - Select when the surface represents the “top-of-dirt” of the finished design. This is usually the finished product for dirt-moving contractors.

**Design** - Select this when the surface represents the proposed surface of a project, typically running across the top of pavement, building pads, concrete sidewalks etc.

In most cases, this is the surface defined by the contours and spot elevations on plans from the engineer.

**As-built** - Select this when the surface represents the completed project.

Often this state is used to verify to an owner or regulatory agency that the site construction conforms to the plans.

**Stockpile** - Select this when the surface represents a storage area for earthwork material.

**Depression** - Select this when the surface represents a hole where material has been removed.

Related topics

- Create a Surface (see “Understanding Surfaces” on page 416)

Create and View a Surface Profile

Create a surface profile to review the elevation of a surface along a vertical alignment. To do this, you must have a surface and an alignment that coincide. If you simply want to see a surface profile without relation to an alignment, use the Surface Slicer View (see "View a Slice of a Surface" on page 423).
To create a surface profile:

1. Do one of the following:
   - Click the 🌡️ icon on the toolbar.
   - Select Surface > Create Surface Profile.
     The Create Profile of Surface command pane displays.

2. Select a surface in the Surface list.

3. Select an alignment in the Alignment list.

4. Click OK. The profile of the surface displays with the alignment in the profile view.

To view a surface cross-section along an alignment:

1. In the Project Explorer, select the alignment that coincides with the surface.

2. Right-click and select New Profile View from the context menu. The profile view of the alignment displays.

Related topics
- Profile View (on page 25)
- Create an Alignment (see "Understanding Alignments" on page 382)
- Create a Surface (see "Understanding Surfaces" on page 416)
- View a Slice of a Surface (on page 423)

Create and View a Surface Cross-Section

Create a surface cross-section to check geometry along a single, specific alignment anywhere it coincides with a single, specific surface. To do this, the surface and alignment must be coincident. The view changes depending on where you are along the alignment. When the alignment or surface that the view is based on is modified or deleted, the view updates accordingly. Multiple cross-section views can be open concurrently.
To create a surface cross-section:

1. Do one of the following:
   - Click the icon on the toolbar.
   - Select Surface > Create Surface Cross-Section.
     The Create Surface Cross-Section command pane displays.
2. Select a surface in the Surface list.
3. Select the coincident alignment in the Alignment list.
4. Click OK.

To view a surface cross-section along an alignment:

1. In the Project Explorer, select the alignment that coincides with the surface.
2. Right-click and select New Cross-Section View from the context menu. A cross-section view displays.
3. Click and drag the slider at the bottom of the view to see the cross-sections along the alignment.
   or
   Type a station value in the box to the left of the slider to see the cross-section at a specific station. After you click in the station box, you can also move the cursor into the plan view and click anywhere along the alignment to specify the station.

Note: The cross-section view maintains the same scale as you move the station slider. Red tick marks denote where the cross-section crosses points or breaklines. Bold vertical lines denote station equations. At certain view magnifications, slope values appear above segments. To hide cross-section slope values, right-click the cross-section, and select Properties from the context menu. In the Properties pane, select Hide in the Label slope list.

Related topics
- Create an Alignment (see "Understanding Alignments" on page 382)
- Create a Surface (see "Understanding Surfaces" on page 416)
- Profile View (on page 25)
- View a Slice of a Surface (on page 423)

View a Slice of a Surface

Use the surface slicer view to check any surface cross-section by slicing vertically through the surface. You need to have the plan view and the surface slicer view open concurrently. Multiple surface slicer views can be open at a time, and you can view multiple surfaces in the view concurrently.
**To view a surface slice:**

1. Do one of the following:
   - Select **Surface > Surface Slicer View**.
   - Click the icon on the toolbar.

   The surface slicer view displays.

2. Click in the **From** box and pick a starting point for the slice in the plan view, or type a coordinate (in the format X,Y) or point ID in the box.

3. Pick an ending point for the slice, or type a coordinate or point ID in the **To** box.

   **Tip:** After picking the **From** point, you can also move the cursor across the surface to view the cross-section slice dynamically, without picking a **To** point. The surface slicer view automatically scales to fill the view as you move the **cursor**.

   **Note:** Red tic marks denote where the slice crosses points or breaklines. At certain view magnifications, slope values appear above segments. To hide cross-section slope values, right-click the cross-section, and select **Properties** from the context menu. In the **Properties** pane, select **Hide** in the **Label slope** list.

   **Note:** You can also right-click in the view to access COGO controls and snaps when picking points.

4. To add additional surfaces to the view, click **Surfaces**. The **Select Surfaces** dialog displays.

5. Check boxes for the surfaces to include in the surface slicer view, and click **OK**.

**Related topics**

- [Create and View a Cross-Section](#) (see "Create and View a Surface Cross-Section" on page 422)

**Edit a Surface by Adding and Removing Members**

Members are not part of a surface; they are simply used to define the surface. Edit a surface by adding to, and removing from, the set of members. As a result, the surface updates to reflect the changes.

You may want to prepare your data by organizing members by layer before using this command.

**Warning:** If you add objects on or beyond the outer edge of a surface, the surface is recalculated and all prior edge trimming is lost. Similarly, if you remove objects from a surface edge, all prior trimming is lost.
To add and remove surface members:

1. Do one of the following:
   - Select Surface > Add/Remove Surface Members.
   - Click the icon on the toolbar.
   - Select a surface in the Project Explorer, right-click, and select Add/Remove Surface Members.

   The Add/Remove Surface Members command pane displays.

2. Select a surface to edit in the Surface list, unless you have already selected one.

3. In a graphic view, pick objects to add to the set of surface members, or click Options and choose a selection method in the context menu. You can also select objects in the Project Explorer.

   **Tip:** Sometimes it is difficult to pick surface members without picking the surface itself. Here are some ways to make it easier:
   Use the View Filter to control the visibility and selectability of surfaces and their members. To view surfaces more clearly, use a 3D view, and set your view filter to Surfaces. If more than one object is in the pick aperture when you pick, a list of the possible selections appears. Refine your pick by selecting from the list. Use windowing and crossing (see "Graphic Selection Methods" on page 49) selection methods to pick only what you need.

4. Click Add to update the surface based on the selected objects. The surface changes in the 3D view.

5. In a graphics view, pick surface members to remove, or click Options and choose a selection method in the context menu.

6. Click Remove to update the surface based on the selected objects.

7. Click Close.

Related topics

- Edit a Surface by Creating a Breakline (on page 430)
- Edit a Surface by Changing a Point Coordinate (on page 425)
- Edit a Surface by Changing Its Properties (on page 434)
- Edit a Surface by Trimming Edge Triangles (on page 432)
- Prepare Layered Data for a Surface

**Edit a Surface by Changing a Point Coordinate**

Make your surface more accurate by editing inaccurate coordinate heights in the Properties pane.
To edit surface member properties:

1. Do one of the following:
   - Pick the point(s) in a graphic view, or select it in the **Project Explorer**.
2. Click the icon next to the point in the **Project Explorer** to expand it, and select the coordinate.
3. Double-click the coordinate, or right-click it and select **Properties** from the context menu. The **Properties** pane displays.
4. Edit any of the values in the **Coordinates** group as needed.
5. Click **Close**. The surface updates accordingly.

Related topics

- [Edit a Surface by Adding and Removing Members](on page 424)
- [Point Coordinate Options](on page 370)

**Point Coordinate Options**

Use these options to edit point coordinates when the point is a member of a surface. The surface that references the edited member updates accordingly. These options are found in the **Properties** pane for a point coordinate.

<table>
<thead>
<tr>
<th>Member type</th>
<th>Properties that affect surfaces</th>
</tr>
</thead>
<tbody>
<tr>
<td>Coordinate</td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Northing</strong> - Edit this to move a surface vertex north or south.</td>
</tr>
<tr>
<td></td>
<td><strong>Easting</strong> - Edit this to move a surface vertex east or west.</td>
</tr>
<tr>
<td></td>
<td><strong>Elevation</strong> - Edit to move a surface vertex up or down, relative to sea-level.</td>
</tr>
<tr>
<td></td>
<td><strong>Latitude</strong> - Edit this to move a surface vertex north or south.</td>
</tr>
<tr>
<td></td>
<td><strong>Longitude</strong> - Edit this to move a surface vertex east or west.</td>
</tr>
<tr>
<td></td>
<td><strong>Height</strong> - Edit this to move a surface vertex up or down.</td>
</tr>
<tr>
<td>Session</td>
<td><strong>Height</strong> (point) - Edit this to move a surface vertex up or down.</td>
</tr>
</tbody>
</table>

Related topics

- [Edit a Surface by Changing a Point Coordinate](on page 425)
- [Edit a Surface by Adding and Removing Members](on page 424)
Understanding Breaklines

Breaklines are lines that help to define the shape of surfaces by controlling how triangles in the surface mesh are formed; triangles forming a surface never cross a breakline. Use breaklines to make surfaces more accurate. For example, if a square area on your surface is formed by two triangles using the wrong opposing points, you can switch the direction of the diagonal to reform the two triangles. This might be done to get drainage to work as the site designer intended, or simply to ‘smooth’ the surface.

The simplest way to create a breakline is to add it between points where surface triangles converge (vertices). You can also create breaklines by picking locations on the surface that are not vertices. The surface triangles are redrawn, creating vertices at the points you picked.

You might add a breakline to a surface to represent:

- A stream bed
- A curb line

A linear feature that was not recorded in the field Here is an example of how adding a breakline (in yellow) can change a surface:

In addition to the breaklines that you actively create, other breaklines are automatically created in surfaces when you import or select linear objects to create a surface. Any linear object, such as a polyline or an alignment, that you use in the creation of a surface will be represented as a breakline in the surface. If you modify the linear object, the breakline will update in response.

**Note:** When you use an alignment in the creation of a surface, you can constrain the resulting breaklines horizontal and vertical distance from the alignment by setting tolerances in the *Project Settings*. Select *Project > Project Settings*. Then click *Computational Settings* and *Surface* in the left pane.

Related topics

- [Edit a Surface by Creating a Breakline](on page 430)
Create and Edit a Simple Breakline

Simple breaklines are simplified linestrings that help to define the shape of a surface as do other 3D line types that act as breaklines, by controlling how triangles in the surface mesh are formed. Triangles forming a surface never cross a breakline. Use breaklines of any type to more accurately reflect where surface topography changes.

Create a simple breakline is to add linestring segments between points where surface triangles converge (vertices), but you can also add simple breakline segments freely between any two locations on or near the surface. The addition, deletion or any edit to a 3D line serving as a surface breakline will cause the entire surface to be reformed. Unlike more complex linestrings, simple breaklines do not use vertical control points; you can enter elevations for each new vertex or derive elevations from existing vertices.

To create a simple breakline:

1. Do one of the following:
   - Select Surface > Create Breakline.
   - Click the icon on the toolbar.

   The Create Breakline command pane displays.

2. In the Name box, type an identifier for the linestring as you want it to appear in the Selection Explorer and in graphic views when you select from multiple objects. You can also use the name to select the linestring in the Advanced Select command.

3. Select a layer on which to create the linestring in the Layer list, or select <<New layer>> to create a new layer for the linestring.

4. Select an option for how smoothly the surface is rendered at this particular linestring in the Surface sharpness list.

5. Select the surface to which the linestring will be assigned as a member in the Add to surface list.

6. Click OK. The Edit Linestring command pane displays with reduced options appropriate for creating a simple breakline.

7. In the Start Point group’s Type list, select Coordinate to start the linestring at any location, or select Point ID to attach the linestring to a named point.

8. Click in either the Coordinate box or Point ID box (depending on what you chose for the starting point type), and use one of these ways to specify each point along the linestring:
   - In a graphic view, pick a vertex on the surface, or pick a named point (which may be a member of the surface and therefore one of its vertices)
Work with Surface Data

- Pick any location on or near the surface in the graphic view, and then type an elevation in the *Elevation* box. Then, click *Save* or press [*Enter*].

- Type a coordinate, press [*Tab*], and type an elevation in the *Elevation* box. Click *Save* or press [*Enter*].

The first point of the simple breakline is saved and you are prompted to add the second point and specify how the segment between them is formed.

**Note:** To use the elevation from a point you pick anywhere on a surface, right-click and select *From Surface Snap* from the context menu. You are prompted to pick the point in the *From Surface Snap* command pane. Then, click *Save* or press [*Enter*].

**Note:** To avoid picking points off of the surface (with no elevation), uncheck the *Free* snap in the *Snap Mode* (see "Snaps Modes and Commands" on page 98) dialog when you create a simple breakline or linestring. If you are prompted for an elevation, you may have missed the vertex point you were trying to pick.

**Note:** You can also draw a ‘freehand’ breakline without using any existing data. In fact, you do not even need to have a surface to create a breakline.

9. Keep adding segments to the linestring using one of the methods in step 8.

10. Click *Close*. The simple breakline appears on the surface in graphic views, but does not appear in the *Project Explorer*.

**Note:** Once created, linestrings can be graphically selected and added to other surfaces.

**Tip:** To view changes to your surface more clearly as you work, open a 3D view and move it to a new tab group next to your plan view so you can see both views concurrently.

To edit a simple breakline:

- Use the operations in *Edit a Linestring’s Horizontal Segments* (on page 397).

**Related topics**

- [Edit a Linestring's Horizontal Segments](on page 397)
- [Create a Linestring](on page 396)
- [Understanding Breaklines](on page 427)

**Breakline Options**

Use these options and those listed in *Horizontal Linestring Options* to create a breakline. They are available in the *Create Breakline* and *Edit Linestring* command panes. After creating a breakline, these properties and others can be edited in the *Properties* pane.
**Options**

**Name**
Type an identifier for the breakline. This name will appear in the *Selection Explorer* and in graphic views when you select from multiple objects. In addition, you can use the name to select the breakline using the *Advanced Select* command.

**Layer**
Select the layer on which you want the breakline to reside, or select `<New layer>` to create a new layer for the breakline. Segregating data onto logical layers makes it easier to filter your graphic views and select related data.

**Surface sharpness**
Select an option for how smoothly surface colors graduate at breaklines.

- **Soft** - Select this to have shading gradually change at the breakline, giving the visual appearance of a soft edge.
- **Sharp** - Select this to have shading abruptly change at the breakline, giving the visual appearance of a sharp edge.

**Add to surface**
Select the surface that you want the breakline to modify.

**Related topics**
- [Create and Edit a Breakline](#) (see "Create and Edit a Simple Breakline" on page 408)
- [Edit a Surface by Creating a Breakline](#) (on page 430)

**Edit a Surface by Creating a Breakline**

3D lines of several types can be designated as members of a surface. They serve to influence the shape of that surface by acting in the classic manner as breaklines. These lines can exhibit complex curvilinear geometry and still serve a breaklines, by employing the breakline approximation parameters as defined in the computational settings for a surface in the *Project Settings* (see "Choose Project Settings" on page 155) dialog.

One of the types of lines that can serve as a member of a surface, thereby acting as a breakline, is the linestring. Like alignments, linestrings can exhibit rather complex curvilinear geometries. But they can also exist as simple strings of straight line segments, connecting 3D coordinate locations, as in the case of the more classic breaklines associated with typical TIN models. A linestring of that nature is referred to here as a simple breakline; a specific command has been devised to allow you to create a linestring of that nature and assign it as a member of a surface at the same time, while defining its surface sharpness. In using the Create Simple Breakline command, you will in fact be creating a linestring object, though through a simpler user interface and one that supports the line's association with a surface as a part of its creation.
The easiest way to create a simple breakline is to add segments between surface vertices (the points where surface triangles converge), but you can also add linestring segments freely between any two locations on or near the surface. Any geometric edit to a breakline of any kind will cause the entire surface to be reformed.

To create a simple breakline:

1. Do one of the following:
   - Select **Surface > Create Breakline**.
   - Click the 
     icon on the toolbar.

   The **Create Breakline** command pane displays.

2. In the **Name** box, type an identifier for the linestring as you want it to appear in the **Selection Explorer** and in graphic views when you select from multiple objects. You can also use the name to select the linestring in the **Advanced Select** command.

3. Select a layer on which to create the linestring in the **Layer** list, or select **<<New layer>>** to create a new layer for the linestring.

4. Select an option for how smoothly the surface is rendered at the linestring in the **Surface sharpness** list.

5. Select the surface to which the linestring will be assigned as a member in the **Add to surface** list.

6. Click **OK**. The **Edit Linestring** command pane displays with reduced options appropriate for creating a simple breakline.

7. In the **Start Point** group’s **Type** list, select **Coordinate** to start the breakline using any location, or select **Point ID** to start the breakline using a named point.

8. Click in either the **Coordinate** box or **Point ID** box (depending on what you chose for the starting point type), and use one of these ways to specify each point along the breakline:
   - In a graphic view, pick a vertex on the surface, or pick a named point (may also be a vertex)
   - Pick any location on or near the surface in the graphic view, and then type an elevation in the **Elevation** box. Then, click **Save** or press [Enter].
   - Type a coordinate, press [Tab], and type an elevation in the **Elevation** box or right-click for **COGO elevation options** (see "Enter an Elevation" on page 134). Click **Save** or press [Enter].

The first point of the linestring is saved and you are prompted to add the second point and specify how the segment between them is formed.
**Work with Surface Data**

| **Note:** To use the elevation from a point you pick anywhere on a surface, right-click and select **From Surface Snap** from the context menu. You are prompted to pick the point in the **From Surface Snap** command pane. Then, click **Save** or press **[Enter]**. |
|---|---|
| **Note:** To avoid picking points off of the surface (with no elevation), uncheck the **Free** snap in the **Snap Mode** (see "Snaps Modes and Commands" on page 98) dialog when you create a breakline. If you are prompted for an elevation, you may have missed the vertex point you were trying to pick. |
| **Note:** You can also draw a 'freehand' breakline without using any existing data using method below. In fact, you don’t even need to have a surface to create a breakline. |

9. Keep adding segments to the breakline using one of the methods in step 8.

10. Click **Close**. The breakline appears on the surface in graphic views, but does not appear in the **Project Explorer**.

| **Note:** Once created, breaklines can be graphically selected and added to other surfaces. |
| **Note:** To see the properties of a breakline (in the **Properties** pane) you have actively created, select the breakline in a graphic view. |
| **Tip:** To view changes to your surface more clearly as you work, open a 3D view and move it to a new tab group next to your plan view so you can see both views concurrently. |

**To edit a simple breakline:**

- Use the operations in **Edit a Linestring's Horizontal Components** (see "Edit a Linestring's Horizontal Segments" on page 397).

**Related topics**

- **Edit a Surface by Adding and Removing Members** (on page 424)
- **Edit a Surface by Changing Its Properties** (on page 434)
- **Edit a Surface by Changing a Point Coordinate** (on page 425)
- **Edit a Surface by Trimming Edge Triangles** (on page 432)

**Edit a Surface by Trimming Edge Triangles**

Clean-up the edges of surfaces in your project so that you can accurately calculate volumes when comparing surfaces.
Note: Before trimming the triangles at a surface's edge, adjust the **Maximum edge length** and the **Maximum edge angle** of the surface in the **Properties** pane. Setting these can reduce the amount of trimming needed on the surface edge. In general, trim the edge triangles of a surface after you have made all other surface edits.

**Warning:** If the program is forced to recompute the edge of a surface, then all edge trimming edits will be lost.

Things that would cause this are:
- Changing the **Maximum edge length** of the surface in the **Properties** pane.
- Changing the **Maximum edge angle** of the surface in the **Properties** pane.
- Adding a new surface member outside of the edge of the surface.
- Removing surface members that lie on the edge of the surface.

### To trim a triangle:

1. Do one of the following:
   - Click the icon on the toolbar.
   - Select **Surface > Trim Surface Edge**.
   - Right-click the surface in a graphic view, or the **Project Explorer** and select **Trim Surface Edge** from the context menu.

   The **Trim Surface Edge** command pane displays.

2. Select a surface to trim in the **Surface to Trim** list.

3. In a graphic view, pick a point to start the trim line or right click for options, or type a coordinate in the **Outside location** box.

4. In the view, pick a point to end the trim line or right click for options, or type a coordinate in the **Inside location** box.

5. Click **Apply** to keep trimming, or **Close**. Any triangle edges occurring outside of the outermost breakline are trimmed, removing the related triangle from the surface.

**Tip:** Trimming stops when a breakline on the surface is encountered. To trim deeper into the surface, remove the breakline using the Edit Surface command. Conversely, you can add breaklines to a surface to prevent trimming an edge beyond a certain point.

**Note:** Trimming maintains a valid surface based on the members used to form the surface. Because any point on the surface will always be connected to a triangle, the order in which you trim edge triangles can result in different formations. If you find that you cannot trim a certain triangle, you may need to remove the member on which it is based.

**Warning:** If you add objects on or beyond the outer edge of a surface, the surface is recalculated and all prior edge trimming is lost. Similarly, if you remove objects from a surface edge, all prior trimming is lost.
Edit a Surface by Changing Its Properties

Edit a surface object by controlling its triangle distance and angle values, as well as display properties in the Properties pane.

To edit surface properties:

1. Do one of the following:
   - Pick the surface in a graphics view, right-click, and select Properties from the context menu.
   - Double-click the surface in the Project Explorer, or right-click it and select Properties from the context menu.

   The Properties pane displays.

2. Click in an available property box, and make changes as necessary.

3. Click Close.

Related topics

- Edit a Surface by Adding and Removing Members (on page 424)
- Edit a Surface by Creating a Breakline (on page 430)
- Edit a Surface by Changing Its Properties (on page 434)
- Edit a Surface by Changing a Point Coordinate (on page 425)
- Surface Properties (on page 434)

Surface Properties

Use these options to change a surface's edge prior to trimming. They are available in the Properties pane when a surface is selected. In addition, you can set display properties for how a surface appears in graphic views.
Options

Max Edge Distance  Type a value for the maximum length that one side of a triangle can be if it lies on the edge of the surface.  
        Basically, this value defines how the longest distance that points can be connected on a surface edge.

Max Internal Angle  Type a value for the maximum angle that a surface triangle can use.
        Practically, this value limits the amount of long, but very narrow triangles that can form on the edge of a surface.

Related topics

-   Edit a Surface by Changing Its Properties (on page 434)
-   Edit a Surface by Trimming Edge Triangles (on page 432)

Run a Surface Report

Run a surface report to see surface measurements and limits, as well as the number of triangles, vertices, and other items in a surface in your project.

To generate a surface report:

1.   Do one of the following:
    -   Select Reports > Surface Information Report.
    -   Click the  icon.
        The Surface Information Report command pane displays.

2.   Select the surface you want to generate a report for in the Surface list.

3.   Click OK. The report displays in your default Web browser.

Related topics

-   Customize and Run a Report (see "Customize a Report" on page 481)

Create a Surface Boundary and Contours
A boundary is a line that delineates a portion of a surface. Boundaries can be polygonal or defined by specifying an offset from an alignment.

Contours are lines that show the topography of a surface at a constant elevation. Contour objects are separate from the surface objects to which they are attached, but they are nested under surfaces in the Project Explorer. You can associate multiple contour objects with a single surface object. When a surface is changed, the contours on the surface update to reflect any changes in elevation.

Related topics
- Create a Surface Boundary (see "Create a Boundary" on page 436)
- Create a Surface Contour at an Elevation (on page 440)
- Create Surface Contours at Intervals (on page 439)

Create a Boundary

Create a boundary to delineate a portion of a surface. This is useful if you do not want to send an entire surface to field software; it enables you to include a smaller surface model with your design data.

**Note:** Boundaries cannot be used to create or modify a surface.

To create a boundary by drawing a polygon:

1. Do one of the following:
   - Select Line > Create Boundary.
   - Click the icon on the toolbar.

   The Create Boundary command pane displays.

2. Type an identifier for the boundary in the Name box.

3. Select the layer on which you want the boundary to reside in the Layer box.

   **Note:** If the layer does not exist in your project yet, you can create it by selecting <New> in the box.

4. Select Polygon in the Creation Method group to define the boundary by drawing a polyline around an area.

5. Click in the Point box and pick a starting point for the polygonal boundary in the plan view, or type a coordinate or point ID in the box and click Apply.

6. Pick another point, or type a coordinate or point ID in the Additional Point box to draw the first line of the boundary. A "rubber-band" line appears, showing you how the boundary will be closed when you click Close.

7. Continue specifying points until you have completed the boundary.

8. To begin another boundary, click in the Name box, and repeat steps 2 - 7.
9. Click **Close**. The boundary appears in the view and the **Project Explorer**.

**To create a boundary offset from an alignment:**

1. Follow steps 1 - 3 above.
2. Select **Alignment corridor** in the **Creation Method** group to define the boundary by specifying an offset around a selected alignment.
3. Select an alignment to create a corridor around in the **Alignment** box.
4. Click in the **Left offset** box and pick a point in the view, or type a distance in the box to specify the left boundary of the corridor parallel to the alignment.

   **Note:** Since the alignment itself denotes a zero offset, typically the left offset value will be a negative number, unless you want to create a corridor on only one side of the alignment, such as for a sidewalk.

5. Pick a point in the view, or type a distance in the **Right offset** box to specify the right boundary of the corridor parallel to the alignment.

6. To create the boundary only between specific stations along the alignment, check the **Limit by station** box.
7. Click in the **Begin station** box and pick a point along the alignment, or type a value in the box.
8. Pick a point along the alignment, or type a value in the **End station** box.
9. Click **OK**. The boundary appears in the view and the **Project Explorer**.

**Related topics**

- **Boundary Options** (on page 437)
- Add and Edit a Design Model

**Boundary Options**

Use these options to specify a subset of a surface by creating a boundary. They are available in the **Create Boundary** command pane.
### Options

**Name**
Type a unique name for the boundary.

**Layer**
Select the layer on which you want to boundary to reside.
You can also select `<New>` to create a new layer for the boundary.

**Creation method**
- **Polygon** - Select this to define the boundary by drawing a polyline around an area.
- **Alignment corridor** - Select this to define the boundary by specifying an offset from a selected alignment.

#### Polygon options

**Point**
Pick a point in the view, or type a coordinate or point ID in the box to draw the first line of the boundary.

**Additional point**
Pick a point in the view, or type a coordinate or point ID in the box to draw additional lines along the boundary.
Open polygons will be closed when you click in the **Name** box to begin a new boundary, or when you close the command.

#### Alignment corridor options

**Alignment**
Select the alignment around which to create the boundary corridor.

**Left offset / Right offset**
Pick points in the view, or type distances in the boxes to specify the left and right boundaries of the corridor parallel to the alignment.

*Note:* Since the alignment itself denotes a zero offset, typically the left offset value will be a negative number, unless you want to create a corridor on only one side of the alignment, such as for a sidewalk.

**Limit by station**
Check this box to create the boundary only between specific stations along the alignment.
Begin station / End station

Pick points along the alignment, or type values in the boxes to specify the first and last stations in the corridor.

Related topics

- [Create a Boundary](on page 436)

Create Surface Contours at Intervals

Add contour lines to a surface at regular elevation intervals to help visualize the topography.

To create contours at intervals:

1. Pick the surface you want to add contours to in the graphics view, or select it in the Project Explorer.

2. Do one of the following:
   - Click the icon on the toolbar.
   - Select Surface > Create Contours.
   - Select a surface in the project explorer, right-click, and select Create Contours from the context menu.

   The Create Contours command pane displays.

3. Confirm the surface to which you want to add contours in the Surface box.

4. Type a name for the contour object in the Name box.

5. Type a value for the vertical distance between contours in the Contour interval box. The Estimated contours value updates in the Surface Information group below.
6. Type a value for the spacing of index contours in the Index frequency box. Index contours are the major contours, while the other contours are the minor contours.

7. Select a layer on which to place the contour object in the Layer box.

8. Select a display color for the contours in the Contour color box.

9. Select a display color for the index contours in the Index color box.

10. Click OK. The contours appear on the surface in graphic views, and under the surface in the Project Explorer.

To edit contours:

1. Do one of the following:
   - Double-click the contour object in the Project Explorer, or right-click it and select Properties from the context menu.
   - Pick a contour line in a graphic view, right-click, and select Properties from the context menu.

   The Properties pane displays.

2. Edit any available properties as needed.

3. Click Close.

Related topics

- Create a Surface Contour at an Elevation (on page 440)
- Surface Contour Options (see "Contour Options" on page 443)

Create a Surface Contour at an Elevation

Add a single contour to mark a specific elevation and help visualize its topography. For example, you might want to create a contour line to indicate a flood plain or a cut/fill line.
To create a contour at an elevation:

1. Do one of the following:
   - Click the 🗺️ icon on the toolbar.
   - Select Surface > Create Contour at Elevation.
   - Pick a surface in a graphic view, or select it in the Project Explorer, right-click and select Create Contour at Elevation from the context menu.

   The Create Contours at Elevation command pane displays.

2. If necessary, select the surface to which you want to add a contour in the Surface box.

3. Type a name for the contour in the Name box.

4. In the view, pick a point, or right-click for options, or type an elevation in the Elevation box. The elevation should be between the Minimum elevation and Maximum elevation displayed in the Surface Information group.

5. Select a layer on which to place the contour in the Layer box.

6. Select a display color for the contour in the Contour color box.

7. Click OK. The contour appears on the surface in the graphics view, and under the surface in the Project Explorer.

Related topics

- Create Surface Contours at Intervals (on page 439)
- Surface Contour Options (see "Contour Options" on page 443)
Create a Surface Cut/Fill Grid

Create a grid of values labeling the elevation differences between two surfaces. The measurements are color-coded to indicate where earth needs to be cut or filled. You can also create a grid of values labeling the absolute elevations of a single surface. The resulting grid is a single object that will dynamically update in response to edits to the related surfaces. The order in which you specify the surfaces, or their classifications (as defined when they are created, and available in the surface properties) will determine the Initial and Final surfaces.

To create a cut/fill grid:

1. Do one of the following:
   - Select Surface > Create Surface Cut/Fill Grid.
   - Click the icon on the toolbar.

   The Create Surface Cut/Fill Grid command pane displays.

2. To compare two surfaces, select Cut/Fill. To show the elevations of a single surface, select Elevation and a surface, and skip to step 5.

3. Select a surface in the Initial surface list. You can select a surface with any classification, but the initial surface should reflect the state of topography before the surface you select as the final surface.

4. Select a surface in the Final surface box. Again, you can select a surface with any classification, but the final surface should reflect the state of topography after the surface you selected as the initial surface.

5. Select the layer on which you want the grid to reside in the Layer box, or select <<New layer>> to create a new layer for the grid.

6. Select a style that controls the text font, font style, justification, and size for the grid annotations in the Text style box, or select <<New style>> to define a new text style.

7. In the Grid spacing box, type a value for the uniform interval at which the grid lines or tick marks for the measurements will be spaced.
8. Select an option for how the location of each measurement will be denoted in the Grid style box.

9. Select the number of decimals to use in the measurement in the Decimal precision list.

10. Click OK. The cut/fill grid is created and appears in graphic views and the Project Explorer. Additional properties, such as the grid's origin point and rotation, and cut, fill, and zero colors, can be set in the Properties pane.

Related topics

- [Surface Cut/Fill Grid Options](on page 444)
- [Create Surface Contours at Intervals](on page 439)

Contour Options

Use these options to define contour lines and their spacing. They are available in the Create Contours and Create Contour at Elevation command panes.
### Options

**Surface**
Select the surface to which you want to add the contours.

**Name**
Type an identifier for the contour object. Duplicate names are allowed.

**Elevation**
Type a value, or pick a point in a graphic view, to specify the elevation.

**Contour interval**
Type a value, or pick two points in a graphic view, for the distance between each contour line. Distance is measured vertically in project units. This setting affects the *Estimated contours* in the read-only *Surface Information* group.

**Index contour frequency**
Type a value for the frequency of major to minor contour lines. Entering 5 means that every fifth line will be an index contour line.

**Layer**
Select the layer on which the contour object will be placed, or select `<New layer>` to open the *New Layer* dialog, in which you can create another layer.

**Contour color**
Select a color for the minor contour lines, or select to have contours derive their colors by layer.

**Index contour color**
Select a color for the major contour lines, or select to have contours derive their colors by layer.

**Maximum elevation**
This displays the elevation at the highest point on the selected surface.

**Minimum elevation**
This displays the elevation at the lowest point on the selected surface.

**Estimated number of contours**
This displays the number of contour lines that will appear on the surface.

### Related topics
- [Create a Surface Contour at an Elevation](#) (on page 440)
- [Create Surface Contours at Intervals](#) (on page 439)

### Surface Cut/Fill Grid Options
Use these options to create cut/fill grids and elevation grids for surfaces. They are available in the *Create Cut/Fill Grid* command pane. These properties and others can be edited in the *Properties* pane.
Work with Surface Data

Options

Grid type
- **Cut/Fill** - Select this to create a grid of values labeling the elevation differences between two surfaces for cut/fill operations.
- **Elevation** - Select this to create a grid of values labeling the absolute elevations of a single surface.

Initial surface
Select the surface that reflects the state of topography before the surface you select as the final surface below.

Final surface
Select the surface that reflects the state of topography after the surface you select as the initial surface above.

Surface
For an elevation grid, select the surface for which you want to see absolute elevations.

Layer
Select the layer on which you want the grid to reside.

Text style
Select a style that controls the text font, font style, justification, and size for the grid annotations.

Grid spacing
Type a value for the uniform interval at which the grid lines or tick marks for the measurements will be spaced.

Grid style
Select an option for how the location of each measurement will be denoted.

Decimal precision
Select the number of decimals to use in the measurement.

Related topics
- [Create a Surface Cut/Fill Grid](on page 442)

Add Surface Materials

Understanding Earthwork Volume Calculations

In the *Earthwork Report*, surface to surface (and surface to elevation) volumes are calculated by computing the isopach between the surfaces (or between the elevation and surface) using the prismoidal method. First, each point is projected onto the other surface. Then, the corresponding elevation is interpolated, and the elevation difference is stored with the generated isopach point. The breaklines of both surfaces are used to generate isopach breaklines in a similar manner. Additional points are inserted into the isopach breaklines where they cross the surface triangles.

A Triangulated Irregular Network (TIN) is generated to represent the surface created by the isopach points and breaklines. The isopach represents the thickness, or difference in elevation, between the two surfaces. The software generates the surface triangles for the isopach by linking the isopach points, while honoring all breaklines and points common to both surfaces.
The triangulated isopach is used to determine the volumes by breaking the data for each triangle into the appropriate number of truncated vertical prisms. If the three points of a triangle all have positive or all have negative elevations (all fill or all cut) then a single triangular prism is present, as shown in case 1.

Case 1: All Excavation

If the isopach triangle has both positive and negative elevations (cut and fill), then the triangle is broken into additional triangular prisms such that each prism represents only cut or fill, as shown in case 2.

Case 2: Partial Excavation and Partial Fill

The volume of each prism is equal to the average height (i.e. isopach elevation) times the planimetric area. The total fill volume for the isopach is the sum of all positive prismatic volumes. The total cut volume is the sum of all negative prismatic volumes.

This method is considered more accurate than cross-section average end area or grid methods. The differences obtained between methods depend on the size of the grid or interval of cross-sections and the irregularity of the surfaces. Smooth surfaces may show differences of less than 1%. Some test cases have shown differences of as much as 10% when the cross-section interval is 15 meters (49.21 feet) and the terrain is rough. Mathematically, as the size of the grid or cross-section interval decreases to a very small value, the volumes of these methods agree with volumes computed from the isopach triangles.
Note: The accuracy of volume calculations is dependent on the accuracy of the data that is used and the surface that is created. If breaklines are not properly used to form a valid surface, good point data can produce bad volumes. If an insufficient number of points are used to describe a surface, then irregularities from the recorded data to the actual ground will produce volumes differing from field conditions.

Note: Duplicate points are re-layered to layer '0' during the linking process. Duplicate points are often created when computing the isopach surface, especially if a boundary line is used. In order to conserve memory, these points should be erased as required.

Related topics
- Define Materials for Earthwork Reports (on page 447)
- Run an Earthwork Report (on page 449)

Define Materials for Earthwork Reports

Define materials that you want to use in earthworks volume calculations and reports. You can enter two of three values for the shrinkage, haul bulkage, or haul compaction of materials to calculate the third value.

To create a material:

1. Do one of the following:
   - Click the icon on the toolbar.
   - Select Surface > Define Materials.

   The Materials dialog displays.

2. Click the option for the value that you want to calculate in the Calculate group.
   The value you select is unavailable in the calculation table.

3. Click the option for the format in which you want to view calculations in the Display as group.

4. Type the name of a material you want to add in the Material column.

5. Type percentages or factors in the Shrinkage, Haul Bulkage, and/or Haul Compaction boxes, as required.

6. Press [Tab] to add another material, if needed.

7. Click OK.

Related topics
- Calculate Volumes Using the Earthwork Report (see "Run an Earthwork Report" on page 449)
- Materials Options (on page 448)
Materials Options

Use these options to define materials to use in earthworks volume calculations and reports. They are available in the Define Materials dialog. For an example, see below the table.

**Options**

**Calculate**

- **Shrinkage** - Select to calculate the shrink or swell from cut or the natural bed to fill.
  
  = (haul bulkage x haul compaction)

- **Haul Bulkage** - Select this to calculate the swell from the natural bed to the loose condition.
  
  = (shrinkage / haul compaction)

- **Haul compaction** - Select this to calculate the shrink to compacted in place condition from the loose condition.
  
  = (shrinkage / haul bulkage)

**Display as**

- **Factor** - Select this to view the calculation as the number by which the volume is multiplied or divided.

- **Percentage** - Select this to view the calculation as a percentage (proportion multiplied by 100).

**Note:** To understand the relationship between factor and percentage in relation to shrinkage and haul bulkage, experiment by entering various numbers. For example:

- Shrinkage or haul compaction of 25% = a multiplication factor of 0.75

  whereas

- Haul bulkage of 25% = multiplication factor of 1.25

**Material**

Type a descriptive name for the material to cut or fill.

**Shrinkage %**

Type the percent, or factor by which, the material will shrink when it is cut and then used as fill.

**Haul bulkage %**

Type the percent that, or factor by which, the material will swell when it is cut and hauled in loose condition.

**Haul compaction %**

Type the percent that, or factor by which, the material will shrink when it is cut and hauled in loose condition.

When entering values for material shrinkage, bulkage, and compaction, consult a standard soils engineering reference. As an example, an industry manual might show these values:
### Work with Surface Data

<table>
<thead>
<tr>
<th>Material</th>
<th>Swell</th>
<th>Shrink (in negative %)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Earth (loam)</td>
<td>35%</td>
<td>12%</td>
</tr>
<tr>
<td>– dry</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Earth (loam)</td>
<td>0%</td>
<td>20%</td>
</tr>
<tr>
<td>– wet (mud)</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

According to the sample reference, if you dig wet earth out of the ground, and pile it, or load it on a truck, it won’t expand (0%). It will remain the same volume as it was in the ground. If you dig dry, compacted dirt out of the ground, and pile it, or load it on a truck, its volume will expand about 35%.

If you dig wet earth out of the ground, use it as fill on the site, and compact it, it should shrink by 20%. The water will be squeezed out as it’s compacted. If you take dry earth and do the same, the difference between its volume will be about 12% less.

**Related topics**

- [Calculate Volumes Using the Earthwork Report](#) (see "Run an Earthwork Report" on page 449)
- [Define Materials for Earthwork Reports](#) (on page 447)

### Run an Earthwork Report

Use the *Earthwork Report* to calculate volumes based on a single surface, or the comparison of two surfaces.

**To generate a volume report:**

1. Do one of the following:
   - Click the icon on the toolbar.
   - Select Reports > Earthwork Report.
     
     The *Earthwork Report* command pane displays.

2. Select the option for the type of surface report you want to generate in the Report type group. Options in the steps below will vary based on the report type you select.

3. Select the surface you want to report on, or the first surface to compare, in the Surface list. The classification for the surface displays below the box.

4. Select the second surface to compare in the Final list, if applicable.

5. Pick a point in a graphic view, right-click for options, or type a value in the Elevation box, if applicable.

6. Pick lines to define the perimeter in the Boundary box, or click Options for more selection methods.
7. To account for materials in the calculations, check **Use in calculation** in the **Materials** group.

   **Note:** Before using this option, you need to have defined surface materials in the **Define Materials** dialog.

8. Select the material at the site in the **Native** list.

9. Select the material that will be brought to the site in the **Borrow** list.

10. Select a type in the **Volume Breakdown** group, specifying a value by picking in the graphics window or typing a value, if necessary.

11. Click **OK**. The report displays in your default Internet browser.

**Related topics**

- [Define Materials for Earthwork Reports](on page 447)
- [Earthwork Report Options](on page 450)
- [Understanding Earthwork Volume Calculations](on page 445)

**Earthwork Report Options**

Use these options to configure what your earthwork report shows. They are available on the **Earthwork Report** command pane. The **icon on the command pane's toolbar gives you quick access to the **Define Materials** dialog, where you can define materials to use in earthwork report calculations.
**Options**

**Report Type**

- **Stockpile/Depression** - Select to generate a comparison of the volume formed by comparing one surface to a temporary surface formed by the edge points of the surface.

  A **Stockpile/Depression Report** uses only one material in the report.

- **Surface to Surface** - Select to generate a comparison between two surfaces.

- **Surface to Elevation** - Select to generate a comparison of the volume formed by comparing one surface to a flat plane defined by the user giving its elevation.

**Note:** You can set the name for the difference between surfaces in the **Computational Settings > Surface** section of the **Project Settings** dialog.

**Select surface**

- **Surface/initial** - Select the surface on which you want to report. If you are comparing a surface to another surface or elevation, select the surface from the earlier phase of construction.

- **Final** - If you are comparing a surface to another surface, select the surface from the later phase of construction.

- **Elevation** - Pick a point in a graphic view, or type a value for the elevation to be compared to the specified surface.

- **Boundary** - Select the perimeter of the volume you want to use in computations.

**Materials**

- **Use in calculation** - Check this to open the **Native** and **Borrow** boxes, if you are using materials in calculations.

- **Native** - Select the material being excavated from the site, and often being reused as fill material on the site.

- **Borrow** - Select the material that is being brought in from off-site to be used as fill material on the site. Borrow material can be the same as native material.
Volume breakdown

**Volume totals only** - Select this to report only the total difference between volumes.

**By depth increment** - Select this to report the volumes in increments. Pick two points in a graphic view, or type a value to specify the depth of the increment.

**By elevation interval** - Select this to report volume differences between specific elevations. Pick two points in a graphic view, or type a value to specify the distance between elevations.

**Index elevation** - Pick a point in a graphic view, or type a value to specify the elevation.

Related topics

- [Calculate Volumes Using the Earthwork Report](#) (see "Run an Earthwork Report" on page 449)
- [Define Materials for Earthwork Reports](#) (on page 447)

### Shrink 3D Faces

If you use a mesh of 3D faces to create a surface, any vertices that exist at the same horizontal location, but which have different elevations, will create vertical 3D faces in the resulting surface. You will know that you need to 'shrink 3D faces' when you see flags at surface vertices and messages in the **Flags** pane stating that "The vertex has been ignored. It is directly above another vertex."

To fix this, 'shrink the 3D faces' to form closed, triangular breaklines slightly inset (.06 mm) from each selected face. These breaklines can then be used to create a surface that closely approximates the original mesh of 3D faces.

This can be helpful in forming a valid surface from data incorporating vertical faces or when coincidental 3D face vertices that have differing elevations at the same location.

**Note:** This command is primarily used to fix data from applications that allow points with different elevations at the same horizontal location.
Initially, the surface is formed using vertical 3D faces with coincidental vertices, resulting in two elevations at these vertices. This data is not valid for forming a surface.

The non-vertical 3D faces are shrunk to create triangular breaklines (shown in black) with offset vertices which can be used to form the surface.

Using the new breaklines, the surface is properly formed with a single elevation at each vertex.
To 'shrink 3D faces' for a surface:

Follow these steps immediately after you receive one or more flagged messages that a vertex is directly above another vertex in a surface. If you cannot undo the surface creation because you have performed other commands in the interim, you will need to delete the surface and start with step 2 below.

1. Select **Edit > Undo Create Surface**. The surface disappears.
2. If the command pane is not already displayed, select **View > Command Pane**, or press **F12**. The **Command Pane** displays.
3. Click **Shrink 3D Faces** in the **All Commands** list, or type `shrink3dfaces` on the **Command** line at the top of the pane and press `[Enter]`. The **Shrink 3D Faces** command pane displays.
4. In the **Plan View**, pick the 3D faces that you want to use to form a surface.
5. Select the layer on which you want the new breaklines to reside in the **Layer for breaklines** box.

   **Note:** You will select the data on this layer to use when you create the surface. If necessary, create a new layer by selecting `<New layer>`.

6. Click **OK**. The breaklines are created within each selected triangular, 3D face.

To create a surface from the newly created breaklines:

1. Select the **View > View Filter Manager**. The **View Filter Manager** displays.
2. If necessary, click the **Collapse** icon to collapse each group except **Layers**.
3. Uncheck the box for each group to hide the data.
4. In the **Layers** group, right-click the name of layer you created the 3D face breaklines on, and select **View Only This** from the context menu. All of the other layers in the group are unchecked so that only the breaklines are visible.
5. Select all of the breaklines in the graphic view, and select **Surface > Create Surface**.
6. Follow the instructions for creating a surface (see "Create a Surface" on page 419).

Related topics

- [Edit a Surface by Trimming Edge Triangles](#) (on page 432)
- [Edit a Surface by Adding and Removing Members](#) (on page 424)
Work with Feature Data

Understanding Feature Data

Features represent objects that surveyors might encounter as they collect survey data. Examples include trees, fences, gates, signs, utility poles, and buildings. After import and processing, the software can display symbols and line work that represent the real world objects. Features can be exported to other systems (for example, CAD packages) as necessary.

There are two basic types of features:

- A point feature is used to identify a single feature, such as tree or utility pole.
- A line feature is made up of two or more points that define a line, such as a fence or path.

A feature is identified in the software by a feature code string that is made up of one or more parts.

A feature code string for a point feature is made up of one or two parts:

- An alphanumeric code identifying the point feature itself (for example, "TREE")
- Optionally, a brief description of the point feature (for example, "West of house")

A feature code string for a line feature is made up of one to four parts:
- An alphanumeric code identifying the line feature itself (for example, "FENCE")
- Optionally, an alphanumeric instance identifier that is used for each point that makes up a single line (for example, "FENCE1" might define one fence; "FENCE2" might define a different fence)
- Optionally, an alphanumeric line control code that identifies the start or end of a line (for example, "START" might be used to identify the start of a fence)
- Optionally, a brief description of the line feature (for example, "Barbwire")

**Note:** If you delete a point used in a line feature, the position for the point is still used to define the line.

**Note:** You can split (see "Split Line Features" on page 462) line features in the software.

To make the feature code strings easier to read in the **Properties** pane and **Point Spreadsheet**, automatic formatting is used to differentiate the parts:
- The code itself is underlined (for example, "FENCE").
- The instance number and line control code are normal text.
- The brief description is in italics (for example "Barbwire").

So, a complete line feature code string might look like this: "FENCE1 START Barbwire"

Each feature code can also include one or more attributes that provide additional information about the feature. For example, a utility pole feature might have these attributes: utility type and owner, pole height, material, and condition.

Feature code types and attributes are defined and managed in the **Feature Definition Manager** software, which outputs a feature definition (.fxl) file that can be loaded on a field device. In the field, the surveyor can select from the feature library contained in the .fxl file the appropriate feature code to assign, add a brief description, and enter values for any attributes defined for the code. This same .fxl file is then used by the software for feature processing (see **Feature Code Processing Settings** (on page 176)) after the feature codes have been imported.

**Note:** If a surveyor manually enters a feature code not represented in an .fxl file, or the .fxl file used on the field device is not specified for the project, the feature code string will display in the software, but it will be ignored during feature code processing and reported in the **Feature Code Processing Report**.

Feature codes are displayed in the **Properties** pane when points to which they are assigned are selected. You can edit or delete feature codes as necessary, or add additional codes. You can also merge multiple line features into a single line feature or split a single line feature into multiple line features.
Workflow for Feature Data

To work with features data, it is recommended that you use the following steps:

1. Specify the appropriate feature definition (.fxl) file and other feature project settings in the Project Settings (see "Feature Code Processing Settings" on page 176) dialog.

2. Import (see "Import Data" on page 212) the data file containing features data into your project.

   **Note:** The Edit Point > Description field used in Survey Pro and Field Surveyor 2.0 (not Field Surveyor 1.x) contains the feature code imported into the software and displayed in the Feature code field.

3. If feature codes were processed on data import, review the resulting Feature Code Processing Report to determine if all codes were processed correctly.

   **Note:** You use the Project Settings (see "Feature Code Processing Settings" on page 176) dialog to specify whether or not to process feature codes on data import.

4. Review the Plan View and Point Spreadsheet to ensure the survey was correctly performed and feature codes were correctly entered.

   **Note:** If feature codes are not displayed in the Plan View, select View > View Filter Manager and ensure the Show feature code option is selected in the View Filter Manager pane.

5. If appropriate, click Surface > Create Surface to ensure features are correctly included in the surface computation.

6. If necessary, make changes to any feature codes as described in Enter, Edit, and Delete Feature Code Strings (on page 459).

7. If necessary, split (see "Split Line Features" on page 462) any line feature into two line features by selecting the segment between the two points you want to separate.

8. If you made any changes to the feature codes in step 6, re-process the feature codes as described in Process Feature Codes (on page 463).

9. Review the resulting Feature Code Processing Report to determine if all codes were processed correctly.
Feature Code Processing Settings

Use feature processing settings to configure how feature codes are processed.

To specify feature processing settings:

1. Do one of the following:
   - Select Project > Project Settings.
   - Click the 📊 icon on the toolbar.

   The Project Settings dialog displays.

2. Select Feature Code Processing in the left pane.

3. Click each section and set the options as shown in the following table.

4. Click OK.
Work with Feature Data

Options

General

Process feature codes on import

Prompt - Select this option if you want to be prompted on whether or not to process feature codes during data import. If you select to process feature codes during import and a feature definition (.fxl) file has not been specified in the project settings, you will be prompted to specify it at the time of import.

Yes - Select this option if you want feature codes to be automatically processed during data import without prompting you. If a feature definition (.fxl) file has not been specified in the project settings, you will be prompted to specify it at the time of import.

No - Select this option if you never want feature codes to be processed during data import.

Decimal precision

Specify the number of decimals to display with a numeric attribute (real number) when no feature definition (.fxl) file is specified.

Processing

Feature definition file

Specify the feature definition (.fxl) file you want to use to process feature codes in the project. This is required if you want to process feature codes.

Related topics

- Choose Project Settings (on page 155)
- Understanding Feature Data (on page 455)
- Workflow for Feature Data (on page 457)
- Enter, Edit, and Delete Feature Code Strings (on page 459)
- Process Feature Codes (on page 463)

Enter, Edit, and Delete Feature Code Strings

If a feature code string has been assigned to a point, it is displayed in the Properties pane when the point is selected.

Note: Feature codes are also visible and editable in the Point Spreadsheet and Occupation Spreadsheet. They can be viewed, but are not editable in the Plan View.

You can edit or delete feature code strings as necessary. You can also assign additional code strings.

To enter, edit, or delete a feature code string:

1. Display in the Properties pane the point with which you want to work.
If a feature code string has been assigned to the point you selected, it is displayed in the **Feature Code** box.

If you select multiple points, the value in the **Feature Code** box is "Varies", indicating that different codes may be assigned to the selected points. Any changes you make to the code affect all of the selected points.

**Note:** The *Edit Point > Description* field used in Survey Pro and Field Surveyor 2.0 (not Field Surveyor 1.x) contains the feature code imported into the software and displayed in the **Feature code** field.

2. Click the [ ] icon in the **Feature code** box. The **Feature Code Editor** dialog displays.

**Note:** If you know the feature code string you want to assign to the point, you can manually enter it directly in the **Feature code** box without opening the **Feature Code Editor** dialog. However, if you need to enter attribute values, you must enter them in the **Feature Code Editor** dialog. In addition, you can manually delete a feature code string from the **Feature code** box.

3. To delete a feature code string assigned to the point, delete it from the **Feature code** box.

4. To assign or edit a feature code string for a point when a feature definition (.fxl) file has not been specified for the project, type the new string, or edit the existing string, in the **Feature code** box.

You can add additional feature code strings to the point as necessary.

5. To assign or edit a feature code string for a point when a feature definition (.fxl) file has been specified for the project, do the following:

   a. If necessary, delete any of the existing code string from the **Feature code** box

   b. Select a feature code (for example, "FENCE") from the **Codes** list and click **Add Code**. The feature code is displayed in the Feature code box.

   c. If the feature code represents a line feature, type the alphanumeric instance of the line feature immediately before or after the code (no spaces) in the **Feature code** box (for example, "FENCE1").

   d. If a line feature requires a control code (for example, "START"), select it in the **Codes** list and click **Add Code**. The control code is displayed in the **Feature code** box.

   e. If appropriate, enter a brief description of the feature in the **Feature code** box at the end of the string (for example, "Barbwire").

When you change focus from the **Feature code** box, the feature code string is reformatted as follows:

- The feature code is underlined.
- The instance for a line feature, if entered, appears in regular text.
- The control code for a line feature, if entered, appears in regular text.
- The description, if entered, appears in italics.

For example, if the feature code is for the line feature "FENCE", the instance is "1", the control code is "START", and the description is "barbwire", the string would appear as "FENCE1 START Barbwire".

f. If the feature code supports attribute values, ensure the feature code is selected in the Details list, then select attribute values for the code in the Attribute list.

If a feature code is changed from the raw data, any attributes associated with the original feature code are merged with the new feature code per specific rules. For more information, see Rules for Merging Feature Attributes (on page 461).

6. To add more feature codes to the point, repeats step 4 or 5 as necessary.

Regardless of the order in which you add additional feature codes, the codes are automatically arranged in alphabetical order in the Feature code box (with the exception of line feature codes).

7. Click **OK**.

After you have completed all feature code changes, you must reprocess the feature codes (see "Process Feature Codes" on page 463).

Related topics
- Understanding Feature Data (on page 455)
- Workflow for Feature Data (on page 457)
- Feature Code Processing Settings (on page 176)
- Rules for Merging Feature Attributes (on page 461)
- Process Feature Codes (on page 463)

**Rules for Merging Feature Attributes**

If a feature code is changed from the imported data, the attributes of the imported data feature code and the attributes that are the same for the imported and new feature code are copied to the new feature code. For example, if the feature code is changed from "FENCE" to "MH", the raw attributes of "FENCE" and the attributes that are the same for "FENCE" and "MH" are copied to "MH".

In the case of multiple feature codes being assigned to a point, the order of the codes before and after editing determine where the attributes in the raw feature code are merged. For example:
- If "FENCE TREE" is changed to "MH TREE", the imported attributes of "FENCE" and attributes that are the same for "FENCE" and "MH" are copied to "MH".
- If "FENCE TREE" is changed to "MH", the attributes of "FENCE" merge to "MH".
- If "FENCE POST TREE" changes to "MH VALVE", the attributes of "FENCE" merge into "MH" and the attributes of "POST" merge to "VALVE".

When attributes are merged to the new feature code and the definition does not recognize it, the attributes become unknown attributes. You can delete these unknown attributes in the Feature Code Editor (see "Enter, Edit, and Delete Feature Code Strings" on page 459) dialog.

Related topics
- Understanding Feature Data (on page 455)
- Workflow for Feature Data (on page 457)
- Enter, Edit, and Delete Feature Code Strings (on page 459)

Split Line Features

You can split a single line feature into two line features by selecting the segment between the two points you want to separate, as shown in the following diagram (example 1). Note that you cannot select a beginning or ending line segment for the split (example 2).

Key to example diagrams:
- Green points ● represent the first line feature selected for the split.
- Maroon points ● represent the new line feature created after the split.
- 1 shows the line feature segment selected for the split.

Example 1:

![Example 1 diagram](image)

Example 2:

![Example 2 diagram](image)
To split a line feature:

1. Do one of the following:
   - Select Survey > Feature Coding > Split Line Feature.
   - Click the ✉️ icon on the toolbar.
     The Split Line Feature pane displays.
2. Click in the Select box.
3. In the Plan View, select the segment between the two line feature points you want to separate. The segment is removed.
   You cannot select a beginning or ending line segment for the split (see example 2).
4. If necessary, select additional line features in the Plan View to split them.
5. When you are done, click Close in the Split Line Feature pane.

Related topics
- Understanding Features Data (see "Understanding Feature Data" on page 455)
- Workflow for Features Data (see "Workflow for Feature Data" on page 457)
- Enter, Edit, and Delete Feature Code Strings (on page 459)

Process Feature Codes

You must process features codes to display features correctly in graphic views or to export. You can process feature codes during data import (depending on your Feature Code Processing settings (on page 176)), or you can process or reprocess them after import. For example, you might have processed feature codes during data import but you have since made changes to the codes in the software and need to reprocess them. Or, you might have added points to the project that include features you want to process.

To process feature codes:

1. Do one of the following:
   - Select Survey > Feature Coding > Process Feature Codes.
   - Click the ✉️ icon on the toolbar.
Work with Feature Data

The Process Feature Codes pane displays listing one or more point sources from which you can select to process feature codes. A point source is either an imported file or a Keyed in Block (points manually added to the project). If you select multiple sources, they are processed separately.

2. In the Select point source(s) to process list, check the box for each source containing points you want to process.

3. Optionally, do either of the following:
   - Click the icon to display the Report Options (on page 483) pane. This allows you to select report options for the Feature Code Processing Report before generating the report.
   - Click the icon to display the Project Settings dialog to change Feature Code Processing settings (on page 176).

Note: This button is enabled only when an imported file is selected as a point source in the list.

4. Click Process to process feature codes in the selected source(s).

   If no feature definition (.fxl) file is specified in the project, you will be prompted to specify it at this time.

   If you have previously processed the features codes in the project, reprocessing will delete the previous results and replace them with new results.

5. After processing, review the Feature Code Processing Report, which provides a summary of the process.

   The report displays on the Feature Code Processing Report tab. Use the tool bar located above the report to navigate, print, or save the report.

Related topics
- Understanding Feature Data (on page 455)
- Workflow for Feature Data (on page 457)
- Feature Code Processing Settings (on page 176)
- Enter, Edit, and Delete Feature Code Strings (on page 459)

Export Geodatabase Files (.xml)

Export feature data contained in your project to a geodatabase XML file from which the data can be imported into an Environmental Systems Research Institute, Inc. (ESRI) geographic information system (GIS).

Click the GIS tab in the Export command pane to access the Geodatabase XML exporter.
Note: The geodatabase XML format represents ESRI’s most current open mechanism for information interchange between geodatabases and other external systems and is a replacement for the earlier shapefile (.shp) spatial data format.

Related topics
- Export Data (on page 486)
- Export Data in a Custom Format (on page 497)

Feature Definition Manager Utility

The Feature Definition Manager is a standalone utility that gives you the ability to create and manage feature libraries (.fxl files) for feature code processing and GIS attribute data collection. A feature library is a collection of features with codes and attributes that describe them, as well as line control codes that modify how the features relate.

The Feature Definition Manager comes with a default library of features with predefined attributes. This library provides a good starting point for feature coding. As you create new features and edit existing ones, the library will become suited to the specific needs of your projects.

Feature coding in the editor enables you to:

- Make detailed data collection in the field more efficient and consistent by controlling how features and attributes can be captured. Setting parameters for what you can and must enter ensures data integrity and completeness.
- Add symbols and annotations to feature-coded field data so that the information can be presented in a more visual format.
- Connect points to define line features, such as pavement or building edges, or the centerlines of ditches or fences. Line control codes give you the power to add new points automatically, and add lines, curves, and arcs between points.

If you are working with surfaces, coded features also let you:

- Define the breaklines of a surface.
- Control how surfaces are formed by specifying which points should be used, and which lines should act as breaklines. Surfaces can be modified by moving points to specific layers based on their feature codes.

Note: The Feature Definition Manager has its own help system. While in the Feature Definition Manager, select Help > Contents, or press [F1].

Related topics
- Understanding Feature Data (on page 455)
- Workflow for Feature Data (on page 457)
Run Reports

Run an Alignment Geometry Report

Generate an Alignment Geometry Report to see a simple summary or detailed listing of the geometry of an alignment in your project. You can choose to report on just the horizontal component or both the horizontal and vertical components of alignments. If you have specified station equations, they will be reported as well.

To run an Alignment Geometry Report:

2. Select an alignment in the Alignment list.
3. Click OK. The Alignment Geometry Report displays in your default Web browser.

To customize the report:

1. Do one of the following:
   - Click the icon on the Alignment Geometry Report command pane's toolbar.
   - Select Reports > Report Options.
     The Report Options command pane displays.
2. Select Alignment Geometry Report in the list.
3. Expand sections and specify output settings in the Settings group as needed.
4. Click Apply if you want to customize additional reports, or OK to close the command pane.

Tip: You can also change the abbreviations used for horizontal and vertical alignment classifications in the Alignment Geometry Report. Select Project > Project Settings, and click Abbreviations in the left pane. Edit any of the abbreviations in the right column and click OK. Rerun the report to see your changes.
Related topics

- Create an Alignment (see "Understanding Alignments" on page 382)
- Customize and Run a Report (see "Customize a Report" on page 481)

Run a Baseline Processing Report

After you have processed baselines in your project, generate a Baseline Processing Report to review the solution types, precisions, and an acceptance summary for the processed baselines. Detailed reports are available for each processed session as well. Use these reports to determine which baselines need to be disabled or investigated further, and which settings may need to be adjusted before reprocessing.

To create and save a Baseline Processing Report:

1. Select Reports > Report Options. Select Baseline Processing Report in the command pane, and verify the column display and section display settings. See section display settings below. (optional)

2. Select one or more vectors in the project. To report on all of the processed baselines (vectors), make sure nothing is selected. To report on individual vectors, pick them in a graphic view, from the Project Explorer, or from the Vector spreadsheet.


4. To save the report, use the browser’s File > Save As feature.

Note: This is the only way to return to a report without regenerating it.
## Baseline Processing Report - Summary

### Summary report sections

<table>
<thead>
<tr>
<th>Section</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Session details</strong></td>
<td>Click one of these links to see a detailed baseline processing report on the vector.</td>
</tr>
<tr>
<td><strong>Processing summary</strong></td>
<td>This displays the number of baselines processed and the number of baselines that failed to process due to insufficient data that meets the acceptance criteria.</td>
</tr>
<tr>
<td><strong>Acceptance summary</strong></td>
<td>This shows the acceptance criteria settings for this project, and the number of baselines passed, flagged, or failed against the criteria. The elevation mask setting is also shown. If data from specific satellites is set to be ignored, the satellite numbers are listed here.</td>
</tr>
<tr>
<td><strong>Note:</strong> A baseline that fails to process cannot be saved in the project.</td>
<td></td>
</tr>
<tr>
<td><strong>Caution:</strong> A baseline that fails the acceptance criteria is not checked for saving by default.</td>
<td></td>
</tr>
<tr>
<td><strong>Results table</strong></td>
<td>This section includes a row for each processed baseline, including From and To points, the solution type (fixed or float), and a summary of the solution. Observation: This column includes an assigned baseline identifier, such as &quot;B1&quot;.</td>
</tr>
<tr>
<td><strong>Failed sessions</strong></td>
<td>This shows details on failed kinematic segments.</td>
</tr>
<tr>
<td><strong>Failed baselines</strong></td>
<td>This provides details the baselines that failed processing. The occupation status column indicates the reason for the failure.</td>
</tr>
</tbody>
</table>

## Baseline Processing Report

### Section options

<table>
<thead>
<tr>
<th>Section</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Session details</strong></td>
<td>This summarizes the observation or trajectory and how it was processed.</td>
</tr>
<tr>
<td><strong>Baseline components</strong></td>
<td>This section details coordinates of the baseline, and delta values from survey mark to survey mark.</td>
</tr>
<tr>
<td><strong>Standard errors</strong></td>
<td>This shows the covariance information.</td>
</tr>
<tr>
<td><strong>Covariance matrix</strong></td>
<td>This lists receiver and antenna details for the points at either end of the session.</td>
</tr>
<tr>
<td><strong>Occupations</strong></td>
<td><strong>Note:</strong> The antenna phase center (APC) value is calculated based on the antenna type.</td>
</tr>
</tbody>
</table>
Run Reports

**Tracking summary**
This plot indicates the quality and continuity of the tracking of the L1 and L2 signals received from each satellite. For trajectories, multiple tracking summaries are shown. Gaps in the data indicate cycle slips (loss of lock).

*Note:* This may vary, depending on whether you are licensed for multi-frequency processing.

**Residuals**
This displays a residual plot for each the satellites used during processing, indicating the amount of noise in the solution. To display residuals, select Reports > Report Options. In the Settings group of the Report Options command pane, select Show in the Residuals box. Then rerun the report.

*Note:* Computing the residuals is CPU-intensive.

**Messages**
Messages report the ephemeris type used in processing and which satellites were below the elevation mask (and therefore not used).

**Processing style**
This shows the settings of the baseline processing style as set in Project Settings.

---

**Related topics**
- Baseline Processing Settings (on page 165)
- Customize and Run a Report (see "Customize a Report" on page 481)
- Process Baselines (on page 305)

---

**Run an Earthwork Report**

Use the Earthwork Report to calculate volumes based on a single surface, or the comparison of two surfaces.

To generate a volume report:

1. Do one of the following:
   - Click the 🗂 icon on the toolbar.
   - Select Reports > Earthwork Report.

   The Earthwork Report command pane displays.
2. Select the option for the type of surface report you want to generate in the **Report type** group. Options in the steps below will vary based on the report type you select.

3. Select the surface you want to report on, or the first surface to compare, in the **Surface** list. The classification for the surface displays below the box.

4. Select the second surface to compare in the **Final** list, if applicable.

5. Pick a point in a graphic view, right-click for options, or type a value in the **Elevation** box, if applicable.

6. Pick lines to define the perimeter in the **Boundary** box, or click **Options** for more selection methods.

7. To account for materials in the calculations, check **Use in calculation** in the **Materials** group.

   **Note:** Before using this option, you need to have defined surface materials in the **Define Materials** dialog.

8. Select the material at the site in the **Native** list.

9. Select the material that will be brought to the site in the **Borrow** list.

10. Select a type in the **Volume Breakdown** group, specifying a value by picking in the graphics window or typing a value, if necessary.

11. Click **OK**. The report displays in your default Internet browser.

**Related topics**

- [Define Materials for Earthwork Reports](on page 447)
- [Earthwork Report Options](on page 450)
- [Understanding Earthwork Volume Calculations](on page 445)

### Run an Import Report

Generate an **Import Report** to see a project summary, details on imported files, and any associated errors or warning messages.

**To run an Import Report:**

- Select **Reports > Import Report**.
- Select **Reports > Report Options**. Select **Import Report** in the command pane, and click **OK**.

  The **Import Report** displays in your default Web browser.

  **Tip:** Click a file name in the report to jump to the creation and import dates and times.
Run a Mean Angle Report

Run a **Mean Angle Report** to view details of how each mean angle was computed.

**To run a Mean Angle Report:**

- Select **Reports > Mean Angle Report**.
- Right-click a mean angle node icon in **Project Explorer** and select **Mean Angle Report** from the context menu.
- Click the **Report** button in the **Mean Angle Residuals** dialog.

The **Mean Angle Report** displays in your default Web browser.

**Note:** In the **Mean Angle Report**, all angles are normalized to the range of 0 to 360 degrees expressed in project units. All distances are displayed in project units.

The **Mean Angle Report** includes a separate table for each mean angle in the project. At the top of each table, the point ID, station ID, and backsight ID are displayed. Beneath that, the table includes a row of information for each enabled observation used to compute the mean angle. Information includes observed readings and residual values for the horizontal angle, vertical angle, and slope distance. The last row in the table displays the computed horizontal angle, vertical angle, and slope distance for the mean angle point.

**Tip:** Click any point in the report to select it in the **Project Explorer** and graphical and spreadsheet views, and display its properties in the **Properties** pane.

**Related topics**

- **Understanding Total Station Data** (on page 315)
- **Workflow for Total Station Data** (on page 320)
- **View Total Station Data in Project Explorer** (on page 322)
- **View and Edit Mean Angle Residuals** (on page 330)
Run a Network Adjustment Report

After you adjust a network, generate a Adjust Network Report to review successful adjustment statistics, such as the adjusted grid and geodetic coordinates, adjusted observations, and covariance terms. You can also use the report to review error ellipse and residual details to determine which vectors need to be disabled, how control points should be fixed, and which settings may need to be changed before re-adjusting the network.

To run a Network Adjustment Report:

- Click the icon on the Network Adjustment command pane toolbar.
- Select Reports > Network Adjustment Report.
- Select Reports > Report Options. Select Network Adjustment Report in the command pane, and click OK.

The Network Adjustment Report displays in your default Web browser. Click any link in the left pane to view a specific section.
### Report components

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Adjustment settings</strong></td>
<td>This shows the set-up error values and covariance display formats as set in <em>Project Settings</em>.</td>
</tr>
</tbody>
</table>
| **Adjustment statistics** | This summarizes the number of iterations it took to adjust the network, and why the adjustment passed or failed.  
**Reference factor** indicates how much adjustment was necessary, whether the random errors in the observations are acceptable, and if they match the estimated standard errors for those observations. 
The reference factor should be about equal to 1.0. This value lets you know how well the adjustment a priori (pre-adjustment) errors are matching the a posteriori (post-adjustment) errors. |
| **Adjusted grid coordinates** | This section shows the adjusted northing, easting, elevation, and computed standard errors for each grid point used. 
The **Fixed** column indicates which point coordinates were fixed (constrained) during network adjustment. |
| **Adjusted geodetic coordinates** | This shows the adjusted latitude, longitude, and height values. 
The **Fixed** column indicates which point coordinates were fixed (constrained) during network adjustment. |
| **Error ellipse components** | This section shows the magnitude and direction of the point errors. |
| **Adjusted GPS observations** | This displays the adjusted observation components, including the standard error, residual (how much of an adjustment had to be made) and standardized residual. 
The observations are sorted to display the worst standardized residual at the top. 
**Note:** Observations with a standardized residual that fails the Tau criteria display in red. These observations are outliers. Examine these to justify keeping them in the network. |
| **Covariance terms** | This shows the relative error in any pair of points in the project. The a-posteriori error and the horizontal (2D) and 3D precision are shown for each observation. The precision can be shown as a ratio or as ppm, depending on your project settings. |

### Related topics
- [Adjust a Network](on page 356)
Run Reports

- Customize and Run a Report (see "Customize a Report" on page 481)
- Network Adjustment Settings (on page 170)

**Run a Point Derivation Report**

Generate a *Point Derivation Report* to see details on the survey data used to calculate the final coordinates of points in your project.

**To run a Point Derivation Report:**

- Select Reports > Point Derivation Report.
- Select Reports > Report Options. Select *Point Derivation Report* in the command pane, and click **OK**.

  The *Point Derivation Report* displays in your default Web browser.

**Tip:** Click a point ID or coordinate in the report to select the point in graphic views and the **Project Explorer**.

**Related topics**

- Customize and Run a Report (see "Customize a Report" on page 481)

**Run a Point List Report**

Generate a *Point List* to see a simple summary of the coordinates for each point in your project.

**To run a Point List report:**

- Select Reports > Point List.

  The *Point List* displays in your default Web browser.

**To modify the report:**

- Select Reports > Report Options. Select *Point List* in the command pane, and click **OK**.
- In the **Settings** group at the bottom of the command pane, you can specify the type of coordinates (grid, local, or global), and the type of data to display. The data options include quality control information such as scale factors and convergence angle.

**Tip:** Click a point ID in the report to select the point in graphic views and the **Project Explorer**.

**Related topics**

- Customize and Run a Report (see "Customize a Report" on page 481)
Run a Project Computation Report

Generate a computation report to see a summary of the errors and warnings that occurred during the last computation of your project data.

To run a Project Computation Report:


To customize the report:

2. Select Project Computation Report in the list.
3. Expand sections and specify output settings in the Settings group as needed.
4. Click Apply if you want to customize additional reports, or OK to close the command pane.

Related topics
- Project Computations (on page 165)
- Customize and Run a Report (see "Customize a Report" on page 481)

Run a Renamed Point List

Generate a Renamed Point List to see a simple summary of the original and new names of points that you have renamed in your project.

2. Select Renamed Point List in the Reports list.
3. Edit options in the Settings group as needed.
4. Click the icon on the pane's toolbar. The Renamed Point List displays in your default web browser.

Related topics
- Customize and Run a Report (see "Customize a Report" on page 481)

Run a Site Calibration Report

After you calibrate a site, generate a Site Calibration Report to see details on the local site settings, horizontal and vertical calibration parameters, and residual differences between GNSS and grid points in your project.
To run a Site Calibration Report:

- Select Reports > Site Calibration Report.

  The Site Calibration Report displays in your default Web browser.

To modify the report:

- Select Reports > Report Options. Select Site Calibration Report in the command pane, and click OK.

  In the Settings group at the bottom of the command pane, you can specify the header and footer data to display.

Related topics

- Customize and Run a Report (see "Customize a Report" on page 481)

Run a Job File Report

Create custom reports (and file formats) by applying style sheets to .job or .jxl job files in the Job File Generator pane. This gives you the flexibility to generate a variety of reports types from a single project's content.

**Note:** Style sheets are applied to the imported job files only; changes made to projects within this software do not appear in the report. Style sheets are not translated.

To customize and run job file reports:


2. Do either of the following to select the job file for which you want to run a report:

   - If the file has been imported into the project, select it in the Job file list.
   - If the file has not been imported into the project, click the icon. The Open dialog displays, allowing you to locate and select the file.

3. Click the icon located next to the Style sheet box. The Open dialog displays, allowing you to locate and select the style sheet file you want to use for the report.

Some default style sheet files are installed with the software in C:\Program Files\Trimble\Trimble Business Center\Support\(language_name).
Run Reports

If you do not find the style sheet file you want in this folder or in any other folder you might be using for style sheet files, click the Trimble style sheet web site link to open the Trimble Survey Controller Support page in your Web browser. You can download the style sheet file from this page to your local drive. Then, click the icon located next to the Style sheet box to locate and select the newly downloaded style sheet file for use with the report. You can reuse any downloaded style sheet file as often as necessary.

4. Confirm the name for the report in the Save as box. The report will be saved in the same folder as the selected job file.

5. Edit survey report options in the Settings group as necessary.

Note: Changes you make to the report settings are not saved in the style sheet file.

6. If you do not need to view the output immediately, uncheck View Output File.

7. Do one of the following:
   - Click Apply to run the job file report and keep the Job Report Generator pane open.
   - Click OK to run the job file report and close the Job Report Generator pane.

   If View Output File is checked, the job file report displays in your Web browser.

8. Click File > Save As in the report if you want to keep it.

Related topics

- Import Trimble GPS Files (.job) (see "Import GNSS Job Files (.job)" on page 225)
- Job Report Generator Options (on page 477)

Job Report Generator Options

Use these options to customize job file (.job or .jxl) reports. They are available in the Job Report Generator command pane.
Run Reports

Options

General

Job file

Do either of the following to select the job file for which you want to run a report:

- If the file has been imported into the project, select it in the Job File list.
- If the file has not been imported into the project, click the icon. The Open dialog displays, allowing you to locate and select the file.

Style sheet

Click the icon located next to the Style sheet box to open the Open dialog, which allows you to locate and select the style sheet file you want to use for the report.

Some default style sheet files are installed with the software in C:\Program Files\Trimble\Trimble Business Center\Support\(language_name). If you do not find the style sheet file you want in this folder or in any other folder you might be using for style sheet files, click the Trimble style sheet web site link to open the Trimble Survey Controller Support page in your Web browser. You can download the style sheet file from this page to your local drive. Then, click the icon located next to the Style sheet box to locate and select the newly downloaded style sheet file for use with the report.

Save as

Confirm the name for the report in the Save as box. The report will be saved in the same folder as the selected job file.

Settings

(Report name)

Edit these settings to control how the output is formatted. Changes you make apply only to the current report, and do not affect the style sheet.

View output file

Leave this box checked to see the report in your default browser window.

Uncheck this box if you do not need to view the report output immediately.

Related topics

- Run a Job File Report (on page 476)

Run a Surface Report

Run a surface report to see surface measurements and limits, as well as the number of triangles, vertices, and other items in a surface in your project.
To generate a surface report:

1. Do one of the following:
   - Select Reports > Surface Information Report.
   - Click the icon.
   
   The Surface Information Report command pane displays.

2. Select the surface you want to generate a report for in the Surface list.

3. Click OK. The report displays in your default Web browser.

Related topics
- Customize and Run a Report (see "Customize a Report" on page 481)

Run a Vector List Report

Generate a Vector List to review the solution types and precisions for all the vectors created from processed baselines in your project. You can customize the report layout as desired, selecting what information to show. You can also select a trajectory and run the report to review the included vectors.

To run a Vector List:

- Select Reports > Vector List.
- Select Reports > Report Options. Select Vector List in the command pane, and click OK.

   The Vector List displays in your default Web browser.

Tip: Click a vector name or point ID in the report to select it in the application.

To customize the Vector List:

- In the Report Options command pane, select Vector List. In the Settings group, expand the Column selection section, and select Show or Hide for each type of data to control which columns show in the report.

Related topics
- Customize and Run a Report (see "Customize a Report" on page 481)
Run a Loop Closure Report

After all the baselines in your project have been processed and saved, run Loop Closure to generate a Loop Closure Results report to identify any bad vectors. To ensure that the loop closure results are useful, structure your network so that the baselines create small closed figures. If all the baselines in a loop are from the same session, station setup errors that are common to all the baselines in that session cannot be detected.

The settings used for computing loop closure are set in Report Options.

**To run a Loop Closure Results report:**

1. Do one of the following:
   - Select Survey > Loop Closure.
   - Click on the Survey toolbar.

   The Loop Closure Results report displays in your default Web browser.

   **Caution:** Be sure no objects are selected before running loop closure; otherwise, you may get erroneous results.

2. Review the failed loop results to determine if there are any bad vectors. Bad lines can be disabled to ensure the quality of your project. If possible, replace a disabled line with a redundant line.

3. To disable a bad vector:
   - In the vector spreadsheet (on page 30), hover over the status column for the vector you are going to disable. On the drop-down menu, select Disabled. You can also disable a vector using the Properties pane. The status updates immediately.
   - To disable several vectors at once, multi-select them, and use the Disable Vectors command.

4. If necessary, disable vectors using different solutions until you are satisfied with the loop closure results. At this point, you are ready to move on to network adjustment.

**To set the loop closure computation parameters:**

1. Select Reports > Report Options.
2. Select Loop Closure Results in the Reports list.
3. Expand the Report Setting section in the Settings group.
4. Edit the report settings as needed.

**Note:** When you set the number of legs to use in each loop, if you select a number greater that 3, all loops with 3 or more legs (up to the number specified) are used in the loop closure computation.

### Loop closure results

#### Summary

This shows the number of loops, loops that passed, failed, and the pass/fail criteria.

**Worst** - Click this to select the worst loop in the project (of all those that failed).

**Note:** The number of legs to use per loop and the pass/fail criteria are set in *Report Settings* in the *Report Options* command pane.

#### Failed Loops

This provides details for each loop that failed the criteria.

**Note:** Click a vector name or point ID in any of the report sections to select it in the *Project Explorer* and graphic views.

#### Observations in Failed Loops

This lists the observations in failed loops and the number of occurrences in each loop.

#### Occupations in Failed Loops

This shows details about occupations in failed loops and the number of occurrences (the number of lines with bad occupations). This information can assist you in determining if you have a problem with an occupation, perhaps due to an incorrect antenna height.

Click a link in the *Point* column to select the point and all of the lines in failed loops derived from this point’s occupation.

Click a link in the *Observations* column to select vector that was in a failed loop from this point’s occupation.

### Related topics

- Adjust a Network (on page 356)
- Customize and Run a Report (see "Customize a Report" on page 481)

### Customize a Report

Use report options to customize your reports. The settings you specify are saved so that output remains consistent each time you run a certain report. The *Report Options* command pane lists all the available reports. For some software modules, the Earthwork Report is available from the Reports menu. All reports are displayed in your default Web browser.

**To customize a report:**

You can customize the report layout as desired, selecting what to show in the header, footer, report settings and report sections.
Run Reports


2. Select the report in the Reports list.

3. To view the settings for a report, click the icons to expand sections in the Settings group. Click in boxes, and change options as needed.

Tip: To access commonly-used reports from the Reports menu, set the Show on Reports menu option to Yes.

4. Click OK.

To run a report:

1. Do one of the following:
   - Select Reports > (report name). The report displays in your default Web browser.
   - Select Reports > Report Options if you want to review the report settings. The Report Options dialog displays.

2. Select the report in the Reports list.

3. Click the icon on the command pane toolbar. The report displays in your default Web browser.

4. Click OK to close the dialog.

Note: Reports are not saved automatically. To save a report, select File > Save as in your Web browser.

Related topics
- Report Options (on page 483)
- Run a Job File Report (on page 476)

Report View

The Report View displays when you run certain reports. Along with the content of the report, the view includes a toolbar located along the top of the tab that allows you to:
Run Reports

- Navigate to a specific page in the report
- View and change the print setup information
- View the print layout and print the report
- Export the report to a spreadsheet or PDF document
- Select a magnification to view the report
- Search for text in the report

Related topics
- Tabbed View Arrangement (on page 40)

Report Options

Use these common options to customize report output. They are available in the Report Options command pane. Specific reports have additional options as well. For a description of any setting, click the name of the setting. The description appears in the information box at the bottom of the command pane.
<table>
<thead>
<tr>
<th><strong>Settings</strong></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Column display</strong></td>
<td>Select which data types to show in the report by setting individual columns to <em>Show</em> or <em>Hide</em>.</td>
</tr>
<tr>
<td><strong>Column selection</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Coordinate type</strong></td>
<td>Select whether to show global, local, or grid coordinates in the report.</td>
</tr>
<tr>
<td></td>
<td>This is for the <em>Point List</em>.</td>
</tr>
<tr>
<td><strong>Footer</strong></td>
<td>Select whether to show the date, project name, and application name by selecting <em>Show</em> or <em>Hide</em> for each.</td>
</tr>
<tr>
<td><strong>Format options</strong></td>
<td>Select from summary or detailed formats.</td>
</tr>
<tr>
<td><strong>Header</strong></td>
<td>Select whether to show company, project, user, and coordinate system data by selecting <em>Show</em> or <em>Hide</em> for each.</td>
</tr>
<tr>
<td><strong>Report sections</strong></td>
<td>Select which data types to show in the report by setting individual sections to <em>Show</em> or <em>Hide</em>.</td>
</tr>
<tr>
<td><strong>Sections</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Report setting</strong></td>
<td>Set the number of legs in loops, as well as PPM and delta criteria for <em>Loop Closure Results</em>.</td>
</tr>
<tr>
<td><strong>Residual plot</strong></td>
<td><em>Separate systems</em> - Select this to combine all satellite residual data into a single graph.</td>
</tr>
<tr>
<td></td>
<td><em>Individual satellites</em> - Select this to plot separate graphs of each satellite’s residuals.</td>
</tr>
<tr>
<td></td>
<td>This is for the detailed <em>Baseline Processing Report</em>.</td>
</tr>
<tr>
<td><strong>Run-time display</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Never</strong></td>
<td>Select this to prevent the report from displaying when it is generated (for example, during import); display it only when selected from the menu or the <em>Report Options</em> command pane.</td>
</tr>
<tr>
<td><strong>Show when warnings or errors are present</strong></td>
<td>Select this to display the report when it is generated if errors or warnings occur (for example, during import).</td>
</tr>
<tr>
<td><strong>Prompt</strong></td>
<td>Select this to display a prompt when the report is generated to ask if you want it to display.</td>
</tr>
<tr>
<td><strong>Prompt on warnings or errors</strong></td>
<td>Select this to display a prompt if errors or warnings are present when the report is generated.</td>
</tr>
<tr>
<td><strong>Always</strong></td>
<td>Select this to always display the report when it is generated.</td>
</tr>
</tbody>
</table>
Run Reports

Save intermediate data  Select whether to include intermediate data in the report.

Show on Reports menu

- **No** - Select this to remove the report from the Reports menu
- **Yes** - Select this to re-add the report to the menu.

Related topics

- [Customize and Run a Report](#) (see "Customize a Report" on page 481)
- [Run a Job File Report](#) (on page 476)
Export Data

Export data from your project in a variety of formats. See the individual file format topics for details.

To export data:

1. Do one of the following:
   - Select **File > Export**.
   - Click the icon on the toolbar.
   
   The **Export** command pane displays.

2. Click an export type (**Survey**, **CAD**, **Custom**, or **Construction**) in the **File Format** group. A list of available exporters displays.

3. Select an export format in the list. If one with the desired format is not listed, create a custom exporter.

   **Caution:** If you have a field device connected, only file types compatible with the device appear.

4. If needed, use the **View Filter** (see "Filter a View" on page 85) command to filter the selectable data in the plan view.

5. Select the data to export using one of the **Selection Options** (see "Selection Methods and Options" on page 49).

6. Select a folder in the **File Name** list, or click the icon to browse for a folder.

   When you click the icon, the **Save As** dialog displays with the export folder specified in **Tools > Options > File Location** selected. However, you can browse to and select a different folder.

7. Type a new file name in the **File Name** box if you do not want to overwrite an existing file.
8. If export settings appear in the Settings group, specify them as needed.

9. Click OK to export the data.

**Tip:** You can select data before you begin the Export command.

**Tip:** To customize the format of the exported data, select File > Export Format Editor.

### Related topics

- Export Format Editor
- Export Data Formats (see "Export and Upload Data Formats" on page 487)

### Export and Upload Data Formats

The Export command and Device pane enable you to send the following types of data out from your project. See file-specific topics for details.

**Note:** The file types listed by format below may only be supported in specific commands or field software.
## Export Data

### By field software

<table>
<thead>
<tr>
<th>Software</th>
<th>Export</th>
<th>Upload</th>
</tr>
</thead>
<tbody>
<tr>
<td>Trimble® Survey Controller™</td>
<td>ASCII (.pts)</td>
<td>.cdg</td>
</tr>
<tr>
<td></td>
<td>.dc</td>
<td>.csd</td>
</tr>
<tr>
<td></td>
<td>.dx</td>
<td>.df</td>
</tr>
<tr>
<td></td>
<td>.job</td>
<td>.fcl/.fal</td>
</tr>
<tr>
<td></td>
<td>.ttm</td>
<td>.ggf</td>
</tr>
<tr>
<td>Spectra Precision® Field Surveyor</td>
<td>ASCII (.csv, .txt)</td>
<td>.ggf</td>
</tr>
<tr>
<td></td>
<td>.asc (Nikon NEH)</td>
<td>.bmp, .gif, .jpg, .tif, .png</td>
</tr>
<tr>
<td>TDS Interlock™</td>
<td>.ilj</td>
<td></td>
</tr>
<tr>
<td>TDS Survey Pro™</td>
<td>ASCII (.csv, .txt)</td>
<td>ASCII (.txt)</td>
</tr>
<tr>
<td></td>
<td>.dx</td>
<td>.tif</td>
</tr>
<tr>
<td></td>
<td>.job</td>
<td>.dgg</td>
</tr>
<tr>
<td></td>
<td>.xml</td>
<td>.ggf</td>
</tr>
<tr>
<td></td>
<td></td>
<td>.xml</td>
</tr>
<tr>
<td>Trimble® Digital Fieldbook™</td>
<td>ASCII (.pts)</td>
<td>.cdg</td>
</tr>
<tr>
<td>(v2, v3, and v5)</td>
<td>.dc</td>
<td>.csd</td>
</tr>
<tr>
<td></td>
<td>.dx</td>
<td>.df</td>
</tr>
<tr>
<td></td>
<td>.job</td>
<td>.fcl/.fal</td>
</tr>
<tr>
<td></td>
<td>.ttm</td>
<td>.ggf</td>
</tr>
<tr>
<td></td>
<td>.xml</td>
<td></td>
</tr>
<tr>
<td>Trimble® Survey Manager™</td>
<td>ASCII (.csv, .txt)</td>
<td>.bmp, .gif, .jpg, .tif, .png</td>
</tr>
<tr>
<td></td>
<td>.dx</td>
<td>.ggf</td>
</tr>
<tr>
<td>GNSS receivers/Survey devices</td>
<td>ASCII (.pts)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>.dc</td>
<td></td>
</tr>
</tbody>
</table>

### By file format

<table>
<thead>
<tr>
<th>File format</th>
<th>Data type</th>
<th>Export</th>
<th>Upload</th>
</tr>
</thead>
<tbody>
<tr>
<td>.asc</td>
<td>ASCII, point, Nikon NEH, TDEF files</td>
<td>✔️</td>
<td></td>
</tr>
<tr>
<td></td>
<td>(See the note on TDEF files below.)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>.bmp, .gif, .jpg, .ttm, .xml, .dgg, .dx, .job</td>
<td>image/background map files</td>
<td>✔️</td>
<td></td>
</tr>
<tr>
<td>File Extension</td>
<td>Description</td>
<td></td>
<td></td>
</tr>
<tr>
<td>----------------</td>
<td>-------------</td>
<td></td>
<td></td>
</tr>
<tr>
<td>.png, .tif</td>
<td>ASCII text, point, trajectory files</td>
<td></td>
<td></td>
</tr>
<tr>
<td>.cdg</td>
<td>NGS data sheets</td>
<td></td>
<td></td>
</tr>
<tr>
<td>.csd</td>
<td>ASCII text, point, trajectory files</td>
<td></td>
<td></td>
</tr>
<tr>
<td>.csv, .txt</td>
<td>ASCII (see &quot;Export ASCII Files&quot; on page 491) text, point, trajectory files</td>
<td></td>
<td></td>
</tr>
<tr>
<td>.dc</td>
<td>Trimble Data Collector (see &quot;Export Trimble Data Collector Files (.dc)&quot; on page 496) files</td>
<td></td>
<td></td>
</tr>
<tr>
<td>.ddf</td>
<td>Data dictionary files</td>
<td></td>
<td></td>
</tr>
<tr>
<td>.dgf</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>.dx, .dwg</td>
<td>CAD (see &quot;Export CAD Files (.dx/.dwg)&quot; on page 491) files</td>
<td></td>
<td></td>
</tr>
<tr>
<td>.fal, .fcl, .fxl</td>
<td>Feature files</td>
<td></td>
<td></td>
</tr>
<tr>
<td>.ggf</td>
<td>Geoid files</td>
<td></td>
<td></td>
</tr>
<tr>
<td>.ilj</td>
<td>TDS Interlock files</td>
<td></td>
<td></td>
</tr>
<tr>
<td>.ini</td>
<td>Antenna files</td>
<td></td>
<td></td>
</tr>
<tr>
<td>.job</td>
<td>TDS Survey Pro (see &quot;Export GNSS Job Files (.job)&quot; on page 493), Trimble Digital Fieldbook (see &quot;Export GNSS Job Files (.job)&quot; on page 493)/GNSS files</td>
<td></td>
<td></td>
</tr>
<tr>
<td>.jxl</td>
<td>JobXML files</td>
<td></td>
<td></td>
</tr>
<tr>
<td>.pts</td>
<td>ASCII point files</td>
<td></td>
<td></td>
</tr>
<tr>
<td>.ttm</td>
<td>Trimble surface (see &quot;Export Trimble Surface Files (.ttm)&quot; on page 496) files</td>
<td></td>
<td></td>
</tr>
<tr>
<td>.xml</td>
<td>LandXML (see &quot;Export LandXML Files (.xml)&quot; on page 493) files</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
**Export Data**

**Note:** When data is exported to a TDEF file, information about mean angles is lost. This may lead to different computation results when using the exported data. **Note:** Trimble Survey Controller JOB files support point names of 16 characters or less. Exported point names exceeding 16 characters are truncated in the file.

**Related topics**
- Export Data (on page 486)
- Export Data in a Custom Format (on page 497)
- Prepare to Connect a Field Device (on page 263)

**Export Related Files**

You can specify which additional related files (for example, geoid files or datum grid files) to automatically export with a JOB file when you are exporting to a field device either directly (the device is connected) or indirectly (the files will be stored for upload at a later date).

**To specify related files to export to a field device:**

1. Select **View > Command Pane**. The **Command Pane** displays.
2. In the **Command Pane**, select **Related Files**. The **Related Files** command pane displays.
   - If there are files that are required for the project (for example, a coordinate system file specified in the **Project Settings** dialog), they are displayed in the **File Name** list with a gray background.
3. Click in the first empty **File Name** box, and then either type the path and name of the related file or click ⌘ to select the file.
4. Click in the **Application** box and select the associated device application (or <All> or <None>) from the drop-down list.
5. Repeat steps 3 and 4 for each additional related file and its associated device you want to specify.
6. In the **Upload with export** list, select to upload all files, just the files required for the project, or no files.
7. Select the **Copy files to project folder** box if you want to copy the files specified in the list to the project folder at the time of export.
   - The file referenced in the list is not changed. If the file already exists in the project folder, it is overwritten so that the project folder contains the same version that was uploaded to the device.
8. If there is a currently active device, it is displayed in the **Active Device** box. Click the **Upload Files Now** button to upload the selected related files to the device.
9. When you are done, click **OK**.

The related files you specified will be automatically uploaded with the JOB file when you perform an upload to a device.

**Related topics**
- **Export Data** (on page 486)
- **Export Data in a Custom Format** (on page 497)

---

## Export ASCII Files

Export ASCII files (.asc, .csv, .txt,) that can be used in a variety of other applications and field devices, including:

- Spectra Precision® Field Surveyor
- TDS Survey Pro™
- Nikon NEH
- Trimble® Survey Manager™
- Trimble® Survey Controller™
- Trimble® Digital Fieldbook™ (v2,v3, and v5)

Click the **Custom** tab in the **Export** command pane to access the ASCII exporters. Click the **Survey** tab to export a trajectory as a .csv file. You can set various unit and format options for trajectory export in the **Settings** group.

**Related topics**
- **Export Data** (on page 486)
- **Export Data in a Custom Format** (on page 497)

---

## Export CAD Files (.dxf/.dwg)

Select and export some or all of the data in your project to a CAD file. This can be used as a background map in field devices.

**Note:** You can also upload .bmp, .gif, .jpg, .png, and .tif formats to use as background maps in TDS Survey Pro, Trimble Survey Manager, and Spectra Precision® Field Surveyor.

Click the **CAD** tab in the **Export** command pane to access the .dxf and .dwg exporters. You can set the file version and an explode option in the **Settings** group.

Exported CAD files can be used in:
- Spectra Precision® Field Surveyor
- Trimble® Survey Controller™
- Trimble® Digital Fieldbook™ (v2, v3, and v5)
- TDS Survey Pro™ (as base maps)
- Trimble® Survey Manager™

**Note:** By default, a point ID exports as an attribute of the point.

**Note:** The .dwg format does not support all alignment information, such as stationing. If you export an alignment as a .dwg and then import it into another application as a .dxf/.dwg, vertical alignments in the file may not appear either.

**Related topics**
- [Export Data](on page 486)
- [Export Data in a Custom Format](on page 497)

### Export Geodatabase Files (.xml)

Export feature data contained in your project to a geodatabase XML file from which the data can be imported into an Environmental Systems Research Institute, Inc. (ESRI) geographic information system (GIS).

Click the [GIS](tab) in the **Export** command pane to access the **Geodatabase XML** exporter.

**Note:** The geodatabase XML format represents ESRI’s most current open mechanism for information interchange between geodatabases and other external systems and is a replacement for the earlier shapefile (.shp) spatial data format.

**Related topics**
- [Export Data](on page 486)
- [Export Data in a Custom Format](on page 497)

### Export Event Data

Export event data contained in your project to a CSV file.

Click the [Survey](tab) in the **Export** command pane to access the **Trajectory (CSV) file exporter**.

In the [Settings](section) section, select the appropriate **Data type**:
- Select **Measurement** to export GNSS measurement location information.
- Select **Event Marker** to export interpolated event marker location information.

**Related topics**
- [Export Data](#) (on page 486)
- [Process Event Data](#) (on page 313)

---

**Export GNSS Job Files (.job)**

Export GNSS Job files suitable for use in a variety of field devices, including:

- TDS Survey Pro™ (Survey Pro Jobs)
- Trimble® Survey Controller™ (via Data Collector)
- Trimble® Digital Fieldbook™ (v2,v3, and v5; coordinate system and points only)

Click the **Survey** tab in the **Export** command pane to access the .job exporters.

**Related topics**
- [Export Data](#) (on page 486)
- [Export Data in a Custom Format](#) (on page 497)

---

**Export LandXML Files (.xml)**

Export alignments, cross-sections, and surfaces using the LandXML file format.

**To export LandXML data:**

1. Select **File > Export**. The **Export** dialog displays.
2. Click the **Construction** tab and then select **LandXML exporter** in the **File Format** group.
3. Click in the **Selected entities** box.
4. In a graphic view, pick the objects you want to include in the export, or click **Options** and choose a selection option in the list.
5. If you want to clip a surface that you are exporting, select a boundary in the **Surface clipping boundary** list, or select **<New>** to create one.
6. Type a path and file name for the exported file in the **File Name** box, or click the ⮕ icon to browse for a location and specify a file name.
7. In the **Settings** group, set export properties.
8. Click **Export**.
Related topics

- LandXML Export Options (on page 494)
- Results of Exporting LandXML Files (on page 494)

LandXML Export Options

Use these options to specify how to handle surfaces definitions and duplicate points when you export LandXML files. They are available in the LandXML Export command pane.

Options

**Surface description**

*Optimize for data* - Select this to let the program choose the best export method (of the two below).

If the surface you have selected for export contains any internal data (surface was imported in a TTM or LandXML file), it will export as triangles.

If the surface only references external data (surface was created entirely in this program), it will export as points and breaklines.

**Note:** If you are exporting a portion of a surface that is clipped by a boundary, all data in the clipped portion is made internal.

*Points and breaklines* - Select this to export the surface, as well as the points, breaklines, contours, and boundaries used to create the surface.

*Triangles* - Select this when you only want to export the triangles defining the surface. This option also handles holes and islands in the data.

**Note:** This setting has no effect if the file does not contain surfaces.

**Duplicate point IDs**

*Always ask* - Select to automatically check for points with the same Point ID. If any are found, you are prompted to import all duplicates, ignore all duplicates, or cancel the import.

*Export all* - Select to have all points export, including those with duplicate Point IDs.

*Ignore all* - Select to have only points without duplicate Point IDs export.

**Note:** This setting has no effect if the file does not contain points.

Related topics

- Export LandXML Files (.xml) (on page 493)
- Results of Exporting LandXML Files (on page 494)

Results of Exporting LandXML Files

When you export LandXML files, the points, alignments, and surfaces are handled in specific ways.
### Exported Points

When points are exported:
- The point name or number is used in the "name" field.
- Any valid feature codes are used in the "desc" fields.
- For invalid feature codes, "*" is used.
- The "LandXML.desc" attribute of the first "LandXML feature" is used for the "desc" attribute, and the "LandXML.code" attribute of the first "LandXML feature" is used for the "code" attribute if they exist. Otherwise no "desc" or "code" attributes are written.

### Alignments

When alignments are exported:
- The data defining the alignment is written as an alignment in the LandXML file.
- Both horizontal and vertical components are retained. Multiple vertical alignments can be exported with each horizontal.

### Surfaces

When surfaces are exported:
- Either the source data or the definition is used, but not both.
- Points influencing the surface are saved as points.
- 3D polylines, breaklines, and sloping lines influencing the surface are saved as breakline or contour point lists, depending whether they are pure 3D or 2D+elevation.
- Internal breaklines are retained.

### Related topics
- [Export LandXML Files (.xml)](on page 493)
- [LandXML Export Options](on page 494)
Export Trimble Data Collector Files (.dc)

Export points and coordinate system only data as .dc files. Click the Survey tab in the Export command pane to access the .dc exporter. You can set the file version, units, and output format in the Settings group.

Related topics
- Export Data (on page 486)
- Export Data in a Custom Format (on page 497)

Export Trimble Surface Files (.ttm)

Export triangulated terrain models (.ttm) to use in:
- Trimble® Survey Controller™
- Trimble® Digital Fieldbook™ (v2, v3, and v5)

Click the Construction tab in the Export command pane to access the .ttm exporter.

Related topics
- Export Data (on page 486)
- Export Data in a Custom Format (on page 497)

Export Trimble JobXML Files (.jxl)

Exporting data in JobXML format allows you to share point data and coordinate system data with Trimble field software.

1. Run Export command
2. Click the Survey tab in the Export command pane and select Trimble Field Software exporter(jobXML) and verify settings below.
3. Select data and click OK to export.

Note: Point data is exported into the JobXML Reductions section; the coordinate system data is exported into the Environmental section; the Fieldbook section is left empty.

Note: JobXML allows only one quality per point. If a point in this software has different qualities for planar and vertical components, the lowest quality is exported.

Exported Point Quality

JobXML does not have a single field to represent coordinate quality. This software uses a combination of the SurveyMethod and Classification record to represent coordinate quality as shown in the table below. This representation is valid only with JobXML version 5.0.
Export Data in a Custom Format

Use the Export Format Editor to create a custom converter to export your custom format. The converters created with this editor are used within the Export (see "Export Data" on page 486) command to export ASCII files with a non-standard format.

To export a custom format:

1. Do one of the following:
   - Select File > Export Format Editor.
   - In the Export dialog, click the icon.

   The Export Format Editor opens and displays the Select Definition (see "Definition Options" on page 498) dialog.

2. Select a custom format in the definition list.
3. Click Next and select options in the Description and Search Type (see "Description and Search Type Options" on page 499) dialog.
4. Click Next and select options in the General Properties (see "General Properties Options" on page 238) dialog.
5. Click Next and select options in the Fields (see "Fields Options" on page 500) dialog.
6. Click Finish to create the exporter file.

You can create a custom converter to export any of the following:
- Delimited files - data is separated by a specific character.
- Fixed-width files - data is separated into defined columns.
- Files where data location is defined by a beginning and/or ending string of text.

**To test a custom format exporter:**

1. Select a custom format in the definition list.
2. Click **Test** in any of the four **Export Format Editor** dialogs. The dialog expands.
3. Click **Read File** and select the number of lines you want the exporter to read. If you select **View File**, it will open in a text editor.
4. Click the icon and navigate to the type of file you want to export. The exporter will read the file and highlight any values that it is unable to convert.

**Note:** The file must have the same file extension as the exporter you chose.

5. Select a different exporter or edit the file to accommodate the reported errors.

**Related commands**

- **Definition Options** (on page 498)
- **Description and Search Type Options** (on page 499)
- **General Properties Options** (on page 500)
- **Fields Options** (on page 500)
- **Export Data Formats** (see "Export and Upload Data Formats" on page 487)
- **Selection Methods and Options** (on page 49)

**Definition Options**

Use these options to create new export format definitions. These buttons appear to the right of the list of definitions on the first dialog of the **Export Format Editor**.
Options

New
Click this to enter a new definition name in the list. A unique name is required; a descriptive name is recommended. Click any other definition row to finish.

Click Next to enter a description and search type (see "Description and Search Type Options" on page 499).

Copy
After you click on a description (listing on left), click Copy to enter a definition name. A unique name is required; a descriptive name is recommended. Click OK to return.

Click Next to enter a description and search type (see "Description and Search Type Options" on page 499).

Rename
Select the name of one of the custom formats you have created, and click this to edit the name.

Delete
After you click on a description (listing on left), click this to remove the definition from the list.

Note: To remove a description as an export option, you can click the Enable checkbox until no green check appears. These descriptions will not appear as export options. If you do not want to display these disabled descriptions on this page, enable Only show enabled definitions at the bottom left of the dialog box.

Related topics
- Description and Search Type Options (on page 499)
- General Properties Options (on page 500)
- Fields Options (on page 500)
- Export Data in a Custom Format (on page 497)

Description and Search Type Options

Use these options to define the type of custom exporter you want to create, and add a description. They are available in the second dialog of the Export Format Editor.

Options

Description
Enter a descriptive string to describe this exporter (optional).

Type
Select one of the following options:

- Delimited - this creates a file of data that is separated by a specific character.
- Fixed Width - this creates a file of data that is in pre-defined columns.
- Search for Text - this creates a file of data that begins and ends with a text string.

Related topics
- Definition Options (on page 498)
- General Properties Options (on page 500)
General Properties Options

Use these options to define how you want the file delimited and saved, and the data stored. They are available in the third dialog of the Export Format Editor.

Options

- **Delimiter**
  From the drop-down list, select the character that is to separate the fields. If you select <other>, you must specify the required character. This can be one of the following: _ ) ( * & ^ % $ # @ ! ~ `.

- **Default extension** (recommended)
  Enter the default extension for the export format. The export analyzer uses this extension to help it decide what conversion options to offer the user in the context menu. This field is optional. If left blank, a default extension of "txt" is assumed.

- **Text qualifier (optional)**
  Enter a special character to identify the beginning and ending of the string.

- **Decimal separator**
  Select a decimal separator if necessary. USA standard uses a point to separate the fractional number from the whole number; some areas in Europe use a comma as standard.

Related topics

- **Definition Options** (on page 498)
- **Description and Search Type Options** (on page 499)
- **Fields Options** (on page 500)
- **Export Data in a Custom Format** (on page 497)

Fields Options

Use these options to define the fields that you want to export, and their field order, and units. The options vary slightly based on the type of converter you are creating. They are available in the fourth dialog of the Export Format Editor.
**Options**

**Fields**

Click **Fields** to display a drop-down list of data properties. Select one and a tag appears as a field in the row of data. Continue to select all the fields that you want to export.

**Note:** If you select the properties out of order, you can click and drag them into the proper order.

---

**Units**

**Apply to all**

To select the distance units for all data, select the units and enable the **Apply to all** check box. You can also disable the **Apply to all** check box, and select a unit for each exported field.

---

**For Fixed Width (only)**

Click on each field, and enter a **Start** and **End** value or a **Start** and **Width** value - the third value will be filled in automatically.

---

**For Add Text (only)**

Click on each field, and enter values with which to **Start** and **End** the field.

**Note:** Spaces will not be visible in the **Start** and **End** fields, but you can see them in the **Preview** area.

---

**Test**

Click **Test** to open the testing display area. If there is selected point data, click **Preview** to see the format that the exporter would create. You can continue to modify the format setting and preview the results until you are satisfied.

**Note:** If you have no data selected, click **Finish** to exit the **Export Format Editor** command, and save the exporter that you are creating. Then select some points and start the **Export Format Editor** again.

---

**Related topics**

- [Definition Options](on page 498)
- [Description and Search Type Options](on page 499)
- [General Properties Options](on page 500)
- [Export Data in a Custom Format](on page 497)
Troubleshoot Issues

Troubleshoot a Coordinate System Problem

Before calling Support, use any applicable solutions to known issues below.

<table>
<thead>
<tr>
<th>Symptom</th>
<th>Possible Cause</th>
<th>Solution</th>
</tr>
</thead>
</table>
| You cannot create or edit coordinate systems, or save sites. | You are running as a Limited User (non-administrator). Limited users do not have “write” permissions for the current.csd file, which means that you cannot create or edit coordinate systems, or save sites. | You must be granted “write” permissions for the current.csd file by an administrator. The location of that file depends on your operating system:  
- **In Windows® XP or earlier:**  
  C:\Documents and Settings\All Users\Application Data\Trimble\GeoData or C:\Program Files\Common Files\Trimble\GeoData.  
- **In Windows Vista™:**  
  C:\ProgramData\Trimble\GeoData or C:\Program Files\Common Files\Trimble\GeoData. |

*Note:* This may be a non-issue if other Trimble software has been previously installed, and access rights have been resolved.  
*Note:* If you do not see the Application Data folder at the path listed above, it may be hidden. To show hidden folders, in Windows® Explorer, select **Tools > Folder Options.** Click the **View** tab and select **Show hidden files and folders** in **Advanced Settings.** Then click **OK.**

Troubleshoot a Data Transfer/Synchronization Problem

Before calling Support, use any applicable solutions to known issues below.
### Troubleshoot Issues

**Symptom** | **Possible Cause** | **Solution**
---|---|---
Active Sync 4.5 will not run. | You are running as a limited user. Active Sync 4.5 is not compatible with limited user accounts. | Change you permissions to the administrator level, or download and use Active Sync 4.0.  
**Start > Control Panel > User Accounts > User Accounts**. In the **User Accounts** dialog, select your user name in the list and click **Properties**. In the **Properties** dialog, click the **Group Membership** tab. Select **Other**, and **Administrators** in the list. Click **OK** twice to close the dialogs.

---

### Troubleshoot a Layer or View Filter Problem

Before calling Support, use any applicable solutions to known issues below.

<table>
<thead>
<tr>
<th>Symptom</th>
<th>Possible Cause</th>
<th>Solution</th>
</tr>
</thead>
</table>
| The graphic view redraws slowly when you make changes to view filters. | Your project contains a lot of data, and your computer's graphics memory is running at capacity. | Click the 🌱 icon on the **View Filter Manager**'s toolbar to open the **Advanced View Filter Settings** dialog. When you make changes to view filters in this dialog, the graphic view does not automatically redraw. You can click **Apply** at any time to have the view redraw.  
or  
Select **Project > Project Settings**. Click **View** and then **View Filters** in the left pane, and select a default view filter other than All so that graphic views refresh more quickly. |

| The points on a layer are not visible, even though you have the layer's box checked in the **View Filter Manager** to make it visible. | The **Point** box in the **Raw Data** group is not checked. | Make sure that the boxes for both the points and the layer that the points are on are checked, making them visible in the view. |
Some of the selection sets you created do not appear in the View Filter Manager's selection sets list. The missing selection sets that do not contain any visible objects. None. Selection sets can contain objects that have no visible display, such as coordinates. In the Selection Explorer, all selection sets are available. In the View Filter Manager, however, only selection sets that contain at least one visible object are available.

**Related topics**
- Create a View Filter (on page 82)
- Edit a View Filter (on page 84)
- Filter a View (on page 85)
- View Filter Options (see "View Filter Manager Options" on page 88)
- Advanced View Filter Options (on page 90)

**Troubleshoot an Import Problem**

Before calling Support, use any applicable solutions to known issues below.

<table>
<thead>
<tr>
<th><strong>Symptom</strong></th>
<th><strong>Possible Cause</strong></th>
<th><strong>Solution</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Duplicate points were created for points in an imported text file and points already in the project that have the same ID (that is, points were not merged as expected).</td>
<td>If you import a text file with &quot;Unknown&quot; or &quot;Mapping&quot; coordinate quality into a project that already contains point data, duplicate points will be created for points in the text file (lightweight points (see &quot;Understanding Point Types&quot; on page 364)) and points already in the project (normal points (see &quot;Understanding Point Types&quot; on page 364)) that have the same ID.</td>
<td>Import the text file into the project first to create the lightweight points, then import the other point data. The lightweight points from the text file will merge with the normal points from the other point data to create normal non-duplicated points.</td>
</tr>
</tbody>
</table>

**Troubleshoot a Program Freeze**

Before calling Support, use any applicable solutions to known issues below.
<table>
<thead>
<tr>
<th>Symptom</th>
<th>Possible Cause</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>Program freezes when selecting many objects.</td>
<td>The <strong>Properties</strong> pane is open. When you select many objects with the <strong>Properties</strong> pane open, it looks for the properties common to all of the objects, slowing the program down and making it look frozen.</td>
<td>Close the program. If you have trouble reopening the project, check the directory where the .vce file is stored. If there is a lock (*.lk) file with the same name as the project, delete it and reopen the project. Close the <strong>Properties</strong> pane before reselecting the objects.</td>
</tr>
<tr>
<td>Program doesn’t respond in the expected way; nothing seems to work.</td>
<td>The mouse may be set to a mode other than <strong>Select</strong>.</td>
<td>Check your mouse mode on the <strong>Mouse</strong> toolbar. If needed, reset it to <strong>Select</strong>.</td>
</tr>
<tr>
<td>The program freezes.</td>
<td>Toolbars are corrupted.</td>
<td>Consider contacting Technical Support. Otherwise, remove the application data folder located at <code>C:\Documents and Settings\&lt;user name&gt;\Application Data\Trimble\Trimble Business Center\&lt;version&gt;</code></td>
</tr>
</tbody>
</table>

**Note:** If you do not see the **Application Data** folder at the path listed above, it may be hidden. To show hidden folders, in Windows® Explorer, select **Tools > Folder Options**. Click the **View** tab and select **Show hidden files and folders** in **Advanced Settings**. Then click **OK**.

| The program appears to freeze when you float a pane or try to open a dialog. | If you are running the program on a secondary monitor, and you float a pane or use a command that launches a dialog, the pane or dialog might appear out of either monitor’s visible range. It will be located off of the primary monitor, in the space opposite the secondary monitor, causing Trimble Business Center to appear ‘frozen’. | To reach the dialog or pane, right-click the application’s name on the Windows Taskbar and select **Move**. Then, press the appropriate arrow key to move the dialog into your primary’s monitor’s visible range. |
Troubleshoot Issues

Program appears to freeze when you are trying to e-mail SCS files.

If you are running the program on a secondary monitor, and you attempt to e-mail SCS files using the Compress/E-mail SCS Files command, your e-mail program may open a dialog confirming the operation out of either monitor’s visible range. The dialog will be located off of the primary monitor, in the space opposite the secondary monitor, causing the program to appear ‘frozen’.

To reach the dialog and confirm the e-mail operation, right-click the e-mail application’s name on the Windows application’s Taskbar and select Move. Then, press the appropriate arrow key to move the dialog into your primary’s monitor’s visible range.

Troubleshoot a Project Problem

Before calling Support, use any applicable solutions to known issues below.

<table>
<thead>
<tr>
<th>Symptom</th>
<th>Possible Cause</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>You cannot reopen a .vce project file.</td>
<td>The project file is locked, possibly due to a crash or an improper program shutdown. Improper shutdown includes when: ▪ A project is open and the power to the computer is interrupted. ▪ A project is open and the process is ended from Windows® Task Manager.</td>
<td>Delete the lock (project name,lk) from the file project folder. The project will lose all changes made since the last save.</td>
</tr>
</tbody>
</table>

Troubleshoot a Toolbar or Menu Problem

Before calling Support, use any applicable solutions to known issues below.

<table>
<thead>
<tr>
<th>Symptom</th>
<th>Possible Cause</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>Toolbars are not in the same language as the installation.</td>
<td>The program was run in one language, and then reinstalled in a different language.</td>
<td>Reset the toolbars to the reinstalled language by loading the default layout. Select Tools &gt; Customize. In the Customize dialog, click Save/Load. In Default Layout, select Default Layout and click Load. Click OK in the New layout dialog.</td>
</tr>
</tbody>
</table>
### Troubleshoot Issues

Some text in the user interface (the units on the Status bar for instance) is in a different language.
This only occurs when opening project files that were created in a different language.

The user interface text is being stored in the project file.
There is no solution at this time. Newly created projects will not have the problem, but it will remain in the original project file.

### Troubleshoot a View or Selection Problem

Before calling Support, use any applicable solutions to known issues below.

<table>
<thead>
<tr>
<th>Symptom</th>
<th>Possible Cause</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>The graphic view redraws slowly when you make changes to view filters, or when you change the size of panes.</td>
<td>Your project contains a lot of data, and your computer's graphics memory is running at capacity.</td>
<td>Click the icon on the View Filter Manager's toolbar to open the Advanced Settings dialog. When you make changes to view filters in this dialog, the graphic view does not automatically redraw. You can click Apply at any time to have the view redraw. or Select Project &gt; Project Settings. Click View and then View Filters in the left pane, and select a default view filter other than All so that graphic views refresh more quickly.</td>
</tr>
<tr>
<td>The 3D view is replaced by a red X and this message: &quot;The system has run out of graphics memory. Close any unnecessary windows and retry.&quot;</td>
<td>The system has run out of graphics memory. (no screen saver interruption)</td>
<td>1. Close any unneeded programs that are running, especially ones that are graphics intensive. 2. Close all 3D views, including those with a red X. 3. Reopen the minimum number of 3D views you need. Long-term: Consider upgrading your graphics card.</td>
</tr>
<tr>
<td>The 3D view is replaced by a red X and this message: Microsoft® DirectX.</td>
<td></td>
<td>▪ Close the 3D view and reopen it. ▪ Close and reopen the program and the project.</td>
</tr>
</tbody>
</table>
## Troubleshoot Issues

<table>
<thead>
<tr>
<th>Issue</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>The system has run out of graphics memory. Close any unnecessary windows and retry.</td>
<td>Update to the latest version of DirectX.</td>
</tr>
<tr>
<td>Some of the selection sets I created do not appear in the View Filter Manager’s selection sets list.</td>
<td>The missing selection sets that do not contain any visible objects. None. Selection sets can contain objects that have no visible display, such as coordinates. In the Selection Explorer, all selection sets are available. In the View Filter Manager, however, only selection sets that contain at least one visible object are available.</td>
</tr>
<tr>
<td>Your graphic views are pixilated or contain artifacts when you pan or rotate them.</td>
<td>You are not using the optimal advanced display setting. Select <strong>Tools &gt; Options</strong>. In the <strong>Options</strong> dialog, click <em>Startup and Display</em> in the left pane, and then click <em>Advanced</em>. Check the <strong>Override automatic detection</strong> box, and select the appropriate option for your operating system.</td>
</tr>
<tr>
<td>Your mouse movements are delayed or track intermittently, even though you are using an advanced display setting (see above).</td>
<td>Your graphics card is integrated into the motherboard, or is not sufficient for advanced display settings. Select <strong>Tools &gt; Options</strong>. In the <strong>Options</strong> dialog, click <em>Startup and Display</em> in the left pane, and then click <em>Advanced</em>. Check the <strong>Override automatic detection</strong> box, and try each of these graphics display packages (in order, restarting the program between each): 1. DirectX 2. OpenGL 3. GDI</td>
</tr>
<tr>
<td>Your system suffers from generally poor graphics performance.</td>
<td>Two system settings are not set to optimize the graphics display. Try the solution directly above first. If it does not improve your graphics performance, right-click on your Windows desktop, and select <em>Properties</em> from the context menu. In the <strong>Display Properties</strong> dialog, click the <strong>Settings</strong> tab, and select <em>Medium (16 bit)</em> in the <strong>Color quality</strong> list. Second, click the <strong>Advanced</strong> button in the same dialog. In the <strong>Plug and Play</strong> dialog, click the <strong>Troubleshoot</strong> tab, and set <strong>Hardware acceleration</strong> to <strong>Full</strong>.</td>
</tr>
</tbody>
</table>

### Troubleshoot an Import Problem

Before calling Support, use any applicable solutions to known issues below.
<table>
<thead>
<tr>
<th>Symptom</th>
<th>Possible Cause</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>LandXML data imports in the wrong location or configuration.</td>
<td>Project units are not set correctly.</td>
<td>Check the units shown on the status bar. If they are not correct, undo the import. Then, click the units name to open the <em>Project Settings</em> dialog. Change to the correct type of units, and reimport the file.</td>
</tr>
<tr>
<td>A LandXML file will not import. The program’s importer says it is a LandXML file, but when you try to import it, a message says the file is invalid.</td>
<td>The file is valid XML, but not valid LandXML.</td>
<td>Open the file in your default Web browser. If it is corrupt, you will get an error message. If you do not get a message, it may be valid XML, but not valid LandXML, in which case the file needs to be recreated in a valid LandXML format.</td>
</tr>
</tbody>
</table>
| Custom point data (.csv) imports at the wrong location.                | 1. Your project units are not set correctly.                                | 1. Make sure that your project units are set correctly.  
2. The wrong custom import definition was selected; the northing and easting order are reversed. | 2. Check the custom import definition you used to import the points. If you accidentally selected the definition with the northing and easting reversed, undo the import and reimport with the correct definition. |
| Duplicate points were created for points in an imported text file and points already in the project that have the same ID (that is, points were not merged as expected). | If you import a text file with "Unknown" or "Mapping" coordinate quality into a project that already contains point data, duplicate points will be created for points in the text file (*lightweight points* (see "Understanding Point Types" on page 364)) and points already in the project (*normal points* (see "Understanding Point Types" on page 364)) that have the same ID. | Import the text file into the project first to create the lightweight points, then import the other point data. The lightweight points from the text file will merge with the normal points from the other point data to create normal non-duplicated points. |
Use Related Utilities

Coordinate System Manager

The Coordinate System Manager is a standalone utility that gives you access to your coordinate system database (Current.csd). Use the manager to create coordinate systems, or to determine which coordinate systems, geoid models, and sites are available for use in your project.

To open the Coordinate System Manager:

- Select Tools > Coordinate System Manager.

Note: The Coordinate System Manager has its own help system. Open the utility and select Help > Help Topics, or press [F1] within the software.

Related topics
- Change the Coordinate System (on page 157)
- Coordinate Systems (see "Understanding Geodetic Reference Data" on page 189)
- Define a New Coordinate System (on page 158)
- Restore the Original Coordinate System File (on page 158)

Feature Definition Manager Utility

The Feature Definition Manager is a standalone utility that gives you the ability to create and manage feature libraries (.fxl files) for feature code processing and GIS attribute data collection. A feature library is a collection of features with codes and attributes that describe them, as well as line control codes that modify how the features relate.

The Feature Definition Manager comes with a default library of features with predefined attributes. This library provides a good starting point for feature coding. As you create new features and edit existing ones, the library will become suited to the specific needs of your projects.

Feature coding in the editor enables you to:
Use Related Utilities

- Make detailed data collection in the field more efficient and consistent by controlling how features and attributes can be captured. Setting parameters for what you can and must enter ensures data integrity and completeness.
- Add symbols and annotations to feature-coded field data so that the information can be presented in a more visual format.
- Connect points to define line features, such as pavement or building edges, or the centerlines of ditches or fences. Line control codes give you the power to add new points automatically, and add lines, curves, and arcs between points.

If you are working with surfaces, coded features also let you:
- Define the breaklines of a surface.
- Control how surfaces are formed by specifying which points should be used, and which lines should act as breaklines. Surfaces can be modified by moving points to specific layers based on their feature codes.

**Note:** The Feature Definition Manager has its own help system. While in the Feature Definition Manager, select Help > Contents, or press [F1].

Related topics
- Understanding Feature Data (on page 455)
- Workflow for Feature Data (on page 457)

Planning Utility

Use the Planning utility to plan and schedule a GPS project based on good and bad satellite coverage information.

**To access the utility:**
- Select Tools > Planning.

**Note:** The Planning software has its own help system. Open the utility and select Help > Index from the Planning menu or press [F1] within the software.

External Tools Manager

Use the External Tools Manager to add menu items for external application and utilities that you might want to use within this software. For example, if you want to have quick access to the Microsoft® Windows® Calculator, you can add it as a menu item. To add external tools to the Tools menu, see Customize the Menu (on page 15).

Trimble Configuration Utility

Use the Trimble Configuration Utility to update your computer with the latest files for:
Use Related Utilities

- GPS antennas
- GPS receivers
- GPS antenna model files

After running the utility, your Trimble software will support the latest GPS hardware.

To access the utility:
- Select Tools > Configuration Web Page.

**Trimble Data Transfer Utility**

Use the *Trimble Data Transfer Utility* to transfer data from a range of devices to your computer. You can then import the data into Trimble Geomatics Office™, Trimble Total Control™, Terramodel®, Trimble Business Center, GPS Pathfinder® Office, Trimble Link™, or the GPS Analyst™ extension for ESRI ArcGIS.

To access the utility:
- Select Tools > Data Transfer Web Page.
Index

2
2D View Navigation • 41

3
3D View • 27
3D View Navigation • 43
3D View Settings • 44

A
Abbreviation Settings • 178
Add a Coordinate to a Point • 367
Add and Edit Points and Coordinates • 365
Add New Data Providers • 252
Add Predefined Data Providers • 257
Add Surface Materials • 445
Adjust a Network • 356
Adjust Level Runs • 347
Adjust Networks • 351
Advanced View Filter Options • 90
Alignment Editor • 36, 395
Alignment Properties • 392
Alignment Stationing Options • 391
Along Line Snap • 137
Apply a Baseline Processing Style • 303
Apply a Network Adjustment Style • 354
Archive a Project • 185
At Point Snap • 136

B
Baseline Initialization Methods • 297
Baseline Processing Options • 306
Baseline Processing Settings • 165
Bearing + Angle Snap • 105
Bearing Bearing Snap • 108
Bearing Distance Snap • 109
Boundary Options • 437
Break a Line • 410
Breakline Options • 410, 429
Calculate and Enter Values • 95
Calculate the Inverse Between Points • 283, 375
Calibrate a Site • 200, 203
Center of Arc Snap • 110
Center of Gravity Snap • 111
Change Baseline Processor Settings • 304
Change Network Adjustment Settings • 355
Change Project Units • 160
Change the Baseline Processing Order • 304
Change the Coordinate System • 157, 190
Change the Default Template • 183
Change the Gridline Display • 162
Change the Template Folder • 152
Check GNSS Data • 280
Check Imported Surfaces • 417
Check Sessions • 286
Check Sessions and Occupations • 286
Check-In Raw GNSS Data • 220
Choose Application Options • 148
Choose Local Site Settings • 178
Choose Project Settings • 155
COGO Expressions, Units, and Entry Formats • 97
Command Pane • 12
Computational Settings • 164
Contour Options • 443
Coordinate Options • 369
Coordinate System Manager • 192, 510
Coordinate System Settings • 156
Coordinates Scroll • 14
Copyright and Trademarks • ii
Corporate Office • ii
Create a Boundary • 436
Create a Datum Grid File • 193
Create a Linestring • 396
Create a New Project • 180
Create a Point • 365
Create a Project Template • 182
Create a Surface • 419
Create a Surface Boundary and Contours • 435
Create a Surface Contour at an Elevation • 440
Create a Surface Cut/Fill Grid • 442
Create a View Filter • 82
Create an Alignment • 384
Create an Alignment from a GENIO String • 393
Create and Edit a Layer • 77
Create and Edit a Linestring • 396
Create and Edit a Simple Breakline • 408, 428
Create and Edit a Surface • 416
Create and Edit an Alignment • 382
Create and Use Selection Sets • 66
Create and View a Surface Cross-Section • 422
Create and View a Surface Profile • 421
Create Surface Contours at Intervals • 439
Cross-Section View • 25
Customization Options and Tools • 19
Customize a Report • 481
Customize the Keyboard • 19
Customize the Menu • 15
Customize the Toolbar • 17

D
Data Provider Group Options • 251
Data Selection • 48
Data Synchronization • 269
Data View Display Formats • 38
Data Views • 15
Datum Grid Options • 195
Default Standard Errors Settings • 174
Define a Geoid Sub-Grid • 196
Define a New Coordinate System • 158, 190
Define a Projection • 195, 225
Define Materials for Earthwork Reports • 447
Define the Coordinate System • 190
Definition Options • 237, 498
Deflection Angle Snap • 101
Delete a Line Segment • 412
Delete an Object • 74
Delta X Delta Y Snap • 112
Description and Search Type Options • 238, 499
Device Pane • 10, 265
Direct Connection • 267
Disable Dependent Baselines Before Network Adjustment • 299
Distance + Distance Snap (distance) • 130
Distance + Distance Snap (offset) • 138
Distance Distance Snap • 112
Distance Snap • 139
Download and Import Data Automatically • 242
Download and Import Data Manually • 249
Download and Import Internet Data • 242
Download Files (via data synchronization) • 269
Download Files (via Direct Connection) • 267
Download Parameter Options • 246
Drag and Drop to Import • 213

E
Earthwork Report Options • 450
Edit a Linestring’s Horizontal Segments • 397
Edit a Linestring’s Vertical Control Points • 405
Edit a Surface by Adding and Removing Members • 424
Edit a Surface by Changing a Point Coordinate • 425
Edit a Surface by Changing Its Properties • 434
Edit a Surface by Creating a Breakline • 430
Edit a Surface by Trimming Edge Triangles • 432
Edit a View Filter • 84
Edit an Alignment • 386
Edit an Alignment's Properties • 391
Edit an Object • 75
Edit Multiple Values • 224
Edit Sessions • 287
Edit the Point ID for a Station Setup and/or Backsight • 373
Enable and Disable Baselines • 298
Enable and Disable Vectors • 353
End Snap • 113
Enter a Bearing • 103
Enter a Coordinate • 106
Enter a Distance • 129
Enter a Station • 142
Enter an Angle • 101
Enter an Elevation • 134
Enter an Offset • 137
Enter, Edit, and Delete Feature Code Strings • 459
Explode a Block • 415
Explore an Object • 414
Export and Upload Data Formats • 487
Export ASCII Files • 491
Export CAD Files (.dxf/.dwg) • 491
Export Data • 486
Export Data in a Custom Format • 497
Export Event Data • 492
Export Geodatabase Files (.xml) • 464, 492
Export GNSS Job Files (.job) • 493
Export LandXML Files (.xml) • 493
Export Related Files • 490
Export Trimble Data Collector Files (.dc) • 496
Export Trimble JobXML Files (.jxl) • 496
Export Trimble Surface Files (.ttm) • 496
External Tools Manager • 511

F
Factor of Distance Snap (distance) • 131
Factor of Distance Snap (offset) • 140
Factor of Line Snap • 114
Factor of Segment Snap • 115
Feature Code Processing Settings • 176, 458
Feature Definition Manager Utility • 465, 510
Fields Options • 240, 500
File Location Options • 150
Filter a View • 85
Find Help Topics • 21
Flags Pane • 13
Free Snap • 116
From Surface Snap • 135

G
General Information Settings • 156
General Properties Options • 238, 500
Geoid Options • 196
Geoid Sub-Grid Options • 198
Get Familiar with the Interface • 5
Get Started • 2
GNSS Baseline Data Sources • 293
GNSS Data Collection Methods • 295
Graphic Selection Methods • 49
Graphic Views • 24

H
Help Options • 22
Horizontal Alignment Options • 387
Horizontal Linestring Segment Options • 401

I
iGate Download Options • 245
Import ASCII Files • 216
Import CAD Files (.dxf/.dwg) • 216
Import Data • 212
Import Data Collector Files (.dc) • 216
Import Data in a Custom Format • 236
Import DiNi Digital Level Files (.dat) • 234, 334
Import GENIO Files • 218
Import GNSS Data • 219
Import GNSS Files (.dat) • 219
Import GNSS Job Files (.job) • 225
Import LandXML Files (.xml) • 226
Import MicroStation Files (.dgn) • 230
Import NGS OPUS Data (.xml) • 233
Import Rangefinder Observation (Laser) Data • 232
Import REB Files (.reb) • 232
Import RINEX Data • 233
Import Trimble Surface Files (.ttm) • 234
Import Wirth YXZ Files (.yxz) • 234
Importable Data Formats • 214
Internet Download Options • 154, 243
Intersection of Lines Snap • 117
Intersection of Offset Lines Snap • 118
Intersection of Offset Segments Snap • 118
Intersection of Segments Snap • 119
Inverse Options • 284, 376
Isolate or Exclude a Layer • 79

Job Report Generator Options • 477
Join Lines • 411

Keyboard Navigation • 46

LandXML Conflict Resolution Options • 229
LandXML Export Options • 494
Layer Options • 80
Level Data Errors • 346
Local Site Setting Options • 179

M
Manage the Data in Your Views • 76
Manage the List of Data Providers • 250
Materials Options • 448
Measure Angle Options • 147
Measure Angles • 146
Measure Options • 145, 378
Measure Values Between Points • 144, 377
Merge Duplicate Points • 373
Merge Level Runs • 348
Merge Points • 374
Middle of Point to Point Snap • 120
Middle of Segment Snap • 121
Modify Selection Sets • 68
Mouse Modes • 48

N
Nearest to Line Snap • 122
Network Adjustment Options • 358
Network Adjustment Settings • 170
New Provider Options • 254
Note on Level Runs Without Benchmarks • 349

Occupation Spreadsheet • 29, 275
Office Synchronizer • 264
Offset at Point Snap • 141
Offset Line Snap • 122
Offset Segment Snap • 123
Open an Existing Project • 183

P
Pane and Data View Positioning • 37
Perpendicular to Line Snap • 124
Perpendicular to Segment Snap • 124
Plan View • 24
Planning Utility • 280, 511
Point Coordinate Options • 370, 426
Point of Intersection Snap • 125
Point Options • 366
Point Snap • 126
Point to Point Bearing Snap • 106
Point to Point Snap (distance) • 132
Point to Point Snap (offset) • 141
Points Spreadsheet • 28, 379
Post-download File Options • 249
Predefined Data Provider Options • 258
Prepare to Connect a Field Device • 263
Print a View or Report • 185
Process Baselines • 291, 305
Process Event Data • 313
Process Feature Codes • 463
Profile View • 25
Project Computations • 165
Project Explorer • 6
Properties Pane • 12

R

Radius of Arc Snap (distance) • 133
Radius of Arc Snap (offset) • 142
Raw Data Check-In Options • 222
Reference

Regular Expressions • 240
URL Parameters • 258
Register This Software • 2
Release Notice • ii
Rename Points • 371
Report Options • 483
Report View • 36, 482
Resolve LandXML Conflicts • 228
Restore the Original Coordinate System File • 158, 191
Results of Default Folder Locations • 153
Results of Exporting LandXML Files • 494
Retaining User Settings When Upgrading • 4
Rules for Merging Feature Attributes • 461
Run a Baseline Processing Report • 308, 467
Run a Job File Report • 476
Run a Loop Closure Report • 310, 480
Run a Mean Angle Report • 331, 471
Run a Network Adjustment Report • 361, 472
Run a Point Derivation Report • 282, 474
Run a Point List Report • 282, 474
Run a Project Computation Report • 165, 475
Run a Renamed Point List • 372, 475
Run a Site Calibration Report • 211, 475
Run a Surface Report • 435, 478
Run a Vector List Report • 312, 479
Run an Alignment Geometry Report • 394, 466
Run an Earthwork Report • 449, 469
Run an Import Report • 261, 470
Run Reports • 466
Running Snap Mode Options • 99

S

Save a Calibrated Site as a Coordinate System • 209
Save a Project • 184
Scale-Only Projection • 193
Select by Elevation Range • 62
Select By Layer • 63
Select Duplicate Points • 58
Select from 2D Views • 50
Select from Spreadsheet Views • 52
Select from the 3D View • 51
Select from the Flags Pane • 54
Select from the Project Explorer • 54
Select Observations • 58
Select Points • 55
Select Unprocessed Sessions • 62
Select Using Advanced Criteria • 63
Selection Explorer • 7, 65
Selection Explorer and Selection Sets • 64
Selection Explorer Options • 69
Selection Methods and Options • 49
Separate Global and Grid/Local Coordinate Points for Site Calibration • 210
Session Editor • 34, 289
Session Editor Options • 291
Set a Line Elevation • 413
Set Default File Locations • 152
Set Download Parameters • 246
Set Running Snap Modes • 99
Set the Pick Aperture • 98
Set Up Geodetic Reference Data • 189
Set Up Projects • 148
Shrink 3D Faces • 452
Site Calibration Options • 206
Snaps Modes and Commands • 98
Split Line Features • 462
Spreadsheets and Other Views • 28
Startup and Display Options • 148
Station at Point Snap • 143
Station from Line Snap • 144
Status Bar • 9
Store Continuous Data as Individual Vectors • 302
Surface Cut/Fill Grid Options • 444
Surface Options • 420
Surface Properties • 434
Surface Slicer View • 26
T
Tabbed View Arrangement • 40
Tangent Snap • 127
Three Point Snap • 102
Time-Based View • 32, 278
Time-Based View Options • 286
Toggle Line Marking • 163
Total Station Data Errors • 329
Total Station Measurement Types • 318
Total Station Nodes Sequence in Project Explorer • 328
Total Station Setup Types • 316
Trajectories and Vectors • 300
Trajectory Options • 302
Transfer/Synchronize Data • 263
Trimble Configuration Utility • 511
Trimble Data Transfer Utility • 512
Troubleshoot a Coordinate System Problem • 192, 502
Troubleshoot a Data Transfer/Synchronization Problem • 274, 502
Troubleshoot a Layer or View Filter Problem • 92, 503
Troubleshoot a Program Freeze • 187, 504
Troubleshoot a Project Problem • 186, 506
Troubleshoot a Toolbar or Menu Problem • 20, 506
Troubleshoot a View or Selection Problem • 93, 507
Troubleshoot an Import Problem • 261, 380, 504, 508
Troubleshoot Issues • 502
U
Undefined Snap • 135
Understanding Alignments • 382
Understanding Baseline Processing • 292
Understanding Baselines and Vectors (for TGO Users) • 313
Understanding Breaklines • 427
Understanding COGO Controls • 95
Understanding Earthwork Volume Calculations • 445
Understanding Feature Data • 455
Understanding Geodetic Reference Data • 189
Understanding Layers and View Filters • 76
Understanding Level Data • 332
Understanding Network Adjustment • 351
Understanding Point Types • 364
Index

Understanding Selection Sets • 64
Understanding Site Calibration • 200
Understanding Surfaces • 416
Understanding Total Station Data • 315
Undo or Redo an Action • 76
Unit Settings • 159
Upload a Datum Grid File • 273
Upload a Geoid File • 273
Upload Files (via data synchronization) • 270
Upload Files (via Direct Connection) • 267
Upload Geodetic Reference Data • 273
Upload Tasks (via data synchronization) • 271
Upload Tasks (via Direct Connection) • 268
URL Wizard Options • 256
Use a Datum • 193
Use a Geoid • 196
Use a Project Template • 181
Use Related Utilities • 510
Use Snap Commands • 100
Use Valid Segment Order • 385
User Guide • i

V
Vector Spreadsheet • 30, 276
Verify Static and Kinematic Data • 280
Vertical Alignment Options • 389
Vertical Linestring Options • 406
View a Slice of a Surface • 423
View and Edit an Object’s Properties • 73
View and Edit Level Data • 336
View and Edit Mean Angle Residuals • 330
View Filter Manager • 8, 81
View Filter Manager Options • 88
View Imported Level Data in Project Explorer • 342
View Imported Total Station Data in Project Explorer • 323
View Level Data Associated with a Point in Project Explorer • 345
View Level Data in Project Explorer • 342
View Settings • 161
View Total Station Data Associated with a Point in Project Explorer • 326
View Total Station Data in Project Explorer • 322
View, Navigate, and Select • 24

W
Welcome To Trimble Business Center • 1
Work with Feature Data • 455
Work with GNSS Data • 275
Work with Level Data • 332
Work with Line Data • 382
Work with Point Data • 364
Work with Surface Data • 416
Work with Total Station Data • 315
Workflow for Adjusting a Network • 352
Workflow for Creating Alignments • 383
Workflow for Creating Surfaces • 418
Workflow for Feature Data • 457
Workflow for Level Data • 333
Workflow for Processing Baselines • 291
Workflow for Total Station Data • 320
Workflow for Using Imported Alignments • 383
Workflow for Using Imported Surfaces • 417

X
XY Snap • 128